Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[solved] dev-lang/spidermonkey-1.8.5-r1 fails to build
View unanswered posts
View posts from last 24 hours

Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
Tux's lil' helper
Tux's lil' helper

Joined: 19 Dec 2004
Posts: 143
Location: Bielefeld, Germany

PostPosted: Fri Jan 25, 2013 1:34 am    Post subject: [solved] dev-lang/spidermonkey-1.8.5-r1 fails to build Reply with quote

hi community.

i just installed a new gentoo system, and when i do "emerge system -ev" i get an error while emerging spidermonkey. here are the last emerge lines:

i686-pc-linux-gnu-g++ -o pm_linux.o -c  -I./dist/system_wrappers_js -include ./config/gcc_hidden.h -DOSTYPE=\"Linux3.5\" -DOSARCH=Linux -DEXPORT_JS_API -D__STDC_LIMIT_MACROS  -I. -I. -I./dist/include -I./dist/include/nsprpub  -I/usr/include/nspr   -I. -I./assembler -I./yarr  -fPIC  -fno-rtti -fno-exceptions -Wall -Wpointer-arith -Woverloaded-virtual -Wsynth -Wno-ctor-dtor-privacy -Wno-non-virtual-dtor -Wcast-align -Wno-invalid-offsetof -Wno-variadic-macros -Werror=return-type -pedantic -Wno-long-long -march=native -O2 -pipe -fno-strict-aliasing -pthread -pipe  -DNDEBUG -DTRIMMED -O3 -fstrict-aliasing -fomit-frame-pointer -DUSE_SYSTEM_MALLOC=1 -DENABLE_ASSEMBLER=1 -DENABLE_JIT=1   -DMOZILLA_CLIENT -include ./js-confdefs.h -MD -MF .deps/pm_linux.pp ./perf/pm_linux.cpp
rm -f libjs_static.a
ar cr libjs_static.a jsanalyze.o jsapi.o jsarena.o jsarray.o jsatom.o jsbool.o jsclone.o jscntxt.o jscompartment.o jsdate.o jsdbgapi.o jsdhash.o jsdtoa.o jsemit.o jsexn.o jsfriendapi.o jsfun.o jsgc.o jsgcchunk.o jsgcstats.o jshash.o jsinterp.o jsinvoke.o jsiter.o jslock.o jslog2.o jsmath.o jsnativestack.o jsnum.o jsobj.o json.o jsopcode.o jsparse.o jsproxy.o jsprf.o jsprobes.o jspropertycache.o jspropertytree.o jsreflect.o jsregexp.o jsscan.o jsscope.o jsscript.o jsstr.o jstypedarray.o jsutil.o jswrapper.o jsxdrapi.o jsxml.o prmjtime.o sharkctl.o jstracer.o Assembler.o Allocator.o CodeAlloc.o Containers.o Fragmento.o LIR.o njconfig.o RegAlloc.o avmplus.o Nativei386.o jsbuiltins.o VMPI.o Writer.o MethodJIT.o StubCalls.o Compiler.o FrameState.o FastArithmetic.o FastOps.o StubCompiler.o MonoIC.o PolyIC.o ImmutableSync.o InvokeHelpers.o Retcon.o TrampolineCompiler.o checks.o conversions.o diy-fp.o v8-dtoa.o fast-dtoa.o platform.o utils.o Assertions.o ExecutableAllocatorPosix.o ExecutableAllocatorWin.o ExecutableAllocatorOS2.o ExecutableAllocator.o ARMAssembler.o Logging.o MacroAssemblerARM.o MacroAssemblerX86Common.o RegexCompiler.o RegexJIT.o pcre_compile.o pcre_exec.o pcre_tables.o pcre_xclass.o pcre_ucp_searchfuncs.o jsperf.o pm_linux.o 
ranlib libjs_static.a
/var/tmp/portage/dev-lang/spidermonkey-1.8.5-r1/work/js-1.8.5/js/src/config/nsinstall -R -m 644 libjs_static.a ./dist/lib
/var/tmp/portage/dev-lang/spidermonkey-1.8.5-r1/work/js-1.8.5/js/src/config/nsinstall -R -m 755 ./dist/lib
/var/tmp/portage/dev-lang/spidermonkey-1.8.5-r1/work/js-1.8.5/js/src/config/nsinstall: cannot access No such file or directory
make[1]: *** [libs] Error 1
make[1]: Leaving directory `/var/tmp/portage/dev-lang/spidermonkey-1.8.5-r1/work/js-1.8.5/js/src'
make: *** [default] Error 2
emake failed
 * ERROR: dev-lang/spidermonkey-1.8.5-r1 failed (compile phase):
 *   (no error message)
 * Call stack:
 *, line  93:  Called src_compile
 *   environment, line 5601:  Called die
 * The specific snippet of code:
 *       emake || die
 * If you need support, post the output of `emerge --info '=dev-lang/spidermonkey-1.8.5-r1'`,
 * the complete build log and the output of `emerge -pqv '=dev-lang/spidermonkey-1.8.5-r1'`.
 * The complete build log is located at '/var/tmp/portage/dev-lang/spidermonkey-1.8.5-r1/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/dev-lang/spidermonkey-1.8.5-r1/temp/environment'.
 * Working directory: '/var/tmp/portage/dev-lang/spidermonkey-1.8.5-r1/work/js-1.8.5/js/src'
 * S: '/var/tmp/portage/dev-lang/spidermonkey-1.8.5-r1/work/js-1.8.5'

here is my "emerge --info" output:

Portage (default/linux/x86/13.0, gcc-4.6.3, glibc-2.15-r3, 3.5.7-gentoo i686)
System uname: Linux-3.5.7-gentoo-i686-Intel-R-_Core-TM-_i7-2600K_CPU_@_3.40GHz-with-gentoo-2.1
Timestamp of tree: Thu, 24 Jan 2013 23:30:01 +0000
ld GNU ld (GNU Binutils) 2.22
app-shells/bash:          4.2_p37
dev-lang/python:          2.7.3-r2, 3.2.3
dev-util/pkgconfig:       0.27.1
sys-apps/baselayout:      2.1-r1
sys-apps/openrc:          0.11.8
sys-apps/sandbox:         2.5
sys-devel/autoconf:       2.13, 2.69
sys-devel/automake:       1.11.6
sys-devel/binutils:       2.22-r1
sys-devel/gcc:            4.6.3
sys-devel/gcc-config:     1.7.3
sys-devel/libtool:        2.4-r1
sys-devel/make:           3.82-r4
sys-kernel/linux-headers: 3.6 (virtual/os-headers)
sys-libs/glibc:           2.15-r3
Repositories: gentoo
CFLAGS="-march=native -O2 -pipe"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-march=native -O2 -pipe"
FCFLAGS="-O2 -march=i686 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch"
FFLAGS="-O2 -march=i686 -pipe"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
USE="acl alsa apng bash-completion berkdb bzip2 cjk cli consolekit cracklib crypt cxx dbus dri dvd encode extensions extras ffmpeg fontconfig fortran gdbm gif gnutls gstreamer gudev iconv icu ipv6 jpeg jpeg2k ldap lzma mmx mmxext mng modules mp3 mp4 mpeg mplayer mudflap multimedia ncurses nls nptl nsplugin nvidia ogg openexr opengl openmp pam pcre pdf perl phonon php png policykit python python3 qt3support qt4 quicktime rar readline samba schroedinger sdl session smp sse sse2 sse3 sse4_1 ssl ssse3 startup-notification svg symlink tcpd theora threads thumbnail tiff truetype udev unicode usb v4l2 vdpau vim-syntax vorbis wicd win32codecs wma wma-fixed wmf x264 x86 xml xmlpatterns xpm zlib" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GRUB_PLATFORMS="pc" INPUT_DEVICES="evdev" KERNEL="linux" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LINGUAS="de en" NETBEANS_MODULES="*" PHP_TARGETS="php5-3" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_2" RUBY_TARGETS="ruby18 ruby19" USERLAND="GNU" VIDEO_CARDS="nvidia"

could this problem be related to using an ssd? the file (or symlinks) are on the disk:

balder ~ # ls -la /usr/lib/libmoz*
lrwxrwxrwx 1 root root      18 Jan 25  2013 /usr/lib/ ->
lrwxrwxrwx 1 root root      20 Jan 25  2013 /usr/lib/ ->
-rwxr-xr-x 1 root root 3166728 Jan 25  2013 /usr/lib/

i would appreciate any help, i don't know further at this point. if you got any more question, just ask.

thanks in advance

Last edited by onelove on Sun Jan 27, 2013 12:34 pm; edited 1 time in total
Back to top
View user's profile Send private message

Joined: 14 Oct 2006
Posts: 6193

PostPosted: Fri Jan 25, 2013 8:25 am    Post subject: Reply with quote

First thing to check here, is whether it's a parallel make failure.
Back to top
View user's profile Send private message
Tux's lil' helper
Tux's lil' helper

Joined: 19 Dec 2004
Posts: 143
Location: Bielefeld, Germany

PostPosted: Sun Jan 27, 2013 12:33 pm    Post subject: Reply with quote

solved "somehow" :-/.

this problem occured on a fresh install, i.e. aufter rebooting for the first time. i had activated a lot more useflags in make.conf after the first reboot and then did an "emerge system -evp". i tried building with "MAKEOPTS="-j1"", but that didn't do it. thank you very much for the tip though, voidmage. i will take this into account when having similar problems related to building in the future.

i simply deactivated most of my useflags and then did an "emerge system -evp". that one went through and after that, i could build sipdermonkey.

thank you.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum