Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED]GNOME 3.6 input sources, english input, no shortcuts
View unanswered posts
View posts from last 24 hours

Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message

Joined: 18 Jan 2013
Posts: 4

PostPosted: Fri Jan 18, 2013 8:12 pm    Post subject: [SOLVED]GNOME 3.6 input sources, english input, no shortcuts Reply with quote


I've updated to the latest gnome-light-3.6.2 from portage (no overlays) and I have the following problem with the new "input sources" feature. I set up a couple of layouts (en, ru, uk) through the gnome-control-center UI utility. But no matter which one is set I always type in English (in any application).

I've installed im-chooser and set to use ibus, installed app-i18n/ibus-table-cyrillic (not sure if I need it for gnome though). Basically I followed this instruction But this did not help either.

Note that pretty much the same is happening in the fallback mode. I don't use systemd and I don't have any entries related to input in Xorg.conf.

Don't know if related, but most of shortcuts (including e.g. switching layouts) and hardware buttons (like volume up/down) do not work.

Does anyone have the same problem? Could someone give an advice where any related errors may have been logged?

Here is the emerge --info output.

Portage (default/linux/amd64/10.0, gcc-4.6.3, glibc-2.15-r3, 3.3.8-gentoo x86_64)
System uname: Linux-3.3.8-gentoo-x86_64-Intel-R-_Core-TM-2_Duo_CPU_T7500_@_2.20GHz-with-gentoo-2.1
Timestamp of tree: Thu, 17 Jan 2013 17:45:01 +0000
ld GNU ld (GNU Binutils) 2.22
app-shells/bash: 4.2_p37
dev-java/java-config: 2.1.11-r3
dev-lang/python: 2.7.3-r2, 3.2.3
dev-util/cmake: 2.8.9
dev-util/pkgconfig: 0.27.1
sys-apps/baselayout: 2.1-r1
sys-apps/openrc: 0.11.8
sys-apps/sandbox: 2.5
sys-devel/autoconf: 2.13, 2.69
sys-devel/automake: 1.9.6-r3, 1.10.3, 1.11.6
sys-devel/binutils: 2.22-r1
sys-devel/gcc: 4.6.3
sys-devel/gcc-config: 1.7.3
sys-devel/libtool: 2.4-r1
sys-devel/make: 3.82-r4
sys-kernel/linux-headers: 3.6 (virtual/os-headers)
sys-libs/glibc: 2.15-r3
Repositories: gentoo x-portage
CFLAGS="-march=k8 -O2 -pipe"
CONFIG_PROTECT="/etc /usr/share/config /usr/share/gnupg/qualified.txt /usr/share/maven-bin-3.0/conf"
CONFIG_PROTECT_MASK="${EPREFIX}/etc/gconf /etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5.4/ext-active/ /etc/php/cgi-php5.4/ext-active/ /etc/php/cli-php5.4/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-march=k8 -O2 -pipe"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch"
FFLAGS="-O2 -pipe"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
USE="X a52 aac acl acpi alsa amd64 autoipd avahi bash-completion berkdb bluetooth branding bzip2 cairo cdr cli cracklib crypt cups cxx dbus device-mapper dhcpcd directfb djvu dlna dri dvd dvdr ffmpeg firefox flac fortran fuse g3dvl gdbm gdu gedit gif git glade glamor glut gmp gnome gnome-keyring gnutls gpm gstreamer gtk gtk3 gtkspell guile gzip iconv icu introspection ipv6 jpeg kpathsea lame laptop libnotify matroska mmx modules mozilla mp3 mp4 mpd mpeg mudflap multilib mysql nautilus ncurses networkmanager nls nokia nptl nss ntp ogg opengl openmp pam pcre pdf pidgin png policykit pppd qt3support readline samba sdl session sna sound spell sqlite sqlite3 sse sse2 ssl subversion svg syslog system-sqlite tcpd theora threads tiff timidity truetype udev unicode upnp usb vorbis wavpack weather wifi x264 xcb xml xpm xulrunner xv xvmc youtube zeroconf zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump" CAMERAS="canon" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="evdev synaptics" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LINGUAS="en ru uk" PHP_TARGETS="php5-3" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7" QEMU_SOFTMMU_TARGETS="arm x86_64" QEMU_USER_TARGETS="arm" RUBY_TARGETS="ruby18 ruby19" USERLAND="GNU" VIDEO_CARDS="intel i965" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
USE_PYTHON="2.7 3.2"

Last edited by inkUA on Wed May 01, 2013 7:02 am; edited 1 time in total
Back to top
View user's profile Send private message

Joined: 18 Jan 2013
Posts: 4

PostPosted: Mon Jan 21, 2013 8:11 pm    Post subject: Reply with quote

I've moved to X input, but still want to resolve this. The last thing I did was running
ibus-daemon -rxv

Which printed a couple out warnings, I managed to resolve most of them, but it's hard to say what two of these are about
(ibus-daemon:29839): IBUS-WARNING **: 20:45:44.519183: Parse buffer failed: Error on line 1 char 1: Document was empty or contained only whitespace

** (ibus-dconf:29845): WARNING **: unknown dconf database description: systemd-db:ibus

As far as I know using systemd is optional.
Back to top
View user's profile Send private message

Joined: 18 Jan 2013
Posts: 4

PostPosted: Wed May 01, 2013 7:00 am    Post subject: Reply with quote

Found what was the problem finally, I didn't have gnome-settings-daemon running. Set
in ~/.config/autostart/gnome-settings-daemon.desktop (since this entry is hidden in gnome-session-properties).

The thread may be marked as RESOLVED now, I guess.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum