Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[solved] gnucash locks up X
View unanswered posts
View posts from last 24 hours

Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message

Joined: 24 Nov 2003
Posts: 11
Location: Orange CT

PostPosted: Mon Jan 14, 2013 3:03 am    Post subject: [solved] gnucash locks up X Reply with quote

I ran a system update this weekend, and now gnucash is locking up X whenever I click on a button that pops up a list (e.g. the button to select a date on an entry in an account register window). I can ssh into the box after it's locked and top's not showing excessive CPU load. I tried killing everything related to gnucash or X, and all the processes go away except the X server which doesn't respond to kill or kill -9. Also, issuing a chvt as root in the ssh session hangs as well (but responds to ^C) so I can't switch away from the X session.

Gnucash itself wasn't updated (at v2.4.10 since late last year) but there were updates to X drivers and libs. I tried rebuilding gnucash and guile (along with media-libs/glu, media-libs/mesa and x11-libs/motif - had got a file collision warning for that didn't show up when rebuilt) but still getting the same result. Anyone else seeing similar behavior?

`emerge --info' output included below.


# emerge --info app-office/gnucash
Portage (default/linux/x86/10.0/desktop/gnome, gcc-4.5.4, glibc-2.15-r3, 2.6.36-gentoo-r8 i686)
                         System Settings
System uname: Linux-2.6.36-gentoo-r8-i686-Intel-R-_Atom-TM-_CPU_N450_@_1.66GHz-with-gentoo-2.1
Timestamp of tree: Sun, 13 Jan 2013 23:30:01 +0000
ld GNU ld (GNU Binutils) 2.22
app-shells/bash:          4.2_p37
dev-java/java-config:     2.1.11-r3
dev-lang/python:          2.7.3-r2, 3.2.3
dev-util/cmake:           2.8.9
dev-util/pkgconfig:       0.27.1
sys-apps/baselayout:      2.1-r1
sys-apps/openrc:          0.11.8
sys-apps/sandbox:         2.5
sys-devel/autoconf:       2.13, 2.69
sys-devel/automake:       1.9.6-r3, 1.10.3, 1.11.6
sys-devel/binutils:       2.22-r1
sys-devel/gcc:            4.5.4, 4.6.3
sys-devel/gcc-config:     1.7.3
sys-devel/libtool:        2.4-r1
sys-devel/make:           3.82-r4
sys-kernel/linux-headers: 3.6 (virtual/os-headers)
sys-libs/glibc:           2.15-r3
Repositories: gentoo
CFLAGS="-O2 -march=prescott -pipe -fomit-frame-pointer"
CONFIG_PROTECT="/etc /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-O2 -march=prescott -pipe -fomit-frame-pointer"
FCFLAGS="-O2 -march=i686 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch"
FFLAGS="-O2 -march=i686 -pipe"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
USE="X a52 aac acl acpi alsa berkdb branding bzip2 cairo cdda cdr cli colord consolekit cracklib crypt cups cxx dbus dga dri dts dvd dvdr eds emboss encode evo exif fam fbcon firefox flac fortran gdbm gif gnome gnome-keyring gnome-online-accounts gpm gstreamer gtk iconv jpeg lcms ldap libnotify mad mmx mng modules mp3 mp4 mpeg mudflap nautilus ncurses nls nptl nptlonly ogg opengl openmp pam pango pcre pdf png policykit ppds pppd pulseaudio qt3support readline sdl session socialweb spell sse sse2 ssl startup-notification svg tcpd tiff truetype udev udisks unicode upower usb vorbis wxwidgets x264 x86 xcb xml xv xvid zlib" ALSA_CARDS="hda-intel" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump" CAMERAS="canon" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="evdev synaptics" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LINGUAS="en" PHP_TARGETS="php5-3" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_2" RUBY_TARGETS="ruby18 ruby19" SANE_BACKENDS="canon pixma" USERLAND="GNU" VIDEO_CARDS="intel fbdev" XFCE_PLUGINS="trash menu brightness logout clock" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"

                        Package Settings

app-office/gnucash-2.4.10 was built with the following:
USE="cxx doc ofx -chipcard -debug -hbci -mysql -postgres -python -quotes -sqlite -webkit"

Last edited by svartulf on Tue Jan 15, 2013 2:48 pm; edited 1 time in total
Back to top
View user's profile Send private message

Joined: 31 Dec 2004
Posts: 1341

PostPosted: Mon Jan 14, 2013 5:50 am    Post subject: Reply with quote

Have you run revdep-rebuild and python-updater?
I suspect it is one of these:
 * dependency graph for app-office/gnucash-2.4.10
 `--  app-office/gnucash-2.4.10  x86
   `--  dev-libs/glib-2.32.4-r1  (>=dev-libs/glib-2.13) x86
   `--  dev-libs/popt-1.16-r1  (>=dev-libs/popt-1.5) x86
   `--  dev-libs/libxml2-2.8.0-r3  (>=dev-libs/libxml2-2.5.10) x86
   `--  dev-scheme/guile-1.8.8-r1  (>=dev-scheme/guile-1.8.3) x86  [deprecated regex]
   `--  dev-scheme/guile-www-2.34  (dev-scheme/guile-www) x86
   `--  dev-scheme/slib-3.1.5-r1  (>=dev-scheme/slib-3.1.4) x86
   `--  gnome-base/gconf-2.32.4  (>=gnome-base/gconf-2) x86
   `--  gnome-base/libgnomeui-2.24.5  (>=gnome-base/libgnomeui-2.4) x86
   `--  gnome-base/libglade-2.6.4  (>=gnome-base/libglade-2.4) x86
   `--  gnome-base/libgnome-keyring-2.32.0  (gnome-base/libgnome-keyring) x86
   `--  media-libs/libart_lgpl-2.3.21-r1  (media-libs/libart_lgpl) x86
   `--  sys-libs/zlib-1.2.7  (>=sys-libs/zlib-1.1.4) x86
   `--  x11-libs/gtk+-2.24.12  (>=x11-libs/gtk+-2.14) x86
   `--  x11-libs/goffice-0.8.17-r1  (x11-libs/goffice) x86  [gnome]
   `--  x11-libs/pango-1.30.1  (x11-libs/pango) x86

Donate to Gentoo
Back to top
View user's profile Send private message

Joined: 05 Aug 2006
Posts: 2152
Location: Berlin, Germany

PostPosted: Mon Jan 14, 2013 12:23 pm    Post subject: Reply with quote

This could be a graphics driver issue. Your kernel is rather old and will probably not work very well with current xf86-video-intel.

If upgrading the kernel to the latest stable version does not help, you can try one or more of the following:
  • start gnucash with LIBGL_ALWAYS_SOFTWARE=1
  • Use uxa acceleration instead of sna for xf86-video-intel
  • Disable any kind of compositing window manager
  • Use xf86-video-vesa/fbdev/modesetting driver instead of xf86-video-intel

The outcome of the above may help in isolating the issue.
Back to top
View user's profile Send private message

Joined: 24 Nov 2003
Posts: 11
Location: Orange CT

PostPosted: Tue Jan 15, 2013 2:47 pm    Post subject: [solved] gnucash locks up X Reply with quote

chithanh wrote:
This could be a graphics driver issue. Your kernel is rather old and will probably not work very well with current xf86-video-intel.

Upgrading the kernel fix it. Thanks --
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum