Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
No vdpau used with vlc
View unanswered posts
View posts from last 24 hours

Goto page 1, 2  Next  
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message
Wallsandfences
Apprentice
Apprentice


Joined: 29 Mar 2010
Posts: 163

PostPosted: Tue Jan 01, 2013 9:42 pm    Post subject: No vdpau used with vlc Reply with quote

Hi,
I have a nvidia GT520, a successfully working nvidia driven Gnome 3.4, Kernel 3.7.1

I am missing the vdpau (hardware acceleratd video playback). On a quadcore AMD, top indicates an estimate of 30% cpu time, and 'use GPU acceleration' in vlc is greyed out.

The card seems to work ok, the desktop effects are smooth, and nvidias setting tool is working fine.

How can I proceed?

Code:
 vdpauinfo
display: :0   screen: 0
API version: 1
Information string: NVIDIA VDPAU Driver Shared Library  310.19  Thu Nov  8 01:15:18 PST 2012

Video surface:

name   width height types
-------------------------------------------
420     4096  4096  NV12 YV12
422     4096  4096  UYVY YUYV

Decoder capabilities:

name               level macbs width height
-------------------------------------------
MPEG1                 0  8192  2048  2048
MPEG2_SIMPLE          3  8192  2048  2048
MPEG2_MAIN            3  8192  2048  2048
H264_MAIN            41  8192  2048  2048
H264_HIGH            41  8192  2048  2048
VC1_SIMPLE            1  8190  2048  2048
VC1_MAIN              2  8190  2048  2048
VC1_ADVANCED          4  8190  2048  2048
MPEG4_PART2_SP        3  8192  2048  2048
MPEG4_PART2_ASP       5  8192  2048  2048
DIVX4_QMOBILE         0  8192  2048  2048
DIVX4_MOBILE          0  8192  2048  2048
DIVX4_HOME_THEATER    0  8192  2048  2048
DIVX4_HD_1080P        0  8192  2048  2048
DIVX5_QMOBILE         0  8192  2048  2048
DIVX5_MOBILE          0  8192  2048  2048
DIVX5_HOME_THEATER    0  8192  2048  2048
DIVX5_HD_1080P        0  8192  2048  2048

Output surface:

name              width height nat types
----------------------------------------------------
B8G8R8A8         16384 16384    y  Y8U8V8A8 V8U8Y8A8
R10G10B10A2      16384 16384    y  Y8U8V8A8 V8U8Y8A8

Bitmap surface:

name              width height
------------------------------
B8G8R8A8         16384 16384
R8G8B8A8         16384 16384
R10G10B10A2      16384 16384
B10G10R10A2      16384 16384
A8               16384 16384

Video mixer:

feature name                    sup
------------------------------------
DEINTERLACE_TEMPORAL             y
DEINTERLACE_TEMPORAL_SPATIAL     y
INVERSE_TELECINE                 y
NOISE_REDUCTION                  y
SHARPNESS                        y
LUMA_KEY                         y
HIGH QUALITY SCALING - L1        y
HIGH QUALITY SCALING - L2        -
HIGH QUALITY SCALING - L3        -
HIGH QUALITY SCALING - L4        -
HIGH QUALITY SCALING - L5        -
HIGH QUALITY SCALING - L6        -
HIGH QUALITY SCALING - L7        -
HIGH QUALITY SCALING - L8        -
HIGH QUALITY SCALING - L9        -

parameter name                  sup      min      max
-----------------------------------------------------
VIDEO_SURFACE_WIDTH              y         1     4096
VIDEO_SURFACE_HEIGHT             y         1     4096
CHROMA_TYPE                      y 
LAYERS                           y         0        4

attribute name                  sup      min      max
-----------------------------------------------------
BACKGROUND_COLOR                 y 
CSC_MATRIX                       y 
NOISE_REDUCTION_LEVEL            y      0.00     1.00
SHARPNESS_LEVEL                  y     -1.00     1.00
LUMA_KEY_MIN_LUMA                y 
LUMA_KEY_MAX_LUMA                y 


ruediger@eg-server ~ $


Xorg.0.log:

http://pastebin.com/BdscXCf7

Rüdiger
Back to top
View user's profile Send private message
_______0
Guru
Guru


Joined: 15 Oct 2012
Posts: 521

PostPosted: Wed Jan 02, 2013 1:17 am    Post subject: Reply with quote

turn on vaapi USE flag, maybe. I just installed vlc and is not grayed out.
Back to top
View user's profile Send private message
DaggyStyle
Advocate
Advocate


Joined: 22 Mar 2006
Posts: 4883

PostPosted: Wed Jan 02, 2013 6:16 am    Post subject: Reply with quote

_______0 wrote:
turn on vaapi USE flag, maybe. I just installed vlc and is not grayed out.


not related, vaapi and vdpau are two different none related implementations for gpu hw decoding.

Wallsandfences, check if opengl points to nvidia, not sure how this can work but on nvidia gpus, opengl must points to nvidia.
_________________
Only two things are infinite, the universe and human stupidity and I'm not sure about the former - Albert Einstein
ProjectFootball
Back to top
View user's profile Send private message
Wallsandfences
Apprentice
Apprentice


Joined: 29 Mar 2010
Posts: 163

PostPosted: Wed Jan 02, 2013 7:59 am    Post subject: Reply with quote

Hi,

vaapi is for intel graphics.
opengl is switched to nvidia during the emerge of nvidia-drivers. I just re-checked, and it is enabled.

Code:
eselect opengl list
Available OpenGL implementations:
  [1]   nvidia *
  [2]   xorg-x11


Rüdiger
Back to top
View user's profile Send private message
DaggyStyle
Advocate
Advocate


Joined: 22 Mar 2006
Posts: 4883

PostPosted: Wed Jan 02, 2013 9:06 am    Post subject: Reply with quote

Wallsandfences wrote:
Hi,

vaapi is for intel graphics.
opengl is switched to nvidia during the emerge of nvidia-drivers. I just re-checked, and it is enabled.

Code:
eselect opengl list
Available OpenGL implementations:
  [1]   nvidia *
  [2]   xorg-x11


Rüdiger


can you post the output of emerge --info vlc?
does it works with other players?
_________________
Only two things are infinite, the universe and human stupidity and I'm not sure about the former - Albert Einstein
ProjectFootball
Back to top
View user's profile Send private message
Wallsandfences
Apprentice
Apprentice


Joined: 29 Mar 2010
Posts: 163

PostPosted: Wed Jan 02, 2013 9:39 am    Post subject: Reply with quote

Hi,

It does not work with totem, as well. I have no other players.
Code:
emerge --info vlc
Portage 2.1.11.38 (default/linux/amd64/10.0/desktop/gnome, gcc-4.6.3, glibc-2.16.0, 3.7.1-gentoo x86_64)
=================================================================
                         System Settings
=================================================================
System uname: Linux-3.7.1-gentoo-x86_64-AMD_Athlon-tm-_II_X4_630_Processor-with-gentoo-2.2
Timestamp of tree: Tue, 25 Dec 2012 21:45:01 +0000
ld GNU ld (GNU Binutils) 2.23.1
app-shells/bash:          4.2_p39-r1
dev-java/java-config:     2.1.12-r1
dev-lang/python:          2.7.3-r3, 3.2.3-r2
dev-util/cmake:           2.8.10.2
dev-util/pkgconfig:       0.27.1
sys-apps/baselayout:      2.2
sys-apps/openrc:          0.11.8
sys-apps/sandbox:         2.6
sys-devel/autoconf:       2.13, 2.69
sys-devel/automake:       1.10.3, 1.11.6, 1.12.6
sys-devel/binutils:       2.23.1
sys-devel/gcc:            4.6.3
sys-devel/gcc-config:     1.8
sys-devel/libtool:        2.4.2
sys-devel/make:           3.82-r4
sys-kernel/linux-headers: 3.7 (virtual/os-headers)
sys-libs/glibc:           2.16.0
Repositories: gentoo sabayon
ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="* -@EULA"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-O2 -march=k8 -pipe -fomit-frame-pointer"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/gnupg/qualified.txt /var/lib/hsqldb"
CONFIG_PROTECT_MASK="${EPREFIX}/etc/gconf /etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5.4/ext-active/ /etc/php/cgi-php5.4/ext-active/ /etc/php/cli-php5.4/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-O2 -march=k8 -pipe -fomit-frame-pointer"
DISTDIR="/usr/portage/distfiles"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="http://mirror.netcologne.de/gentoo/"
LANG="de_DE.utf8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j5"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/var/lib/layman/sabayon"
SYNC="rsync://rsync5.de.gentoo.org/gentoo-portage"
USE="(-selinux) X a52 aac acl acpi alsa amd64 apache2 berkdb bluetooth branding bzip2 cairo cdda cdr cli colord consolekit cracklib crypt cups cxx dbus dri dts dvd dvdr eds emboss encode evo exif fam ffh264vdpau firefox flac fortran g3dvl gdbm gif gnome gnome-keyring gnome-online-accounts gpm gstreamer gtk iconv ipv6 jpeg lcms libnotify libsamplerate lm_sensors mad mmx mng modules mp3 mp4 mpeg mudflap multilib mysql nautilus ncurses nls nptl nvidia ogg opengl openmp pam pango pcre pdf php pipe png policykit ppds pppd pulseaudio python qt3support qt4 readline sdl session socialweb spell sse sse2 ssl startup-notification svg tcpd threads tiff truetype udev udisks unicode upower usb vdpau vorbis wxwidgets x264 xcb xml xmvc xv xvid zlib" ALSA_CARDS="rme96" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic auth_digest authn_anon authn_dbd authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile unixd socache_shmcb authn_core authz_core authm_core authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock dbd deflate dir disk_cache env expires ext_filter file_cache filter headers ident imagemap include info log_config logio mem_cache mime mime_magic negotiation proxy proxy_ajp proxy_balancer proxy_connect proxy_http rewrite setenvif speling status unique_id userdir usertrack vhost_alias mod_access xml python nls ubicode postgres cgi cgid" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LINGUAS="de" PHP_TARGETS="php5-3" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_2" RUBY_TARGETS="ruby18 ruby19" USERLAND="GNU" VIDEO_CARDS="nvidia" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, USE_PYTHON

=================================================================
                        Package Settings
=================================================================

media-video/vlc-2.0.5 was built with the following:
USE="X a52 aac alsa avcodec avformat cdda dbus dts dvbpsi dvd encode ffmpeg flac gcrypt gnome libnotify libsamplerate mmx mp3 mpeg (multilib) ncurses ogg opengl png postproc pulseaudio qt4 sdl sse svg swscale truetype udev vorbis x264 xcb xml xv -aalib (-altivec) -atmo (-audioqueue) -avahi -bidi -bluray -cddb -dc1394 -debug -dirac (-direct2d) -directfb (-directx) (-dshow) -dvb (-dxva2) -egl -fbosd -fluidsynth -fontconfig -gme -gnutls -growl -httpd -ieee1394 (-ios-vout) -jack -kate -kde -libass -libcaca -libproxy -libtar -libtiger -linsys -lirc -live -lua (-macosx) (-macosx-audio) (-macosx-dialog-provider) (-macosx-eyetv) (-macosx-qtkit) (-macosx-quartztext) (-macosx-vout) -matroska (-media-library) -modplug -mtp -musepack (-neon) -omxil -optimisememory -opus -oss -portaudio -projectm -pvr -rtsp -run-as-root -samba -schroedinger -sdl-image -shine -shout -sid -skins -speex -sqlite -switcher -taglib -theora -twolame -upnp -v4l -vaapi -vcdx -vlm (-waveout) (-win32codecs) (-wingdi) -wma-fixed -xosd -zvbi"


The vdpau is done via ffmpeg, I guess
Code:
media-video/ffmpeg-0.10.6 was built with the following:
USE="X aac alsa bzip2 encode hardcoded-tables mmx mp3 (multilib) pulseaudio sdl threads truetype vdpau vorbis x264 xvid zlib -3dnow -3dnowext -aacplus (-altivec) -amr -avx -bindist -cdio (-celt) -cpudetection -debug -dirac -doc -faac -frei0r -gnutls -gsm -ieee1394 -jack -jpeg2k -libass -libv4l -mmxext -modplug (-neon) -network -openal -openssl -oss -pic -rtmp -schroedinger -speex -ssse3 -static-libs -test -theora -v4l -vaapi (-vis) -vpx" FFTOOLS="aviocat cws2fws ffeval graph2dot ismindex pktdumper qt-faststart trasher"


Rüdiger
Back to top
View user's profile Send private message
_______0
Guru
Guru


Joined: 15 Oct 2012
Posts: 521

PostPosted: Wed Jan 02, 2013 9:56 am    Post subject: Reply with quote

did you add yourself to the video group? And possibly set "eselect xvmc" to nvidia. Triple check ALL USE flags are set to nvidia and vdpau properly.
Back to top
View user's profile Send private message
Wallsandfences
Apprentice
Apprentice


Joined: 29 Mar 2010
Posts: 163

PostPosted: Wed Jan 02, 2013 10:01 am    Post subject: Reply with quote

Hi,
of course, without the user being member of 'video', one could not log in to gnome 3.

vdpau and nvidia are set globally in make.conf

But:

Code:
eselect xvmc list
!!! Error: Can't load module xvmc
exiting


Rüdiger
Back to top
View user's profile Send private message
Wallsandfences
Apprentice
Apprentice


Joined: 29 Mar 2010
Posts: 163

PostPosted: Wed Jan 02, 2013 10:16 am    Post subject: Reply with quote

OK, I corrected the use flag in make.conf and ran emerge -avuDN @world, but I get:

Code:
 eselect xvmc set nvidia
Switching to nvidia XvMC implementation... done
eg-server rudi # eselect xvmc list
Available XvMC implementations  ( * is current ):
  [1]   xorg-x11
eg-server rudi #


Hardware encoding stll does not work.

Rüdiger
Back to top
View user's profile Send private message
DaggyStyle
Advocate
Advocate


Joined: 22 Mar 2006
Posts: 4883

PostPosted: Wed Jan 02, 2013 11:30 am    Post subject: Reply with quote

Wallsandfences wrote:
OK, I corrected the use flag in make.conf and ran emerge -avuDN @world, but I get:

Code:
 eselect xvmc set nvidia
Switching to nvidia XvMC implementation... done
eg-server rudi # eselect xvmc list
Available XvMC implementations  ( * is current ):
  [1]   xorg-x11
eg-server rudi #


Hardware encoding stll does not work.

Rüdiger


set it to 1, also install mplayer and try playing the file using vdpau on mplayer
_________________
Only two things are infinite, the universe and human stupidity and I'm not sure about the former - Albert Einstein
ProjectFootball
Back to top
View user's profile Send private message
Mr_Maniac
Guru
Guru


Joined: 10 Jun 2004
Posts: 534

PostPosted: Wed Jan 02, 2013 11:54 am    Post subject: Reply with quote

AFAIK, "vaapi" is not limited to Intel-GPUs, even if it was developed for them. There's also an backend-module to use vdpau (Okay... An API that uses an API...), so that vaapi's more like a wrapper in this case.
So VLC uses vaapi to accelerate video-playback and vaapi just has to use vdpau. Works for me at home.
_________________
Intel Core2Quad Q9450
MSI P35 Neo2-FR
4GB DDR2-800 RAM - Dual Channel
SB X-Fi Fatality Gamer
GeForce GTX 460
Gentoo Linux (kernel 2.6.x (was gerade stable im Portage ist ;) ), amd64, Stage 1)
Windows 7 x64
Windows XP x64 SP2
Back to top
View user's profile Send private message
Wallsandfences
Apprentice
Apprentice


Joined: 29 Mar 2010
Posts: 163

PostPosted: Wed Jan 02, 2013 12:01 pm    Post subject: Reply with quote

Ok, it works with mplayer, top indicates 2.7% cpu time. VLC still does not work. (Why is 3dnow disabled?)

Code:
MPlayer 1.1-4.6.3 (C) 2000-2012 MPlayer Team
MMX2 supported but disabled
3DNow supported but disabled
3DNowExt supported but disabled

Spiele /daten/gemeinsameordner/filme/film.mkv
libavformat version 53.32.100 (external)
libavformat-Dateiformat erkannt!
[lavf] stream 0: video (h264), -vid 0
[lavf] stream 1: audio (aac), -aid 0, -alang eng
VIDEO:  [H264]  720x432  0bpp  25.000 fps    0.0 kbps ( 0.0 kbyte/s)
Load subtitles in /daten/gemeinsameordner/filme/Day after tomorrow_mkv/
==========================================================================
Erzwungener Videocodec: ffh264vdpau
Öffne Videodecoder: [ffmpeg] FFmpeg's libavcodec codec family
libavcodec version 53.61.100 (external)
Ausgewählter Videocodec: [ffh264vdpau] vfm: ffmpeg (FFmpeg H.264 (VDPAU))
==========================================================================
==========================================================================
Öffne Audiodecoder: [ffmpeg] FFmpeg/libavcodec audio decoders
AUDIO: 48000 Hz, 2 ch, s16le, 0.0 kbit/0.00% (ratio: 0->192000)
Ausgewählter Audiocodec: [ffaac] afm: ffmpeg (FFmpeg AAC (MPEG-2/MPEG-4 Audio))
==========================================================================
AO: [alsa] 48000Hz 2ch s16le (2 bytes per sample)
Starte Wiedergabe...
[VD_FFMPEG] Versuche pixfmt=0.
Film-Aspekt ist 2.37:1 - Vorskalierung zur Korrektur der Seitenverhältnisse.
VO: [vdpau] 720x432 => 1024x432 H.264 VDPAU acceleration
[VD_FFMPEG] XVMC-beschleunigtes MPEG-2.
Back to top
View user's profile Send private message
Wallsandfences
Apprentice
Apprentice


Joined: 29 Mar 2010
Posts: 163

PostPosted: Wed Jan 02, 2013 12:13 pm    Post subject: Reply with quote

But, I have to force the use of the codecs with
Code:
mplayer -vo vdpau -vc ffh264vdpau


or it runs with software decoding.

Rüdiger
Back to top
View user's profile Send private message
Wallsandfences
Apprentice
Apprentice


Joined: 29 Mar 2010
Posts: 163

PostPosted: Wed Jan 02, 2013 12:22 pm    Post subject: Reply with quote

Now, with vaapi enabled, vlc pretends to use hardware acc:

Code:
 vlc
VLC media player 2.0.5 Twoflower (revision 2.0.5-0-g1661b7d)
[0x14d6108] main libvlc: VLC wird mit dem Standard-Interface ausgeführt. Benutzen Sie 'cvlc', um VLC ohne Interface zu verwenden.
[0x15a21b8] qt4 interface error: Unable to load extensions module
[0x14e9928] main playlist: stopping playback
libva info: VA-API version 0.33.0
libva info: va_getDriverName() returns 0
libva info: Trying to open /usr/lib64/va/drivers/nvidia_drv_video.so
libva info: Found init function __vaDriverInit_0_33
libva info: va_openDriver() returns 0
[0x7f8850c02ca8] avcodec decoder: Using VA API version 0.33 for hardware decoding.


cpu-usage is still somewhat high, around 16%. Is this the penalty one pays for vlc's versatility or is somesthing still wrong?

Rüdiger
Back to top
View user's profile Send private message
DaggyStyle
Advocate
Advocate


Joined: 22 Mar 2006
Posts: 4883

PostPosted: Wed Jan 02, 2013 12:45 pm    Post subject: Reply with quote

it should work with vdpau regardless if vaapi is set or not.
as said before vaapi and vdpau are competing protocols over the same outcome, see:
http://en.wikipedia.org/wiki/Video_Acceleration_API#Supported_hardware_and_drivers

vaapi has a wapper that converts it from vaapi calls to vdpau calls.
the poc of mplayer + ffmepg shows it, what is the gpu driver's version?
_________________
Only two things are infinite, the universe and human stupidity and I'm not sure about the former - Albert Einstein
ProjectFootball
Back to top
View user's profile Send private message
Wallsandfences
Apprentice
Apprentice


Joined: 29 Mar 2010
Posts: 163

PostPosted: Wed Jan 02, 2013 12:47 pm    Post subject: Reply with quote

I'm using the latest nividia-drivers from portage,
Code:
x11-drivers/nvidia-drivers-310.19


Rüdiger
Back to top
View user's profile Send private message
Gusar
Advocate
Advocate


Joined: 09 Apr 2005
Posts: 2633
Location: Slovenia

PostPosted: Wed Jan 02, 2013 1:05 pm    Post subject: Reply with quote

https://forums.gentoo.org/viewtopic-p-7152098.html#7152098
Back to top
View user's profile Send private message
Wallsandfences
Apprentice
Apprentice


Joined: 29 Mar 2010
Posts: 163

PostPosted: Wed Jan 02, 2013 1:53 pm    Post subject: Reply with quote

I have diffitulties to understand all of the linked thread, and if it is related to my problem.
Further testing showed, that mplayer does not play all my videos. Also, is tough to set options, without interface. VLC seems to, but with high cpu load.

Totem still does software decoding.

Rüdiger
Back to top
View user's profile Send private message
Gusar
Advocate
Advocate


Joined: 09 Apr 2005
Posts: 2633
Location: Slovenia

PostPosted: Wed Jan 02, 2013 1:55 pm    Post subject: Reply with quote

You don't have any "problem". As that thread explains, VLC and mplayer simply work differently.
Back to top
View user's profile Send private message
Wallsandfences
Apprentice
Apprentice


Joined: 29 Mar 2010
Posts: 163

PostPosted: Wed Jan 02, 2013 1:59 pm    Post subject: Reply with quote

I disagree.. Because with all I know, totem should play hardware decoding, and mplayer should play all my files, no? VLC might not be able to use the graphic driver completly due to it's internal design or different desgin goals, ok.

Rüdiger
Back to top
View user's profile Send private message
Gusar
Advocate
Advocate


Joined: 09 Apr 2005
Posts: 2633
Location: Slovenia

PostPosted: Wed Jan 02, 2013 2:24 pm    Post subject: Reply with quote

I'm not aware of Gstreamer (which Totem uses) having VDPAU support.
Back to top
View user's profile Send private message
Mr_Maniac
Guru
Guru


Joined: 10 Jun 2004
Posts: 534

PostPosted: Wed Jan 02, 2013 3:15 pm    Post subject: Reply with quote

VLC does NOT directly use vdpau! It only uses vaapi which can redirect to vdpau!

From http://en.wikipedia.org/wiki/VDPAU:
Quote:
VDPAU can also be used as a backend for the Video Acceleration API (VA API) which itself covers a subset of VDPAU's capabilities; so any software that supports VA API also partly supports VDPAU (e.g., VLC media player).


So you need vaapi with the correct use-flag (vdpau or nvidia?)

EDIT: Not USE-Flag... VIDEO_CARDS:

Quote:

x11-libs/libva-vdpau-driver-0.7.3 USE="opengl -debug" 0 kB

x11-libs/libva-1.0.15 USE="opengl" VIDEO_CARDS="nvidia -dummy -fglrx -intel"

media-video/ffmpeg-0.10.6 USE="X aac aacplus alsa amr bzip2 dirac encode faac hardcoded-tables jpeg2k libass mmx mmxext modplug mp3 openal rtmp schroedinger sdl speex ssse3 theora threads truetype vaapi vdpau vorbis vpx x264 xvid zlib -3dnow -3dnowext (-altivec) -avx -bindist -cdio (-celt) -cpudetection -debug -doc -frei0r -gnutls -gsm -ieee1394 -jack -libv4l (-neon) -network -openssl -oss -pic -pulseaudio -static-libs {-test} -v4l (-vis)" FFTOOLS="aviocat cws2fws ffeval graph2dot ismindex pktdumper qt-faststart trasher"

media-video/vlc-2.0.5 USE="X a52 aac alsa avcodec avformat bluray cdda cddb dbus dirac dts dvb dvbpsi dvd encode ffmpeg flac fluidsynth gcrypt libass matroska mmx modplug mp3 mpeg ncurses ogg opengl opus png postproc projectm qt4 rtsp samba schroedinger sdl speex sse svg swscale theora truetype vaapi vorbis x264 xcb xml xv -aalib (-altivec) -atmo (-audioqueue) -avahi -bidi -dc1394 -debug (-direct2d) -directfb (-directx) (-dshow) (-dxva2) -egl -fbosd -fontconfig -gme -gnome -gnutls -growl -httpd -ieee1394 (-ios-vout) -jack -kate -kde -libcaca -libnotify -libproxy -libsamplerate -libtar -libtiger -linsys -lirc -live -lua (-macosx) (-macosx-audio) (-macosx-dialog-provider) (-macosx-eyetv) (-macosx-qtkit) (-macosx-quartztext) (-macosx-vout) (-media-library) -mtp -musepack (-neon) -omxil -optimisememory -oss -portaudio -pulseaudio -pvr -run-as-root -sdl-image -shine -shout -sid -skins -sqlite -switcher -taglib -twolame -udev -upnp -v4l -vcdx -vlm (-waveout) (-win32codecs) (-wingdi) -wma-fixed -xosd -zvbi"

_________________
Intel Core2Quad Q9450
MSI P35 Neo2-FR
4GB DDR2-800 RAM - Dual Channel
SB X-Fi Fatality Gamer
GeForce GTX 460
Gentoo Linux (kernel 2.6.x (was gerade stable im Portage ist ;) ), amd64, Stage 1)
Windows 7 x64
Windows XP x64 SP2
Back to top
View user's profile Send private message
Wallsandfences
Apprentice
Apprentice


Joined: 29 Mar 2010
Posts: 163

PostPosted: Wed Jan 02, 2013 5:48 pm    Post subject: Reply with quote

OK, then what I have is considered state of the art?

Code:
media-video/ffmpeg-0.10.6 was built with the following:
USE="X aac alsa bzip2 encode hardcoded-tables mmx mp3 (multilib) pulseaudio sdl threads truetype vaapi vdpau vorbis x264 xvid zlib -3dnow -3dnowext -aacplus (-altivec) -amr -avx -bindist -cdio (-celt) -cpudetection -debug -dirac -doc -faac -frei0r -gnutls -gsm -ieee1394 -jack -jpeg2k -libass -libv4l -mmxext -modplug (-neon) -network -openal -openssl -oss -pic -rtmp -schroedinger -speex -ssse3 -static-libs -test -theora -v4l (-vis) -vpx" FFTOOLS="aviocat cws2fws ffeval graph2dot ismindex pktdumper qt-faststart trasher"


media-video/vlc-2.0.5 was built with the following:
USE="X a52 aac alsa avcodec avformat cdda dbus dts dvbpsi dvd encode ffmpeg flac gcrypt gnome libnotify libsamplerate mmx mp3 mpeg (multilib) ncurses ogg opengl png postproc pulseaudio qt4 sdl sse svg swscale truetype udev vaapi vorbis x264 xcb xml xv -aalib (-altivec) -atmo (-audioqueue) -avahi -bidi -bluray -cddb -dc1394 -debug -dirac (-direct2d) -directfb (-directx) (-dshow) -dvb (-dxva2) -egl -fbosd -fluidsynth -fontconfig -gme -gnutls -growl -httpd -ieee1394 (-ios-vout) -jack -kate -kde -libass -libcaca -libproxy -libtar -libtiger -linsys -lirc -live -lua (-macosx) (-macosx-audio) (-macosx-dialog-provider) (-macosx-eyetv) (-macosx-qtkit) (-macosx-quartztext) (-macosx-vout) -matroska (-media-library) -modplug -mtp -musepack (-neon) -omxil -optimisememory -opus -oss -portaudio -projectm -pvr -rtsp -run-as-root -samba -schroedinger -sdl-image -shine -shout -sid -skins -speex -sqlite -switcher -taglib -theora -twolame -upnp -v4l -vcdx -vlm (-waveout) (-win32codecs) (-wingdi) -wma-fixed -xosd -zvbi"


x11-libs/libva-1.1.0 was built with the following:
USE="X (multilib) opengl -egl -wayland" VIDEO_CARDS="nvidia -dummy -fglrx -intel"


x11-libs/libva-vdpau-driver-0.7.4 was built with the following:
USE="(multilib) opengl -debug"


Rüdiger
Back to top
View user's profile Send private message
Gusar
Advocate
Advocate


Joined: 09 Apr 2005
Posts: 2633
Location: Slovenia

PostPosted: Wed Jan 02, 2013 7:04 pm    Post subject: Reply with quote

x11-libs/libva-vdpau-driver
Back to top
View user's profile Send private message
Wallsandfences
Apprentice
Apprentice


Joined: 29 Mar 2010
Posts: 163

PostPosted: Wed Jan 02, 2013 7:06 pm    Post subject: Reply with quote

Sorry, I don't get it
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Goto page 1, 2  Next
Page 1 of 2

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum