Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
issues with qgis-1.7.x and pyqt4-4.9.x
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
donc_oe
n00b
n00b


Joined: 26 Feb 2012
Posts: 8

PostPosted: Sun Dec 30, 2012 6:26 pm    Post subject: issues with qgis-1.7.x and pyqt4-4.9.x Reply with quote

i want to emerge qgis-1.7.4 on my machine.
Code:
~ # uname -a
Linux host 3.7.0-sabayon #1 SMP Thu Dec 20 07:12:55 UTC 2012 x86_64 AMD Athlon(tm) 64 X2 Dual Core Processor 5200+ AuthenticAMD GNU/Linux

but it seems version 1.7.4 has unmet dependencies:
Code:
!!! The following update has been skipped due to unsatisfied dependencies:

sci-geosciences/qgis:0

emerge: there are no ebuilds to satisfy "<dev-python/PyQt4-4.9[X,sql,svg]".
(dependency required by "sci-geosciences/qgis-1.7.4[python]" [ebuild])

that's the first issue: where can i find dev-python/PyQt4 < 4.9 with[X,sql,svg] to install qgis-1.7.4? there is no pyqt4 with version lower than 4.9 in portage anymore. should i report this as a bug?

and the second is that the older release version 1.7.0 fails to compile.
Code:
These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild   R    ] sci-geosciences/qgis-1.7.0  USE="grass* python*"
...
Code:
[ 85%] Built target qgis
make: *** [all] Error 2
emake failed
 * ERROR: sci-geosciences/qgis-1.7.0 failed (compile phase):
 *   Make failed!
 *
 * Call stack:
 *     ebuild.sh, line   93:  Called src_compile
 *   environment, line 5422:  Called cmake-utils_src_compile
 *   environment, line 1369:  Called _execute_optionaly 'src_compile'
 *   environment, line  422:  Called enable_cmake-utils_src_compile
 *   environment, line 1608:  Called cmake-utils_src_make
 *   environment, line 1394:  Called die
 * The specific snippet of code:
 *               emake VERBOSE=1 "$@" || die "Make failed!";

i need the use flags +grass and +python. this is my aim: How to correctly install QGIS with plugins and GRASS-integration in Linux?.

any ideas?

attached logs:
emerge --info : http://qhor.net/paste/qgis-1.7.0-emerge.info.txt
emerge -pqv : http://qhor.net/paste/qgis-1.7.0-emerge.pqv.txt
build log : http://qhor.net/paste/qgis-1.7.0-build.log.txt
environment file : http://qhor.net/paste/qgis-1.7.0-environment.file.txt
Back to top
View user's profile Send private message
VoidMage
Watchman
Watchman


Joined: 14 Oct 2006
Posts: 6194

PostPosted: Sun Dec 30, 2012 8:21 pm    Post subject: Reply with quote

Less put it this way - there's a very good reason, why some of the devs argue, that '<foo' deps should be disallowed.

It seems that all <PyQt4-4.9 ebuilds have been removed in the meanwhile and nobody noticed this particular ebuild (not like it has many users and python is technically optional).
First of all, there's qgis 1.8.0 (not in the tree yet - if it's not reported yet, it should be), which might have fixed whatever the problem with more recent PyQt4 versions was.
You may want to see what changes to the old ebuild are necessary for this version - perhaps besides patch corrections there's very little to do.
Back to top
View user's profile Send private message
donc_oe
n00b
n00b


Joined: 26 Feb 2012
Posts: 8

PostPosted: Sun Dec 30, 2012 8:59 pm    Post subject: Reply with quote

Ok reported broken deps for qgis-1.7.4 : https://bugs.gentoo.org/show_bug.cgi?id=449348
Version bumb for qgis-1.8.0 is already discussed here : https://bugs.gentoo.org/show_bug.cgi?id=421093 (Bump!)

But any ideas on that compilation fail of qgis-1.7.0?

Edit: after some more research i've found this topic: https://forums.gentoo.org/viewtopic-p-7031758.html#7031758
It's tagged [SOLVED] by removing the python USE flag. but that is no solution for me as i really need the python flag.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum