Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
The current version of portage supports EAPI '2'
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
wils
n00b
n00b


Joined: 12 Dec 2012
Posts: 8

PostPosted: Wed Dec 12, 2012 1:33 am    Post subject: The current version of portage supports EAPI '2' Reply with quote

Have a rather bare system - but not easy to reinstall from scratch (few thousand km away).
Tried to update portage on 10.0 system:

emerge portage

* IMPORTANT: 10 news items need reading for repository 'gentoo'.
* Use eselect news to read news items.

Calculating dependencies... done!

!!! All ebuilds that could satisfy ">=dev-libs/libffi-3.0.11" have been masked.
!!! One of the following masked packages is required to complete your request:
- dev-libs/libffi-3.0.11 (masked by: EAPI 4, invalid: SLOT is undefined)

The current version of portage supports EAPI '2'. You must upgrade to a
newer version of portage before EAPI masked packages can be installed.
Back to top
View user's profile Send private message
John R. Graham
Administrator
Administrator


Joined: 08 Mar 2005
Posts: 7397
Location: Somewhere over Atlanta, Georgia

PostPosted: Wed Dec 12, 2012 12:18 pm    Post subject: Reply with quote

Remote or local, a system that out of date is going to be a challenge to update. An old version of portage is left in the tree to help with situations like this, though. Try
Code:
mkdir -p /etc/portage/package.unmask
echo '=sys-apps/portage-2.1.6.7_p1' >/etc/portage/package.unmask/portage
emerge -v =sys-apps/portage-2.1.6.7_p1
and report any additional blockages.

- John
_________________
This space intentionally left blank.
Back to top
View user's profile Send private message
wils
n00b
n00b


Joined: 12 Dec 2012
Posts: 8

PostPosted: Wed Dec 12, 2012 5:24 pm    Post subject: Reply with quote

Thanks for the assistance John.
Portage is now a bit newer:

Code:
*  sys-apps/portage
      Latest version available: 2.1.11.31
      Latest version installed: 2.1.6.7_p1


But still exactly the same error persists:

Code:
# emerge portage
Calculating dependencies... done!

!!! All ebuilds that could satisfy ">=dev-libs/libffi-3.0.11" have been masked.
!!! One of the following masked packages is required to complete your request:
- dev-libs/libffi-3.0.11 (masked by: EAPI 4, invalid: SLOT is undefined)

The current version of portage supports EAPI '2'. You must upgrade to a
newer version of portage before EAPI masked packages can be installed.

For more information, see the MASKED PACKAGES section in the emerge
man page or refer to the Gentoo Handbook.
(dependency required by "dev-lang/python-2.7.3-r2" [ebuild])
(dependency required by "sys-apps/portage-2.1.11.31" [ebuild])
(dependency required by "portage" [argument])
Back to top
View user's profile Send private message
John R. Graham
Administrator
Administrator


Joined: 08 Mar 2005
Posts: 7397
Location: Somewhere over Atlanta, Georgia

PostPosted: Wed Dec 12, 2012 5:40 pm    Post subject: Reply with quote

Next step, upgrade Portage to version 2.1.11.9:
Code:
emerge -1v =portage-2.1.11.9
and report any blocks.

- John
_________________
This space intentionally left blank.
Back to top
View user's profile Send private message
wils
n00b
n00b


Joined: 12 Dec 2012
Posts: 8

PostPosted: Wed Dec 12, 2012 9:19 pm    Post subject: Reply with quote

Still the same.

Code:
emerge -1v =portage-2.1.11.9

These are the packages that would be merged, in order:

Calculating dependencies... done!

!!! All ebuilds that could satisfy ">=dev-libs/libffi-3.0.11" have been masked.
!!! One of the following masked packages is required to complete your request:
- dev-libs/libffi-3.0.11 (masked by: EAPI 4, invalid: SLOT is undefined)

The current version of portage supports EAPI '2'. You must upgrade to a
newer version of portage before EAPI masked packages can be installed.

For more information, see the MASKED PACKAGES section in the emerge
man page or refer to the Gentoo Handbook.
(dependency required by "dev-lang/python-2.7.3-r2" [ebuild])
(dependency required by "sys-apps/portage-2.1.11.9" [ebuild])
(dependency required by "=portage-2.1.11.9" [argument])
Back to top
View user's profile Send private message
John R. Graham
Administrator
Administrator


Joined: 08 Mar 2005
Posts: 7397
Location: Somewhere over Atlanta, Georgia

PostPosted: Wed Dec 12, 2012 9:24 pm    Post subject: Reply with quote

Hmm. Do you have equery installed? If so, could you post the output of
Code:
equery list -i python
please? If you don't have equery, then
Code:
python --version
will suffice.

- John
_________________
This space intentionally left blank.
Back to top
View user's profile Send private message
wils
n00b
n00b


Joined: 12 Dec 2012
Posts: 8

PostPosted: Wed Dec 12, 2012 9:37 pm    Post subject: Reply with quote

Out of date python seems to be the real issue here. You get same error libffi-3.0.11 mentioned before. I don't have gentoolkit and similar EAPI error as before.

Code:
goe2 package.unmask # python --version
Unknown option: --
usage: python [option] ... [-c cmd | -m mod | file | -] [arg] ...
Try `python -h' for more information.
goe2 package.unmask # python -V
Python 2.4.4
Back to top
View user's profile Send private message
John R. Graham
Administrator
Administrator


Joined: 08 Mar 2005
Posts: 7397
Location: Somewhere over Atlanta, Georgia

PostPosted: Wed Dec 12, 2012 10:56 pm    Post subject: Reply with quote

One more quick & dirty attempt before we do things that're more complex. Try
Code:
emerge -1v --nodeps =portage-2.1.11.9
and, if that works, then go get the dependencies with
Code:
emerge -1v =portage-2.1.11.9
and report back.

- John
_________________
This space intentionally left blank.
Back to top
View user's profile Send private message
wils
n00b
n00b


Joined: 12 Dec 2012
Posts: 8

PostPosted: Wed Dec 12, 2012 11:20 pm    Post subject: Reply with quote

again thanks for the help; lets get dirty.

Code:
 "This version of portage requires at least python-2.6 to be selected as the default python interpreter (see `eselect python --help`)."
Back to top
View user's profile Send private message
John R. Graham
Administrator
Administrator


Joined: 08 Mar 2005
Posts: 7397
Location: Somewhere over Atlanta, Georgia

PostPosted: Wed Dec 12, 2012 11:25 pm    Post subject: Reply with quote

Did the first command run to completion?

- John
_________________
This space intentionally left blank.
Back to top
View user's profile Send private message
wils
n00b
n00b


Joined: 12 Dec 2012
Posts: 8

PostPosted: Wed Dec 12, 2012 11:31 pm    Post subject: Reply with quote

No.

Code:
emerge -1v --nodeps =portage-2.1.11.9

These are the packages that would be merged, in order:

[ebuild     U ] sys-apps/portage-2.1.11.9 [2.1.6.7_p1] USE="(ipc%*) -build -doc -epydoc (-pypy1_9) -python2% -python3% (-selinux) -xattr% (-less%)" LINGUAS="-pl" 825 kB

Total: 1 package (1 upgrade), Size of downloads: 825 kB


>>> Verifying ebuild manifests

>>> Emerging (1 of 1) sys-apps/portage-2.1.11.9
>>> Downloading 'http://mirror.gentoo.no/distfiles/portage-2.1.11.9.tar.bz2'
--00:08:56--  http://mirror.gentoo.no/distfiles/portage-2.1.11.9.tar.bz2
           => `/usr/portage/distfiles/portage-2.1.11.9.tar.bz2'
Resolving mirror.gentoo.no... 92.62.42.211
Connecting to mirror.gentoo.no|92.62.42.211|:80... failed: No route to host.
>>> Downloading 'http://gentoo.tiscali.nl/distfiles/portage-2.1.11.9.tar.bz2'
--00:08:59--  http://gentoo.tiscali.nl/distfiles/portage-2.1.11.9.tar.bz2
           => `/usr/portage/distfiles/portage-2.1.11.9.tar.bz2'
Resolving gentoo.tiscali.nl... 195.241.77.98
Connecting to gentoo.tiscali.nl|195.241.77.98|:80... connected.
HTTP request sent, awaiting response... 200 OK
Length: 844,344 (825K) [application/x-bzip2]

100%[================================================================================================>] 844,344        3.05M/s

00:08:59 (3.05 MB/s) - `/usr/portage/distfiles/portage-2.1.11.9.tar.bz2' saved [844344/844344]

 * portage-2.1.11.9.tar.bz2 SHA256 SHA512 WHIRLPOOL size ;-) ...                                                                     [ ok ]
 * checking ebuild checksums ;-) ...                                                                                                 [ ok ]
 * checking auxfile checksums ;-) ...                                                                                                [ ok ]
 * checking miscfile checksums ;-) ...                                                                                               [ ok ]
 * Attempting to select a compatible default python interpreter
 * Unable to select a compatible default python interpreter!
 *
 * ERROR: sys-apps/portage-2.1.11.9 failed.
 * Call stack:
 *                 ebuild.sh, line   49:  Called pkg_setup
 *   portage-2.1.11.9.ebuild, line  135:  Called die
 * The specific snippet of code:
 *                      die "This version of portage requires at least python-2.6 to be selected as the default python interpreter (see `eselect python --help`)."
 *  The die message:
 *   This version of portage requires at least python-2.6 to be selected as the default python interpreter (see `eselect python --help`).
 *
 * If you need support, post the topmost build error, and the call stack if relevant.
 * A complete build log is located at '/var/tmp/portage/sys-apps/portage-2.1.11.9/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/sys-apps/portage-2.1.11.9/temp/die.env'.
Back to top
View user's profile Send private message
John R. Graham
Administrator
Administrator


Joined: 08 Mar 2005
Posts: 7397
Location: Somewhere over Atlanta, Georgia

PostPosted: Wed Dec 12, 2012 11:58 pm    Post subject: Reply with quote

Code:
eselect python list
please.

- John
_________________
This space intentionally left blank.
Back to top
View user's profile Send private message
wils
n00b
n00b


Joined: 12 Dec 2012
Posts: 8

PostPosted: Thu Dec 13, 2012 12:05 am    Post subject: Reply with quote

Code:
goe2 ~ # eselect python --help
!!! Error: Can't load module python
exiting
goe2 ~ # eselect python list
!!! Error: Can't load module python
exiting
goe2 ~ # eselect
Usage: eselect <global options> <module name> <module options>

Global options:
  --brief                   Make output shorter
  --no-color,--no-colour    Disable coloured output

Built-in modules:
  help                      Display a help message
  usage                     Display a usage message
  version                   Display version information

Extra modules:
  bashcomp                  Manage contributed bash-completion scripts
  binutils                  Manage installed versions of sys-devel/binutils
  editor                    Manage the EDITOR environment variable
  env                       Manage environment variables set in /etc/env.d/
  kernel                    Manage the /usr/src/linux symlink
  locale                    Manage the LANG environment variable
  modules                   A module for querying modules. By default, it lists all available modules
  news                      Read Gentoo ("GLEP 42") news items
  pager                     Manage the PAGER environment variable
  profile                   Manage the make.profile symlink
  rc                        Manage /etc/init.d scripts in runlevels
  visual                    Manage the VISUAL environment variable
[/quote]
Back to top
View user's profile Send private message
dol-sen
Developer
Developer


Joined: 30 Jun 2002
Posts: 2503
Location: Richmond, BC, Canada

PostPosted: Thu Dec 13, 2012 4:24 am    Post subject: Reply with quote

Code:
emerge -1v app-admin/eselect-python


Then you will need to emerge python-2.6. Then eselect python2.6. After that you should be able to emerge a newer portage.

You will eventually update to python-2.7, but that can wait till you have system updated.

There will be other troublesome packages. Check out the sticky thread here in "Portage & Programming" It is old and somewhat out of date, but will likely have some good info there still to help you.
_________________
Brian
Porthole, the Portage GUI frontend irc@freenode: #gentoo-guis, #porthole, Blog
layman, gentoolkit, CoreBuilder, esearch...
Back to top
View user's profile Send private message
wils
n00b
n00b


Joined: 12 Dec 2012
Posts: 8

PostPosted: Thu Dec 13, 2012 1:08 pm    Post subject: Reply with quote

So I did "emerge -1v app-admin/eselect-python" which worked.
Python 2.6 gave the same errors though. So I tried to go down the binary route:

PORTAGE_BINHOST="http://tinderbox.dev.gentoo.org/default-linux/x86"
export
emerge --getbinpkgonly --usepkg python
emerge --getbinpkgonly --usepkg portage

Then I did "emerge portage" worked.
Then I did "emerge python" but that failed on pkgconfig.

I've now got the opertunity to reinstall from scratch, so think I'll go down that route!

Thanks for the effort guys.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum