Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
GUI hangs, sometimes need to reboot
View unanswered posts
View posts from last 24 hours

Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message

Joined: 02 Mar 2005
Posts: 221
Location: Digne les bains, France

PostPosted: Tue Nov 27, 2012 10:37 pm    Post subject: GUI hangs, sometimes need to reboot Reply with quote


I am facing a strange problem for about 10 days.

Sometimes the GUI Hangs for some seconds. the mouse is working but has interaction with nothing. The sound continues to play (DVB application for exemple, but the screen becomes black). This generally happen when displaying images in a browser (any) or moving the DVB window.
Sometimes there is no way to recover the system, and I have to reboot.

My dmesg shows this output :
------------[ cut here ]------------
WARNING: at drivers/gpu/drm/i915/i915_drv.c:485 gen6_gt_check_fifodbg.clone.2+0x2e/0x40()
Hardware name: To Be Filled By O.E.M.
MMIO read or write has been dropped 3
Modules linked in: vboxnetadp(O) vboxnetflt(O) vboxdrv(O) ghash_clmulni_intel cryptd scsi_wait_scan
Pid: 4732, comm: X Tainted: G        W  O 3.5.7-gentoo #1
Call Trace:
 [<ffffffff8103b69b>] ? warn_slowpath_common+0x7b/0xc0
 [<ffffffff8103b795>] ? warn_slowpath_fmt+0x45/0x50
 [<ffffffff8131a25e>] ? gen6_gt_check_fifodbg.clone.2+0x2e/0x40
 [<ffffffff8131a639>] ? gen6_gt_force_wake_put+0x39/0x60
 [<ffffffff81325c16>] ? __wait_seqno+0x96/0x210
 [<ffffffff81058ca0>] ? wake_up_bit+0x40/0x40
 [<ffffffff8132a0e9>] ? i915_gem_throttle_ioctl+0xd9/0x110
 [<ffffffff8130218e>] ? drm_ioctl+0x2ce/0x4e0
[drm:i915_reset] *ERROR* GPU hanging too fast, declaring wedged!
 [<ffffffff8132a010>] ? i915_gem_busy_ioctl+0x110/0x110
 [<ffffffff813fab1f>] ? evdev_read+0x1ff/0x420
 [<ffffffff8100cd07>] ? check_for_xstate+0x27/0x90
[drm:i915_reset] *ERROR* Failed to reset chip.
 [<ffffffff810f4f16>] ? do_vfs_ioctl+0x96/0x500
 [<ffffffff81001892>] ? restore_sigcontext+0x112/0x150
 [<ffffffff810f53c9>] ? sys_ioctl+0x49/0x80
 [<ffffffff815a76e6>] ? system_call_fastpath+0x1a/0x1f
---[ end trace b7f98c5acf9fee19 ]---

I dont know if it is an hardware or a software issue.

Everything started whith the computer that did not start a morning. Just a repeating "click" sound,no fan spinning. After having unplugged the power cord, and plugged it again it worked. Now the "non starting" issue happens every 4 start up on average. This is not a PSU issue since it happens with a new one. I suspect the motherboard ( Asrock Z68 Pro3-M ).

About 10 days after that, the hangs started. I am not sure if there is a relationship or if it is just a coincidence.
I can beat unplugging sometimes the power cord, but the hangs are really annoying.

To try to solve them updated the bios (from 1.0 to 1.7) as suggested asrock support. I also updated many things including kernel and xorg, but with no results.

I am using the GPU included in my i5-2500K on a dual screen configuration. One monitor on DVI and another on D-SUB.

# emerge --info
Portage (default/linux/amd64/10.0/desktop/gnome, gcc-4.5.4, glibc-2.15-r3, 3.5.7-gentoo x86_64)
System uname: Linux-3.5.7-gentoo-x86_64-Intel-R-_Core-TM-_i5-2500K_CPU_@_3.30GHz-with-gentoo-2.1
Timestamp of tree: Tue, 27 Nov 2012 20:15:02 +0000
ld GNU ld (GNU Binutils) 2.22
app-shells/bash:          4.2_p37
dev-java/java-config:     2.1.11-r3
dev-lang/python:          2.7.3-r2, 3.2.3
dev-util/cmake:           2.8.9
dev-util/pkgconfig:       0.27.1
sys-apps/baselayout:      2.1-r1
sys-apps/openrc:          0.11.5
sys-apps/sandbox:         2.5
sys-devel/autoconf:       2.13, 2.68
sys-devel/automake:       1.11.6
sys-devel/binutils:       2.22-r1
sys-devel/gcc:            4.3.6-r1, 4.5.4
sys-devel/gcc-config:     1.7.3
sys-devel/libtool:        2.4-r1
sys-devel/make:           3.82-r3
sys-kernel/linux-headers: 3.6 (virtual/os-headers)
sys-libs/glibc:           2.15-r3
Repositories: gentoo x-liquidx rion ltsp sunrise lordvan x-portage zugaina
CFLAGS="-march=native -O2 -pipe"
CONFIG_PROTECT="/etc /usr/share/config /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-march=native -O2 -pipe"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch"
FFLAGS="-O2 -pipe"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTDIR_OVERLAY="/var/lib/layman/liquidx /var/lib/layman/rion /var/lib/layman/ltsp /var/lib/layman/sunrise /var/lib/layman/lordvan /usr/local/portage /var/lib/layman/zugaina"
USE="# A B C D E F G H I J K L M N O P Q R S T U V W X Z a52 aac acl acpi alsa amd64 avahi avi avx berkdb bluray branding bzip2 cairo cdda cdr cli colord consolekit cracklib crypt css cups cxx dbus device-mapper divx divx4linux dri dts dv dvb dvd dvdr eac3 ebook eds emboss encode exif extras fam ffac3 ffmpeg ffmpeg-mt firefox flac foomaticdb fortran gdbm gif gimp gimpprint glitz gmedia gnome gnome-keyring gnome-online-accounts gpm gstreamer gtk gtk2 iconv imagemagick imlib ipv6 java jbig jpeg jpeg2k lcms ldap libnotify lm_sensors mad matroska midi mmx mmxext mng modules mp3 mp4 mpeg mplayer mudflap multilib nautilus ncurses new-login nls nowin nptl nsplugin ntfs ogg opengl openmp pam pango pcre pdf pic png policykit ppds pppd pps print pulseaudio qt3support quicktime raw readline realmedia scanner sdl semantic-desktop session smp socialweb sound spell sse sse2 ssl ssse3 startup-notification svg tcl tcpd theora threads tiff timidity tk truetype udev udisks unicode upower usb v4l v4l2 vaapi vorbis wmf wmp wxwidgets x264 xcb xinerama xml xmms xpm xv xvid xvmc zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="evdev keyboard mouse wacom" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LINGUAS="fr" PHP_TARGETS="php5-3" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_2" RUBY_TARGETS="ruby18 ruby19" USERLAND="GNU" VIDEO_CARDS="intel" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"

Linux, cause booting is for adding new hardware
Back to top
View user's profile Send private message

Joined: 06 Jan 2011
Posts: 548
Location: Scotland

PostPosted: Sun Dec 23, 2012 5:33 pm    Post subject: Reply with quote

Modules linked in: vboxnetadp(O) vboxnetflt(O) vboxdrv(O) ghash_clmulni_intel cryptd scsi_wait_scan

I'm intrigued by that line. Mainly because the backtrace highlights vbox modules.

Also, there is deffo something going on with the graphics driver.

Try downgrading your intel graphics card driver and see if that helps.
Whatever you do, do it properly!
Back to top
View user's profile Send private message

Joined: 02 Mar 2005
Posts: 221
Location: Digne les bains, France

PostPosted: Sun Dec 23, 2012 8:06 pm    Post subject: Reply with quote

Thank you for your answer.

I bought a new motherboard and that solved the problem. So this was probably a hardware problem.
Linux, cause booting is for adding new hardware
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Page 1 of 1

Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum