Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
64-bit VLC2 with V4L2: Distorted video decoding [SOLVED]
View unanswered posts
View posts from last 24 hours

Reply to topic    Gentoo Forums Forum Index Multimedia
View previous topic :: View next topic  
Author Message
Tux's lil' helper
Tux's lil' helper

Joined: 20 Jan 2004
Posts: 125

PostPosted: Sun Nov 25, 2012 1:23 am    Post subject: 64-bit VLC2 with V4L2: Distorted video decoding [SOLVED] Reply with quote

This was posted onto the forums over at Videolan about three weeks ago, and aside from a "check the logs" suggestion, nothing has come up to even hint at how to solve this strange issue. I will put an adjusted copy of my original post below; hopefully I can gather some clues from other Gentoo users.

Darkmorph wrote:


I have been troubled by an issue that has surfaced ever since I have tried VLC 2.0.0. I have tried 2.0.1, 2.0.2, 2.0.3, and now today, 2.0.4, with no success. I'm using a Dazzle DVC 100 which is driven by v4l2 and the kernel module em28xx (and em28xx-alsa, but I have no audio issues.) I have been using VLC 1.1.9 for an extremely long time; I was unable to upgrade to the later revisions of the 1.1 series because of a bug where overriding format to NTSC simply did not work, and this Dazzle defaults to PAL otherwise. (I have in fact reported this bug and it has been corrected in the 2.x branch.)

Since Portage has purged all 1.1 ebuilds already, I have a modified 1.1.9 ebuild in portage overlay. With quickpkg I can switch between 1.1.9 and 2.0.4 easily.

This is a snapshot of a media player captured from my TV using the Dazzle, taken from VLC2:

Now, this is how it would look in VLC 1.1.9 (for saving time's sake I took this snapshot with MPlayer):

All I am doing is opening device /dev/video0 and forcing NTSC mode, nothing else. By viewing the device with VLC 1.1.9 or MPlayer, I'm also proving there is no problem with the device driver, or my kernel, or some other factor since anything except VLC2 can open and decode the image properly.

I also noticed that overlay text is just as blurry as the decoded image which further indicates this is an issue specifically with VLC2. (For example, the message that appears to indicate that I have opened /dev/video0 is really blurry.) I have no idea why this is happening, what is causing it, or how to correct it. I have tried to search the VLC forums, Gentoo forums, documentation, the internet in general, for any sign or indication of this issue being reported, and come up with absolutely no results. I would really like to figure out what is wrong and get VLC2 working with this V4L2 device.

To eliminate the possibility that there is something wrong with the VLC frontend, I have adjusted my encoding/recording script that calls cvlc to work properly with VLC2 and generated a stream with an SDP file output being generated continuously. Viewing this SDP file with MPlayer, I still get the same distorted image.

It shouldn't be meaningful but here's a copy of the script:


cvlc v4l2:///dev/video0 :input-slave=alsa://hw:2,0 :v4l2-standard=NTSC :v4l2-width=-1 :v4l2-height=-1 :v4l2-fps=30 :v4l2-brightness=150 :v4l2-audio-volume=200 :file-caching=300 :sout='#transcode{vcodec=h264,vb=500,scale=0.5,acodec=mp4a,ab=128,channels=2,samplerate=44100,deinterlace}:rtp{dst=,port=5004,mux=ts,sdp=file:///home/dm/vlc.sdp}' :no-sout-rtp-sap :no-sout-standard-sap :ttl=1 :sout-keep

Now for other info..

Build environment:


    # emerge --info
    Portage (default/linux/amd64/10.0/desktop, gcc-4.5.3, glibc-2.14.1-r3, 3.4.9-gentoo x86_64)
    System uname: Linux-3.4.9-gentoo-x86_64-AMD_Turion-tm-_64_Mobile_Technology_MT-37-with-gentoo-2.1
    Timestamp of tree: Fri, 02 Nov 2012 19:30:01 +0000
    ccache version 3.1.7 [enabled]
    app-shells/bash:          4.2_p37
    dev-java/java-config:     2.1.11-r3
    dev-lang/python:          2.7.2-r3, 3.2.3
    dev-util/ccache:          3.1.7
    dev-util/cmake:           2.8.8-r3
    dev-util/pkgconfig:       0.27.1
    sys-apps/baselayout:      2.1-r1
    sys-apps/sandbox:         2.5
    sys-devel/autoconf:       2.13::<unknown repository>, 2.68
    sys-devel/automake:       1.4_p6-r1, 1.5-r1, 1.6.3-r1, 1.7.9-r2, 1.8.5-r4, 1.9.6-r3, 1.10.3, 1.11.6
    sys-devel/binutils:       2.22-r1
    sys-devel/gcc:            4.5.3-r1
    sys-devel/gcc-config:     1.7.3
    sys-devel/libtool:        2.4-r1
    sys-devel/make:           3.82-r3
    sys-kernel/linux-headers: 3.4-r2 (virtual/os-headers)
    sys-libs/glibc:           2.14.1-r3
    Repositories: gentoo x-portage
    CFLAGS="-march=k8 -Os -pipe -fomit-frame-pointer"
    CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
    CXXFLAGS="-march=k8 -Os -pipe -fomit-frame-pointer"
    FCFLAGS="-O2 -pipe"
    FEATURES="assume-digests binpkg-logs ccache config-protect-if-modified distlocks ebuild-locks fixlafiles news nodoc parallel-fetch parse-eapi-ebuild-head protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch"
    FFLAGS="-O2 -pipe"
    LDFLAGS="-Wl,-O1 -Wl,--as-needed"
    LINGUAS="en en_US ja"
    PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
    USE="3dnow 3dnowext X a52 aac acl acpi alsa amazon amd64 anthy asf branding bzip2 cairo ccache cdda cdparanoia cdr cjk cli consolekit cracklib crypt cups cxx dbus device-mapper dhcpcd digitalradio dvd dvdr dvdread emboss emul-linux-x86 encode exif fam ffmpeg firefox flac ftp gdu gif glut gstreamer gtkstyle iconv imlib ipv6 javascript joystick jpeg jpeg2k kdeenablefinal kerberos lame lastfmradio libnotify lm_sensors mad matroska mime mmx mmxext mng modules mp3 mp4 mpeg mudflap multilib musicbrainz ncurses networkmanager nls nptl nptlonly nsplugin nss offensive ogg oggvorbis openal opengl openmp oscar pam pango pcre pda pdf perl png policykit pppd quicktime readline sdl session sndfile spell sse sse2 ssl startup-notification svg taglib tcpd theora threads threadsafe tiff truetype udev udisks unicode upower usb utempter v4l v4l2 vaapi vdpau vorbis wifi wxwidgets x264 xcb xinerama xml xml2 xv xvid zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="evdev keyboard mouse synaptics" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LINGUAS="en en_US ja" PHP_TARGETS="php5-3" PYTHON_TARGETS="python3_2 python2_7" RUBY_TARGETS="ruby18 ruby19" USERLAND="GNU" VIDEO_CARDS="nv nvidia vesa" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"

    # emerge -pv vlc
    [ebuild   R    ] media-video/vlc-2.0.4  USE="X a52 aac alsa avcodec avformat cdda dbus dvbpsi dvd encode ffmpeg flac fontconfig gcrypt gnome libass libnotify live matroska mmx mp3 mpeg ncurses ogg opengl png postproc qt4 rtsp sdl sse svg swscale taglib theora truetype udev v4l vaapi vorbis x264 xcb xml xv -aalib (-altivec) -atmo (-audioqueue) -avahi -bidi -bluray -cddb -dc1394 -debug -dirac (-direct2d) -directfb (-directx) (-dshow) -dts -dvb (-dxva2) -egl -fbosd -fluidsynth -gme -gnutls -growl -httpd -ieee1394 (-ios-vout) -jack -kate -kde -libcaca -libproxy -libsamplerate -libtar -libtiger -linsys -lirc -lua (-macosx) (-macosx-audio) (-macosx-dialog-provider) (-macosx-eyetv) (-macosx-qtkit) (-macosx-quartztext) (-macosx-vout) (-media-library) -modplug -mtp -musepack (-neon) -omxil -optimisememory -opus -oss -portaudio -projectm -pulseaudio -pvr -run-as-root -samba -schroedinger -sdl-image -shine -shout -sid -skins -speex -sqlite -switcher -twolame -upnp -vcdx -vlm (-waveout) (-win32codecs) (-wingdi) -wma-fixed -xosd -zvbi" 0 kB

VLC 1.1.9 log

VLC 2.0.4 log

At the moment I haven't a clue what to check or test to get this fixed. Any ideas?
ProtonMail - Free encrypted e-mail from Switzerland
Let's Encrypt - Free SSL cert organisation

Last edited by kitsunenokenja on Sun Mar 03, 2013 9:57 pm; edited 1 time in total
Back to top
View user's profile Send private message
Tux's lil' helper
Tux's lil' helper

Joined: 20 Jan 2004
Posts: 125

PostPosted: Sat Jan 26, 2013 4:40 am    Post subject: Reply with quote

Upgraded to GCC 4.6.3, flushed ccache, built VLC 2.0.5.

No progress. Still absolutely clueless what is causing this and no plan on how to fix it. :cry:

Back to 1.1.9 I go. :?
ProtonMail - Free encrypted e-mail from Switzerland
Let's Encrypt - Free SSL cert organisation
Back to top
View user's profile Send private message
Tux's lil' helper
Tux's lil' helper

Joined: 20 Jan 2004
Posts: 125

PostPosted: Sun Mar 03, 2013 9:58 pm    Post subject: Reply with quote

Filed a bug report and it is closed with the answer to this problem.
ProtonMail - Free encrypted e-mail from Switzerland
Let's Encrypt - Free SSL cert organisation
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Multimedia All times are GMT
Page 1 of 1

Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum