Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED] qlist - Segmentation fault
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
Joseph_sys
Advocate
Advocate


Joined: 08 Jun 2004
Posts: 2359
Location: Edmonton, AB

PostPosted: Mon Nov 19, 2012 2:42 am    Post subject: [SOLVED] qlist - Segmentation fault Reply with quote

I'm trying to run "qlist" but I get: Segmentation fault

emerge $(qlist -IC x11-drivers)
command is not recognized.

qlist -IC x11-drivers
Segmentation fault

I'm running portage-utils-0.10
I tried to downgrade to portage-utils-0.8 but get an error message:
Code:
app-portage/portage-utils-0.8, Log file:
>>>  '/var/log/portage/app-portage:portage-utils-0.8:20121119-021014.log'
 * Package:    app-portage/portage-utils-0.8
 * Repository: gentoo
 * Maintainer: portage-utils@gentoo.org
 * USE:        amd64 elibc_glibc kernel_linux multilib userland_GNU
 * FEATURES:   sandbox
: q : qatom : qcache : qcheck : qdepends : qfile : qgrep : qlist : qlop : qmerge : qpkg : qsearch : qsize : qtbz2 : quse : qxpak :
x86_64-pc-linux-gnu-gcc -march=nocona -O2 -pipe -std=gnu99 -Wl,-O1 -Wl,--as-needed main.c -o q
In file included from libq/libq.c:37:0,
                 from main.c:97:
libq/scandirat.c:10:12: error: static declaration of ‘scandirat’ follows non-static declaration
/usr/include/dirent.h:294:12: note: previous declaration of ‘scandirat’ was here
libq/xmkdir.c:110:15: warning: ‘rmdir_r’ defined but not used
make: *** [q] Error 1
emake failed
 * ERROR: app-portage/portage-utils-0.8 failed (compile phase):
 *   emake failed
 *
 * Call stack:
 *          ebuild.sh, line   93:  Called src_compile
 *        environment, line 2339:  Called __eapi2_src_compile
 *   phase-helpers.sh, line  612:  Called die
 * The specific snippet of code:
 *         emake || die "emake failed"

_________________
#Joseph


Last edited by Joseph_sys on Mon Nov 19, 2012 2:45 pm; edited 1 time in total
Back to top
View user's profile Send private message
ulenrich
Veteran
Veteran


Joined: 10 Oct 2010
Posts: 1122

PostPosted: Mon Nov 19, 2012 2:34 pm    Post subject: Reply with quote

portage-utils-0.20 working here:

# qlist -IC x11-drivers
x11-drivers/nvidia-drivers
x11-drivers/xf86-input-evdev
x11-drivers/xf86-input-keyboard
x11-drivers/xf86-input-mouse
x11-drivers/xf86-video-v4l
x11-drivers/xf86-video-vesa

There is a newer than You use: stable portage-utils-0.10
_________________
fun2gen2
Back to top
View user's profile Send private message
Joseph_sys
Advocate
Advocate


Joined: 08 Jun 2004
Posts: 2359
Location: Edmonton, AB

PostPosted: Mon Nov 19, 2012 2:45 pm    Post subject: Reply with quote

ulenrich wrote:
portage-utils-0.20 working here:

# qlist -IC x11-drivers
x11-drivers/nvidia-drivers
x11-drivers/xf86-input-evdev
x11-drivers/xf86-input-keyboard
x11-drivers/xf86-input-mouse
x11-drivers/xf86-video-v4l
x11-drivers/xf86-video-vesa

There is a newer than You use: stable portage-utils-0.10


I have upgraded to portage-utils-0.20 as well and it is working now.
_________________
#Joseph
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum