Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
texlive-langcjk-2011 emerge fails [SOLVED]
View unanswered posts
View posts from last 24 hours

Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message

Joined: 17 Oct 2010
Posts: 29

PostPosted: Fri Nov 09, 2012 3:02 am    Post subject: texlive-langcjk-2011 emerge fails [SOLVED] Reply with quote

Build log copied from terminal (cleaner) :

Build log copied from file:

emerge --info:

Portage 2.2.0_alpha142 (hardened/linux/amd64, gcc-4.4.7, glibc-2.15-r3, 3.2.9-hardened-r1 x86_64)
System uname: Linux-3.2.9-hardened-r1-x86_64-Intel-R-_Core-TM-2_Duo_CPU_T9300_@_2.50GHz-with-gentoo-2.1
Timestamp of tree: Sun, 04 Nov 2012 18:00:01 +0000
ld GNU ld (GNU Binutils) 2.22
distcc[30582] (dcc_mkdir) ERROR: mkdir '/var/tmp/portage/.distcc/state' failed: No such file or directory [disabled]
ccache version 3.1.7 [disabled]
app-shells/bash:          4.2_p37
dev-java/java-config:     2.1.11-r3
dev-lang/python:          2.4.6, 2.7.3-r2, 3.1.3-r1, 3.2.3
dev-util/ccache:          3.1.7
dev-util/cmake:           2.8.9
dev-util/pkgconfig:       0.27.1
sys-apps/baselayout:      2.1-r1
sys-apps/sandbox:         2.5
sys-devel/autoconf:       2.13, 2.68
sys-devel/automake:       1.9.6-r3, 1.10.3, 1.11.6
sys-devel/binutils:       2.22-r1
sys-devel/gcc:            4.4.7, 4.5.4
sys-devel/gcc-config:     1.7.3
sys-devel/libtool:        2.4-r1
sys-devel/make:           3.82-r3
sys-kernel/linux-headers: 3.4-r2 (virtual/os-headers)
sys-libs/glibc:           2.15-r3
Repositories: gentoo kde-sunset x11 Hugin
Installed sets: @system
CFLAGS="-march=x86-64 -mtune=nocona -O2 -finline-functions -pipe"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/config /usr/share/gnupg/qualified.txt /var/lib/hsqldb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-march=x86-64 -mtune=nocona -O2 -finline-functions -pipe"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch"
FFLAGS="-O2 -pipe"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
LINGUAS="en_US en ja_JP ja"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTDIR_OVERLAY="/var/lib/layman/kde-sunset /var/lib/layman/x11 /usr/local/portage"
USE="64bit 7zip S3TC X a52 aac aalib ace acl acpi aiglx aim aimextras alsa amarok amazon amd64 amr amrnb amrr amrwb anthy bash-completion berkdb bidi bittorrent bluetooth boost bzip2 cairo cdaudio cdda cddb cdrom cdsound cjk cli colordiff completion compress console consolekit cpufreq cracklib crypt css cups curl cvs cxx d daap dbus device-mapper dnotify dri dts dv dvd dvdnav dvdr dvdread enca encode enscript festival ffmpeg firefox firefox3 flac flash ftp fuse g3dvl gaim gallium gdbm gimp gnutls gocr gphoto2 gpm grammar gtalk gzip hardened http iconv icu id3 imagemagick immqt injection ipfilter iproute2 ipv6 irc jack java jpeg jpeg2k justify kde kdeenablefinal kdepim kdm kqemu ladcca ladspa lame latex ldap libburn libcaca libnotify lm_sensors lxde lzo lzw mad mail mailbox maildir matroska mbox mbrola md5sum mjpeg mmap mmx mng mod modules mozilla mp2 mp3 mp4 mpeg mpeg2 mplayer mudflap multilib musepack music musicbrainz ncurses netpbm network nls nntp nptl nsplugin ntfs nut nuv offensive office ogg openal opengl p2p pam pango pax_kernel pcmcia pcre pdf pidgin plotutils plugins pmount png pnm policykit pop portage posix postscript ppds pppd ps qemu qt3 qt3support qt4 quicktime rar rdesktop readline realmedia reiserfs rle rss rtc samba sasl scanner sdl sdl-image sdl-sound sdlaudio semantic-desktop server session sftp shorten sid slp smime smpeg smtp sox spell sql sqlite sse sse2 ssl ssse3 subtitles subversion svg svgz taglib tagwriting tcpd tetex textures tga tgif themes theora threads tiff timidity tk truetype tta twolame udev uim unicode unzip upnp urandom usb valgrind vcd vga videos vim vim-syntax vim-with-x vnc vncviewer voice vorbis vorbis-psy wav wavpack wideband wifi wma wmf wmp x11vnc x264 xanim xcomposite xinerama xiph xprint xrandr xrender xscreensaver xsettings xv xvid xvmc yahoo yv12 zip zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="evdev keyboard mouse synaptics" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LINGUAS="en_US en ja_JP ja" PHP_TARGETS="php5-3" PYTHON_TARGETS="python3_2 python2_7" RUBY_TARGETS="ruby18 ruby19" USERLAND="GNU" VIDEO_CARDS="nouveau" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"

This is preventing me from getting @world updated and thus also preventing me from --depclean'ing.

Last edited by ChadJoan on Sun Nov 11, 2012 4:04 am; edited 1 time in total
Back to top
View user's profile Send private message

Joined: 24 Nov 2010
Posts: 209
Location: AU

PostPosted: Sat Nov 10, 2012 11:22 pm    Post subject: Reply with quote

To debug it, you can scan through the build log looking for the first error. Often searching for the string "error" or "Error:" works. So we find:

eptex: symbol lookup error: eptex: undefined symbol: toDVI
Error: `eptex -ini  -jobname=eptex -progname=eptex *eptex.ini' failed

Then since something went wrong with the program eptex, we search for which package provides the program eptex, and rebuild that package. To search for the package that owns eptex:

equery belongs `which eptex`
Back to top
View user's profile Send private message

Joined: 17 Oct 2010
Posts: 29

PostPosted: Sun Nov 11, 2012 4:04 am    Post subject: Reply with quote


It wasn't clear to me at first exactly what eptex was. Thanks for the tip.

I did this:

chad@Hugin ~/ $ equery belongs `which eptex`
 * Searching for /usr/bin/eptex ...
app-text/texlive-core-2011-r6 (/usr/bin/eptex)

and recompiled texlive-core and then texlive-langcjk. It worked!

Thank you.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum