Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
bluetooth kernel linux
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian) Forum di discussione italiano
View previous topic :: View next topic  
Author Message
polslinux
Apprentice
Apprentice


Joined: 12 Apr 2010
Posts: 251
Location: Veneto

PostPosted: Wed Oct 10, 2012 2:32 pm    Post subject: bluetooth kernel linux Reply with quote

Il dispositivo bluetooth del mio Sony Vaio VPCEH1S0E non viene rilevato (modulo kernel ath3k).

Output di lspci:
Code:
00:00.0 Host bridge: Intel Corporation 2nd Generation Core Processor Family DRAM Controller (rev 09)
00:02.0 VGA compatible controller: Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller (rev 09)
00:16.0 Communication controller: Intel Corporation 6 Series/C200 Series Chipset Family MEI Controller #1 (rev 04)
00:1a.0 USB controller: Intel Corporation 6 Series/C200 Series Chipset Family USB Enhanced Host Controller #2 (rev 04)
00:1b.0 Audio device: Intel Corporation 6 Series/C200 Series Chipset Family High Definition Audio Controller (rev 04)
00:1c.0 PCI bridge: Intel Corporation 6 Series/C200 Series Chipset Family PCI Express Root Port 1 (rev b4)
00:1c.3 PCI bridge: Intel Corporation 6 Series/C200 Series Chipset Family PCI Express Root Port 4 (rev b4)
00:1c.5 PCI bridge: Intel Corporation 6 Series/C200 Series Chipset Family PCI Express Root Port 6 (rev b4)
00:1d.0 USB controller: Intel Corporation 6 Series/C200 Series Chipset Family USB Enhanced Host Controller #1 (rev 04)
00:1f.0 ISA bridge: Intel Corporation HM65 Express Chipset Family LPC Controller (rev 04)
00:1f.2 SATA controller: Intel Corporation 6 Series/C200 Series Chipset Family 6 port SATA AHCI Controller (rev 04)
00:1f.3 SMBus: Intel Corporation 6 Series/C200 Series Chipset Family SMBus Controller (rev 04)
07:00.0 Network controller: Atheros Communications Inc. AR9285 Wireless Network Adapter (PCI-Express) (rev 01)
0d:00.0 Unassigned class [ff00]: Realtek Semiconductor Co., Ltd. RTS5209 PCI Express Card Reader (rev 01)
13:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168B PCI Express Gigabit Ethernet controller (rev 06)


ho compilato il kernel mettendo l'asterisco (*) su:
Code:
(*)Networking support -> (*)Bluetooth Subsystem Support -> (*)RFCOMM tutto, (*)BNEP tutto, (*)HDIP -> (*)Atheros firmware download driver, (*)HCI USB driver


lsmod:
Code:
Module                  Size  Used by


lsusb:
Code:
Bus 001 Device 004: ID 0489:e027 Foxconn / Hon Hai


dove sbaglio??
Ma cmq il bluetooth non funziona. Non viene rilevato nessun dispositivo.
Ho installato anche linux-firmware
_________________
PC-Desktop: Ubuntu 12.04 x86
Notebook Sony Vaio VPCEH: Gentoo ~amd64
Back to top
View user's profile Send private message
Onip
Advocate
Advocate


Joined: 02 Sep 2004
Posts: 2907
Location: Parma (Italy)

PostPosted: Wed Oct 10, 2012 6:41 pm    Post subject: Reply with quote

ammesso (e non concesso) che lato linux sia tutto a posto a me non viene rilevato se, per caso, lo disabilito da windows. Inoltre hai attivato il servizio "bluetooth" all'avvio della macchina?

scusa se non sono più preciso, ma il bt lo uso sul portatile che, adesso, è in ufficio...
_________________
Linux Registered User n. 373835

Titus Lucretius Carus, De Rerum Natura - Tantum religio potuit suadere malorum
Back to top
View user's profile Send private message
polslinux
Apprentice
Apprentice


Joined: 12 Apr 2010
Posts: 251
Location: Veneto

PostPosted: Thu Oct 11, 2012 12:00 pm    Post subject: Reply with quote

Ciao, ho ricompilato il kernel e messo tutto il necessario come moduli, giusto per prova, ma comunque non va.
Come puoi vedere qui qualche tempo fa mentre usavo Ubuntu ho riportato un bug report (https://bugs.launchpad.net/ubuntu/+source/linux/+bug/898826) e cercando in internet ho scoperto che è colpa del kernel che non vede il mio dispositivo come un utilizzatore del modulo ath3k.
Ho letto che su ubuntu hanno fixato (kernel 3.5) ma su Gentoo usando il kernel 3.5 non è cambiato niente.
Ora come posso fare per sistemare la questione?? Idee??
_________________
PC-Desktop: Ubuntu 12.04 x86
Notebook Sony Vaio VPCEH: Gentoo ~amd64
Back to top
View user's profile Send private message
Onip
Advocate
Advocate


Joined: 02 Sep 2004
Posts: 2907
Location: Parma (Italy)

PostPosted: Thu Oct 11, 2012 1:28 pm    Post subject: Reply with quote

hai controllato le due cosette di cui ti ho parlato sopra?

per il kernel: sei sicuro che quello che usa Ubuntu non sia un vanilla a cui applicano delle patch che, in quello gentoo, non ci sono?

Io nella configurazione del kernel ho le stesse cose abilitate a parte il fatto che anche nella sezione drivers ho abilitato quasi tutto per non stare a sbattermi troppo a cercare quello giusto.

Che versione di net-wireless/bluez hai installato?
_________________
Linux Registered User n. 373835

Titus Lucretius Carus, De Rerum Natura - Tantum religio potuit suadere malorum
Back to top
View user's profile Send private message
polslinux
Apprentice
Apprentice


Joined: 12 Apr 2010
Posts: 251
Location: Veneto

PostPosted: Thu Oct 11, 2012 1:35 pm    Post subject: Reply with quote

Windows non è presente nel mio notebook (da diverso tempo :P )
E sì, il servizio bluetooth è aggiunto al runlevel "default" e viene avviato correttamente...

Ho la versione di Bluez 4.99 e ora sto aggiornando alla 4.101 sperando che sia questo...ma non ci conto xD
_________________
PC-Desktop: Ubuntu 12.04 x86
Notebook Sony Vaio VPCEH: Gentoo ~amd64
Back to top
View user's profile Send private message
bandreabis
Advocate
Advocate


Joined: 18 Feb 2005
Posts: 2076
Location: ロヂで

PostPosted: Thu Oct 11, 2012 6:27 pm    Post subject: Reply with quote

Nel BIOS del mio Pavillion c'è la voce bluetooth, da te esiste? E' attiva?
Inoltre se avvio il pc, nemmeno la mia Gentoo non vede il dispositivo ma appare se disattivo e poi riattivo il wireless.

Prova e facci sapere.
Back to top
View user's profile Send private message
polslinux
Apprentice
Apprentice


Joined: 12 Apr 2010
Posts: 251
Location: Veneto

PostPosted: Thu Oct 11, 2012 9:23 pm    Post subject: Reply with quote

nel bios non c'è niente...e il metodo del wifi non funge :(
_________________
PC-Desktop: Ubuntu 12.04 x86
Notebook Sony Vaio VPCEH: Gentoo ~amd64
Back to top
View user's profile Send private message
Massimog
Tux's lil' helper
Tux's lil' helper


Joined: 04 Nov 2011
Posts: 106
Location: Osimo(AN)

PostPosted: Mon Oct 15, 2012 12:40 pm    Post subject: Reply with quote

a me per la mia chiavetta bluetooth carica questi moduli
Code:
lsusb|grep Blu
Bus 006 Device 002: ID 0a12:0001 Cambridge Silicon Radio, Ltd Bluetooth Dongle (HCI mode)

Code:
lsmod |grep bluetooth
bluetooth             119540  23 rfcomm,bnep,btusb
rfkill                  7032  4 bluetooth,cfg80211


quando ho configuratto la chiavetta ho seguito il wiki http://wiki.gentoo.org/wiki/Bluetooth
Back to top
View user's profile Send private message
polslinux
Apprentice
Apprentice


Joined: 12 Apr 2010
Posts: 251
Location: Veneto

PostPosted: Sat Oct 20, 2012 9:59 am    Post subject: Reply with quote

grazie ma il problema è più difficile :)
Ho provato a fare come dice sto tizio:
http://www.linuxquestions.org/questions/slackware-14/%5Bsolved%5D-bluetooth-adapter-not-working-0489-e027-foxconn-hon-hai-4175430169/
ma nada :(
_________________
PC-Desktop: Ubuntu 12.04 x86
Notebook Sony Vaio VPCEH: Gentoo ~amd64
Back to top
View user's profile Send private message
Massimog
Tux's lil' helper
Tux's lil' helper


Joined: 04 Nov 2011
Posts: 106
Location: Osimo(AN)

PostPosted: Sat Oct 20, 2012 6:51 pm    Post subject: Reply with quote

nei log non c'è niente ?
hai copiato il firmware in
Code:
/lib/firmware
Back to top
View user's profile Send private message
polslinux
Apprentice
Apprentice


Joined: 12 Apr 2010
Posts: 251
Location: Veneto

PostPosted: Sun Oct 21, 2012 12:21 pm    Post subject: Reply with quote

è giusto così:

Code:
locate ath3k
/lib64/modules/3.6.1-pol/kernel/drivers/bluetooth/ath3k.ko
/lib64/modules/3.6.2-pol/kernel/drivers/bluetooth/ath3k.ko
/usr/src/linux-3.6.2-gentoo/.tmp_versions/ath3k.mod
/usr/src/linux-3.6.2-gentoo/drivers/bluetooth/.ath3k.ko.cmd
/usr/src/linux-3.6.2-gentoo/drivers/bluetooth/.ath3k.mod.o.cmd
/usr/src/linux-3.6.2-gentoo/drivers/bluetooth/.ath3k.o.cmd
/usr/src/linux-3.6.2-gentoo/drivers/bluetooth/ath3k.c
/usr/src/linux-3.6.2-gentoo/drivers/bluetooth/ath3k.ko
/usr/src/linux-3.6.2-gentoo/drivers/bluetooth/ath3k.mod.c
/usr/src/linux-3.6.2-gentoo/drivers/bluetooth/ath3k.mod.o
/usr/src/linux-3.6.2-gentoo/drivers/bluetooth/ath3k.o
/usr/src/linux-3.6.2-gentoo/include/config/bt/ath3k.h


o devo copiarlo anche da altre parti?

PS: devo avere linux-firmware installato oppure andrebbe in conflitto con la versione modificata che ho io del modulo ath3k.ko?
_________________
PC-Desktop: Ubuntu 12.04 x86
Notebook Sony Vaio VPCEH: Gentoo ~amd64
Back to top
View user's profile Send private message
Massimog
Tux's lil' helper
Tux's lil' helper


Joined: 04 Nov 2011
Posts: 106
Location: Osimo(AN)

PostPosted: Sun Oct 21, 2012 6:12 pm    Post subject: Reply with quote

guarda se ti da qualche ifo
Code:
less /var/log/messages|grep ath3k
Back to top
View user's profile Send private message
polslinux
Apprentice
Apprentice


Joined: 12 Apr 2010
Posts: 251
Location: Veneto

PostPosted: Sun Oct 21, 2012 6:31 pm    Post subject: Reply with quote

A te :)

Code:
less /var/log/messages|grep ath3k
Oct 10 16:45:56 vaio kernel: [   63.183655] usbcore: registered new interface driver ath3k
Oct 10 17:07:40 vaio kernel: [ 1366.671991] usbcore: deregistering interface driver ath3k
Oct 10 17:11:20 vaio kernel: [ 1586.673304] usbcore: registered new interface driver ath3k
Oct 10 17:25:35 vaio kernel: [  492.837396] usbcore: deregistering interface driver ath3k
Oct 10 17:25:58 vaio kernel: [  516.085230] ath3k 1-1.5:1.0: usb_probe_interface
Oct 10 17:25:58 vaio kernel: [  516.085241] ath3k 1-1.5:1.0: usb_probe_interface - got id
Oct 10 17:26:03 vaio kernel: [  521.082004] ath3k: probe of 1-1.5:1.0 failed with error -110
Oct 10 17:26:03 vaio kernel: [  521.082013] ath3k 1-1.5:1.1: usb_probe_interface
Oct 10 17:26:03 vaio kernel: [  521.082016] ath3k 1-1.5:1.1: usb_probe_interface - got id
Oct 10 17:26:03 vaio kernel: [  521.082044] usbcore: registered new interface driver ath3k
Oct 10 17:27:53 vaio kernel: [  630.962181] usbcore: deregistering interface driver ath3k
Oct 10 19:25:00 vaio kernel: [    6.739029] ath3k 1-1.5:1.0: usb_probe_interface
Oct 10 19:25:00 vaio kernel: [    6.739037] ath3k 1-1.5:1.0: usb_probe_interface - got id
Oct 10 19:25:00 vaio kernel: [   11.736256] ath3k: probe of 1-1.5:1.0 failed with error -110
Oct 10 19:25:00 vaio kernel: [   11.736279] ath3k 1-1.5:1.1: usb_probe_interface
Oct 10 19:25:00 vaio kernel: [   11.736286] ath3k 1-1.5:1.1: usb_probe_interface - got id
Oct 10 19:25:00 vaio kernel: [   11.736350] usbcore: registered new interface driver ath3k
Oct 11 23:24:35 vaio kernel: [    6.478813] usbcore: registered new interface driver ath3k
Oct 13 21:10:28 vaio kernel: [    6.489787] usbcore: registered new interface driver ath3k
Oct 15 22:40:45 vaio kernel: [    6.323210] usbcore: registered new interface driver ath3k
Oct 15 23:15:44 vaio kernel: [    7.999941] usbcore: registered new interface driver ath3k
Oct 16 09:01:40 vaio kernel: [    7.912547] usbcore: registered new interface driver ath3k
Oct 16 14:21:04 vaio kernel: [    8.366673] usbcore: registered new interface driver ath3k
Oct 18 16:22:40 localhost kernel: [    6.003099] usbcore: registered new interface driver ath3k
Oct 20 09:21:53 localhost kernel: [    6.016844] usbcore: registered new interface driver ath3k
Oct 20 09:28:22 localhost kernel: [    6.417219] ath3k 1-1.5:1.0: usb_probe_interface
Oct 20 09:28:22 localhost kernel: [    6.417221] ath3k 1-1.5:1.0: usb_probe_interface - got id
Oct 20 09:28:22 localhost kernel: [   11.414506] ath3k: probe of 1-1.5:1.0 failed with error -110
Oct 20 09:28:22 localhost kernel: [   11.414530] ath3k 1-1.5:1.1: usb_probe_interface
Oct 20 09:28:22 localhost kernel: [   11.414538] ath3k 1-1.5:1.1: usb_probe_interface - got id
Oct 20 09:28:22 localhost kernel: [   11.414595] usbcore: registered new interface driver ath3k
Oct 21 09:43:21 localhost kernel: [    6.250525] ath3k 1-1.5:1.0: usb_probe_interface
Oct 21 09:43:21 localhost kernel: [    6.250529] ath3k 1-1.5:1.0: usb_probe_interface - got id
Oct 21 09:43:21 localhost kernel: [   11.248802] ath3k: probe of 1-1.5:1.0 failed with error -110
Oct 21 09:43:21 localhost kernel: [   11.248824] ath3k 1-1.5:1.1: usb_probe_interface
Oct 21 09:43:21 localhost kernel: [   11.248831] ath3k 1-1.5:1.1: usb_probe_interface - got id
Oct 21 09:43:21 localhost kernel: [   11.248886] usbcore: registered new interface driver ath3k
Oct 21 20:22:43 localhost kernel: [    6.159089] ath3k 1-1.5:1.0: usb_probe_interface
Oct 21 20:22:43 localhost kernel: [    6.159092] ath3k 1-1.5:1.0: usb_probe_interface - got id
Oct 21 20:22:43 localhost kernel: [   11.156813] ath3k: probe of 1-1.5:1.0 failed with error -110
Oct 21 20:22:43 localhost kernel: [   11.156837] ath3k 1-1.5:1.1: usb_probe_interface
Oct 21 20:22:43 localhost kernel: [   11.156844] ath3k 1-1.5:1.1: usb_probe_interface - got id
Oct 21 20:22:43 localhost kernel: [   11.156899] usbcore: registered new interface driver ath3k

_________________
PC-Desktop: Ubuntu 12.04 x86
Notebook Sony Vaio VPCEH: Gentoo ~amd64
Back to top
View user's profile Send private message
polslinux
Apprentice
Apprentice


Joined: 12 Apr 2010
Posts: 251
Location: Veneto

PostPosted: Thu Oct 25, 2012 3:08 pm    Post subject: Reply with quote

risolto :D
ho proposto la patch qui: https://bugs.gentoo.org/show_bug.cgi?id=439620
_________________
PC-Desktop: Ubuntu 12.04 x86
Notebook Sony Vaio VPCEH: Gentoo ~amd64
Back to top
View user's profile Send private message
.:deadhead:.
Advocate
Advocate


Joined: 25 Nov 2003
Posts: 2959
Location: Milano, Italy

PostPosted: Tue Nov 13, 2012 9:53 pm    Post subject: Reply with quote

polslinux wrote:
risolto :D
ho proposto la patch qui: https://bugs.gentoo.org/show_bug.cgi?id=439620

;) good job
Ora non ti resta che modificare l'oggetto del thread, aggiungendo [Risolto] nel titolo
_________________
Proudly member of the Gentoo Documentation Project: the Italian Conspiracy ! ;)
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian) Forum di discussione italiano All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum