Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[solved]ins/gst-plugins-v4l2-0.10.30 failed gstv4l2bufferp
View unanswered posts
View posts from last 24 hours

Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message

Joined: 30 Dec 2005
Posts: 4185
Location: india

PostPosted: Mon Oct 08, 2012 3:15 am    Post subject: [solved]ins/gst-plugins-v4l2-0.10.30 failed gstv4l2bufferp Reply with quote

configure: *** Orc acceleration enabled.

 * Building system plugin v4l2 ...
make -j3
  CC     libgstvideo4linux2_la-gstv4l2.lo
  CC     libgstvideo4linux2_la-gstv4l2colorbalance.lo
  CC     libgstvideo4linux2_la-gstv4l2object.lo
  CC     libgstvideo4linux2_la-gstv4l2bufferpool.lo
  CC     libgstvideo4linux2_la-gstv4l2src.lo
gstv4l2bufferpool.c: In function 'gst_v4l2_buffer_new':
gstv4l2bufferpool.c:183:3: error: 'struct v4l2_buffer' has no member named 'input'
make: *** [libgstvideo4linux2_la-gstv4l2bufferpool.lo] Error 1
make: *** Waiting for unfinished jobs....
emake failed
 * ERROR: media-plugins/gst-plugins-v4l2-0.10.30 failed (compile phase):
 *   compile failure
 * Call stack:
 *, line   89:  Called src_compile
 *   environment, line 2174:  Called gst-plugins-good_src_compile
 *   environment, line 1506:  Called die
 * The specific snippet of code:
 *       emake || die "compile failure"
 * If you need support, post the output of `emerge --info '=media-plugins/gst-plugins-v4l2-0.10.30'`,
 * the complete build log and the output of `emerge -pqv '=media-plugins/gst-plugins-v4l2-0.10.30'`.
 * The complete build log is located at '/var/tmp/portage/media-plugins/gst-plugins-v4l2-0.10.30/temp/build.log'.

localhost ramaswamy # emerge --info =media-plugins/gst-plugins-v4l2-0.10.30
Portage (default/linux/x86/10.0, gcc-4.5.4, glibc-2.15-r3, 3.5.4-gentoo i686)
                         System Settings
System uname: Linux-3.5.4-gentoo-i686-AMD_E1-1200_APU_with_Radeon-tm-_HD_Graphics-with-gentoo-2.2
Timestamp of tree: Mon, 08 Oct 2012 02:00:01 +0000
app-shells/bash:          4.2_p37
dev-lang/python:          2.7.3-r2, 3.2.3-r1
dev-util/cmake:           2.8.9-r1
dev-util/pkgconfig:       0.27.1
sys-apps/baselayout:      2.2
sys-apps/openrc:          0.10.5
sys-apps/sandbox:         2.6
sys-devel/autoconf:       2.13, 2.69
sys-devel/automake:       1.11.6, 1.12.4
sys-devel/binutils:       2.22.90
sys-devel/gcc:            4.5.4, 4.6.3
sys-devel/gcc-config:     1.7.3
sys-devel/libtool:        2.4.2
sys-devel/make:           3.82-r4
sys-kernel/linux-headers: 3.6 (virtual/os-headers)
sys-libs/glibc:           2.15-r3
Repositories: gentoo kde-sunset
CFLAGS="-O2 -march=i686 -pipe"
CONFIG_PROTECT="/etc /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="${EPREFIX}/etc/gconf /etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-O2 -march=i686 -pipe"
FCFLAGS="-O2 -march=i686 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles news parallel-fetch protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch"
FFLAGS="-O2 -march=i686 -pipe"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
USE="acl alsa berkdb bzip2 cdr cli cracklib crypt cups cxx dri dvd fortran gdbm gnome gpm iconv ipv6 modules mudflap ncurses nls nptl openmp pam pcre pppd qt4 readline session ssl tcpd unicode x86 zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1 emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" PHP_TARGETS="php5-3" PYTHON_TARGETS="python3_2 python2_7" RUBY_TARGETS="ruby18 ruby19" USERLAND="GNU" VIDEO_CARDS="ati radeon vesa" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"

localhost ramaswamy #

i dont know why v4l2 is being merged.
currently it is a new install.
gnome being installed.
reach out a little bit more to catch it (DON'T BELIEVE the advocate part under my user name)

Last edited by padoor on Tue Oct 09, 2012 2:34 am; edited 1 time in total
Back to top
View user's profile Send private message
John R. Graham

Joined: 08 Mar 2005
Posts: 9872
Location: Somewhere over Atlanta, Georgia

PostPosted: Mon Oct 08, 2012 5:50 pm    Post subject: Reply with quote


This compiles cleanly here with both of my installed compilers (4.5.4, which you're using, and 4.6.1-r1). I'd start out by looking at the package's dependency graph
equery depgraph gst-plugins-v4l2-0.10.30
and selectively rebuild the dependencies.

The other thing that I would do, just in case this was an ephemeral issue with the Portage tree or the upstream tarball is to
emerge --sync
to account for the former, and
rm /usr/portage/distfiles/gst-plugins-good-0.10.30.tar.bz2
to account for the latter and then try the emerge again.

- John
I can confirm that I have received between 0 and 499 National Security Letters.

Last edited by John R. Graham on Mon Oct 08, 2012 6:23 pm; edited 1 time in total
Back to top
View user's profile Send private message
Leo Laursen

Joined: 29 Mar 2012
Posts: 38

PostPosted: Mon Oct 08, 2012 6:11 pm    Post subject: Reply with quote

See the post can't compile gst-plugins-v4l2.
Back to top
View user's profile Send private message

Joined: 30 Dec 2005
Posts: 4185
Location: india

PostPosted: Tue Oct 09, 2012 2:33 am    Post subject: Reply with quote

Leo Laursen
thanks for showing the link.
sure downgrading linux-headers helped merging the v4l2
now the updates are going ahed. :)
reach out a little bit more to catch it (DON'T BELIEVE the advocate part under my user name)
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum