Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
mesa-9999 and libGLU split-out
View unanswered posts
View posts from last 24 hours

Goto page 1, 2  Next  
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
genstorm
Advocate
Advocate


Joined: 05 Apr 2007
Posts: 2349
Location: Austria

PostPosted: Sun Sep 02, 2012 11:50 am    Post subject: mesa-9999 and libGLU split-out Reply with quote

Two days ago, libGLU was removed from mesa.git master and is now it's own package. mesa-9_pre20120831 which is in portage should be the last version to include the library, anyway, it seems to be broken for me so I went -9999. Changes are needed for bleeding edge mesa guys, and bugs.gentoo.org is currently down, so here I will cover the handful of changes required to do.

Requires of course:
Code:
# layman -a x11

...and a personal overlay for the modified ebuilds, I called it mesa-edge.


virtual/glu-7.0
Code:
--- a/virtual/glu/glu-7.0.ebuild        2012-05-10 20:31:28.000000000 +0200
+++ b/virtual/glu/glu-7.0.ebuild        2012-09-02 11:17:04.650071875 +0200
@@ -9,5 +9,5 @@
 SLOT="0"
 KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 sh sparc x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
 IUSE=""
-RDEPEND="|| ( media-libs/mesa media-libs/opengl-apple )"
+RDEPEND="|| ( <media-libs/mesa-9.0 media-libs/opengl-apple )"
 DEPEND=""


virtual/glu-9.0 (bump)
Code:
--- a/virtual/glu/glu-7.0.ebuild        2012-05-10 20:31:28.000000000 +0200
+++ b/virtual/glu/glu-9.0.ebuild        2012-09-02 11:31:18.594396102 +0200
@@ -9,5 +9,5 @@
 SLOT="0"
 KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 sh sparc x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
 IUSE=""
-RDEPEND="|| ( media-libs/mesa media-libs/opengl-apple )"
+RDEPEND="|| ( >=media-libs/glu-9.0 media-libs/opengl-apple )"
 DEPEND=""


x11-libs/gtkglext-1.2.0 (configure fails)
Code:
--- a/x11-libs/gtkglext/gtkglext-1.2.0.ebuild   2012-05-05 06:01:30.000000000 +0200
+++ b/x11-libs/gtkglext/gtkglext-1.2.0.ebuild   2012-09-02 11:42:29.338010652 +0200
@@ -18,6 +18,7 @@
 RDEPEND=">=dev-libs/glib-2:2
        >=x11-libs/gtk+-2:2
        >=x11-libs/pango-1[X]
+       virtual/glu
        virtual/opengl"
 DEPEND="${RDEPEND}
        virtual/pkgconfig"


media-gfx/freecad-0.12.5284-r2 (configure fails)
Code:
--- a/media-gfx/freecad/freecad-0.12.5284-r2.ebuild     2012-05-06 21:01:16.000000000 +0200
+++ b/media-gfx/freecad/freecad-0.12.5284-r2.ebuild     2012-09-02 11:41:28.266774150 +0200
@@ -33,6 +33,7 @@
        sci-libs/gts
        sys-libs/zlib
        virtual/fortran
+       virtual/glu
        x11-libs/qt-gui:4
        x11-libs/qt-opengl:4
        x11-libs/qt-svg:4


app-office/libreoffice-3.6.9999 (configure fails)
Code:
--- a/app-office/libreoffice/libreoffice-3.6.9999.ebuild        2012-08-25 11:01:05.000000000 +0200
+++ b/app-office/libreoffice/libreoffice-3.6.9999.ebuild        2012-09-02 12:05:14.507943680 +0200
@@ -152,7 +152,9 @@
                dev-java/tomcat-servlet-api:3.0
        )
        mysql? ( >=dev-db/mysql-connector-c++-1.1.0 )
-       opengl? ( virtual/opengl )
+       opengl? ( virtual/glu
+               virtual/opengl
+       )
        postgres? ( >=dev-db/postgresql-base-9.0[kerberos] )
        svg? ( gnome-base/librsvg )
        webdav? ( net-libs/neon )


www-plugins/gnash-0.8.10-r2 (configure: WARNING: No GLU library found! ...compile fails later then)
Code:
--- a/www-plugins/gnash/gnash-0.8.10-r2.ebuild  2012-05-21 08:31:28.000000000 +0200
+++ b/www-plugins/gnash/gnash-0.8.10-r2.ebuild  2012-09-02 12:50:22.499089134 +0200
@@ -84,6 +84,7 @@
        )
        kde? ( $(add_kdebase_dep kdebase-startkde) )
        opengl? (
+               virtual/glu
                virtual/opengl
                gtk? ( x11-libs/gtkglext )
        )


media-libs/opencv-2.4.2 (goes through configure, but fails early at compile time)
Code:
--- a/media-libs/opencv/opencv-2.4.2.ebuild     2012-08-23 13:31:19.000000000 +0200
+++ b/media-libs/opencv/opencv-2.4.2.ebuild     2012-09-02 13:01:50.852483532 +0200
@@ -38,6 +38,7 @@
        ieee1394? ( media-libs/libdc1394 sys-libs/libraw1394 )
        ipp? ( sci-libs/ipp )
        openexr? ( media-libs/openexr )
+       opengl? ( virtual/glu )
        png? ( media-libs/libpng )
        qt4? (
                x11-libs/qt-gui:4


media-gfx/darktable-1.0.5 (goes through configure, but fails later at compile time)
Code:
--- a/media-gfx/darktable/darktable-1.0.5.ebuild        2012-08-01 09:27:18.000000000 +0200
+++ b/media-gfx/darktable/darktable-1.0.5.ebuild        2012-09-02 13:07:45.332051927 +0200
@@ -41,6 +41,7 @@
                virtual/opengl
        )
        virtual/jpeg
+       virtual/glu
        x11-libs/cairo
        x11-libs/gdk-pixbuf:2
        x11-libs/gtk+:2"


sci-libs/opencascade-6.5 (goes through configure, but is listed in @preserved-rebuild, won't wait for that moloch to fail)
Code:
--- a/sci-libs/opencascade/opencascade-6.5.ebuild       2012-06-22 15:31:26.000000000 +0200
+++ b/sci-libs/opencascade/opencascade-6.5.ebuild       2012-09-02 13:17:50.116491080 +0200
@@ -17,6 +17,7 @@
 
 DEPEND="
        media-libs/ftgl
+       virtual/glu
        virtual/opengl
        x11-libs/libXmu
        >=dev-lang/tcl-8.4


app-emulation/wine-1.5.12 (last but not least)
Code:
--- a/app-emulation/wine/wine-1.5.11.ebuild     2012-08-23 19:01:03.000000000 +0200
+++ b/app-emulation/wine/wine-1.5.12.ebuild     2012-09-02 14:32:27.468516477 +0200
@@ -78,7 +78,10 @@
        alsa? ( media-libs/alsa-lib )
        cups? ( net-print/cups )
        opencl? ( virtual/opencl )
-       opengl? ( virtual/opengl )
+       opengl? (
+               virtual/glu
+               virtual/opengl
+       )
        gsm? ( media-sound/gsm )
        jpeg? ( virtual/jpeg )
        ldap? ( net-nds/openldap )


Packages already making use of virtual/glu, no change needed:
  • media-libs/ftgl-2.1.3_rc5
  • games-action/rrootage-0.23a
  • kde-base/kinfocenter-4.9.0
  • dev-java/swt-3.7.1
  • games-fps/alienarena-20120629
  • media-libs/coin-3.1.3-r1
  • media-libs/freeglut-2.8.0-r1
  • media-libs/libsdl-1.2.15-r2


Code:
# emerge -uvaD world

This should pull in virtual/glu-9.0, thus media-libs/glu-9999 automatically. At the time of writing this, glu-9999 and also mesa-9999 both build fine.

I don't claim ultimate knowledge over the virtual and R/DEPEND handling - it works for me though. Other packages will likely need similar changes, those were just mine. In the hopes this isn't too big a nonsense and will help someone...

PS: Right now, media-libs/glu-9999 collides with emul-linux-x86-opengl because it also installs into /usr/lib32. A dirty workaround:
Code:
FEATURES="-collision-protect" emerge -1 media-libs/glu

_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
hedmo
l33t
l33t


Joined: 29 Aug 2009
Posts: 839
Location: halmstad

PostPosted: Wed Sep 05, 2012 4:27 pm    Post subject: Reply with quote

genstorm

thanks for the info and i found :

x11-drivers/ati-drivers

fails with compiling fgl_glxgears (gl/glu.h no such file or directory).to fix it i had to emerge media-libs/glu but with :

FEATURES="-collision-detect -protect-owned" emerge media-libs/glu


regards hedmo
Back to top
View user's profile Send private message
mattst88
Developer
Developer


Joined: 28 Oct 2004
Posts: 362

PostPosted: Wed Sep 05, 2012 5:21 pm    Post subject: Reply with quote

genstorm,

Awesome work. Thanks a lot!

I made a tracker bug for packages needing virtual/glu changes: https://bugs.gentoo.org/show_bug.cgi?id=432516
_________________
My 1U Dual 833 MHz Alphaserver DS20L
The AlphaLinux.org Wiki
Back to top
View user's profile Send private message
kernelOfTruth
Watchman
Watchman


Joined: 20 Dec 2005
Posts: 5610
Location: Vienna, Austria; Germany; hello world :)

PostPosted: Wed Sep 05, 2012 8:10 pm    Post subject: Reply with quote

I just stumbled over the same issue and couldn't install freeglut, kinfocenter, etc.


unfortunately I couldn't install media-libs/glu so far (from the x11 overlay) since there were file collisions underway from emul-linux-x86-opengl

so I had to manually copy over /usr/include/GL/glu.h

basically did the same like your "-collision-protect"



thanks genstorm !
_________________
Unofficial minimal livecd x86/amd64 w/reiser4+truecrypt (by Neo2)
2.6.37.2_plus_v1: BFS, CFS,THP,compaction, zcache or TOI
Hardcore Linux user since 2004 :D
Back to top
View user's profile Send private message
hedmo
l33t
l33t


Joined: 29 Aug 2009
Posts: 839
Location: halmstad

PostPosted: Wed Sep 05, 2012 8:33 pm    Post subject: Reply with quote

kernelOfTruth wrote:

so I had to manually copy over /usr/include/GL/glu.h

basically did the same like your "-collision-protect"


kernelOfTruth

i want to try your way.can you post how for me ( /usr/include/GL/glu.h only? to?)

regards hedmo
Back to top
View user's profile Send private message
kernelOfTruth
Watchman
Watchman


Joined: 20 Dec 2005
Posts: 5610
Location: Vienna, Austria; Germany; hello world :)

PostPosted: Wed Sep 05, 2012 10:37 pm    Post subject: Reply with quote

hedmo wrote:
kernelOfTruth wrote:

so I had to manually copy over /usr/include/GL/glu.h

basically did the same like your "-collision-protect"


kernelOfTruth

i want to try your way.can you post how for me ( /usr/include/GL/glu.h only? to?)

regards hedmo


Hi hedmo,

I got following message:

Quote:
* Detected file collision(s):
*
* /usr/lib32/pkgconfig/glu.pc
* /usr/lib32/libGLU.so.1
* /usr/lib32/libGLU.so
*
* Searching all installed packages for file collisions...
*
* Press Ctrl-C to Stop
*
* app-emulation/emul-linux-x86-opengl-20120520
* /usr/lib32/libGLU.so
* /usr/lib32/libGLU.so.1
* /usr/lib32/pkgconfig/glu.pc
*
* Package 'media-libs/glu-9999' NOT merged due to file collisions. If
* necessary, refer to your elog messages for the whole content of the
* above message.


for me /usr/include/GL/glu.h

was missing so I unpacked

ebuild media-libs/glu-9999.ebuild unpack

and copied over glu.h from

/var/tmp/portage/media-libs/glu-9999/work/glu-9999/include/GL/

to /usr/include/GL




to be future-safe and do it the "Gentoo way" I'd go with genstorm's posted steps above

Code:
FEATURES="-collision-protect" emerge -1 media-libs/glu


for now - that's the more efficient way



and either update the ebuilds of the packages depending on it now

or wait until they're updated in the tree and then update them via emerge


thanks
_________________
Unofficial minimal livecd x86/amd64 w/reiser4+truecrypt (by Neo2)
2.6.37.2_plus_v1: BFS, CFS,THP,compaction, zcache or TOI
Hardcore Linux user since 2004 :D
Back to top
View user's profile Send private message
ryszardzonk
Apprentice
Apprentice


Joined: 18 Dec 2003
Posts: 182
Location: Rzeszów, POLAND

PostPosted: Fri Sep 07, 2012 6:56 am    Post subject: Reply with quote

well guys I tried several thing and I am not able to compile media-libs/glu-9999 which I presume is now required. It bails with the following error

media-libs/glu-9999
Code:
  CXX      src/libnurbs/nurbtess/sampleMonoPoly.lo
  CXX      src/libnurbs/nurbtess/sampledLine.lo
/tmp/portage/media-libs/glu-9999/work/glu-9999/src/libnurbs/nurbtess/sampleCompTop.cc: In function ‘void sampleCompTop(Real*, vertexArray*, Int, vertexArray*, Int, gridBoundaryChain*, gridBoundaryChain*, Int, Int, Int, Int, Int, primStream*)’:
/tmp/portage/media-libs/glu-9999/work/glu-9999/src/libnurbs/nurbtess/sampleCompTop.cc:514:13: warning: variable ‘tempTop’ set but not used [-Wunused-but-set-variable]
/tmp/portage/media-libs/glu-9999/work/glu-9999/src/libnurbs/nurbtess/sampleCompTop.cc:515:11: warning: variable ‘tempLeftStart’ set but not used [-Wunused-but-set-variable]
  CXX      src/libnurbs/nurbtess/searchTree.lo
  CXXLD    libGLU.la
/usr/lib/gcc/x86_64-pc-linux-gnu/4.6.3/../../../../x86_64-pc-linux-gnu/bin/ld: skipping incompatible /usr/lib/gcc/x86_64-pc-linux-gnu/4.6.3/../../../libGL.so when searching for -lGL
/usr/lib/gcc/x86_64-pc-linux-gnu/4.6.3/../../../../x86_64-pc-linux-gnu/bin/ld: skipping incompatible /usr/lib/gcc/x86_64-pc-linux-gnu/4.6.3/../../../libGL.so when searching for -lGL
/usr/lib/gcc/x86_64-pc-linux-gnu/4.6.3/../../../../x86_64-pc-linux-gnu/bin/ld: skipping incompatible /usr/lib/libGL.so when searching for -lGL
/usr/lib/gcc/x86_64-pc-linux-gnu/4.6.3/../../../../x86_64-pc-linux-gnu/bin/ld: cannot find -lGL
collect2: ld returned 1 exit status
make: *** [libGLU.la] Error 1

libGL.so
Code:
# ll /usr/lib/libGL.so*
lrwxrwxrwx 1 root root 34 09-07 08:48 /usr/lib/libGL.so -> opengl/xorg-x11/lib/libGL.so.1.2.0*
lrwxrwxrwx 1 root root 34 09-07 08:48 /usr/lib/libGL.so.1 -> opengl/xorg-x11/lib/libGL.so.1.2.0*


Code:
# ll /usr/lib/opengl/xorg-x11/lib/libGL.so.1.2.0
-rwxr-xr-x 1 root root 480488 09-07 08:48 /usr/lib/opengl/xorg-x11/lib/libGL.so.1.2.0*
bigvo2 media-plugins # qfile libGL.so.1.2.0
media-libs/mesa (/usr/lib64/opengl/xorg-x11/lib/libGL.so.1.2.0)

# genlop -t mesa
 * media-libs/mesa

   Fri Sep  7 08:48:24 2012 >>> media-libs/mesa-9999
       merge time: 10 minutes and 46 seconds.


I have mesa installed from the x11 overlay. Any ideas?
_________________
Sky is not the limit...
Back to top
View user's profile Send private message
mattst88
Developer
Developer


Joined: 28 Oct 2004
Posts: 362

PostPosted: Fri Sep 07, 2012 6:58 am    Post subject: Reply with quote

You need a 32-bit libGL provided by app-emulation/emul-linux-x86-opengl
_________________
My 1U Dual 833 MHz Alphaserver DS20L
The AlphaLinux.org Wiki
Back to top
View user's profile Send private message
kernelOfTruth
Watchman
Watchman


Joined: 20 Dec 2005
Posts: 5610
Location: Vienna, Austria; Germany; hello world :)

PostPosted: Fri Sep 07, 2012 7:48 pm    Post subject: Reply with quote

just wanted to update system (emerge -e system)

and ran into the following blocker:

Quote:
These are the packages that would be merged, in order:

Calculating dependencies ... done!
[ebuild R #] media-libs/glu-9999::x11 USE="(multilib) -static-libs" 0 kB
[blocks B ] app-emulation/emul-linux-x86-opengl ("app-emulation/emul-linux-x86-opengl" is blocking media-libs/glu-9999)

Total: 1 package (1 reinstall), Size of downloads: 0 kB
Conflict: 1 block (1 unsatisfied)

* Error: The above package list contains packages which cannot be
* installed at the same time on the same system.

(app-emulation/emul-linux-x86-opengl-20120520::gentoo, installed) pulled in by
app-emulation/emul-linux-x86-opengl required by (app-emulation/emul-linux-x86-xlibs-20120520::gentoo, installed)
app-emulation/emul-linux-x86-opengl required by (app-emulation/wine-1.5.12::init6, installed)
~app-emulation/emul-linux-x86-opengl-20120520 required by (app-emulation/emul-linux-x86-qtlibs-20120520::gentoo, installed)
~app-emulation/emul-linux-x86-opengl-20120520 required by (app-emulation/emul-linux-x86-gtklibs-20120520::gentoo, installed)

(media-libs/glu-9999::x11, ebuild scheduled for merge) pulled in by
media-libs/glu required by (virtual/glu-7.0::gentoo, installed)
media-libs/glu
media-libs/glu required by @selected


For more information about Blocked Packages, please refer to the following
section of the Gentoo Linux x86 Handbook (architecture is irrelevant):


Quote:
* These packages depend on app-emulation/emul-linux-x86-opengl:
app-emulation/emul-linux-x86-gtklibs-20120520 (~app-emulation/emul-linux-x86-opengl-20120520)
app-emulation/emul-linux-x86-qtlibs-20120520 (~app-emulation/emul-linux-x86-opengl-20120520)
app-emulation/emul-linux-x86-xlibs-20120520 (opengl ? app-emulation/emul-linux-x86-opengl)
app-emulation/wine-1.5.12 (opengl ? app-emulation/emul-linux-x86-opengl)



am I doing something wrong ?

or is this corner-case not covered yet by the new ebuilds ?


thanks
_________________
Unofficial minimal livecd x86/amd64 w/reiser4+truecrypt (by Neo2)
2.6.37.2_plus_v1: BFS, CFS,THP,compaction, zcache or TOI
Hardcore Linux user since 2004 :D
Back to top
View user's profile Send private message
genstorm
Advocate
Advocate


Joined: 05 Apr 2007
Posts: 2349
Location: Austria

PostPosted: Fri Sep 07, 2012 8:24 pm    Post subject: Reply with quote

media-libs/glu-9999 in x11 overlay was updated to block emul-linux-x86-opengl, that's what is hitting you now.

But I hear the solution is already being worked on, so if you can hold off your emerge -e system for a while still... ;)
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
mattst88
Developer
Developer


Joined: 28 Oct 2004
Posts: 362

PostPosted: Fri Sep 07, 2012 8:34 pm    Post subject: Reply with quote

genstorm wrote:
media-libs/glu-9999 in x11 overlay was updated to block emul-linux-x86-opengl, that's what is hitting you now.

But I hear the solution is already being worked on, so if you can hold off your emerge -e system for a while still... ;)


So, you have to explicitly unmask glu-9999 now (sorry, I missed that in the initial commit). I can't figure out why people are still having trouble with this.
_________________
My 1U Dual 833 MHz Alphaserver DS20L
The AlphaLinux.org Wiki
Back to top
View user's profile Send private message
kernelOfTruth
Watchman
Watchman


Joined: 20 Dec 2005
Posts: 5610
Location: Vienna, Austria; Germany; hello world :)

PostPosted: Fri Sep 07, 2012 8:42 pm    Post subject: Reply with quote

I already unmasked, no worries

what troubles me is that there's a block with this essential component:

libGLU is missing on the system - without it and thus lots of stuff doesn't compile (and without emul-linux-x86-opengl it also doesn't work)


so I thought I better ask if I missed some voodoo steps that I had to do to get it working or my portage-tree is sort of broken :)


good to know that it's being worked on

but since I'm giving my (Gentoo) system an overhaul and need the system ready within a few days - I'm using a modified local ebuild for now


thanks :)
_________________
Unofficial minimal livecd x86/amd64 w/reiser4+truecrypt (by Neo2)
2.6.37.2_plus_v1: BFS, CFS,THP,compaction, zcache or TOI
Hardcore Linux user since 2004 :D
Back to top
View user's profile Send private message
mattst88
Developer
Developer


Joined: 28 Oct 2004
Posts: 362

PostPosted: Fri Sep 07, 2012 8:45 pm    Post subject: Reply with quote

Quote:
I already unmasked, no worries

what troubles me is that there's a block with this essential component:


These are mutually-exclusive thoughts. The GLU split is upstream work, and if you don't want to be bothered with it, you can simply not unmask it. I can't (and won't try) to make it work with the current emul-opengl package.
_________________
My 1U Dual 833 MHz Alphaserver DS20L
The AlphaLinux.org Wiki
Back to top
View user's profile Send private message
genstorm
Advocate
Advocate


Joined: 05 Apr 2007
Posts: 2349
Location: Austria

PostPosted: Fri Sep 07, 2012 9:02 pm    Post subject: Reply with quote

@kernelOfTruth, since you are not a fearful guy, you can also solve this by adding the FireBurn overlay and have your 32bit mesa libs built on your own. see this for further explanations ;)

PS: I think I still rely on his overlay because the too dark textures on GM45 aren't yet fixed in the emul version of mesa.
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
ryszardzonk
Apprentice
Apprentice


Joined: 18 Dec 2003
Posts: 182
Location: Rzeszów, POLAND

PostPosted: Sat Sep 08, 2012 6:34 am    Post subject: Reply with quote

mattst88 wrote:
You need a 32-bit libGL provided by app-emulation/emul-linux-x86-opengl


it turned out that is what did the trick of course after several trials and errors and blocking issues like the shown it this thread. However it still find it hard to believe that I need 32bit library just to install glu library in the otherwise 64bit only system. Is it just temporary? If not then IMHO app-emulation/emul-linux-x86-opengl should be added to the dependencies of media-libs/glu-9999
_________________
Sky is not the limit...
Back to top
View user's profile Send private message
mattst88
Developer
Developer


Joined: 28 Oct 2004
Posts: 362

PostPosted: Sat Sep 08, 2012 5:23 pm    Post subject: Reply with quote

ryszardzonk wrote:
mattst88 wrote:
You need a 32-bit libGL provided by app-emulation/emul-linux-x86-opengl


it turned out that is what did the trick of course after several trials and errors and blocking issues like the shown it this thread. However it still find it hard to believe that I need 32bit library just to install glu library in the otherwise 64bit only system. Is it just temporary? If not then IMHO app-emulation/emul-linux-x86-opengl should be added to the dependencies of media-libs/glu-9999


Of course it's temporary. You're using ebuilds from git.

GLU is the OpenGL utility library. It changes very rarely. It's obnoxious to have to recompile something every time you build Mesa when it hasn't changed. So, I split it into its own repository upstream and out of Mesa.

The plan is to add a multilib USE flag to Mesa so that it will be able to build 32-bit and 64-bit libraries. This way, users can update their 32-bit Mesa installations whenever they update Mesa, instead of waiting months and months between emul- package updates.

This is testing stuff. Please don't use it if you're uncomfortable with breakage or file collisions... I'm serious.
_________________
My 1U Dual 833 MHz Alphaserver DS20L
The AlphaLinux.org Wiki
Back to top
View user's profile Send private message
genstorm
Advocate
Advocate


Joined: 05 Apr 2007
Posts: 2349
Location: Austria

PostPosted: Sat Sep 08, 2012 5:27 pm    Post subject: Reply with quote

Hey, I didn't realise you were doing the upstream work. :)

Should we start filing blockers against your tracker?

mattst88 wrote:
The plan is to add a multilib USE flag to Mesa so that it will be able to build 32-bit and 64-bit libraries.

Looking forward to this _so_much_ ;)
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
mattst88
Developer
Developer


Joined: 28 Oct 2004
Posts: 362

PostPosted: Sat Sep 08, 2012 6:35 pm    Post subject: Reply with quote

genstorm wrote:
Should we start filing blockers against your tracker?


Yes, if you see software that depends on GLU but doesn't depend on virtual/glu (instead depends on Mesa and relies on it to provide GLU) please file a bug and make it block the tracker. Thanks a lot! :)
_________________
My 1U Dual 833 MHz Alphaserver DS20L
The AlphaLinux.org Wiki
Back to top
View user's profile Send private message
genstorm
Advocate
Advocate


Joined: 05 Apr 2007
Posts: 2349
Location: Austria

PostPosted: Sun Sep 09, 2012 6:08 pm    Post subject: Reply with quote

I propose the following change for media-libs/glu-9999:

Code:
--- a/media-libs/glu/glu-9999.ebuild  2012-09-06 11:18:06.761815473 +0200
+++ b/media-libs/glu/glu-9999.ebuild 2012-09-09 20:02:05.584095514 +0200
@@ -25,7 +25,7 @@
 DEPEND=""
 RDEPEND="${DEPEND}
        !<=media-libs/mesa-9_pre20120831
-       multilib? ( !app-emulation/emul-linux-x86-opengl )"
+       multilib? ( !<app-emulation/emul-linux-x86-opengl-20120901 )"
 
 foreachabi() {
        if use multilib; then

This will work perfectly fine for now and even when there will finally be a new emul-linux-x86-opengl bump after the glu split.

Meanwhile, it would enable the Fireburn overlay to provide a dummy emul-linux-x86-opengl-20120901.ebuild and remove the block. :)
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
darkbasic
Tux's lil' helper
Tux's lil' helper


Joined: 06 Sep 2006
Posts: 123

PostPosted: Tue Sep 11, 2012 10:21 am    Post subject: Reply with quote

I can't emerge media-libs/glu because it blocks app-emulation/emul-linux-x86-opengl (which is required by a lot of packages).
How can I fix it? I use the fireburn overlay.
_________________
Computers are like air conditioners:
they stop working properly when you open Windows...

Coltiva Linux, Windows si pianta da solo.


http://www.linuxsystems.it/
Back to top
View user's profile Send private message
chithanh
Developer
Developer


Joined: 05 Aug 2006
Posts: 1558
Location: Berlin, Germany

PostPosted: Tue Sep 11, 2012 11:29 am    Post subject: Reply with quote

To avoid the blocker, disable the multilib USE flag for media-libs/glu.
You have to override package.use.force if you are using the multilib profile.
Back to top
View user's profile Send private message
darkbasic
Tux's lil' helper
Tux's lil' helper


Joined: 06 Sep 2006
Posts: 123

PostPosted: Tue Sep 11, 2012 12:18 pm    Post subject: Reply with quote

Thanks! I put
Code:
media-libs/glu -multilib

in /etc/portage/profile/package.use.force/$something
_________________
Computers are like air conditioners:
they stop working properly when you open Windows...

Coltiva Linux, Windows si pianta da solo.


http://www.linuxsystems.it/
Back to top
View user's profile Send private message
tclover
Apprentice
Apprentice


Joined: 10 Apr 2011
Posts: 295

PostPosted: Thu Sep 13, 2012 1:11 pm    Post subject: Reply with quote

i was facing this issue until i decided to mask emul-linux-x86-opengl or alternatively if not both put a line to package.provided to force remove it and be able to merge media-libs/glu-9999 because i was facing multiple breakages due to, mainly, files corruptions (sigh) and a sudden update (only a single month without!) to mesa-9999 (getting mesa-9.0 headaches and breakages), xorg-{drivers,server}-1.13[.0]. i did not try to found any useful forums threads because i did not try to search any and was more than busy to bring back up my system. i lost two days in a attempt to repair it only to finish re-installing a clean system from scratch (well, using my old config files and built packages). and media-libs/glu-9999 was one of those packages that gave me a hard time. sigh.

and yeah, did not think to read the forum nor modify the ebuilds because my time was counted: i could no longer have access to internet for while, again, starting today! yeah!

until next time... thanks for sharing.

edit: why the hell have we have to install emul-linux-x86-xxx things when we, i should say i here, decided to use multilib profile?!
_________________
mkinitramfs-ll:topic 879125::(bar-)overlay:topic 889918
Back to top
View user's profile Send private message
chithanh
Developer
Developer


Joined: 05 Aug 2006
Posts: 1558
Location: Berlin, Germany

PostPosted: Thu Sep 13, 2012 1:28 pm    Post subject: Reply with quote

"Masked by corruption" is caused by editing ebuilds and neglecting to re-create the Manifest. In any case, downgrading to the mesa in portage will give you a working system again.
Back to top
View user's profile Send private message
kernelOfTruth
Watchman
Watchman


Joined: 20 Dec 2005
Posts: 5610
Location: Vienna, Austria; Germany; hello world :)

PostPosted: Thu Sep 13, 2012 3:05 pm    Post subject: Reply with quote

@genstorm:

what I've been looking for - thanks ! :D


@chithanh:

thanks for the advice - I'll mask out the multilib flag
_________________
Unofficial minimal livecd x86/amd64 w/reiser4+truecrypt (by Neo2)
2.6.37.2_plus_v1: BFS, CFS,THP,compaction, zcache or TOI
Hardcore Linux user since 2004 :D
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Goto page 1, 2  Next
Page 1 of 2

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum