Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[Xorg] Xorg black screen
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
bouriquo
Guru
Guru


Joined: 29 May 2004
Posts: 304
Location: Collonges (01)

PostPosted: Sun Aug 12, 2012 5:37 am    Post subject: [Xorg] Xorg black screen Reply with quote

Hi,

I have done a fresh install on my gentoo but when i try to use Xorg i have the message that can't find screen. I have try to generate xorg.conf with X -configure but when i try to use it i obtain a black screen.

I have drivers nvidia. Do you know how can i have my xorg ?

best regards
Back to top
View user's profile Send private message
audiodef
Watchman
Watchman


Joined: 06 Jul 2005
Posts: 6335
Location: /usr/lib64/lv2

PostPosted: Sun Aug 12, 2012 3:27 pm    Post subject: Reply with quote

Is dbus started?
_________________
Gentoo Studio: A Gentoo-based, professional digital audio workstation OS.
Back to top
View user's profile Send private message
bouriquo
Guru
Guru


Joined: 29 May 2004
Posts: 304
Location: Collonges (01)

PostPosted: Sun Aug 12, 2012 5:35 pm    Post subject: Reply with quote

Yes dbus and consolekit too
Back to top
View user's profile Send private message
BillWho
Veteran
Veteran


Joined: 03 Mar 2012
Posts: 1600
Location: US

PostPosted: Sun Aug 12, 2012 6:02 pm    Post subject: Reply with quote

bouriquo,

What's in the driver section of xorg.conf :?: You should probably use the nvidia config tool.
Code:
egrep  '(Driver|Load|Option)' /etc/X11/xorg.conf

_________________
Good luck :wink:

Since installing gentoo, my life has become one long emerge :)
Back to top
View user's profile Send private message
bouriquo
Guru
Guru


Joined: 29 May 2004
Posts: 304
Location: Collonges (01)

PostPosted: Sun Aug 12, 2012 6:14 pm    Post subject: Reply with quote

Hello billwho,

I haven't xorg.conf. if i try without i have error no screen found but if i generate it with xorg -configure i have blackscreen
Back to top
View user's profile Send private message
gorkypl
Guru
Guru


Joined: 04 Oct 2010
Posts: 444
Location: Kraków, PL

PostPosted: Sun Aug 12, 2012 7:14 pm    Post subject: Reply with quote

Xorg -configure is deprecated since the Stone Age.

also look here: http://lmgtfy.com/?q=nvidia+gentoo
_________________
BTW, TWM FTW!
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum