Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
compiz-0.9.7.8->
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2, 3, 4  Next  
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
BlueDragonX
n00b
n00b


Joined: 26 Mar 2004
Posts: 44
Location: United States

PostPosted: Sat Jun 30, 2012 9:14 pm    Post subject: Reply with quote

Ok then. The Compiz v0.9.8 tree is monolithic. In other words, all of the Compiz components are in a single build tree now. I've created an ebuild for the latest revision (as of yesterday) of v0.9.8. I've had to roll two patches for it: one that fixes the sandbox violations (there were only two this time) and the other to fix a bug in the ccsm installation process (it would silently fail, leaving you without the ccsm tool). It builds and installs but I haven't tested to see if it actually works yet. I'm about to test building my emerald 0.9.5 ebuild. Once that's done I'll test running both and let ya'll know how it goes.

My overlay is here: https://github.com/bluedragonx/fm-overlay

All of the work I'm doing on Compiz v0.9.8 is in the compiz-v0.9.8 branch.

The master branch has ebuilds for the Compiz v0.8.8 and v0.9.4. Version 0.9.4 does not work. Version 0.8.8 is stable and what I've been using since Gentoo announced they're no longer supporting Compiz.
Back to top
View user's profile Send private message
BlueDragonX
n00b
n00b


Joined: 26 Mar 2004
Posts: 44
Location: United States

PostPosted: Sun Jul 01, 2012 6:25 pm    Post subject: Reply with quote

I've got v0.9.8 working. I've made a few small changes to the ebuild, such as setting it to load the ccp module automatically on run, that I'm testing.

This is an RC for v0.9.8. Meaning, there's no official releases, I just picked the latest revision and ran with it. I'll roll a live ebuild to go with this, chery-picking RC's as it becomes more stable. I'm looking forward to the first stable release in this series.

Now that I've got this done I'd also like to build a set of ebuilds for Unity. Now that would be interesting.
Back to top
View user's profile Send private message
BlueDragonX
n00b
n00b


Joined: 26 Mar 2004
Posts: 44
Location: United States

PostPosted: Wed Jul 04, 2012 3:56 am    Post subject: Reply with quote

Ok, I've completed the v0.9.7 and v0.9.8_rc3275 (that's revision 3275) ebuilds. I'm running the v0.9.8 build and it's working well enough. There's an issue with the dbus plugin. When it's loaded it causes Compiz to crash any time you load or unload any other plugin. I've put an ewarn into the ebuild to indicate this. Everything else I've tested so far works.

The v0.9 series does not work with fusion-icon. You'll need to run compiz --replace to replace your current WM. If you're running Gnome2 you can set it up to run on login by setting the gconf variable /desktop/gnome/session/required_components/windowmanager to compiz.

I also recommend enabling the Crash Handler plugin and enabling Start Other Window Manager. Set the command line option to your window manager. For Gnome2 that is metacity --replace.
Back to top
View user's profile Send private message
hedmo
l33t
l33t


Joined: 29 Aug 2009
Posts: 839
Location: halmstad

PostPosted: Wed Jul 04, 2012 4:58 am    Post subject: Reply with quote

BlueDragonX

the dbus plugin did not work with 0.9.7.x but with 0.9.8.are you saying that its the dbus plugin that makes ccsm
to crash? i Will check it when i come home after work .how about fade Windows ?does it work for you.it hasnt work for
me for à long time ( even with 0.8.6).about start at boot,i have to make it reload it self to get "fade desktop".this is not a problem when you run it "stand alone".

regards Hedmo
Back to top
View user's profile Send private message
shiznix
Guru
Guru


Joined: 29 Jun 2003
Posts: 358
Location: Adelaide, Australia

PostPosted: Thu Jul 19, 2012 5:09 am    Post subject: Reply with quote

BlueDragonX wrote:
I've got v0.9.8 working. I've made a few small changes to the ebuild, such as setting it to load the ccp module automatically on run, that I'm testing.

This is an RC for v0.9.8. Meaning, there's no official releases, I just picked the latest revision and ran with it. I'll roll a live ebuild to go with this, chery-picking RC's as it becomes more stable. I'm looking forward to the first stable release in this series.

Now that I've got this done I'd also like to build a set of ebuilds for Unity. Now that would be interesting.
We have Unity on Gentoo now. You can browse the overlay at https://github.com/shiznix/unity-gentoo and/or add the overlay with 'layman -a unity-gentoo'.
This overlay also comes with a compiz-0.9.7.8 ebuild that doesn't require patching the source or disabling sandbox to get around sandbox violations.
The default set of plugins enabled by the ebuild may not suit you if you're not aiming to use the Unity desktop nor the Ubuntu patchset but you may be able to use it as a template for your own modifications.
Back to top
View user's profile Send private message
smookey
n00b
n00b


Joined: 28 May 2006
Posts: 17

PostPosted: Tue Aug 28, 2012 11:16 pm    Post subject: Reply with quote

Hey BlueDragonX

Is it possible to use kde4 with compiz-0.9.8_rc3275 from your overlay? I've spend all day trying to make it work, but nothing. It won't compile with kde USE flag.
Back to top
View user's profile Send private message
Jupiter1TX
Guru
Guru


Joined: 24 Feb 2006
Posts: 546
Location: 3rd Rock

PostPosted: Tue Aug 28, 2012 11:56 pm    Post subject: Reply with quote

smookey wrote:
Hey BlueDragonX

Is it possible to use kde4 with compiz-0.9.8_rc3275 from your overlay? I've spend all day trying to make it work, but nothing. It won't compile with kde USE flag.


The 'kde' use flag on compiz is for kde backend integration.
It's much easier and less troublesome to use flat-file backend.
If i remember correctly it also installs kde decorations so just
use emerald decos!
_________________
Core i7 920 D0 | Asus P6T DLX | Patriot Viper 1600 6GB | Antec Quattro 850W
Geforce 8800GTX OC2 768MB | Dell 22" LCD | Koolance Exos2/Swiftech GTZ
GCC 4.6.1 | 3.7.x-geek | Xorg-7.4-x | KDE-4.7.x | Compiz
Back to top
View user's profile Send private message
smookey
n00b
n00b


Joined: 28 May 2006
Posts: 17

PostPosted: Wed Aug 29, 2012 11:40 am    Post subject: Reply with quote

Jupiter1TX wrote:
smookey wrote:
Hey BlueDragonX

Is it possible to use kde4 with compiz-0.9.8_rc3275 from your overlay? I've spend all day trying to make it work, but nothing. It won't compile with kde USE flag.


The 'kde' use flag on compiz is for kde backend integration.
It's much easier and less troublesome to use flat-file backend.
If i remember correctly it also installs kde decorations so just
use emerald decos!


Thanks Jupiter1TX.

How would I do that exactly?
I have now compiz-0.9.8_rc3275 installed with (cairo dbus svg -debug -fuse -gnome -gtk -kde) flags. This is what I get after running compiz:

Code:
# compiz --replace
compiz (core) - Info: Loading plugin: core
compiz (core) - Info: Starting plugin: core
compiz (core) - Warn: Attempted to restack relative to 0x1c0005c which is not a child of the root window or a window compiz owns
compiz (core) - Warn: Attempted to restack relative to 0x1c0005f which is not a child of the root window or a window compiz owns                                                               
compiz (core) - Warn: Attempted to restack relative to 0x1c0005f which is not a child of the root window or a window compiz owns
compiz (core) - Info: Loading plugin: ccp
compiz (core) - Info: Starting plugin: ccp
libcompizconfig: dlopen: /usr/lib/compizconfig/backends/libkconfig4.so: cannot open shared object file: No such file or directory
Backend     : ini
Integration : true
Profile     : default
Adding plugins
Initializing core options...done


There's no window decorations. If I run emerald after that, still no window decorations.
And I don't know what's with the:
Code:
libcompizconfig: dlopen: /usr/lib/compizconfig/backends/libkconfig4.so: cannot open shared object file: No such file or directory
Back to top
View user's profile Send private message
Jupiter1TX
Guru
Guru


Joined: 24 Feb 2006
Posts: 546
Location: 3rd Rock

PostPosted: Thu Aug 30, 2012 3:14 pm    Post subject: Reply with quote

If you open compizconfig settings manager 'ccsm'
ccsm --> preferences --> backend = flat-file
And while you have ccsm open, enable your decorator
ccsm --> window decorations --> command = emerald --replace

Emerald will fail of course if compiz is not running!
As you can see in the error output it is looking for
kde backend which there is none because you disabled
the kde use flag. Changing to flat-file backend should
fix that issue.
Code:

compiz (core) - Info: Starting plugin: ccp
libcompizconfig: dlopen: /usr/lib/compizconfig/backends/libkconfig4.so: cannot open shared object file: No such file or directory


After changing to flat-file backend, try starting compiz with
Quote:
compiz --replace ccp & disown

_________________
Core i7 920 D0 | Asus P6T DLX | Patriot Viper 1600 6GB | Antec Quattro 850W
Geforce 8800GTX OC2 768MB | Dell 22" LCD | Koolance Exos2/Swiftech GTZ
GCC 4.6.1 | 3.7.x-geek | Xorg-7.4-x | KDE-4.7.x | Compiz
Back to top
View user's profile Send private message
smookey
n00b
n00b


Joined: 28 May 2006
Posts: 17

PostPosted: Thu Aug 30, 2012 9:37 pm    Post subject: Reply with quote

Flat-file backend was already set in ccsm. I enabled "window decorations". Now, it almost works, but there's still something wrong with decorations:

Code:
# compiz --replace ccp & disown

ompiz (core) - Info: Starting plugin: core
compiz (core) - Warn: Attempted to restack relative to 0x2a0005c which is not a child of the root window or a window compiz owns
compiz (core) - Warn: Attempted to restack relative to 0x2a0005f which is not a child of the root window or a window compiz owns
compiz (core) - Warn: Attempted to restack relative to 0x2a00062 which is not a child of the root window or a window compiz owns
compiz (core) - Warn: Attempted to restack relative to 0x2a00065 which is not a child of the root window or a window compiz owns
compiz (core) - Warn: Attempted to restack relative to 0x2a00068 which is not a child of the root window or a window compiz owns
compiz (core) - Info: Loading plugin: ccp
compiz (core) - Info: Starting plugin: ccp
Backend     : ini
Integration : true
Profile     : default
Adding plugins
Initializing core options...done
compiz (core) - Info: Loading plugin: decor
compiz (core) - Info: Starting plugin: decor
Initializing decor options...done
Setting Update "command"
compiz (decor) - Warn: failed to bind pixmap to texture
compiz (decor) - Warn: No default decoration found, placement will not be correct
compiz (decor) - Warn: No default decoration found, placement will not be correct
compiz (decor) - Warn: No default decoration found, placement will not be correct
compiz (decor) - Warn: No default decoration found, placement will not be correct
compiz (decor) - Warn: failed to bind pixmap to texture
compiz (decor) - Warn: No default decoration found, placement will not be correct
compiz (decor) - Warn: No default decoration found, placement will not be correct
compiz (decor) - Warn: No default decoration found, placement will not be correct
compiz (decor) - Warn: No default decoration found, placement will not be correct
compiz (decor) - Warn: failed to bind pixmap to texture
Back to top
View user's profile Send private message
hedmo
l33t
l33t


Joined: 29 Aug 2009
Posts: 839
Location: halmstad

PostPosted: Fri Aug 31, 2012 6:38 am    Post subject: Reply with quote

smookey


here is my set of compiz-fusion

hedmo@mybox ~ $ sudo emerge -av @compiz-fusion

* IMPORTANT: 3 news items need reading for repository 'gentoo'.
* Use eselect news to read news items.


These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild R #] x11-wm/compiz-9999::hedmo USE="cairo dbus svg -fuse -gnome -gtk -kde" 0 kB
[ebuild R #] x11-plugins/compiz-plugins-main-9999::hedmo 0 kB
[ebuild R #] x11-libs/libcompizconfig-9999::hedmo 0 kB
[ebuild R #] x11-plugins/compiz-plugins-unsupported-9999::hedmo 0 kB
[ebuild R #] dev-python/compizconfig-python-9999::hedmo 0 kB
[ebuild R #] x11-plugins/compiz-plugins-extra-9999::hedmo USE="-gnome" 0 kB
[ebuild R *] x11-apps/ccsm-9999::hedmo 0 kB
[ebuild R #] x11-wm/compiz-fusion-9999::hedmo USE="emerald unsupported -gnome -kde" 0 kB

Total: 8 packages (8 reinstalls), Size of downloads: 0 kB

Would you like to merge these packages? [Yes/No] n

Quitting.

hedmo@mybox ~ $


and emerald start by default but if you like to use emerald with compiz --replace ccp & disown,just set
compiz --replace ccp & disown & emerald --replace and it should work. i start compiz manually by :

compiz --replace --sm-disable ccp

regards hedmo
Back to top
View user's profile Send private message
smookey
n00b
n00b


Joined: 28 May 2006
Posts: 17

PostPosted: Fri Aug 31, 2012 11:45 am    Post subject: Reply with quote

Thanks hedmo, but I don't see your overlay in layman. And by the way, is there any difference between your compiz build and BlueDragonX's? Is it the same branch?

If I stick with compiz-0.9.8_rc3275 from fm-overlay and run it like you suggested: compiz --replace ccp & disown & emerald --replace, it works.
However, If I enable some basic plugins which require "composite" & "opengl" plugins, everything crushes:

Code:
$ compiz --replace ccp & disown & emerald --replace
compiz (core) - Info: Loading plugin: core
compiz (core) - Info: Starting plugin: core
compiz (core) - Warn: Attempted to restack relative to 0x260005c which is not a child of the root window or a window compiz owns
compiz (core) - Warn: Attempted to restack relative to 0x260005f which is not a child of the root window or a window compiz owns
compiz (core) - Warn: Attempted to restack relative to 0x2600062 which is not a child of the root window or a window compiz owns
compiz (core) - Warn: Attempted to restack relative to 0x2600065 which is not a child of the root window or a window compiz owns
compiz (core) - Info: Loading plugin: ccp
compiz (core) - Info: Starting plugin: ccp
Backend     : ini
Integration : true
Profile     : default
Adding plugins
Initializing core options...done
compiz (core) - Info: Loading plugin: composite
compiz (core) - Info: Starting plugin: composite
Initializing composite options...done
compiz (core) - Info: Loading plugin: opengl
compiz (core) - Info: Starting plugin: opengl
compiz (core) - Fatal: Private index value "15CompositeScreen_index_4" already stored in screen.


Ohh, there's always so many problems with compiz. But it's lightning fast compared to kde's desktop effects. In the worst case, I'll have to downgrade to compiz-fusion-0.8.8.

Regards.
Back to top
View user's profile Send private message
hedmo
l33t
l33t


Joined: 29 Aug 2009
Posts: 839
Location: halmstad

PostPosted: Sat Sep 01, 2012 6:39 am    Post subject: Reply with quote

smookey

i dont have my ebuilds in layman.i have them in my local overlay an you can get them
at my git.some one post a mail to me how to put them in layman but i did not fully understan how.i do not know of the sources at my git is as new as in the fm-overlay.mine is about 4 mounth.i have fixed the the sandbox problem on compiz-plugins.... but not compiz-0.9.8.its patched.ccsm is quite unstable and i set my plugins before i start compiz and when i have started compiz i can modify the plugins as i like but not turn them on and off because "some times" it craches.all plugins work even freewins and can say its quite stable.

regards hedmo
Back to top
View user's profile Send private message
yellowhat
Guru
Guru


Joined: 10 Sep 2008
Posts: 482

PostPosted: Tue Sep 04, 2012 9:17 pm    Post subject: Reply with quote

Hi hedmo,
I am trying to use your ebuild, but when I emerge compiz-9999 I get this error:

Code:
[ 40%] Building CXX object src/option/tests/CMakeFiles/compiz_option_test.dir/option.cpp.o
cd /tmp/portage/x11-wm/compiz-9999/work/compiz-9999_build/src/option/tests && /usr/bin/i686-pc-linux-gnu-g++  -DHAVE_SCANDIR_POSIX -DHAVE_SCANDIR_POSIX  -DNDEBUG -march=native -O2 -pipe -fomit-frame-pointer  -fPIC -Wall -Wno-deprecated-declarations -Werror -fPIC -Wall -Wno-deprecated-declarations -Werror -I/tmp/portage/x11-wm/compiz-9999/work/compiz/src/option/tests -I/tmp/portage/x11-wm/compiz-9999/work/compiz/include -I/tmp/portage/x11-wm/compiz-9999/work/compiz/src/pluginclasshandler/include -I/tmp/portage/x11-wm/compiz-9999/work/compiz/src/timer/include -I/tmp/portage/x11-wm/compiz-9999/work/compiz/src/logmessage/include -I/tmp/portage/x11-wm/compiz-9999/work/compiz/src/string/include -I/tmp/portage/x11-wm/compiz-9999/work/compiz/src/rect/include -I/tmp/portage/x11-wm/compiz-9999/work/compiz/src/point/include -I/tmp/portage/x11-wm/compiz-9999/work/compiz/src/window/geometry/include -I/tmp/portage/x11-wm/compiz-9999/work/compiz/src/window/extents/include -I/usr/include/libxml2 -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include -I/usr/include/glibmm-2.4 -I/usr/lib/glibmm-2.4/include -I/usr/include/sigc++-2.0 -I/usr/lib/sigc++-2.0/include -I/usr/include/startup-notification-1.0 -I/tmp/portage/x11-wm/compiz-9999/work/compiz-9999_build    -o CMakeFiles/compiz_option_test.dir/option.cpp.o -c /tmp/portage/x11-wm/compiz-9999/work/compiz/src/option/tests/option.cpp
/tmp/portage/x11-wm/compiz-9999/work/compiz/src/option/tests/option.cpp: In member function ‘virtual void CompOption_Const_Test::TestBody()’:
/tmp/portage/x11-wm/compiz-9999/work/compiz/src/option/tests/option.cpp:192:2: error: converting ‘false’ to pointer type for argument 1 of ‘char testing::internal::IsNullLiteralHelper(testing::internal::Secret*)’ [-Werror=conversion-null]
/tmp/portage/x11-wm/compiz-9999/work/compiz/src/option/tests/option.cpp:193:2: error: converting ‘false’ to pointer type for argument 1 of ‘char testing::internal::IsNullLiteralHelper(testing::internal::Secret*)’ [-Werror=conversion-null]
cc1plus: all warnings being treated as errors
make[2]: *** [src/option/tests/CMakeFiles/compiz_option_test.dir/option.cpp.o] Errore 1
make[2]: Leaving directory `/tmp/portage/x11-wm/compiz-9999/work/compiz-9999_build'
make[1]: *** [src/option/tests/CMakeFiles/compiz_option_test.dir/all] Errore 2
make[1]: *** Attesa dei processi non terminati....
Linking CXX executable compiz_plugin_test
cd /tmp/portage/x11-wm/compiz-9999/work/compiz-9999_build/src/plugin/tests && /usr/bin/cmake -E cmake_link_script CMakeFiles/compiz_plugin_test.dir/link.txt --verbose=1
/usr/bin/i686-pc-linux-gnu-g++   -march=native -O2 -pipe -fomit-frame-pointer  -fPIC -Wall -Wno-deprecated-declarations -Werror -fPIC -Wall -Wno-deprecated-declarations -Werror -fPIC -Wall -Wno-deprecated-declarations -Werror   -Wl,-O1 -Wl,--as-needed -Wl,--hash-style=gnu CMakeFiles/compiz_plugin_test.dir/test-plugin.cpp.o  -o compiz_plugin_test -rdynamic ../libcompiz_plugin.a ../../libcompiz_core.so.0.9.8 -lgtest -lgtest_main -lgmock -lpthread -Wl,-rpath,/tmp/portage/x11-wm/compiz-9999/work/compiz-9999_build/src
make[2]: Leaving directory `/tmp/portage/x11-wm/compiz-9999/work/compiz-9999_build'
/usr/bin/cmake -E cmake_progress_report /tmp/portage/x11-wm/compiz-9999/work/compiz-9999_build/CMakeFiles
[ 40%] Built target compiz_plugin_test
Linking CXX executable compiz_privatescreen_test
cd /tmp/portage/x11-wm/compiz-9999/work/compiz-9999_build/src/privatescreen/tests && /usr/bin/cmake -E cmake_link_script CMakeFiles/compiz_privatescreen_test.dir/link.txt --verbose=1
/usr/bin/i686-pc-linux-gnu-g++   -march=native -O2 -pipe -fomit-frame-pointer  -fPIC -Wall -Wno-deprecated-declarations -Werror -fPIC -Wall -Wno-deprecated-declarations -Werror   -Wl,-O1 -Wl,--as-needed -Wl,--hash-style=gnu CMakeFiles/compiz_privatescreen_test.dir/test-privatescreen.cpp.o  -o compiz_privatescreen_test -rdynamic ../../libcompiz_core.so.0.9.8 ../../window/constrainment/libcompiz_window_constrainment.a ../../logmessage/libcompiz_logmessage.a -lgtest -lgtest_main -lgmock -lpthread ../../window/geometry/libcompiz_window_geometry.a ../../rect/libcompiz_rect.a ../../point/libcompiz_point.a -lglibmm-2.4 -lgobject-2.0 -lsigc-2.0 -lglib-2.0 -Wl,-rpath,/tmp/portage/x11-wm/compiz-9999/work/compiz-9999_build/src
make[2]: Leaving directory `/tmp/portage/x11-wm/compiz-9999/work/compiz-9999_build'
/usr/bin/cmake -E cmake_progress_report /tmp/portage/x11-wm/compiz-9999/work/compiz-9999_build/CMakeFiles
[ 40%] Built target compiz_privatescreen_test
make[1]: Leaving directory `/tmp/portage/x11-wm/compiz-9999/work/compiz-9999_build'
make: *** [all] Errore 2

_________________
Gentoo Linux ~x86, Kernel 3.11.2, Enermax Revolutions85+ 850W, AMD Athlon 64 X2 5000+ BE, Corsair XMS2 PC6400 3GB, ASUS M2R32, Sapphire HD6870, Creative X-Fi Platinum, WD Raptor 150GB, WD 2.5 320GB, Asus DRW-24B1ST
Back to top
View user's profile Send private message
hedmo
l33t
l33t


Joined: 29 Aug 2009
Posts: 839
Location: halmstad

PostPosted: Wed Sep 05, 2012 4:41 am    Post subject: Reply with quote

yellowhat

can you wgetpaste/pastebin the full log and post your useflag?

regards Hedmo
Back to top
View user's profile Send private message
yellowhat
Guru
Guru


Joined: 10 Sep 2008
Posts: 482

PostPosted: Wed Sep 05, 2012 7:03 am    Post subject: Reply with quote

This is the build.log http://pastebin.com/raw.php?i=F4dbFkBz

These are the use flag for compiz:

Code:
Calculating dependencies... done!
[ebuild  N     ] x11-wm/compiz-9999::yellowhat-overlay  USE="cairo dbus svg -fuse -gnome -gtk -kde" 0 kB

Total: 1 package (1 new), Size of downloads: 0 kB


Same errore with FEATURES="-sandbox"
_________________
Gentoo Linux ~x86, Kernel 3.11.2, Enermax Revolutions85+ 850W, AMD Athlon 64 X2 5000+ BE, Corsair XMS2 PC6400 3GB, ASUS M2R32, Sapphire HD6870, Creative X-Fi Platinum, WD Raptor 150GB, WD 2.5 320GB, Asus DRW-24B1ST
Back to top
View user's profile Send private message
hedmo
l33t
l33t


Joined: 29 Aug 2009
Posts: 839
Location: halmstad

PostPosted: Wed Sep 05, 2012 4:51 pm    Post subject: Reply with quote

yellowhat

there is two ting i found in your log:


1.
WARNING:
"FindCompiz.cmake" file not found in cmake module directories.
It should be installed to allow building of external compiz packages.
Call "sudo make findcompiz_install" to install it.

answer try to install it twice

2.Dependee "/tmp/portage/x11-wm/compiz-9999/work/compiz-9999_build/src/timer/CMakeFiles/CMakeDirectoryInformation.cmake" is newer than depender "/tmp/portage/x11-wm/compiz-9999/work/compiz-9999_build/src/timer/CMakeFiles/compiz_timer.dir/depend.internal".
Scanning dependencies of target compiz_timer

can be a to new version of emake.try to downgrade

regards hedmo
Back to top
View user's profile Send private message
yellowhat
Guru
Guru


Joined: 10 Sep 2008
Posts: 482

PostPosted: Wed Sep 05, 2012 9:03 pm    Post subject: Reply with quote

Quote:
can be a to new version of emake.try to downgrade


Did you mean cmake? If yes to which version?
_________________
Gentoo Linux ~x86, Kernel 3.11.2, Enermax Revolutions85+ 850W, AMD Athlon 64 X2 5000+ BE, Corsair XMS2 PC6400 3GB, ASUS M2R32, Sapphire HD6870, Creative X-Fi Platinum, WD Raptor 150GB, WD 2.5 320GB, Asus DRW-24B1ST
Back to top
View user's profile Send private message
yellowhat
Guru
Guru


Joined: 10 Sep 2008
Posts: 482

PostPosted: Wed Sep 05, 2012 10:03 pm    Post subject: Reply with quote

Sorry I wrote in wrong thread.
Nothing to do with KDE.
_________________
Gentoo Linux ~x86, Kernel 3.11.2, Enermax Revolutions85+ 850W, AMD Athlon 64 X2 5000+ BE, Corsair XMS2 PC6400 3GB, ASUS M2R32, Sapphire HD6870, Creative X-Fi Platinum, WD Raptor 150GB, WD 2.5 320GB, Asus DRW-24B1ST


Last edited by yellowhat on Thu Sep 06, 2012 7:29 am; edited 1 time in total
Back to top
View user's profile Send private message
hedmo
l33t
l33t


Joined: 29 Aug 2009
Posts: 839
Location: halmstad

PostPosted: Thu Sep 06, 2012 4:49 am    Post subject: Reply with quote

yellowhat

i dont remember the version nor if it was emake or cmake that gave me that error to.i check what i have and recompile
compiz fusion.about kde,i am using kde-4.9.90 and dont have any problem with it if i dont set the kde flag.

regards Hedmo
Back to top
View user's profile Send private message
hedmo
l33t
l33t


Joined: 29 Aug 2009
Posts: 839
Location: halmstad

PostPosted: Thu Sep 06, 2012 4:03 pm    Post subject: Reply with quote

yellowhat

dev-util/cmake-2.8.9 runs fine with compiz on my box.

regards hedmo
Back to top
View user's profile Send private message
yellowhat
Guru
Guru


Joined: 10 Sep 2008
Posts: 482

PostPosted: Thu Sep 06, 2012 4:28 pm    Post subject: Reply with quote

So do I am on dev-util/cmake-2.8.9.
Which version of mesa and xorg-server are you running?
_________________
Gentoo Linux ~x86, Kernel 3.11.2, Enermax Revolutions85+ 850W, AMD Athlon 64 X2 5000+ BE, Corsair XMS2 PC6400 3GB, ASUS M2R32, Sapphire HD6870, Creative X-Fi Platinum, WD Raptor 150GB, WD 2.5 320GB, Asus DRW-24B1ST
Back to top
View user's profile Send private message
hedmo
l33t
l33t


Joined: 29 Aug 2009
Posts: 839
Location: halmstad

PostPosted: Thu Sep 06, 2012 8:58 pm    Post subject: Reply with quote

hedmo@mybox ~ $ X -version

X.Org X Server 1.12.3
Release Date: 2012-07-09
X Protocol Version 11, Revision 0
Build Operating System: Linux 3.5.0-rc4-mm1 x86_64 Gentoo
Current Operating System: Linux mybox 3.5.0-rc4-mm1 #8 SMP Fri Aug 31 11:02:25 Local time zone must be set--see zic x86_64
Kernel command line: BOOT_IMAGE=/kernel-3.5.0-rc4-mm1 root=UUID=c9fd79b2-3edf-4cad-af11-213dd80a3252 ro real_root=/dev/md3 dolvm domdadm noapic acpi_enforce_resources=lax pci=assign-busses apicmaintimer idle=poll init=/linuxrc video=uvesafb:1024x768@60 splash=silent,fadein,theme:emerge-world console=tty1
Build Date: 23 July 2012 11:09:40AM

Current version of pixman: 0.27.2
Before reporting problems, check http://wiki.x.org
to make sure that you have the latest version.
hedmo@mybox ~ $ glxinfo | grep OpenGL
OpenGL vendor string: Advanced Micro Devices, Inc.
OpenGL renderer string: AMD Radeon HD 6800 Series
OpenGL version string: 4.2.11762 Compatibility Profile Context
OpenGL shading language version string: 4.20
OpenGL extensions:
hedmo@mybox ~ $ sudo emerge -av ati-drivers mesa

* IMPORTANT: 3 news items need reading for repository 'gentoo'.
* Use eselect news to read news items.


These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild R ] x11-drivers/ati-drivers-12.8::mrueg USE="modules (multilib) qt4 -debug -static-libs" 0 kB
[ebuild R #] media-libs/mesa-9999::x11 USE="classic egl gallium llvm nptl shared-glapi -bindist -d3d -debug -g3dvl -gbm -gles1 -gles2 -openvg -osmesa -pax_kernel -pic -r600-llvm-compiler (-selinux) -vdpau -wayland -xa -xorg -xvmc" VIDEO_CARDS="-i915 -i965 -intel -nouveau -r100 -r200 -r300 -r600 -radeon -radeonsi -vmware" 0 kB

Total: 2 packages (2 reinstalls), Size of downloads: 0 kB

Would you like to merge these packages? [Yes/No] n

Quitting.

hedmo@mybox ~ $
Back to top
View user's profile Send private message
mlp56
n00b
n00b


Joined: 19 Sep 2012
Posts: 3

PostPosted: Wed Sep 19, 2012 5:54 pm    Post subject: Reply with quote

BlueDragonX and hedmo,

a big thanks for taking this on. Despite all the issues with compiz, no other wm can touch it - none of the effects (obviously inspired by compiz's) in KWin come close to the original, and I have been using it for years and should be able to contribute a bit upstream - we'll see. The real issue is that recent upgrades to the X server and drivers have rendered compiz 0.8x unusable for me. I have to go back or forward. And I find myself unable to use a projector with KWin - there's always an issue with proper mapping of the screens in both libreoffice and any of the pdf-displaying applications.

I'm a bit confused about the scope of the fm-overlay. I'll try hedmo's next, also tried unity on for size. Unity has an excessive list of required keyword changes - I'll leave that for now, because unity isn't the actual goal.

So in fm-overlay, is this meant to provide just compiz, or the whole suite? Because if I'm trying to build emerald, ccsm etc with this, I see a lot of blocks that I have been unable to resolve. On your systems, are you building compiz-9x but use the standard emerald etc?

A minor issue is that the compiz ebuild doesn't verify:

Code:
!!! Digest verification failed:
!!! /var/lib/layman/fm-overlay/x11-wm/compiz/compiz-0.9.7.8.ebuild
!!! Reason: Failed on RMD160 verification
!!! Got: 535aac3b88ac9d3526ce310d957bce9372407eab
!!! Expected: 5a8ebd6ed482fee1eaa4ce54729619c10f212951


I can fix that of course, but is that something to worry about?

If I try ccsm I get

Code:

# emerge -p ccsm   

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild  N     ] dev-cpp/gtest-1.6.0  USE="static-libs threads -examples"
[ebuild  N     ] app-admin/chrpath-0.13-r2  USE="static-libs"
[ebuild  N     ] dev-python/paramiko-1.7.7.1  USE="-doc -examples"
[ebuild  N     ] dev-cpp/gmock-1.6.0  USE="static-libs"
[ebuild  N     ] dev-vcs/bzr-2.4.1  USE="sftp -bash-completion -curl -doc -emacs -test"
[ebuild  N    ~] x11-wm/compiz-0.9.8_rc3275  USE="cairo dbus gnome gtk svg -debug -fuse -kde"
[ebuild  N    ~] x11-libs/libcompizconfig-0.9.7.0
[ebuild  N    ~] dev-python/compizconfig-python-0.9.5.94
[ebuild  N    ~] x11-apps/ccsm-0.9.5.92
[blocks B      ] x11-libs/libcompizconfig ("x11-libs/libcompizconfig" is blocking x11-wm/compiz-0.9.8_rc3275)
[blocks B      ] dev-python/compizconfig-python ("dev-python/compizconfig-python" is blocking x11-wm/compiz-0.9.8_rc3275)
[blocks B      ] x11-apps/ccsm ("x11-apps/ccsm" is blocking x11-wm/compiz-0.9.8_rc3275)


I tried several version combinations of 0.9.7 etc, but there are always blocks.

I'll keep on trying. Hedmo, is there a main page about your overlay? As you noted, it's not yet in layman.

Thanks a bunch for any hints,

Martin
Back to top
View user's profile Send private message
yellowhat
Guru
Guru


Joined: 10 Sep 2008
Posts: 482

PostPosted: Wed Sep 19, 2012 5:57 pm    Post subject: Reply with quote

Try my overlay https://github.com/yellowhat/ebuilds for me live version is great.
I am using modified ebuild from unity overlay.
_________________
Gentoo Linux ~x86, Kernel 3.11.2, Enermax Revolutions85+ 850W, AMD Athlon 64 X2 5000+ BE, Corsair XMS2 PC6400 3GB, ASUS M2R32, Sapphire HD6870, Creative X-Fi Platinum, WD Raptor 150GB, WD 2.5 320GB, Asus DRW-24B1ST
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Goto page Previous  1, 2, 3, 4  Next
Page 2 of 4

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum