Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[RESOLU][matériel] Pas d'interfaces réseaux
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index French
View previous topic :: View next topic  
Author Message
Benkkei
n00b
n00b


Joined: 29 May 2012
Posts: 14

PostPosted: Wed May 30, 2012 2:37 pm    Post subject: [RESOLU][matériel] Pas d'interfaces réseaux Reply with quote

hello à tous,


Je suis nouveau sur Gentoo. J'ai déjà dde l'expèrience avec Debian, Ubuntu et un peut de CentOs.... J'ai décider de me mettre à Gentoo pour augmenter un peu mes compètences.

J'ai donc télecharger l'iso 64bits de l'instal minimal et suivis les étapes de la documentations pas à pas pour l'installer sur un latptop Lenovo ThinkPad t61p en dualboot avec Linux Mint.

Malheureusement, il semblerais qu'auncune de mes interfaces réseaux (filliaire et WiFi) ne soient prises en charge( "ifconfig -a" n'affiche que l'interface de loopback), pourtant j'ai bien éxecuter "rc-update add eth0 default" lors de l'installation.

J'ai aussi tenté de recompiler mon kernel avec les drivers intel pour mes cartes réseaux.

Voici ce qu'affiche un lspci
Code:
benkint@ThinkPad ~ $ lspci
00:00.0 Host bridge: Intel Corporation Mobile PM965/GM965/GL960 Memory Controller Hub (rev 0c)
00:01.0 PCI bridge: Intel Corporation Mobile PM965/GM965/GL960 PCI Express Root Port (rev 0c)
00:03.0 Communication controller: Intel Corporation Mobile PM965/GM965 MEI Controller (rev 0c)
00:03.2 IDE interface: Intel Corporation Mobile PM965/GM965 PT IDER Controller (rev 0c)
00:03.3 Serial controller: Intel Corporation Mobile PM965/GM965 KT Controller (rev 0c)
00:19.0 Ethernet controller: Intel Corporation 82566MM Gigabit Network Connection (rev 03)
00:1a.0 USB Controller: Intel Corporation 82801H (ICH8 Family) USB UHCI Controller #4 (rev 03)
00:1a.1 USB Controller: Intel Corporation 82801H (ICH8 Family) USB UHCI Controller #5 (rev 03)
00:1a.7 USB Controller: Intel Corporation 82801H (ICH8 Family) USB2 EHCI Controller #2 (rev 03)
00:1b.0 Audio device: Intel Corporation 82801H (ICH8 Family) HD Audio Controller (rev 03)
00:1c.0 PCI bridge: Intel Corporation 82801H (ICH8 Family) PCI Express Port 1 (rev 03)
00:1c.1 PCI bridge: Intel Corporation 82801H (ICH8 Family) PCI Express Port 2 (rev 03)
00:1c.2 PCI bridge: Intel Corporation 82801H (ICH8 Family) PCI Express Port 3 (rev 03)
00:1c.3 PCI bridge: Intel Corporation 82801H (ICH8 Family) PCI Express Port 4 (rev 03)
00:1c.4 PCI bridge: Intel Corporation 82801H (ICH8 Family) PCI Express Port 5 (rev 03)
00:1d.0 USB Controller: Intel Corporation 82801H (ICH8 Family) USB UHCI Controller #1 (rev 03)
00:1d.1 USB Controller: Intel Corporation 82801H (ICH8 Family) USB UHCI Controller #2 (rev 03)
00:1d.2 USB Controller: Intel Corporation 82801H (ICH8 Family) USB UHCI Controller #3 (rev 03)
00:1d.7 USB Controller: Intel Corporation 82801H (ICH8 Family) USB2 EHCI Controller #1 (rev 03)
00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev f3)
00:1f.0 ISA bridge: Intel Corporation 82801HBM (ICH8M-E) LPC Interface Controller (rev 03)
00:1f.1 IDE interface: Intel Corporation 82801HBM/HEM (ICH8M/ICH8M-E) IDE Controller (rev 03)
00:1f.2 SATA controller: Intel Corporation 82801HBM/HEM (ICH8M/ICH8M-E) SATA AHCI Controller (rev 03)
00:1f.3 SMBus: Intel Corporation 82801H (ICH8 Family) SMBus Controller (rev 03)
01:00.0 VGA compatible controller: nVidia Corporation G84M [Quadro FX 570M] (rev a1)
02:00.0 Memory controller: Intel Corporation Turbo Memory Controller (rev 01)
03:00.0 Network controller: Intel Corporation PRO/Wireless 4965 AG or AGN [Kedron] Network Connection (rev 61)
15:00.0 CardBus bridge: Ricoh Co Ltd RL5c476 II (rev ba)
15:00.2 SD Host controller: Ricoh Co Ltd R5C822 SD/SDIO/MMC/MS/MSPro Host Adapter (rev 21)
15:00.4 System peripheral: Ricoh Co Ltd R5C592 Memory Stick Bus Host Adapter (rev 11)
15:00.5 System peripheral: Ricoh Co Ltd xD-Picture Card Controller (rev 11)


Merci de me venir en aide.

Bonne soirée,

Benkkei


Last edited by Benkkei on Wed May 30, 2012 9:01 pm; edited 1 time in total
Back to top
View user's profile Send private message
El_Goretto
Moderator
Moderator


Joined: 29 May 2004
Posts: 3098
Location: Paris

PostPosted: Wed May 30, 2012 4:02 pm    Post subject: Re: [matériel] Pas d'interfaces réseaux Reply with quote

Benkkei wrote:
hello à tous,
Je suis nouveau sur Gentoo. J'ai déjà dde l'expèrience avec Debian, Ubuntu et un peut de CentOs.... J'ai décider de me mettre à Gentoo pour augmenter un peu mes compètences.

Bienvenue à toi, et très bonne raison pour essayer gentoo :)

Benkkei wrote:
Malheureusement, il semblerais qu'auncune de mes interfaces réseaux (filliaire et WiFi) ne soient prises en charge( "ifconfig -a" n'affiche que l'interface de loopback), pourtant j'ai bien éxecuter "rc-update add eth0 default" lors de l'installation.
J'ai aussi tenté de recompiler mon kernel avec les drivers intel pour mes cartes réseaux.

En effet, si "ifconfig -a" n'affiche pas les interface, c'est que les drivers n'ont pas été chargés. Je te conseille de regarder précisément le driver adapté à ton modèle intel (par exemple, de mémoire, il y an plusieurs variétés de e1000, d'où une possible gamelle pour l'interface filaire). Le côté "rc-update add eth0" (c'est pas plutôt net.eth0?) n'est là que pour la configuration de la carte, donc l'étape d'après, une fois qu'elle existe...
Vérifie que tu travailles/configures bien sur le noyau que tu bootes après-coup (et vice-versa, c'est bête, mais on a vu des gens (moi par exemple un jour)) configurer un kernel comme un fou et ne pas comprendre pourquoi le driver ajouté n'était pas disponible en module... ahem.
_________________
-Gentoo hardened [EoL]: µ-serv Gen8 G1610T, 8Go ECC ; NF9D-2700, 4Go
-FreeBSD 11/Vimage/Jails: DS61, i3 2100T, 16Go ; FreeNAS: µ-serv N40L, 8Go ECC
-Réseau: ERL-3 + ESL-24 + GS108Tv2
-NAS: RN312
Back to top
View user's profile Send private message
Benkkei
n00b
n00b


Joined: 29 May 2012
Posts: 14

PostPosted: Wed May 30, 2012 6:22 pm    Post subject: Re: [matériel] Pas d'interfaces réseaux Reply with quote

El_Goretto wrote:
Le côté "rc-update add eth0" (c'est pas plutôt net.eth0?) n'est là que pour la configuration de la carte, donc l'étape d'après, une fois qu'elle existe....


Oui effectivement c'est de cette commande dont je voulais parler.

En ce qui concerne le driver de ma carte réseau, J'ai trouvé le driver correspondant à cette adresse (je pense): http://downloadcenter.intel.com/Detail_Desc.aspx?agr=Y&DwnldID=15817&lang=eng&OSVersion=Linux*&DownloadType=Drivers. J'ai télecharger le drivers et l'ai extraits pour obtenir le module e1000e (qui est placé dans /lib/modules/3.2.12/kernel/drivers/net/e1000e).

Pour ce qui est de la carte WiFi, j'ai suivis ce post: https://forums.gentoo.org/viewtopic-t-923576-start-0.html . J'ai télecharger le .ucode et placé dans /lib/firmware pour compilé ce modulenavec le noyaux
L'entrée suivante à été rajoutée dans /etc/conf.d/modules:
Code:
#Driver carte reseau
modules=e1000e
modules=iwlwifi



Malheureusement, aucune trace de mes interfaces réseaux....
Back to top
View user's profile Send private message
Poussin
l33t
l33t


Joined: 08 Jun 2007
Posts: 659
Location: Liège

PostPosted: Wed May 30, 2012 7:30 pm    Post subject: Reply with quote

Personnellement, l'installation de brol dans le système via autre chose que le package manager, je ne suis pas fan (pas de mise à jour, gestion de dépendance, tout ça).

C'est donc le moment de sortir un de mes liens favoris lors de la config kernel (from debian d'ailleurs...): http://kmuto.jp/debian/hcl/
Tu lui colles l'identifiant numérique de ton périf et il va te dire quel est le module qui va bien (et la version minimum du kernel). Elle n'est pas belle la vie?


edit: et si le réseau fonctionnait lors du l'utilisation de l'iso gentoo minimal machin, un lspci -k te donne le module utilisé
Back to top
View user's profile Send private message
Benkkei
n00b
n00b


Joined: 29 May 2012
Posts: 14

PostPosted: Wed May 30, 2012 8:13 pm    Post subject: Reply with quote

Merci pour ce dernier lien il m'a été utile, j'ai pu indentifier le driver correct pour ma carte wifi et maintenant ifconfig -a m'affiche wlan0 en plus de l'interface de loopback.

Malheureusement j'ai pas pu m'en servir car je ne sais pas comment gérer le wifi en ligne de commande (se connecter au wifi de ma box, fournir la clef etc,...)

Il me reste plus qu'a trouver poruquoi ma carte ethernet n'est pas encore reconnue.
Back to top
View user's profile Send private message
Poussin
l33t
l33t


Joined: 08 Jun 2007
Posts: 659
Location: Liège

PostPosted: Wed May 30, 2012 8:36 pm    Post subject: Reply with quote

Comme je le disais, je suppose que cela fonctionnait depuis le cd d'install. N'hésite pas à booter dessus et faire un lspci -k

Tu peux aussi nous donner la sortie de lspci -knn
Back to top
View user's profile Send private message
boozo
Advocate
Advocate


Joined: 01 Jul 2004
Posts: 3193

PostPosted: Wed May 30, 2012 8:45 pm    Post subject: Reply with quote

'alute

tout-à-fait d'accords avec les remarques de Poussin concernant l'utiliation des drivers externes (temps qu'on peut s'en passer sans trop de perte de fonctionnalités) ; vu que le T61P n'est pas vraiment qqch d'exotique en matos tout doit marcher out of the box depuis des lustres ;-)

Autant ne pas se priver des retours d'expériences pour te bâtir une config noyau propre et concernant la configuration du wifi, le manuel aide bien en général :wink:
_________________
" Un psychotique, c'est quelqu'un qui croit dur comme fer que 2 et 2 font 5, et qui en est pleinement satisfait.
Un névrosé, c'est quelqu'un qui sait pertinemment que 2 et 2 font 4, et ça le rend malade ! "
Back to top
View user's profile Send private message
Benkkei
n00b
n00b


Joined: 29 May 2012
Posts: 14

PostPosted: Wed May 30, 2012 9:00 pm    Post subject: Reply with quote

Hello,


Merci à tous pour vos réponses.... Grâce au lien de poussin et au wiki de gentoo j'ai pu trouver les drivers adéquats pour mes cartes réseaux et maintenant elles fonctionnent....


Il me reste plus qu'à comprendre le fonctionnement de wpa_supplicant pour le wifi et tout sera parfait.

Je tag ce post comme étant résolu.

Encore merci pour les réponses, bonne soirée.

Benkei
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index French All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum