Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
early userspace mounting (initramfs) fsck not found [SOLVED]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Other Things Gentoo
View previous topic :: View next topic  
Author Message
eliszka
n00b
n00b


Joined: 13 Nov 2007
Posts: 12
Location: Colorado, USA

PostPosted: Mon May 14, 2012 10:22 pm    Post subject: early userspace mounting (initramfs) fsck not found [SOLVED] Reply with quote

Hi - I have a couple of systems with a separate /usr and lately noticed a new Early Userspace Mounting wiki http://wiki.gentoo.org/wiki/Early_Userspace_Mounting
that describes what I wanted. I was able to follow this wiki on my desktop with no problems at all, but the same procedure will not work on my laptop.
My /usr on both systems in ext3, so I added the following to /usr/src/initramfs/initramfs_list:
file /sbin/fsck.ext3 /sbin/fsck.ext3 755 0 0
just above the ext4 line, so I have this:

file /sbin/fsck /sbin/fsck 755 0 0
file /sbin/fsck.ext3 /sbin/fsck.ext3 755 0 0
file /sbin/fsck.ext4 /sbin/fsck.ext4 755 0 0

Both the desktop and laptop are running 3.2.12.
When I boot the laptop trying to use the initrd.cpio.gz that I created, I get "/sbin/fsck: not found" and am dropped to a shell.
Within that shell, everything under /sbin (and possibly elsewhere) is a link, except for /sbin/fsck, /sbin/fsck.ext3 and /sbin/fsck.ext4.
I can see those files with ls, but when I try to run them from with the rescue shell I also get "not found".

I've repeated the process a few times in case I missed something but to no avail.
The main differences I guess between the 2 systems is that the desktop is 32 bit, the laptop 64 bit and I'm sure there are differences
in the kernel options but I'm not sure what to look for.
I'd appreciate any insight if anyone else has followed this wiki and run into similar problems and I'll keep looking on my own.

Thanks.


Last edited by eliszka on Tue May 15, 2012 4:08 pm; edited 1 time in total
Back to top
View user's profile Send private message
eliszka
n00b
n00b


Joined: 13 Nov 2007
Posts: 12
Location: Colorado, USA

PostPosted: Tue May 15, 2012 2:59 am    Post subject: Reply with quote

I was able to figure this one out on my own
/lib is a link to /lib64 on my 64-bit laptop, so looks like although links are followed within /lib or /lib64 when the initramfs is created, the link from /lib to /lib64 is not followed.

added the following lines to /usr/src/linitramfs/initramfs_list:
dir /lib64 755 0 0
file /lib64/ld-linux-x86-64.so.2 /lib64/ld-linux-x86-64.so.2 755 0 0

and changed /lib/ to /lib64/ in the rest of the libraries file list.

then re-created the initramfs, and now all is well.
Back to top
View user's profile Send private message
alexey.kuznecov
n00b
n00b


Joined: 26 Jun 2012
Posts: 1

PostPosted: Tue Jun 26, 2012 9:02 am    Post subject: Reply with quote

Great job! I've got the same error message and was going to dust off strace this evening. Please consider adding a section for amd64 users there http://wiki.gentoo.org/wiki/Early_Userspace_Mounting
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Other Things Gentoo All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum