Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Kernel Lockup
View unanswered posts
View posts from last 24 hours

Reply to topic    Gentoo Forums Forum Index Installing Gentoo
View previous topic :: View next topic  
Author Message

Joined: 03 Apr 2005
Posts: 214
Location: Ur-th

PostPosted: Fri Apr 20, 2012 4:49 am    Post subject: Reply with quote

I've got a Dell Optiplex 320 with a Pentium D processor in it. I followed the AMD64 (multilib) install guide and used a kernel seed (from for the correct kernel (3.3.2 in this case) and it just isn't booting. I mean I don't even get a "Uncompressing Linux..." message on the screen. What it shows is:
 Booting 'Gentoo Linux 3.3.2'

root (hd0,0)
 Filesystem type is ext2fs, partition type 0x83
kernel /boot/kernel-3.3.2-gentoo-amd64 root=/dev/sda3
 [Linux-bzImage, setup=0x3600, size=0x2b9000]

I've tried different kernel versions (3.2.12), tried genkernel even, disabled "no execute" and floppy devices in the BIOS, tried booting with noapic and ahci=off (and a few others I can't remember now off the top of my head), set the option in the "Kernel Hacking" section to show verbose messages, and each time, it locks in the same place. I've never seen a kernel that didn't uncompress itself, so I'm not 100% sure if this is a grub thing or not. Google is useless and has had me chasing my tail for quite some time now. :(

Obviously, grub is installed in the MBR properly as it comes up on a reboot, and it's seeing the right partition as it shows the splash behind the text. I've tried reinstalling grub (through portage) and then running through the grub installation on the MBR steps afterwards and there's no change. I even tried going to the grub command line and entering the commands in the menu one by one, and it still locks hard after I type in the "kernel" line.

Now I *can* boot the system and it will run just fine *if* I boot it from a SysRescueCD and tell it to boot from an installed hard drive, but it has an older kernel (2.6 series). It boots into a 64 bit kernel, utilizes both cores, and I can otherwise use the system normally this way, but I need to figure out why it can't boot its own kernel.

Any help would be greatly appreciated. :)
Back to top
View user's profile Send private message

Joined: 05 Jul 2003
Posts: 40807
Location: 56N 3W

PostPosted: Fri Apr 20, 2012 4:51 pm    Post subject: Reply with quote


Its not a grub issue - your kernel is loaded so grub has done its thing and is now in unallocated RAM, if its still around at all.
Thats why I split your post off. Feel free to edit the title if you don't likelit.

It has to be someting in your kernel - this early in the boot process, your initrd isn't yet mounts (if you have one).
Please put your kernel .config file on a pastebin.

With a GentooCD or inside your chroot, you can use wgetpaste.

Does the boot process actually stop, or is it just nothing more appears on the screen ?


Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Installing Gentoo All times are GMT
Page 1 of 1

Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum