Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
gentoo package downgrade
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
ashi
n00b
n00b


Joined: 22 Aug 2011
Posts: 5

PostPosted: Thu Feb 09, 2012 10:35 am    Post subject: gentoo package downgrade Reply with quote

Hi, all. I want to downgrade mesa7.11.2 to mesa 7.10.2 by adding a line to /etc/portage/package.accept_words:
=media-libs/mesa-7.10.2
then I run emerge -avt mesa ,but it seems not work. I've read Maintaining packages section from http://en.gentoo-wiki.com/wiki/Portage. where am I wrong? thanks for any reply.
Back to top
View user's profile Send private message
Yuu
Apprentice
Apprentice


Joined: 23 Dec 2008
Posts: 223
Location: France

PostPosted: Thu Feb 09, 2012 10:59 am    Post subject: Reply with quote

Hi ashi,

just mask the packages which are newer than media-libs/mesa-7.0.3:
Code:
echo ">media-libs/mesa-7.10.3" >> /etc/portage/package.mask



Then, try an emerge:
Code:
# emerge -DuNpv world

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild  N     ] sys-libs/talloc-2.0.1-r2  USE="-compat -doc -static-libs -swig" 0 kB
[ebuild     UD ] media-libs/mesa-7.10.3 [7.11.2] USE="classic gallium nptl -debug -gles -hardened% -llvm* -motif -pic (-selinux) (-bindist%) (-egl%*) (-gbm%) (-openvg%) (-osmesa%) (-pax_kernel%) (-shared-dricore%) (-shared-glapi%*)" VIDEO_CARDS="-intel -mach64 -mga -nouveau -r128 -radeon -savage -sis -tdfx -via -vmware" 0 kB

Total: 2 packages (1 downgrade, 1 new), Size of downloads: 0 kB


Note: media-libs/mesa-7.10.2 is not is the tree, but media-libs/mesa-7.10.3 is.


Good luck :]
_________________
Main laptop : T8300 cpu | 200 GB hard drive | 2 GB of ram | 8600M GT | Gentoo x86_64
Server : Celeron 220 cpu | 250 GB hard drive | 2 GB of ram | SiS 662 VGA | Gentoo x86_64
Back to top
View user's profile Send private message
ashi
n00b
n00b


Joined: 22 Aug 2011
Posts: 5

PostPosted: Thu Feb 09, 2012 12:13 pm    Post subject: Reply with quote

Yuu wrote:
Hi ashi,

just mask the packages which are newer than media-libs/mesa-7.0.3:
Code:
echo ">media-libs/mesa-7.10.3" >> /etc/portage/package.mask



Then, try an emerge:
Code:
# emerge -DuNpv world

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild  N     ] sys-libs/talloc-2.0.1-r2  USE="-compat -doc -static-libs -swig" 0 kB
[ebuild     UD ] media-libs/mesa-7.10.3 [7.11.2] USE="classic gallium nptl -debug -gles -hardened% -llvm* -motif -pic (-selinux) (-bindist%) (-egl%*) (-gbm%) (-openvg%) (-osmesa%) (-pax_kernel%) (-shared-dricore%) (-shared-glapi%*)" VIDEO_CARDS="-intel -mach64 -mga -nouveau -r128 -radeon -savage -sis -tdfx -via -vmware" 0 kB

Total: 2 packages (1 downgrade, 1 new), Size of downloads: 0 kB


Note: media-libs/mesa-7.10.2 is not is the tree, but media-libs/mesa-7.10.3 is.


Good luck :]

Thanks, Yuu. it works.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum