Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
fstab error >> boot fails
View unanswered posts
View posts from last 24 hours

 
This topic is locked: you cannot edit posts or make replies.    Gentoo Forums Forum Index Duplicate Threads
View previous topic :: View next topic  
Author Message
Syruz
n00b
n00b


Joined: 02 May 2002
Posts: 38

PostPosted: Sun May 05, 2002 4:03 pm    Post subject: fstab error >> boot fails Reply with quote

I edited my /etc/fstab file to mount my windows partition on boot. Apparently I made a mistake because now my system won't fully boot. It stops and says that there is an error on line 21 and it can't continue.

I opened up /etc/fstab and found that line 21 was the line I added the command to mount the windows partition.

Unfortunately I can't edit this file because my file system is set to read-only.

How can I boot my system so I can fix my mistake?

This is the command I added...
/dev/hdd5 /mnt/windows win95 fat32 noatime 0 1

I made a /mnt/windows dir, I think my mistake is the 'win95 fat32' part. I was just using what fdisk labeled the partition as, which probably is what fstab wants.

So how can I fix this without reinstall?
Back to top
View user's profile Send private message
Syntaxis
Guru
Guru


Joined: 28 Apr 2002
Posts: 511
Location: London, UK

PostPosted: Sun May 05, 2002 4:34 pm    Post subject: Re: fstab error >> boot fails Reply with quote

The install CD can be used as a rescue shell. Boot into it, and mount your root partition from there. Then you can edit the /etc/fstab and reboot. :-)
Back to top
View user's profile Send private message
Syruz
n00b
n00b


Joined: 02 May 2002
Posts: 38

PostPosted: Sun May 05, 2002 4:56 pm    Post subject: Reply with quote

boot into the install or just to where it says 'boot:'

what commands to I have to pass? I'm not exactly sure how to mount devices.
Back to top
View user's profile Send private message
Syntaxis
Guru
Guru


Joined: 28 Apr 2002
Posts: 511
Location: London, UK

PostPosted: Sun May 05, 2002 6:01 pm    Post subject: Reply with quote

Boot into the install environment by pressing enter.
Type "mount --help | more" to see the options in full, but I think the option you need is "mount -t <fs type> <device> <mount point>" - you mightn't even have to specify the filesystem.
Just be sure to create the mountpoint in /mnt with "mkdir" first.
Back to top
View user's profile Send private message
Syruz
n00b
n00b


Joined: 02 May 2002
Posts: 38

PostPosted: Sun May 05, 2002 6:41 pm    Post subject: Reply with quote

Ok. I fixed the fstab and now my system boots.

What is the proper way to mount a windows partition?

My windows extended partition is located at /dev/hdd2 and my logical partition is at /dev/hdd5 I don't no why its split up like it is, but it is.
Back to top
View user's profile Send private message
Syntaxis
Guru
Guru


Joined: 28 Apr 2002
Posts: 511
Location: London, UK

PostPosted: Sun May 05, 2002 6:56 pm    Post subject: Reply with quote

from a prompt:
"mount -t vfat <device> <mount point>"

or in fstab, something like:
"/dev/hdd2 /mnt/win vfat defaults 0 0"
now add hdd5 in the same way.

and you should be set :-)
Back to top
View user's profile Send private message
Syntaxis
Guru
Guru


Joined: 28 Apr 2002
Posts: 511
Location: London, UK

PostPosted: Sun May 05, 2002 7:10 pm    Post subject: Reply with quote

Oh yeah, I just remembered:
Permissions with fat32 act a little screwy under Linux, you can only specify them at mount time.
If you want to be able to have the files on the windows partition owned by a user/group other than root, check out the "uid= " and "gid= " mount options.
Back to top
View user's profile Send private message
pjp
Administrator
Administrator


Joined: 16 Apr 2002
Posts: 17345

PostPosted: Sun May 05, 2002 7:21 pm    Post subject: Reply with quote

On a related topic... how do you find out what type a fs is? My fstab was changed somehow.
I have a partition "/" that is now listed as xfs. During install, I'm pretty sure I set it for ext3. /boot
is listed as ext3, and I thought I had set it for ext2. I've had the system running for a while now.
I have been rebuilding kernels, but I wouldn't think that would have changed my fstab.

I asked here and included some boottime errors, but no response yet:
https://forums.gentoo.org/viewtopic.php?t=1784

My system boots and seems to work ok.

EDIT: solved, if not the easiest way. parted will apparently report fs types.


Last edited by pjp on Sun May 05, 2002 10:29 pm; edited 1 time in total
Back to top
View user's profile Send private message
Syruz
n00b
n00b


Joined: 02 May 2002
Posts: 38

PostPosted: Sun May 05, 2002 10:00 pm    Post subject: Reply with quote

It tells me that vfat is not supported by kernel. I know that I included it in my kernel. Built-in not as a module.
Back to top
View user's profile Send private message
Syruz
n00b
n00b


Joined: 02 May 2002
Posts: 38

PostPosted: Mon May 06, 2002 2:06 am    Post subject: Reply with quote

I compiled a new kernel with support for all microsoft filesystems and I still can't mount my windows partition.

It tells me that vfat isn't supported by the kernel. Do I have to make support built-in or as a module?
Back to top
View user's profile Send private message
pjp
Administrator
Administrator


Joined: 16 Apr 2002
Posts: 17345

PostPosted: Mon May 06, 2002 3:07 am    Post subject: Reply with quote

I have mine in the kernel... here's what I've selected under File ssytem:
[*] POSIX Access Control List Support
<*> Ext3 journalling
[*] JBD (ext3) debugging
<*> DOS FAT fs support
<*> MSDOS fs support
<*> UMSDOS: Unix-like fs on top of standard MSDOS
<*> VFAT (Windows-95) fs support
[*] Virtual memory fs support
<*> ISO 9660 CDROM
[*] MS Joliet CD
<*> NTFS (read only)
[*] /proc fs
[*] /dev fs
[*] Auto mount at boot
[*] debug devfs
<*> SGI XFS fs
[*] Enable XFS quota

I've also included PC BIOS (MSDOS partition tables support) under Partitions

I doubt I need all of that, but I can mount my fat32 drive.
Back to top
View user's profile Send private message
fghellar
Bodhisattva
Bodhisattva


Joined: 10 Apr 2002
Posts: 856
Location: Porto Alegre, BR

PostPosted: Mon May 06, 2002 4:27 am    Post subject: Reply with quote

Syruz wrote:
I compiled a new kernel with support for all microsoft filesystems and I still can't mount my windows partition.

Did you remember to copy your new kernel to /boot? And to mount /boot before copying? Also, did you add it to your menu.lst?
_________________
| www.gentoo.org | www.tldp.org | www.google.com |
Back to top
View user's profile Send private message
arkane
l33t
l33t


Joined: 30 Apr 2002
Posts: 918
Location: Phoenix, AZ

PostPosted: Mon May 06, 2002 4:01 pm    Post subject: Reply with quote

kanuslupus wrote:
On a related topic... how do you find out what type a fs is? My fstab was changed somehow.



I use df -T to see the filesystem types of all my partitions.
Back to top
View user's profile Send private message
pjp
Administrator
Administrator


Joined: 16 Apr 2002
Posts: 17345

PostPosted: Mon May 06, 2002 4:19 pm    Post subject: Reply with quote

arkane wrote:
I use df -T to see the filesystem types of all my partitions.

Interesting... does -T report the fs type regardless of how it is mounted? I mounted an fs incorrectly and wanted to know the true fs type.
man df -T:
Code:

       -T, --print-type
              Print  each filesystem's type.  The types given are
              those reported by the system (and are  found  in  a
              system-dependent   way,   for  example  by  reading
              /etc/mtab).  See also mount(8).

That sounds like it reports the fs type of how it is mounted... am I wrong?
Back to top
View user's profile Send private message
dufnutz
Apprentice
Apprentice


Joined: 01 May 2002
Posts: 209

PostPosted: Mon May 06, 2002 5:36 pm    Post subject: Reply with quote

Syntaxis wrote:
Oh yeah, I just remembered:






Permissions with fat32 act a little screwy under Linux, you can only specify them at mount time.





If you want to be able to have the files on the windows partition owned by a user/group other than root, check out the "uid= " and "gid= " mount options.





how do i put that into the /etc/fstab? thanks
Back to top
View user's profile Send private message
justus
n00b
n00b


Joined: 16 Apr 2002
Posts: 48

PostPosted: Mon May 06, 2002 8:00 pm    Post subject: FStab setup :) Reply with quote

Try something along these lines:
Code:

/dev/hdb1 /Windows ntfs noatime,rw,uid=nobody,gid=fileshare,umask=007   0 0

Idea is the same for vfat (fat and fat32 drives)

[Partition][MountPoint][Type][Options][dump/pass]

Where [Partition] is the partion on your drive (ie. /dev/hda1)
Where [Mountpoint] is the mountpoint on your system (ie. /Windows)
Where [Type] is the filesystem type (ie. NTFS, VFAT)
Where [Options] are options that include but isn't limited to:
noatime - don't update access time
rw - make partition read and writeable
ro - make partition read only
uid - sets the user id (can be the uid or username)
gid - sets the group id (can be the gid or groupname)
umask - permissions for device
umask = 777 - permissions you want (ie. 777-755= 022... normal rwxr-xr-x permissions)

There are other options you can use, but these are the basics. Try a
Code:
man fstab
or
man mount
to learn more (or a simple google search)

Hope that helps :)

Justin T
Back to top
View user's profile Send private message
Syruz
n00b
n00b


Joined: 02 May 2002
Posts: 38

PostPosted: Mon May 06, 2002 9:43 pm    Post subject: Reply with quote

Crap, I forgot to mount /boot before I copied the bzImage. Now I have a /boot dir with 2 images, no wonder my cdrw drive didn't work after I thought I fixed the kernel. :oops:
Back to top
View user's profile Send private message
Syntaxis
Guru
Guru


Joined: 28 Apr 2002
Posts: 511
Location: London, UK

PostPosted: Tue May 07, 2002 7:45 pm    Post subject: Reply with quote

This topics's also been covered in its own thread: https://forums.gentoo.org/viewtopic.php?t=1868&highlight=&sid=6414a332a99f2aa1ae1fa5c17c050b73
In case there's any new info there.
Back to top
View user's profile Send private message
pjp
Administrator
Administrator


Joined: 16 Apr 2002
Posts: 17345

PostPosted: Thu Aug 22, 2002 6:14 am    Post subject: Reply with quote

Locking in favor of this thread.

Yes, this thread is 'newer' (by a day), but the other thread has a more helpful title.
_________________
The whole system has to go. The modern criminal justice system is incompatible with Neuroscience. --Sapolsky
Back to top
View user's profile Send private message
Display posts from previous:   
This topic is locked: you cannot edit posts or make replies.    Gentoo Forums Forum Index Duplicate Threads All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum