Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Insolito problemi di permessi...[risolto]
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian) Forum di discussione italiano
View previous topic :: View next topic  
Author Message
mrl4n
Guru
Guru


Joined: 08 Apr 2009
Posts: 588

PostPosted: Sat Jan 28, 2012 7:33 pm    Post subject: Insolito problemi di permessi...[risolto] Reply with quote

Sono diversi giorni che sto sbattendo la testa nel tentativo di capire come risolvere uno strano problema di permessi di un utente in un sistema che non può eseguire diversi comandi/applicazioni.
L'utente si trova nei gruppi wheel audio video users games scanner plugdev.
Posso modificare le impostazioni del monitor dal interfaccia grafica del pannello nvidia, ma se cerco di lanciare comandi come
Code:
nvidia-settings --config=~/.nvidia-settings-rc --load-config-only

non succede assolutamente nulla. (inutile dire che se l'utente root esegue il comando tutto funziona perfettamente.
Ho provato ad installare gnome-system-tools nel tentativo di avere più interfaccie grafiche da cui modificare le impostazioni, ma scopro, con mio grande dispiacere, diverse applicazione dal menu amministrazione (editor profili utente, rete, servizi, utente e gruppi) sono inaccessibili a causa della mancanza di diritti di accesso.
Quali info possono essere utili per spiegare meglio il problema, o trovarne una soluzione?


Last edited by mrl4n on Wed Feb 01, 2012 7:36 pm; edited 2 times in total
Back to top
View user's profile Send private message
ago
Developer
Developer


Joined: 01 Mar 2008
Posts: 1485
Location: Cosenza, Italy

PostPosted: Tue Jan 31, 2012 7:52 pm    Post subject: Reply with quote

hai provato a creare un utente ex-novo?
_________________
Contattami se vuoi contribuire in:
-Arch tester
-Chromium tester
-Traduzione doc. it
-Security
Back to top
View user's profile Send private message
mrl4n
Guru
Guru


Joined: 08 Apr 2009
Posts: 588

PostPosted: Tue Jan 31, 2012 7:54 pm    Post subject: Reply with quote

Siceramente no... :oops:

EDIT:Con il nuovo utente i comandi funzionano... :roll:
Back to top
View user's profile Send private message
ago
Developer
Developer


Joined: 01 Mar 2008
Posts: 1485
Location: Cosenza, Italy

PostPosted: Tue Jan 31, 2012 9:01 pm    Post subject: Reply with quote

mrl4n wrote:
EDIT:Con il nuovo utente i comandi funzionano... :roll:


Mi sembra un buon workaround per ora
_________________
Contattami se vuoi contribuire in:
-Arch tester
-Chromium tester
-Traduzione doc. it
-Security
Back to top
View user's profile Send private message
mrl4n
Guru
Guru


Joined: 08 Apr 2009
Posts: 588

PostPosted: Tue Jan 31, 2012 9:11 pm    Post subject: Reply with quote

Si...certamente, grazie.

Ora se devo copiare i file da una cartella home all'altra per aggiornare al vecchio utente il nuovo, spero di non trascinarmi il problema.

EDIT:

Infatti... :twisted:

Fino a questo momento ero convinto che il modo migliore per copiare i file della vecchia home nella nuova fosse
Code:
rsync home1 home2

ma ora non ne sono più sicuro, senza contare il problema che mi perseguita di nuovo.
Back to top
View user's profile Send private message
ago
Developer
Developer


Joined: 01 Mar 2008
Posts: 1485
Location: Cosenza, Italy

PostPosted: Wed Feb 01, 2012 12:01 pm    Post subject: Reply with quote

una soluzione più lunga ma pulita:

copia tutti i file che ti interessano, inteso come dati e altro, non tutto /home/${utente} in posto che non sia /home

Cancella l'utente con userdel, cancella la sua home con rm -fr e crea di nuovo l'utente con lo stesso nome.

Il tutto per avere sempre la stessa utenza, se poi per te poco importa fai un nuovo utente e trasferisci la roba.

NON devi copiare tutta la home compreso le configurazioni perché il problema sta proprio lì, quindi faresti un buco nell'acqua
_________________
Contattami se vuoi contribuire in:
-Arch tester
-Chromium tester
-Traduzione doc. it
-Security
Back to top
View user's profile Send private message
mrl4n
Guru
Guru


Joined: 08 Apr 2009
Posts: 588

PostPosted: Wed Feb 01, 2012 7:36 pm    Post subject: Reply with quote

Spero di aver salvato tutto...lo scoprirò presto.
Grazie.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian) Forum di discussione italiano All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum