Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED] cannot access hardware clock!!
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC
View previous topic :: View next topic  
Author Message
makaveli87
Guru
Guru


Joined: 22 Aug 2005
Posts: 311
Location: Italy

PostPosted: Fri Aug 26, 2005 6:20 pm    Post subject: [SOLVED] cannot access hardware clock!! Reply with quote

I've a G4 cube (it's the one with problems with alsa, X ,....).

When I boot I have this error:
Failed to set the System Clock to Hardaware clock
Failed to start /etc/init.d/clock

If I try hwclock -w :

cannot access the Hardware Clock via any known method
_________________
GoogleTalk: romanovic@gmail.com
Back to top
View user's profile Send private message
makaveli87
Guru
Guru


Joined: 22 Aug 2005
Posts: 311
Location: Italy

PostPosted: Sun Aug 28, 2005 12:41 pm    Post subject: SOLVED Reply with quote

I forgot to enable the kernel support :

Device Drivers -> Character devices -> <*> Generic /dev/rtc emulation
<*> Extended ETC operation



Now the clock works .

Thanks
_________________
GoogleTalk: romanovic@gmail.com
Back to top
View user's profile Send private message
Frostwarrior
Apprentice
Apprentice


Joined: 02 Mar 2007
Posts: 165

PostPosted: Thu Sep 09, 2010 8:16 pm    Post subject: Reply with quote

constructive revive (?)

I had the same problem, until I realized the real time clock support needs to be integrated in the kernel to work properly.

cheers
Back to top
View user's profile Send private message
mimosinnet
Guru
Guru


Joined: 10 Aug 2006
Posts: 512
Location: Barcelona, Spain

PostPosted: Sun Dec 26, 2010 12:58 am    Post subject: Reply with quote

Good to find this thread. I have been able to revive the hardware clock by enabling in the kernel:

Devide Drivers -> Real Time Clock -> PC-style 'CMOS'

CONFIG_RTC_DRV_CMOS=m

Thanks for the thread!

Cheers!
Back to top
View user's profile Send private message
gohmdoree
Guru
Guru


Joined: 12 Oct 2004
Posts: 533

PostPosted: Mon Dec 27, 2010 2:21 pm    Post subject: Reply with quote

hasn't work for me as of yet on my ppc64
Back to top
View user's profile Send private message
mimosinnet
Guru
Guru


Joined: 10 Aug 2006
Posts: 512
Location: Barcelona, Spain

PostPosted: Tue Dec 28, 2010 7:37 pm    Post subject: Reply with quote

gohmdoree wrote:
hasn't work for me as of yet on my ppc64


I do not have much experience on ppc64. Do you have any relevant messages on dmesg? The kernel option I have used above (CONFIG_RTC_DRV_CMOS=m) is platform specific. I have no idea of what kernel options are needed on a ppc64.

Cheers!
Back to top
View user's profile Send private message
gohmdoree
Guru
Guru


Joined: 12 Oct 2004
Posts: 533

PostPosted: Tue Dec 28, 2010 7:58 pm    Post subject: Reply with quote

I will have to fire up my machine and check. It was something similar to the above. The suggestions for the fix did not work for me. Still searching around.
Back to top
View user's profile Send private message
fbcyborg
Advocate
Advocate


Joined: 16 Oct 2005
Posts: 3020
Location: ROMA

PostPosted: Fri Sep 09, 2011 11:34 am    Post subject: Reply with quote

The suggestion for the fix doesn't work for mee too. Actually the CONFIG_RTC_DRV_CMOS module, was already set to "y".
_________________
[HOWTO] Come criptare la /home usando cryptsetup e luks
[HOWTO] Abilitare il supporto al dom0 XEN su kernel 3.X
Help answer the unanswered
Back to top
View user's profile Send private message
depontius
Advocate
Advocate


Joined: 05 May 2004
Posts: 2384

PostPosted: Fri Sep 09, 2011 12:21 pm    Post subject: Reply with quote

Just an odd note on this...

I never paid much attention to the RTC. I normally build my kernels by tweaking a previous config, and for years now most things have "just worked" (TM) with occasional hiccups as kernel features changed. One of those changes, and I'm not sure what it was, came with the 3.0 kernel series. Suddenly I was having hardware clock problems at boot and shutdown. Once I was fully aware of it and had a little time to chase it down, it was easy to fix, as in this thread. But something changed with the 3.0 config, either the name or the way the option was split out, because that's when it broke.
_________________
.sigs waste space and bandwidth
Back to top
View user's profile Send private message
fbcyborg
Advocate
Advocate


Joined: 16 Oct 2005
Posts: 3020
Location: ROMA

PostPosted: Fri Sep 09, 2011 12:27 pm    Post subject: Reply with quote

As a matter of fact I am now using gentoo-sources-3.0.4 both for the dom0 and the domU, since I'm having this problem on a Xen guest gentoo system.
Maybe it's because of that.
_________________
[HOWTO] Come criptare la /home usando cryptsetup e luks
[HOWTO] Abilitare il supporto al dom0 XEN su kernel 3.X
Help answer the unanswered
Back to top
View user's profile Send private message
fbcyborg
Advocate
Advocate


Joined: 16 Oct 2005
Posts: 3020
Location: ROMA

PostPosted: Thu Nov 03, 2011 3:02 pm    Post subject: Reply with quote

The problem has gone, after deleting the following line in /etc/conf.d/hwclock:
Code:
clock_hctosys="YES"

And the module CONFIG_RTC_HCTOSYS is compiled as built in now.
_________________
[HOWTO] Come criptare la /home usando cryptsetup e luks
[HOWTO] Abilitare il supporto al dom0 XEN su kernel 3.X
Help answer the unanswered
Back to top
View user's profile Send private message
DirtyHairy
l33t
l33t


Joined: 03 Jul 2006
Posts: 604
Location: Würzburg, Deutschland

PostPosted: Fri Nov 04, 2011 10:53 am    Post subject: Reply with quote

I remember having a similar issue of "unable to access the hardware clock" which was actually completely unrelated to the hardware clock but instead the result of a screwed up /etc/adjtime. While I don't remember what exactly I did to resolve it (which was slightly more complex), removing the file should resolve the problem.
Back to top
View user's profile Send private message
Bashrc
n00b
n00b


Joined: 06 Nov 2011
Posts: 1

PostPosted: Sun Nov 06, 2011 12:52 pm    Post subject: Reply with quote

For some reason I was unable to make this work until I set rtc_cmos as a module (CONFIG_RTC_DRV_CMOS=m) instead of in-kernel (CONFIG_RTC_DRV_CMOS=y).
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum