Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
IOError: [Errno 5] Input/output error
View unanswered posts
View posts from last 24 hours

Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
Tux's lil' helper
Tux's lil' helper

Joined: 24 Apr 2007
Posts: 91
Location: UK

PostPosted: Wed Jun 01, 2011 12:57 am    Post subject: IOError: [Errno 5] Input/output error Reply with quote

Hey, so im not actually sure if the error in the subject is the issue but i've been googling and searching for hours and i've done the usual rundown of things that i would expect...

Anyway i'll start at the top, I have an asrock ion 330 that during a recent bout of powercuts went a bit tits up, lots of errors across the drive after running fsck, took overnight to fix them all but now does appear fine, everything boots correctly all things appear to be working fine, its been 4-5 months since this happened and i finally managed to get time to fix it, being gentoo i don't ever want to stay too far behind on updates as some things become an absolute nightmare to fix if you do so as soon as i got it up and running again i started hitting the update list:

emerge --sync
ran fine

emerge portage
ran fine

emerge -avuDN world
is where problems arose, some 300 400 packages or so /replace/reinstall/upgrade, most were new slot though due to KDE upgrades. all things were going fine till about 40 packages in and i hit this error on the package dev-util/dialog-1.1.20100428:

Traceback (most recent call last):
  File "/usr/lib/portage/pym/_emerge/", line 113, in _spawn
  File "/usr/lib/portage/pym/portage/package/ebuild/", line 636, in fetch
    myfile_path, pruned_digests, eout)
  File "/usr/lib/portage/pym/portage/package/ebuild/", line 211, in _check_distfile
    if _check_digests(filename, digests, show_errors=show_errors):
  File "/usr/lib/portage/pym/portage/package/ebuild/", line 172, in _check_digests
    verified_ok, reason = verify_all(filename, digests)
  File "/usr/lib/portage/pym/portage/", line 192, in verify_all
    myhash = perform_checksum(filename, x, calc_prelink=calc_prelink)[0]
  File "/usr/lib/portage/pym/portage/", line 248, in perform_checksum
    myhash, mysize = hashfunc_map[hashname](myfilename)
  File "/usr/lib/portage/pym/portage/", line 41, in pyhash
    data =
IOError: [Errno 5] Input/output error

I've since run "python-updater" thinking it was a python issue and i had missed an output from emerge, no such luck, i then hit up "revdep-rebuild", hoping that might pick up what was missing, that threw multiple errors untill i ran lafilefixer --justfixit after which it ran perfectly, i tried "emerge -avuDN world" after but again it failed with the same error on a dev-util/dialog-1.1.20100428. At which point i figure a full emerge might be in order so i started running "emerge -ave world" 40 packages of 800 or so in i hit the exact same error on "dev-libs/lzo-2.04"

I'm now at a bit of a loss, its not like the system is that out of date, ive done this type of thing with my server and desktop over the last few months with no problems, admiteddly the times in between were not quite as long.

If anyone could shed some light on this please i would be most grateful, i have searched and googled though if i have missed something i do apologise.

emerge --info:

Portage (default/linux/x86/10.0, gcc-4.4.5, libc-0-r0, 2.6.34-gentoo-r1 i686)
System uname: Linux-2.6.34-gentoo-r1-i686-Intel-R-_Atom-TM-_CPU_330_@_1.60GHz-with-gentoo-2.0.2
Timestamp of tree: Tue, 31 May 2011 18:15:01 +0000
distcc 3.1 i686-pc-linux-gnu [disabled]
app-shells/bash:     4.1_p9
dev-java/java-config: 2.1.11-r3
dev-lang/python:     2.6.6-r1, 3.1.3-r1
dev-util/cmake:      2.8.1-r2
sys-apps/baselayout: 2.0.2
sys-apps/openrc:     0.7.0
sys-apps/sandbox:    2.4
sys-devel/autoconf:  2.13, 2.65-r1
sys-devel/automake:  1.9.6-r3, 1.11.1
sys-devel/binutils:  2.20.1-r1
sys-devel/gcc:       4.4.5
sys-devel/gcc-config: 1.4.1-r1
sys-devel/libtool:   2.2.10
sys-devel/make:      3.81-r2
sys-libs/glibc:      2.11.3
virtual/os-headers:  0
CFLAGS="-march=prescott -O2 -fomit-frame-pointer -pipe"
CONFIG_PROTECT="/etc /usr/share/config"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/splash /etc/terminfo"
CXXFLAGS="-march=prescott -O2 -fomit-frame-pointer -pipe"
FEATURES="assume-digests binpkg-logs distlocks fixlafiles fixpackages news parallel-fetch protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTDIR_OVERLAY="/var/lib/layman/iElectric /var/lib/layman/sunrise"
USE="X acl alsa berkdb bzip2 caps cdr cli cracklib crypt cups cxx daemon dbus declarative device-mapper dri dvd embedded extensions fbcondecor flac fortran gdbm gif git gnutls gpm gtk iconv ipv6 java joystick jpeg kde mercurial mmx mng modules mp3 mudflap mysql ncurses nls nptl nptlonly nvidia opengl openmp pam pcre perl png policykit pppd python qt3support qt4 readline session sql sse sse2 ssl ssse3 static-libs subversion svg sysfs system-libvncserver tcpd threads truetype udev unicode vdpau webkit webserver x264 x86 xinerama xorg xvid zlib" ALSA_CARDS="hda-intel" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="braindump flow karbon kexi kpresenter krita tables words" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIRC_DEVICES="wpc8769l" PHP_TARGETS="php5-3" RUBY_TARGETS="ruby18" USERLAND="GNU" VIDEO_CARDS="nvidia vdpau" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"

If you require more info please ask.

Thanks in advance.


Edit: build.log is the first [code] quote just incase you wanted to know.
Back to top
View user's profile Send private message

Joined: 28 May 2003
Posts: 368
Location: Alexandria, Egypt

PostPosted: Wed Jun 01, 2011 2:22 am    Post subject: Reply with quote

IO errors are never good, paste dmesg somewhere and link it.
Back to top
View user's profile Send private message
Tux's lil' helper
Tux's lil' helper

Joined: 24 Apr 2007
Posts: 91
Location: UK

PostPosted: Wed Jun 01, 2011 3:28 am    Post subject: Reply with quote

OneOfOne wrote:
IO errors are never good

This i know too well, however im hoping this is left overs from the powercuts and not the HD dying, it literally is err 10 months old or so but that is evening usage, so its on and off once a day, well was till 4-5 months ago so really bad luck if it is the drive.


have to say even to me thats an interesting one, i forgot to put it on my last post but it does seem to have alot more oddities than i would expect from a general dmesg output.

Edit: So seriously unless i am one unlucky mf this is not the HD dying its due to the HD being switched off instantly 20 or so times (yes i had bad powercuts) and numerous errors acrross the drive from that. fsck solved the booting problem, im currently running spinrite across the disk but i would appreciate some other suggestions. Everything is working, i can watch videos listen to music etc etc, its the update part that is throwing the errors, so i dont feel that its at the point that its dead at all.

I'm pretty good at recovery, i have no doubt i can pull it all from the drive, sadly running low on space so dont have anywhere to move it too if i did. It's the error tha confuses me, ive found numerous erro no XX, just not 05 and that is the one popping up over and over.
Back to top
View user's profile Send private message

Joined: 13 May 2005
Posts: 419
Location: Nederland

PostPosted: Sun Sep 30, 2012 12:14 pm    Post subject: IOError: [Errno 5] Input/output error Reply with quote

after one year :

I ran into this problem since few weeks, some package could not emerge wit the same errors : python - IOError: [Errno 5] Input/output error

I tried python-updater, revd-rebuild, emerge world....

finally I found in my /etc/make.conf MAKEOPTS="-j2"

change it to MAKEOPTS="-j1"

problem solved for me

I hope this can help someone even after so long


"Don't wiggle the tail of the frog in the oil of the frying peanuts"
Back to top
View user's profile Send private message

Joined: 21 Feb 2014
Posts: 6

PostPosted: Mon Aug 04, 2014 6:41 pm    Post subject: Similar Issue Reply with quote


I just wanted to add to this post because I've just finished fixing this same kind of error in a very similar situation.

Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum