Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
kdepimlibs-4.5.5 emerge fails [Solved]
View unanswered posts
View posts from last 24 hours

Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
Tux's lil' helper
Tux's lil' helper

Joined: 30 Nov 2003
Posts: 143

PostPosted: Wed Feb 23, 2011 12:11 am    Post subject: kdepimlibs-4.5.5 emerge fails [Solved] Reply with quote

I'm trying to downgrade from KDE 4.6.0 back to KDE 4.5.5 (on amd64).
I removed KDE using a command elsewhere in these forums and have got part way through rebuilding kde 4.5.5 but it's failing at kdepimlibs-4.5.5
I've tried rebuilding akonadi, soprano and some other packages but kdepimlibs still fail :(

Here is the last bit of the emerge process before it fails:

[ 70%] Building CXX object akonadi/CMakeFiles/akonadi-kde.dir/agentmanagerinterface.o
[ 71%] Building CXX object kldap/CMakeFiles/kldap.dir/ldapdn.o
[ 71%] Building CXX object kldap/CMakeFiles/kldap.dir/ldapmodelnode_p.o
[ 71%] Building CXX object akonadi/CMakeFiles/akonadi-kde.dir/tracerinterface.o
[ 71%] Building CXX object kcal/CMakeFiles/kcal.dir/incidenceformatter.o
[ 71%] Building CXX object kldap/CMakeFiles/kldap.dir/ldapmodel.o
[ 71%] Building CXX object akonadi/CMakeFiles/akonadi-kde.dir/controlinterface.o
[ 71%] Building CXX object kldap/CMakeFiles/kldap.dir/ldapmodel_p.o
[ 71%] Building CXX object akonadi/CMakeFiles/akonadi-kde.dir/resourceadaptor.o
[ 71%] Building CXX object kldap/CMakeFiles/kldap.dir/ldapstructureproxymodel.o
[ 71%] Building CXX object kldap/CMakeFiles/kldap.dir/ldapattributeproxymodel.o
/var/tmp/portage/kde-base/kdepimlibs-4.5.5/work/kdepimlibs-4.5.5_build/akonadi/resourceadaptor.cpp: In member function ‘void Akonadi__ResourceAdaptor::synchronizeCollection(qlonglong, bool)’:
/var/tmp/portage/kde-base/kdepimlibs-4.5.5/work/kdepimlibs-4.5.5_build/akonadi/resourceadaptor.cpp:63: error: no matching function for call to ‘Akonadi::ResourceBase::synchronizeCollection(qlonglong&, bool&)’
/var/tmp/portage/kde-base/kdepimlibs-4.5.5/work/kdepimlibs-4.5.5/akonadi/resourcebase.h:399: note: candidates are: void Akonadi::ResourceBase::synchronizeCollection(qint64)
/var/tmp/portage/kde-base/kdepimlibs-4.5.5/work/kdepimlibs-4.5.5_build/akonadi/resourceadaptor.cpp: In member function ‘void Akonadi__ResourceAdaptor::synchronizeCollectionAttributes(qlonglong)’:
/var/tmp/portage/kde-base/kdepimlibs-4.5.5/work/kdepimlibs-4.5.5_build/akonadi/resourceadaptor.cpp:75: error: ‘class Akonadi::ResourceBase’ has no member named ‘synchronizeCollectionAttributes’
make[2]: *** [akonadi/CMakeFiles/akonadi-kde.dir/resourceadaptor.o] Error 1
make[1]: *** [akonadi/CMakeFiles/akonadi-kde.dir/all] Error 2
make[1]: *** Waiting for unfinished jobs....
[ 71%] Building CXX object kcal/CMakeFiles/kcal.dir/vcaldrag.o
Linking CXX shared library ../lib/
[ 71%] Building CXX object kcal/CMakeFiles/kcal.dir/icaldrag.o
[ 71%] Built target kldap
[ 71%] Building CXX object kcal/CMakeFiles/kcal.dir/exceptions.o
[ 71%] Building CXX object kcal/CMakeFiles/kcal.dir/scheduler.o
[ 73%] Building CXX object kcal/CMakeFiles/kcal.dir/imipscheduler.o
[ 73%] Building CXX object kcal/CMakeFiles/kcal.dir/dummyscheduler.o
[ 73%] Building CXX object kcal/CMakeFiles/kcal.dir/calfilter.o
[ 73%] Building CXX object kcal/CMakeFiles/kcal.dir/person.o
[ 73%] Building CXX object kcal/CMakeFiles/kcal.dir/period.o
[ 73%] Building CXX object kcal/CMakeFiles/kcal.dir/duration.o
[ 73%] Building CXX object kcal/CMakeFiles/kcal.dir/dndfactory.o
[ 73%] Building CXX object kcal/CMakeFiles/kcal.dir/calstorage.o
[ 73%] Building CXX object kcal/CMakeFiles/kcal.dir/filestorage.o
[ 73%] Building CXX object kcal/CMakeFiles/kcal.dir/compat.o
[ 74%] Building CXX object kcal/CMakeFiles/kcal.dir/qtopiaformat.o
[ 74%] Building CXX object kcal/CMakeFiles/kcal.dir/htmlexport.o
[ 74%] Building CXX object kcal/CMakeFiles/kcal.dir/calendarnull.o
[ 74%] Building CXX object kcal/CMakeFiles/kcal.dir/freebusyurlstore.o
[ 74%] Building CXX object kcal/CMakeFiles/kcal.dir/confirmsavedialog.o
[ 74%] Building CXX object kcal/CMakeFiles/kcal.dir/icaltimezones.o
[ 74%] Building CXX object kcal/CMakeFiles/kcal.dir/kresult.o
[ 74%] Building CXX object kcal/CMakeFiles/kcal.dir/assignmentvisitor.o
[ 74%] Building CXX object kcal/CMakeFiles/kcal.dir/comparisonvisitor.o
[ 74%] Building CXX object kcal/CMakeFiles/kcal.dir/calhelper.o
[ 76%] Building CXX object kcal/CMakeFiles/kcal.dir/resourcecalendar.o
[ 76%] Building CXX object kcal/CMakeFiles/kcal.dir/resourcelocal.o
[ 76%] Building CXX object kcal/CMakeFiles/kcal.dir/resourcelocalconfig.o
[ 76%] Building CXX object kcal/CMakeFiles/kcal.dir/resourcelocaldir.o
[ 76%] Building CXX object kcal/CMakeFiles/kcal.dir/resourcelocaldirconfig.o
[ 76%] Building CXX object kcal/CMakeFiles/kcal.dir/resourcecached.o
[ 76%] Building CXX object kcal/CMakeFiles/kcal.dir/resourcecachedconfig.o
[ 76%] Building CXX object kcal/CMakeFiles/kcal.dir/calendarresources.o
[ 76%] Building CXX object kcal/CMakeFiles/kcal.dir/htmlexportsettings.o
Linking CXX shared library ../lib/
[ 76%] Built target kcal
make: *** [all] Error 2
emake failed
 * ERROR: kde-base/kdepimlibs-4.5.5 failed:
 *   Make failed!
 * Call stack:
 *, line   56:  Called src_compile
 *   environment, line 3926:  Called kde4-base_src_compile
 *   environment, line 2983:  Called cmake-utils_src_compile
 *   environment, line 1169:  Called _execute_optionaly 'src_compile'
 *   environment, line  543:  Called enable_cmake-utils_src_compile
 *   environment, line 1538:  Called cmake-utils_src_make
 *   environment, line 1188:  Called die
 * The specific snippet of code:
 *           emake "$@" || die "Make failed!";
 * If you need support, post the output of 'emerge --info =kde-base/kdepimlibs-4.5.5',
 * the complete build log and the output of 'emerge -pqv =kde-base/kdepimlibs-4.5.5'.
 * The complete build log is located at '/var/tmp/portage/kde-base/kdepimlibs-4.5.5/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/kde-base/kdepimlibs-4.5.5/temp/environment'.
 * S: '/var/tmp/portage/kde-base/kdepimlibs-4.5.5/work/kdepimlibs-4.5.5'

Akonadi-server-1.5.0 is installed (and has been rebuilt immeditely before kdepimlibs)

revdep-rebuild has been run several times and there is now nothing needing a rebuild.

Here is my emerge --info

Portage (default/linux/amd64/10.0, gcc-4.4.4, glibc-2.11.2-r3, 2.6.36-gentoo-r5 x86_64)
System uname: Linux-2.6.36-gentoo-r5-x86_64-Intel-R-_Core-TM-2_CPU_T7200_@_2.00GHz-with-gentoo-1.12.14
Timestamp of tree: Sat, 19 Feb 2011 05:00:01 +0000
app-shells/bash:     4.1_p9
dev-java/java-config: 2.1.11-r3
dev-lang/python:     2.6.6-r1, 3.1.2-r4
dev-util/cmake:      2.8.1-r2
sys-apps/baselayout: 1.12.14-r1
sys-apps/sandbox:    2.4
sys-devel/autoconf:  2.13, 2.65-r1
sys-devel/automake:  1.9.6-r3, 1.10.3, 1.11.1
sys-devel/binutils:  2.20.1-r1
sys-devel/gcc:       4.4.4-r2
sys-devel/gcc-config: 1.4.1
sys-devel/libtool:   2.2.10
sys-devel/make:      3.81-r2
virtual/os-headers: (sys-kernel/linux-headers)
CFLAGS="-O2 -march=native -fomit-frame-pointer -pipe"
CONFIG_PROTECT="/etc /usr/share/config /usr/share/themes/oxygen-gtk/gtk-2.0"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/revdep-rebuild /etc/sandbox.d /etc/splash /etc/terminfo"
CXXFLAGS="-O2 -march=native -fomit-frame-pointer -pipe"
FEATURES="assume-digests binpkg-logs distlocks fixlafiles fixpackages news parallel-fetch protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
USE="X a52 aac acl acpi alsa amd64 amr arts berkdb bluetooth bzip2 cdr cli clucene consolekit cracklib crypt css cups cxx dbus dri dts dv dvb dvd dvdr dvdread encode exif faac fam ffmpeg flac fltk fortran gcj gdbm gif gpm gtk gtk2 hal iconv ieee1394 imagemagick jpeg kde kdehiddenvisibility kdexdeltas kino mad mmx modules motif mp3 mpeg mplayer mudflap multilib ncurses nls nptl nptlonly nsplugin nvidia ogg openal opengl openmp pam pcre pdf perl plasma png policykit pppd pulseaudio python qt3 qt3support qt4 quicktime rdesktop readline samba sdl semantic-desktop session sse sse2 ssl svg sysfs tcpd theora truetype unicode usb vorbis wifi x264 xcomposite xine xml xorg xvid xvmc zlib" ALSA_CARDS="hda-intel" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="en" PHP_TARGETS="php5-3" RUBY_TARGETS="ruby18" USERLAND="GNU" VIDEO_CARDS="nvidia" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"

Can anyone suggest something that might help?


Last edited by rolypoly on Thu Feb 24, 2011 1:55 am; edited 1 time in total
Back to top
View user's profile Send private message
Tux's lil' helper
Tux's lil' helper

Joined: 30 Nov 2003
Posts: 143

PostPosted: Wed Feb 23, 2011 8:01 pm    Post subject: Reply with quote

This is driving me nuts!
Just left an emerge -e world running over night to make sure everything is rebuilt that needs to be rebuilt and it still fell over on kdepimlibs!

The reason I'm trying to go back to KDE 4.5.5 is that under 4.6.0 I lost about 10 years of email.
My email is stored under ~/Mail and has always worked perfectly with kmail. kmail2, now using Akonadi for everything, didn't convert my Mail folder correctly. I changed the akonadi configuration to use sqlite (and also tried mysql) but it made no difference. When starting akonadi (either akonadictl or using the tray icon) it gets stuck in a loop creating multiple local mail folders and I end up with hundreds of them! And my mail is missing from kmail.

My ~/Mail folder seems ok, so I'm hoping that going back to an earlier version of kmail that I knew worked will restore my mail. I also have a backup copy of the ~/Mail folder before I upgraded to kmail2. I've tried running a maildir to mbox conversion script, but that fails to complete the process, so I can't even use Thunderbird to read my old mails in the mean time.

Any suggestions for this?

Back to top
View user's profile Send private message
Tux's lil' helper
Tux's lil' helper

Joined: 30 Nov 2003
Posts: 143

PostPosted: Wed Feb 23, 2011 11:20 pm    Post subject: Reply with quote

This gets worse.
I've now uninstalled all of KDE again using the following command:

qlist -IC kde | xargs emerge -Cv

Then cleaned out my package.keywords file and then tried to install the stable version of KDE 4.4.5 and kdepimlibs still fails!!!!!!

How can I find out the dependencies of kdepimlibs to see if I can rebuild something it requires?
Back to top
View user's profile Send private message
Tux's lil' helper
Tux's lil' helper

Joined: 30 Nov 2003
Posts: 143

PostPosted: Thu Feb 24, 2011 1:57 am    Post subject: Reply with quote

Although the above command will uninstall kde components, it doesn't uninstall some of the dependencies, like akonadi-server.
So, because I was downgrading, akonadi-server was still at version 1.5.0 while kdepimlibs is expecting 1.3.1
Once I'd downgraded akonadi-server (which wasn't keyworded ~amd64), kdepimlibs compiled ok.

Hopefully all this effort will 'fix' my kmail problem...
Back to top
View user's profile Send private message

Joined: 20 May 2004
Posts: 678

PostPosted: Sun May 29, 2011 5:47 am    Post subject: Reply with quote

Your solution works for kdepimlibs-4.6.80 as well. I reemerged akonadi-server and kdepimlibs emerged right away.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum