Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
alsa errors on a e350 board.
View unanswered posts
View posts from last 24 hours

Reply to topic    Gentoo Forums Forum Index Multimedia
View previous topic :: View next topic  
Author Message

Joined: 05 Mar 2004
Posts: 762

PostPosted: Tue May 03, 2011 1:17 am    Post subject: alsa errors on a e350 board. Reply with quote

Is getting a bit annoying. Important information first.
aplay -l

**** List of PLAYBACK Hardware Devices ****
card 0: Generic [HD-Audio Generic], device 3: HDMI 0 [HDMI 0]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 1: SB [HDA ATI SB], device 0: ALC892 Analog [ALC892 Analog]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 1: SB [HDA ATI SB], device 1: ALC892 Digital [ALC892 Digital]
Subdevices: 1/1
Subdevice #0: subdevice #0

aplay -L

Discard all samples (playback) or generate zero samples (capture)
HD-Audio Generic, HDMI 0
HDMI Audio Output
HDA ATI SB, ALC892 Analog
Front speakers
HDA ATI SB, ALC892 Analog
4.0 Surround output to Front and Rear speakers
HDA ATI SB, ALC892 Analog
4.1 Surround output to Front, Rear and Subwoofer speakers
HDA ATI SB, ALC892 Analog
5.0 Surround output to Front, Center and Rear speakers
HDA ATI SB, ALC892 Analog
5.1 Surround output to Front, Center, Rear and Subwoofer speakers
HDA ATI SB, ALC892 Analog
7.1 Surround output to Front, Center, Side, Rear and Woofer speakers
HDA ATI SB, ALC892 Digital
IEC958 (S/PDIF) Digital Audio Output

ls -l /dev/snd

total 0
drwxr-xr-x 2 root root 80 May 2 13:08 by-path
crw-rw---- 1 root audio 116, 4 May 2 13:08 controlC0
crw-rw---- 1 root audio 116, 9 May 2 13:08 controlC1
crw-rw---- 1 root audio 116, 3 May 2 13:08 hwC0D0
crw-rw---- 1 root audio 116, 8 May 2 13:08 hwC1D0
crw-rw---- 1 root audio 116, 2 May 2 13:08 pcmC0D3p
crw-rw---- 1 root audio 116, 7 May 2 13:08 pcmC1D0c
crw-rw---- 1 root audio 116, 6 May 2 13:08 pcmC1D0p
crw-rw---- 1 root audio 116, 5 May 2 13:08 pcmC1D1p
crw-rw---- 1 root audio 116, 1 May 2 13:08 seq
crw-rw---- 1 root audio 116, 33 May 2 13:08 timer

emerge --info
Portage (default/linux/amd64/10.0/desktop, gcc-4.4.5, libc-0-r0, 2.6.38-gentoo-r3 x86_64)
System uname: Linux-2.6.38-gentoo-r3-x86_64-AMD_E-350_Processor-with-gentoo-1.12.14
Timestamp of tree: Sat, 30 Apr 2011 04:30:01 +0000
app-shells/bash: 4.1_p9
dev-java/java-config: 2.1.11-r3
dev-lang/python: 2.7.1-r1, 3.1.3-r1
dev-util/cmake: 2.8.4-r1
sys-apps/baselayout: 1.12.14-r1
sys-apps/sandbox: 2.4
sys-devel/autoconf: 2.13, 2.65-r1
sys-devel/automake: 1.9.6-r3, 1.11.1
sys-devel/binutils: 2.20.1-r1
sys-devel/gcc: 4.4.5
sys-devel/gcc-config: 1.4.1-r1
sys-devel/libtool: 2.2.10
sys-devel/make: 3.81-r2
sys-libs/glibc: 2.11.3
virtual/os-headers: 0
CFLAGS="-mtune=generic -mmmx -msse -msse2 -msse3 -mssse3 -msse4a -mabm -O2 -pipe"
CONFIG_PROTECT="/etc /usr/share/config /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-mtune=generic -mmmx -msse -msse2 -msse3 -mssse3 -msse4a -mabm -O2 -pipe"
FEATURES="assume-digests binpkg-logs distlocks fixlafiles fixpackages news parallel-fetch protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
USE="X a52 aac acpi aiglx aim alsa amd64 archive berkdb branding bzip2 cairo cdr cdrw cli consolekit cracklib crypt cups cxx dbus dri dts dvd dvdr dvdread emboss encode exif ffmpeg ffmpeg-mt firefox flac font-server fortran gdbm gdu gif gpm gtk gtk2 iconv java joystick jpeg kde lame lcms ldap libnotify lzma mad mjpeg mmx mng modules mp3 mp4 mpeg msn mudflap multilib ncurses nls nptl nptlonly nsplugin ntpl ogg oggvorbis opengl openmp oss pam pango pcre pdf perl png pnp policykit ppds pppd python qt3 qt3support qt4 quicktime readline sdl semantic-desktop session spell sse sse2 sse3 sse4a ssl ssse3 startup-notification svg symlink sysfs tcpd theroa tiff truetype udev unicode usb v4l v4l2 vcd vorbis x264 xcb xcomposite xfce xine xinerama xml xorg xpm xulrunner xv xvid zip zlib" ALSA_CARDS="hda-intel" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="evdev keyboard mouse" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="en_US" PHP_TARGETS="php5-3" RUBY_TARGETS="ruby18" USERLAND="GNU" VIDEO_CARDS="vesa radeon ati" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"


Module Size Used by
snd_hrtimer 1556 0
snd_seq_dummy 1255 0
snd_seq_oss 23341 0
snd_seq_midi_event 4652 1 snd_seq_oss
snd_seq 40950 5 snd_seq_dummy,snd_seq_oss,snd_seq_midi_event
snd_seq_device 4531 3 snd_seq_dummy,snd_seq_oss,snd_seq
snd_pcm_oss 31992 0
snd_mixer_oss 12425 1 snd_pcm_oss
generic_bl 1865 0
backlight 3356 1 generic_bl
scsi_wait_scan 719 0
i2c_dev 4594 0
radeon 712269 0
ttm 46463 1 radeon
fbcon 33031 0
i2c_algo_bit 4274 1 radeon
tileblit 1965 1 fbcon
cfbcopyarea 2897 1 radeon
font 7292 1 fbcon
cfbimgblt 1937 1 radeon
bitblit 4346 1 fbcon
cfbfillrect 2989 1 radeon
softcursor 1141 1 bitblit
drm_kms_helper 22053 1 radeon,[permanent]
fb 44556 6 radeon,fbcon,tileblit,bitblit,softcursor,drm_kms_helper
drm 155530 3 radeon,ttm,drm_kms_helper
i2c_core 15706 5 i2c_dev,radeon,i2c_algo_bit,drm_kms_helper,drm
fbdev 721 1 fb
test_nx 1539 0
snd_hda_codec_realtek 274727 1
snd_hda_codec_hdmi 19985 1
snd_hda_intel 19134 0
snd_hda_codec 60411 3 snd_hda_codec_realtek,snd_hda_codec_hdmi,snd_hda_intel
xhci_hcd 54033 0
snd_hwdep 5276 1 snd_hda_codec
snd_pcm 60166 4 snd_pcm_oss,snd_hda_codec_hdmi,snd_hda_intel,snd_hda_codec
snd_timer 15848 3 snd_hrtimer,snd_seq,snd_pcm
snd 46528 12 snd_seq_oss,snd_seq,snd_seq_device,snd_pcm_oss,snd_mixer_oss,snd_hda_codec_realtek,snd_hda_codec_hdmi,snd_hda_intel,snd_hda_codec,snd_hwdep,snd_pcm,snd_timer
snd_page_alloc 6001 2 snd_hda_intel,snd_pcm
k10temp 2611 0


## You need to customise this section for your specific sound card(s)
## and then run `update-modules' command.
## Read alsa-driver's INSTALL file in /usr/share/doc for more info.
## ALSA portion
alias snd-card-0 snd-hda-intel
## alias snd-card-1 snd-ens1371
## OSS/Free portion
#alias sound-slot-0 snd-card-0
#alias sound-slot-1 snd-card-1

# OSS/Free portion - card #1
## OSS/Free portion - card #2
#alias sound-service-1-0 snd-mixer-oss
#alias sound-service-1-3 snd-pcm-oss
#alias sound-service-1-12 snd-pcm-oss

alias /dev/mixer snd-mixer-oss
alias /dev/dsp snd-pcm-oss
alias /dev/midi snd-seq-oss

#options snd cards_limit=1

I have all the needed modules and codecs. I have the system set up for dual cards since it sees the audio out on the hdmi connector as a sound card.
but this is what i get when i try to set it to use the second card, the actual sound card.

Playing WAVE '/home/kevin/tf.wav' : Unsigned 8 bit, Rate 11025 Hz, Mono
aplay: set_params:1053: Sample format non available
Available formats:
- S16_LE
- S32_LE

ok so maybe if i let it work on it's own like my laptop it will 'just work', tried that and got this.

ALSA lib pcm_dmix.c:1018:(snd_pcm_dmix_open) unable to open slave
aplay: main:654: audio open error: No such file or directory

Nope i guess not.

any ideas what i am doing wrong?
Back to top
View user's profile Send private message

Joined: 13 Aug 2006
Posts: 16
Location: France

PostPosted: Mon Aug 15, 2011 6:17 pm    Post subject: Reply with quote

I've got exactly the same problem with my E350.

I've tried with driver compiled into the kernel or as module.

May it be due to the fact that there is 2 cards using the same driver (the ATI hdmi audio and the on board sound controler) ?

Edit : I've just checked using minimal boot CD (amd64 install 20110804) and I've got the same error message.

Edit : I don't have /dev/sndstat file

Edit :
I find a solution, I don't know if it is the better one but it works.
I created /etc/asound.conf with the following content :

pcm.!default {
type hw
card 1

ctl.!default {
type hw
card 1

I think the problem comes from HDMI audio that alsa use as default device.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Multimedia All times are GMT
Page 1 of 1

Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum