Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
How to install an old version of automake?
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
devlaam
n00b
n00b


Joined: 22 Oct 2009
Posts: 49
Location: Alkmaar, Netherlands

PostPosted: Mon Mar 28, 2011 11:22 am    Post subject: How to install an old version of automake? Reply with quote

For an (older) cross-compiler i try to build i need automake-1.9
However, my system is already on 1.11.1 and does seem to
have that version available any more:

Code:
emerge -p "=sys-devel/automake-1.9"

These are the packages that would be merged, in order:

Calculating dependencies... done!

emerge: there are no ebuilds to satisfy "=sys-devel/automake-1.9.6".

emerge: searching for similar names...
emerge: Maybe you meant any of these: dev-ruby/osmlib-base, dev-ruby/kirbybase, dev-ruby/snmplib?

I also tried =automake-1.9.6. Same result. How to proceed?

Btw: on an other gentoo system i have 1.7, 1.8. 1.9, and 1.10 available, so it must be possible somehow.

Ruud
Back to top
View user's profile Send private message
Aquous
l33t
l33t


Joined: 08 Jan 2011
Posts: 699

PostPosted: Mon Mar 28, 2011 11:32 am    Post subject: Reply with quote

emerge =sys-devel/automake-1.9.6-r3
Back to top
View user's profile Send private message
devlaam
n00b
n00b


Joined: 22 Oct 2009
Posts: 49
Location: Alkmaar, Netherlands

PostPosted: Mon Mar 28, 2011 12:11 pm    Post subject: [SOLVED] How to install an old version of automake? Reply with quote

Super! Works like a charm. Thanks.

Maybe it is a good idea to revamp the part of emerge that
searches for similar names: automake-1.9.6-r3 seems a lot
closer to automake-1.9 than dev-ruby/osmlib-base,
dev-ruby/kirbybase or dev-ruby/snmplib !

Ruud
Back to top
View user's profile Send private message
krinn
Watchman
Watchman


Joined: 02 May 2003
Posts: 5740

PostPosted: Mon Mar 28, 2011 12:19 pm    Post subject: Reply with quote

use star :)

Code:
emerge -pv =automake-1.9*

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild  NS   ] sys-devel/automake-1.9.6-r3 [1.10.3, 1.11.1] 0 kB
Back to top
View user's profile Send private message
VoidMage
Watchman
Watchman


Joined: 14 Oct 2006
Posts: 6192

PostPosted: Mon Mar 28, 2011 12:34 pm    Post subject: Reply with quote

Actually, unless your portage is significantly outdated, simply use slot:
Code:
emerge -1pv automake:1.9
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum