Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[solved] Atheros Wlan-Karte will nicht
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German)
View previous topic :: View next topic  
Author Message
72_6f_6c_61_6e_64
Guru
Guru


Joined: 16 Nov 2009
Posts: 438
Location: 39° 6′ 18″ N, 76° 44′ 29″ W

PostPosted: Tue Jan 04, 2011 9:01 pm    Post subject: [solved] Atheros Wlan-Karte will nicht Reply with quote

Hallo,

ich hab Probleme mit meinem WLAN.

lspci -v zeigt mir bei meiner WLAN-Karte folgendes:
Code:
02:00.0 Network controller: Atheros Communications Inc. Device 002c (rev 01)
   Subsystem: Device 1a3b:1112
   Flags: bus master, fast devsel, latency 0, IRQ 17
   Memory at fbff0000 (64-bit, non-prefetchable) [size=64K]
   Capabilities: [40] Power Management version 3
   Capabilities: [50] MSI: Enable- Count=1/1 Maskable- 64bit-
   Capabilities: [60] Express Legacy Endpoint, MSI 00
   Capabilities: [100] Advanced Error Reporting
   Capabilities: [140] Virtual Channel <?>
   Capabilities: [160] Device Serial Number 00-15-17-ff-ff-24-14-12
   Capabilities: [170] Power Budgeting <?>
   Kernel driver in use: ath9k

Im kernel hab ich folgendes:
Code:
Linux Kernel Configuration
  [*] Networking support --->
     -*-  Wireless --->
     <*>     cfg80211 - wireless configuration API
     [ ]   n180211 testmode command
     [ ]   enable developer warnings
     [ ]   cfg80211 regulatory debugging
     [*]   enable powersave by default
     [ ]   cfg80211 DebugFS entries
     [*]   cfg80211 wireless extensions sysfs files
     < >   Common routines for IEEE802.11 drivers
     <*>   Generic IEEE 802.11 Networking Stack (mac80211)
      Default rate control algorithm (Minstrell) --->
     [ ]   Enable mac80211 mesh networking (pre-802.11s) support
     [ ]   Select mac80211 debugging features --->
 
  Device Drivers --->
     [*] Network device support -->
     [*] Wireless LAN --->
   <*>  Atheros Wireless Cards --->
   [*]   Atheros wireless debugging
   <*>   Atheros 5xxx wireless cards support
   [*]     Atheros 5xxx debugging
   <*>   Atheros 802.11n wireless card support
   [*]     Atheros ath9k debugging
   < >   Atheros AR9170 802.11n USB support

Ich schätze das zu viel auch nicht gut ist oder? Was hab ich da vergessen zu aktivieren, bzw was ist zu viel?

Wenn ich als root /etc/init.d/net.wlan0 restart ausführe, bekam ich das:
Code:
SIOCSIFFLAGS: Unknown error 132
SIOCSIFFLAGS: Unknown error 132
SIOCSIFFLAGS: Unknown error 132
 You either need to set a preferred_aps list in /etc/conf.d/wireless
    preferred_aps=( "ESSID" "ESSID" )
    and set associate_order_wlan0="forcepreferred"
    or set associate_order_wlan0="forcepreferredonly"
 or hardcode the ESSID to "any" and let the driver find an Access Point
    essid_wlan0="any"
 or configure defaulting to Ad-Hoc when Managed fails
    adhoc_essid_wlan0="WLAN"
 or hardcode the ESSID against the interface (not recommended)
    essid_wlan0="ESSID"
 Failed to configure wireless for wlan0

Dann hab ich in der /etc/conf.d/net folgendes ergänzt.

config_wlan0=( "dhcp" )
essid_wlan0="any"

Danach bekomm ich folgenden Fehler:
Code:
/etc/init.d/net.wlan0 restart\
 * Caching service dependencies ...\
 *  Cannot add provide 'net', as a service with the same name exists!
 * Service net.wlan0 starting
SIOCSIFFLAGS: Unknown error 132
SIOCSIFFLAGS: Unknown error 132
SIOCSIFFLAGS: Unknown error 132
 Failed to configure wireless for wlan0
 * ERROR: net.wlan0 failed to start

Was mach ich falsch?

LG Roland
_________________
Man gewöhnt sich an allem, sogar am Dativ.


Last edited by 72_6f_6c_61_6e_64 on Sun Jan 09, 2011 4:01 pm; edited 1 time in total
Back to top
View user's profile Send private message
tuam
l33t
l33t


Joined: 04 May 2004
Posts: 765
Location: CGN, Germany

PostPosted: Tue Jan 04, 2011 9:40 pm    Post subject: Reply with quote

Hallo Roland,

der hier sollte der richtige Treiber sein: "Atheros 802.11n wireless card support".

Wenn es keinen Grund dagegen gibt, würde ich die Treiber zunächst alle als Modul kompilieren, dann testet es sich leichter. Die "Debugging information" brauchst Du meiner Meinung nach eher nicht, das spammt nur das Log voll.

Dann würde ich schrittweise weiter vorgehen:
- wird das Modul geladen (lsmod)
- Was sagt dmesg?
- Kann man mit "iwlist scan" etc. Deinen Router finden?
- wpa_supplicant einrichten
- net.wlan0 scharfschalten oder networkmanager / wicd einrichten

FF,

Daniel
_________________
Logic clearly dictates that the needs of the many outweigh the needs of the few. - Spock
The needs of the one outweigh the needs of the many. - Kirk
I refuse to let arithmetic decide questions like that. - Picard
Back to top
View user's profile Send private message
LinuxTom
l33t
l33t


Joined: 26 Mar 2006
Posts: 798

PostPosted: Wed Jan 05, 2011 6:43 am    Post subject: Re: Atheros Wlan-Karte will nicht Reply with quote

72_6f_6c_61_6e_64 wrote:
lspci -v zeigt mir bei meiner WLAN-Karte folgendes:

02:00.0 Network controller: Atheros Communications Inc. Device 002c (rev 01)

Mach mal folgenden Befehl (aus sys-apps/pciutils):
Code:
update-pciids

Dann sollte da auch ein richtiger Name stehen. ;)
Back to top
View user's profile Send private message
72_6f_6c_61_6e_64
Guru
Guru


Joined: 16 Nov 2009
Posts: 438
Location: 39° 6′ 18″ N, 76° 44′ 29″ W

PostPosted: Thu Jan 06, 2011 10:01 am    Post subject: Reply with quote

@tuam
muss ich demnächst probieren.

@LinuxTom
Besser?
Code:

02:00.0 Network controller: Atheros Communications Inc. AR2427 Wireless Network Adapter (PCI-Express) (rev 01)
   Subsystem: AzureWave Device 1112
   Flags: bus master, fast devsel, latency 0, IRQ 17
   Memory at fbff0000 (64-bit, non-prefetchable) [size=64K]
   Capabilities: [40] Power Management version 3
   Capabilities: [50] MSI: Enable- Count=1/1 Maskable- 64bit-
   Capabilities: [60] Express Legacy Endpoint, MSI 00
   Capabilities: [100] Advanced Error Reporting
   Capabilities: [140] Virtual Channel <?>
   Capabilities: [160] Device Serial Number 00-15-17-ff-ff-24-14-12
   Capabilities: [170] Power Budgeting <?>
   Kernel driver in use: ath9k

LG Roland
_________________
Man gewöhnt sich an allem, sogar am Dativ.
Back to top
View user's profile Send private message
Beforegod
Bodhisattva
Bodhisattva


Joined: 10 Apr 2002
Posts: 1493
Location: Frankfurt/Main

PostPosted: Fri Jan 07, 2011 8:44 am    Post subject: Reply with quote

Hast Du das mal angesehen: http://de.gentoo-wiki.com/wiki/Rfkill

Kann es sein das Deine Karte Software/Hardwareseitig deaktiviert ist?
Back to top
View user's profile Send private message
72_6f_6c_61_6e_64
Guru
Guru


Joined: 16 Nov 2009
Posts: 438
Location: 39° 6′ 18″ N, 76° 44′ 29″ W

PostPosted: Fri Jan 07, 2011 12:18 pm    Post subject: Reply with quote

Beforegod wrote:

Hast Du das mal angesehen: http://de.gentoo-wiki.com/wiki/Rfkill

Kann es sein das Deine Karte Software/Hardwareseitig deaktiviert ist?

Hab mir den Artikel durchgelesen, und gemerkt, dass ich rfkill auch installiert habe.

Wenn ich das WLAN per FN + F2 aktiviere (Lämpchen leuchtet) bekomme ich bei rfkill list folgendes:
0: phy0: Wireless LAN
Soft blocked: no
Hard blocked: no

Wenn ich es wieder ausschalte (Lämpchen leuchtet nicht) bekomme ich folgendes:
0: phy0: Wireless LAN
Soft blocked: no
Hard blocked: yes

Ich habe aber nicht ganz verstanden was er damit sagen will.
Ich glaube es betrifft mich damit nur der Soft blocked Wert, da der Hard blocked Wert nur anzeigt obs aktiviert ist oder nicht (und das macht auch das Lämpchen)


@ tuam
alle drei (ath5k, ath9k und ar9170usb) als Modul eingebunden. (Kann mir aber nicht vorstellen, dass es der ar9170usb ist, die ist ja über pci eingehängt.)

Wie lade ich treibermodule?

lsmod zeigt mir dann an welche Module geladen sind oder?

LG Roland
_________________
Man gewöhnt sich an allem, sogar am Dativ.
Back to top
View user's profile Send private message
Beforegod
Bodhisattva
Bodhisattva


Joined: 10 Apr 2002
Posts: 1493
Location: Frankfurt/Main

PostPosted: Fri Jan 07, 2011 12:38 pm    Post subject: Reply with quote

Ok, das wäre in die Kategorie "ist ausgeschalten" gegangen.
wenn die WLAN Karte aktiv ist, sollte es auch gehen.

Probier mal ein:

modprobe ath9k

Danach ein lsmod und ein iwconfig ob ein Device "wlan0" vorhanden ist.

Sollte alles bis hierhin funktionieren, probiere dann nochmal ein /etc/init.d/net.wlan0 restart
Back to top
View user's profile Send private message
72_6f_6c_61_6e_64
Guru
Guru


Joined: 16 Nov 2009
Posts: 438
Location: 39° 6′ 18″ N, 76° 44′ 29″ W

PostPosted: Fri Jan 07, 2011 3:03 pm    Post subject: Reply with quote

@Beforegod
Du hättest gemeint dass ich das Wlan aufdrehe, und rfkill es softwaremäßig wieder abdreht?

Also:
Code:
# modprobe ath9k
FATAL: Error inserting ath9k (/lib/modules/2.6.34-gentoo-r12/kernel/drivers/net/
wireless/ath/ath9k/ath9k.ko): Invalid argument

# ls /lib/modules/2.6.34-gentoo-r12/kernel/drivers/net/wireless/ath/ath9k/
ath9k_common.ko  ath9k_hw.ko  ath9k.ko

# lsmod
Module      Size Used by

# iwconfig
wlan0   IEEE 802.11bg   Mode:Managed   Access Point: Not-Associated
   Tx-Power=off
   Retry   long limit:7   RTS thr:off   Fragment thr:off
   Encryption key:off
   Power Management:off

# /etc/init.d/net.wlan0 restart
 * Service net.wlan0 starting
SIOCSIFFLAGS: Unknown error 132
SIOCSIFFLAGS: Unknown error 132
SIOCSIFFLAGS: Unknown error 132
 Failed to configure wireless for wlan0            [ !! ]
 * ERROR:  net.wlan0 failed to start

Das komische ist nur, ich hab den Rechner mal neu aufgesetzt weil ich ihn kaputt-konfiguriert habe, aber davor ist es gegangen.

LG Roland
_________________
Man gewöhnt sich an allem, sogar am Dativ.
Back to top
View user's profile Send private message
Beforegod
Bodhisattva
Bodhisattva


Joined: 10 Apr 2002
Posts: 1493
Location: Frankfurt/Main

PostPosted: Fri Jan 07, 2011 5:28 pm    Post subject: Reply with quote

Verwundert mich jetzt etwas. Sind Deine Wireless Treiber nun als Modul oder im Kernel?

Meinte eher das WLAN Softwareseitig ausgeschaltet ist. Sind irgendwelche Wireless Treiber im Kernel?

Ansonsten mal.mit rfkill alles auf off und dann wieder on schalten.
Back to top
View user's profile Send private message
72_6f_6c_61_6e_64
Guru
Guru


Joined: 16 Nov 2009
Posts: 438
Location: 39° 6′ 18″ N, 76° 44′ 29″ W

PostPosted: Fri Jan 07, 2011 7:49 pm    Post subject: Reply with quote

wie geht das mit rfkill?
_________________
Man gewöhnt sich an allem, sogar am Dativ.
Back to top
View user's profile Send private message
Beforegod
Bodhisattva
Bodhisattva


Joined: 10 Apr 2002
Posts: 1493
Location: Frankfurt/Main

PostPosted: Fri Jan 07, 2011 8:10 pm    Post subject: Reply with quote

rfkill block all
rfkill list
rfkill unblock all
Back to top
View user's profile Send private message
Josef.95
Advocate
Advocate


Joined: 03 Sep 2007
Posts: 3672
Location: Germany

PostPosted: Fri Jan 07, 2011 9:19 pm    Post subject: Reply with quote

Hmm, ich würde auch die /etc/conf.d/net zunächst auf folgendes anpassen
Code:
modules=( "wpa_supplicant" )
wpa_supplicant_wlan0="-Dwext"
wpa_timeout_wlan0=15

Für weiteres schaue auch noch mal im Wiki
http://en.gentoo-wiki.com/wiki/Wireless_Networking

Mann verzeihe mir wenn ich daneben liege, ich habe schon ewig kein WLAN mehr eingerichtet...
Back to top
View user's profile Send private message
72_6f_6c_61_6e_64
Guru
Guru


Joined: 16 Nov 2009
Posts: 438
Location: 39° 6′ 18″ N, 76° 44′ 29″ W

PostPosted: Sun Jan 09, 2011 4:00 pm    Post subject: Reply with quote

Danke, ich hab das eingetragen, und die wpa_supplicant.conf erstellt, und jetzt funktioniert die Karte
_________________
Man gewöhnt sich an allem, sogar am Dativ.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum