Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
tar command failed at least partially...
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian)
View previous topic :: View next topic  
Author Message
Spinmc
n00b
n00b


Joined: 06 Sep 2010
Posts: 39
Location: Ruvo di Puglia (BA) Italy

PostPosted: Tue Jan 04, 2011 9:32 am    Post subject: tar command failed at least partially... Reply with quote

Ciao a tutti e Buon Anno!
Da ieri ogni volta che installo un pacchetto relativo a KDE alla fine leggo il messaggio:

Quote:
Tar command failed at least partially - continuing anyway


ma poi tutto sembra andare bene.
E questo succede per ogni pacchetto relativo a KDE.

Durante la decompressione dell'archivio sorgente leggo che tar non trova nell'archivio file relativi a CMAKE.

Ad esempio per "kshisen":

Quote:
tar: kdegames-4.4.5/ConfigureChecks.cmake: non trovato nell'archivio
tar: kdegames-4.4.5/config.h.cmake: non trovato nell'archivio
tar: kdegames-4.4.5/NEWS: non trovato nell'archivio
tar: kdegames-4.4.5/ChangeLog: non trovato nell'archivio
tar: kdegames-4.4.5/cmake/modules: non trovato nell'archivio
tar: kdegames-4.4.5/cmake/CMakeLists.txt: non trovato nell'archivio
tar: Uscita con stato di fallimento in base agli errori precedenti
* tar extract command failed at least partially - continuing anyway


Ovviamente ho già provato a ricompilare sia tar che cmake.

Succede anche a voi?
So che probabilmente si può ignorare questo messaggio (ho installato quasi tutto KDE così e sembra funzionare tutto), ma vorrei capirci qualcosa di più.
Grazie mille!
_________________
Excuse me for my English, I'm working on it! :-)

Proud Gentoo donor. Help Gentoo making a donation so do you.

My italian-language blog: http://www.paba-blog.it ;)
Back to top
View user's profile Send private message
cloc3
Advocate
Advocate


Joined: 13 Jan 2004
Posts: 4670
Location: http://www.gentoo-users.org/user/cloc3/

PostPosted: Tue Jan 04, 2011 9:44 am    Post subject: Reply with quote

confermo.tar: kdebase-workspace-4.5.4/config.h.cmake: non trovato nell'archivio
tar: kdebase-workspace-4.5.4/config.h.cmake: non trovato nell'archivio

accade anche a me.
non me ne ero accorto solo perché compilo kde in batch e, normalmente, non guardo i log (soprattutto le parti iniziali dei log compilati con successo).

ad occhio non mi pare che ci sia molto da preoccuparsi.
probabilmente chi ha confezionato il pacchetto, ha fatto qualche hack sul tarball originare per allegerirlo di qualche byte.
in ogni caso, i sorgenti gentoo sono da un controllo sha1sum prima di essere scompattati.

puoi sempre fare una segnalazione su bugzilla per saperne di più.
o fare una ricerca. forse non sei l'unico ad avere visto il problema.
ecco un esempio datato dello stesso problema.
_________________
vu vu vu
gentù
mi piaci tu
Back to top
View user's profile Send private message
Spinmc
n00b
n00b


Joined: 06 Sep 2010
Posts: 39
Location: Ruvo di Puglia (BA) Italy

PostPosted: Tue Jan 04, 2011 10:47 am    Post subject: Reply with quote

Grazie di aver confermato.
Ho appena riportato il bug.
A quanto mi è sembrato di capire c'è stata una modifica nel kde4-meta.eclass (ultima modifica il 30/12) in cui ciò che mi dà a pensare sono le righe:

Code:
      for f in cmake/ CMakeLists.txt ConfigureChecks.cmake config.h.cmake \
         AUTHORS COPYING INSTALL README NEWS ChangeLog
                        do
         extractlist+=" ${topdir}${moduleprefix}${f}"
              done


(non a caso alcuni dei file non trovati sono elencati in f) e

Code:

tar -xpf "${tarfile}" ${KMTARPARAMS} ${extractlist} || ewarn "tar extract command failed at least partially - continuing anyway"


In altre parole mi sembra che l'eclass sia stato modificato per un tipo diverso di archivi sorgente, forse in preparazione di qualche avanzamento di versione? Può essere?
_________________
Excuse me for my English, I'm working on it! :-)

Proud Gentoo donor. Help Gentoo making a donation so do you.

My italian-language blog: http://www.paba-blog.it ;)
Back to top
View user's profile Send private message
ago
Developer
Developer


Joined: 01 Mar 2008
Posts: 1520
Location: Cosenza, Italy

PostPosted: Tue Jan 04, 2011 11:06 am    Post subject: Reply with quote

Spinmc wrote:
Grazie di aver confermato.
Ho appena riportato il bug


L'ho immediatamente assegnato a kde...sono stati effettuati 3 bump ma sembra che l'errore che stiamo cercando dovrebbe essere proprio questo
_________________
Contattami se vuoi contribuire in:
-Arch tester
-Chromium tester
-Traduzione doc. it
-Security
Back to top
View user's profile Send private message
Spinmc
n00b
n00b


Joined: 06 Sep 2010
Posts: 39
Location: Ruvo di Puglia (BA) Italy

PostPosted: Tue Jan 04, 2011 11:15 am    Post subject: Reply with quote

Grazie!
Si, in effetti leggo dal diff che i file non trovati li cercava anche prima, quindi ciò che è cambiato è solo e soltanto l'ewarn.

Edit.

Già oggi pomeriggio il bug è stato marcato come "resolved invalid". Quindi mi sa che ce lo teniamo così e basta... :(
_________________
Excuse me for my English, I'm working on it! :-)

Proud Gentoo donor. Help Gentoo making a donation so do you.

My italian-language blog: http://www.paba-blog.it ;)
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum