Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[locale kde] Impossible de mettre KDE en français ! (résolu)
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index French
View previous topic :: View next topic  
Author Message
22decembre
Guru
Guru


Joined: 08 May 2010
Posts: 308
Location: Paris, banlieue sud (Massy et alentours)

PostPosted: Mon Dec 13, 2010 3:16 pm    Post subject: [locale kde] Impossible de mettre KDE en français ! (résolu) Reply with quote

Recemment, j'ai mis à jour kde à 4.5.4, puis dans la foulée à 4.6. Or, dès 4.5.4, j'ai perdu la locale française !

Quand je vais voir dans Localisation, de Configuration du système, j'ai bien un drapeau français, le symbole €... Seulement je ne peut mettre aucun accent dans aucune appli kde !

Bien sûr, j'ai les locale système :

Code:

16:14 stephane@luciole ~ $ locale -a
C
POSIX
en_US
en_US.iso88591
en_US.utf8
fr_FR
fr_FR.iso88591
fr_FR.iso885915@euro
fr_FR.utf8
fr_FR@euro
français
french


Mais dans kde, quedalle, pourtant kde-l10n est bien installé ! (d'ailleurs, j'ai le €, les feuilles A4...).
Une idée ?
_________________
Portable Gentoo installé depuis ~fevrier 2010, kde4 ( doc : http://www.22decembre.eu/gentoo-portable/)
Serveur Maison Gentoo depuis ~avril 2010 (doc : http://www.22decembre.eu/gentoo-serveur/)
http://www.22decembre.eu


Last edited by 22decembre on Wed Dec 29, 2010 11:51 am; edited 1 time in total
Back to top
View user's profile Send private message
d2_racing
Bodhisattva
Bodhisattva


Joined: 25 Apr 2005
Posts: 13047
Location: Ste-Foy,Canada

PostPosted: Mon Dec 13, 2010 5:49 pm    Post subject: Reply with quote

Salut, pourrais-tu poster ceci :

Code:

# emerge --info
# cat /etc/locale.gen
Back to top
View user's profile Send private message
22decembre
Guru
Guru


Joined: 08 May 2010
Posts: 308
Location: Paris, banlieue sud (Massy et alentours)

PostPosted: Mon Dec 13, 2010 6:00 pm    Post subject: Reply with quote

au dire d'un gars de l'irc de kde, c'est un probleme de clavier mal configure.

En meme temps, au demarrage de k3b, konsole me dit qu'il y a un probleme de locale...

Code:
18:58 root@luciole /home/stephane # emerge --info
Portage 2.1.9.25 (default/linux/amd64/10.0/desktop/kde, gcc-4.5.1, glibc-2.12.1-r3, 2.6.36-tuxonice-r2 x86_64)
=================================================================
System uname: Linux-2.6.36-tuxonice-r2-x86_64-Pentium-R-_Dual-Core_CPU_T4200_@_2.00GHz-with-gentoo-2.0.1
Timestamp of tree: Mon, 13 Dec 2010 13:00:22 +0000
ccache version 3.1.3 [enabled]
app-shells/bash:     4.1_p9
dev-lang/python:     2.6.6-r1, 2.7.1, 3.1.3
dev-util/cmake:      2.8.1-r2
sys-apps/baselayout: 2.0.1-r1
sys-apps/openrc:     0.6.8
sys-apps/sandbox:    2.4
sys-devel/autoconf:  2.13, 2.68
sys-devel/automake:  1.9.6-r3, 1.10.3, 1.11.1
sys-devel/binutils:  2.21
sys-devel/gcc:       4.4.5, 4.5.1-r1
sys-devel/gcc-config: 1.4.1
sys-devel/libtool:   2.4-r1
sys-devel/make:      3.82
virtual/os-headers:  2.6.36.1 (sys-kernel/linux-headers)
ACCEPT_KEYWORDS="amd64 ~amd64 ~amd64-linux"
ACCEPT_LICENSE="* -@EULA LOKI-EULA PUEL dlj-1.1 makemkv-EULA"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-O3 -pipe -march=native -fomit-frame-pointer"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /lib64/dhcpcd/ /usr/kde/share/config/kdm /usr/share/config"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/skel /etc/splash /etc/terminfo"
CXXFLAGS="-O3 -pipe -march=native -fomit-frame-pointer"
DISTDIR="/mnt/distfiles"
EMERGE_DEFAULT_OPTS="--jobs=5 --load-average=5.0"
FEATURES="assume-digests binpkg-logs ccache distlocks fixlafiles fixpackages news parallel-fetch protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch"
GENTOO_MIRRORS="ftp://ftp.snt.ipv6.utwente.nl/pub/os/linux/gentoo/ ftp://mirrors.ipv6.linuxant.fr/distfiles.gentoo.org/ ftp://mirror.switch.ch/mirror/gentoo/"
LANG="fr_FR.UTF-8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
LINGUAS="fr"
MAKEOPTS="-s -j3 -l5"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/tmp"
PORTDIR="/mnt/portage"
PORTDIR_OVERLAY="/var/lib/layman/x11 /var/lib/layman/sunrise /var/lib/layman/kde /var/lib/layman/multimedia"
SYNC="rsync://trumpetti.ip6.atm.tut.fi/gentoo-portage/"
USE="X a52 aac aalib acer acpi akonadi alsa amd64 amr avahi bash-completion battery berkdb bluetooth branding bzip2 cairo cdda cddb cdr cli consolekit cpudetection cracklib crypt cups cxx dbus device-mapper dga dri dts dvd dvdr emboss enca encode exif fam ffmpeg fftw firefox flac fortran gdbm gif gpm hal iconv innodb inotify ipv6 jpeg kde kontact lame laptop lcms libnotify live lm_sensors lvm2 lzo mad matroska mikmod mjpeg mmx mng modules mp3 mp4 mpeg msn mtp mudflap multilib musepack musicbrainz mysql ncurses network nfsv3 nis nls nptl nptlonly nsplugin ogg opengl openmp pam pango pcre pdf perl png policykit ppds pppd python qt3support qt4 quicktime readline reports rss sdl semantic-desktop session sip slp speex spell sse sse2 ssl startup-notification svg sysfs tcpd theora tiff truetype udev unicode usb v4l v4l2 vorbis webkit wicd wifi x264 xcb xine xml xorg xulrunner xv xvid xvmc zeroconf zlib zsh-completion" ALSA_CARDS="hda-intel" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="evdev synaptics keyboard mouse void" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="fr" PHP_TARGETS="php5-2" RUBY_TARGETS="ruby18" SANE_BACKENDS="net epson epson2" USERLAND="GNU" VIDEO_CARDS="fbdev vesa nvidia" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, FFLAGS, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS

18:58 root@luciole /home/stephane # cat /etc/locale.gen
# /etc/locale.gen: list all of the locales you want to have on your system
#
# The format of each line:
# <locale> <charmap>
#
# Where <locale> is a locale located in /usr/share/i18n/locales/ and
# where <charmap> is a charmap located in /usr/share/i18n/charmaps/.
#
# All blank lines and lines starting with # are ignored.
#
# For the default list of supported combinations, see the file:
# /usr/share/i18n/SUPPORTED
#
# Whenever glibc is emerged, the locales listed here will be automatically
# rebuilt for you.  After updating this file, you can simply run `locale-gen`
# yourself instead of re-emerging glibc.

en_US ISO-8859-1
en_US.UTF-8 UTF-8
#ja_JP.EUC-JP EUC-JP
#ja_JP.UTF-8 UTF-8
#ja_JP EUC-JP
#en_HK ISO-8859-1
#en_PH ISO-8859-1
#de_DE ISO-8859-1
#de_DE@euro ISO-8859-15
#es_MX ISO-8859-1
fr_FR UTF-8
fr_FR ISO-8859-1
fr_FR@euro ISO-8859-15
#it_IT ISO-8859-1
18:58 root@luciole /home/stephane #

_________________
Portable Gentoo installé depuis ~fevrier 2010, kde4 ( doc : http://www.22decembre.eu/gentoo-portable/)
Serveur Maison Gentoo depuis ~avril 2010 (doc : http://www.22decembre.eu/gentoo-serveur/)
http://www.22decembre.eu
Back to top
View user's profile Send private message
d2_racing
Bodhisattva
Bodhisattva


Joined: 25 Apr 2005
Posts: 13047
Location: Ste-Foy,Canada

PostPosted: Mon Dec 13, 2010 6:53 pm    Post subject: Reply with quote

Tu pourrais essayer ceci :

Code:

# nano /etc/locale.gen


Met en commentaire :

en_US ISO-8859-1
en_US.UTF-8 UTF-8

Ensuite lance ceci :

Code:

# locale.gen


Ensuite, efface ton fichier .kde4 dans ton home et recompile le package de localisation de KDE4, au redémarrage de ta gentoo, ton KDE devrait être exclusivement en francais.
Back to top
View user's profile Send private message
22decembre
Guru
Guru


Joined: 08 May 2010
Posts: 308
Location: Paris, banlieue sud (Massy et alentours)

PostPosted: Wed Dec 22, 2010 10:11 am    Post subject: Reply with quote

Ça n'a pas fait grand chose ! (non, ça n'a rien fait du tout, mais je suis, bizarrement, trop poli pour le dire tout de brut).

De plus, il n' y a pas que ma session de touché. L'autre utilisateur de l'ordinateur n'a plus de kde en français pur non plus !
Autre truc soulant : les noms de fichiers accentués dans dolphin sont en Bordel et Amarok peut plus les lire. Tout est lié, mais je ne sais pas comment résoudre ça !
_________________
Portable Gentoo installé depuis ~fevrier 2010, kde4 ( doc : http://www.22decembre.eu/gentoo-portable/)
Serveur Maison Gentoo depuis ~avril 2010 (doc : http://www.22decembre.eu/gentoo-serveur/)
http://www.22decembre.eu
Back to top
View user's profile Send private message
_droop_
l33t
l33t


Joined: 30 May 2004
Posts: 957

PostPosted: Wed Dec 22, 2010 12:20 pm    Post subject: Reply with quote

Salut,

Ca donne quoi locale ?

Normalement, tu devrais avoir quelque chose du genre :
Code:
LANG=fr_FR
LC_CTYPE="fr_FR"
LC_NUMERIC="fr_FR"
LC_TIME="fr_FR"
LC_COLLATE="fr_FR"
LC_ALL=


Bon courage.
Back to top
View user's profile Send private message
22decembre
Guru
Guru


Joined: 08 May 2010
Posts: 308
Location: Paris, banlieue sud (Massy et alentours)

PostPosted: Wed Dec 22, 2010 1:02 pm    Post subject: Reply with quote

Code:
14:00 stephane@luciole ~ $ locale
LANG=fr_FR.UTF-8
LC_CTYPE="fr_FR.UTF-8"
LC_NUMERIC="fr_FR.UTF-8"
LC_TIME="fr_FR.UTF-8"
LC_COLLATE=C
LC_MONETARY="fr_FR.UTF-8"
LC_MESSAGES="fr_FR.UTF-8"
LC_PAPER="fr_FR.UTF-8"
LC_NAME="fr_FR.UTF-8"
LC_ADDRESS="fr_FR.UTF-8"
LC_TELEPHONE="fr_FR.UTF-8"
LC_MEASUREMENT="fr_FR.UTF-8"
LC_IDENTIFICATION="fr_FR.UTF-8"
LC_ALL=


oups... merci quand même pour ceux qui m'aident !
_________________
Portable Gentoo installé depuis ~fevrier 2010, kde4 ( doc : http://www.22decembre.eu/gentoo-portable/)
Serveur Maison Gentoo depuis ~avril 2010 (doc : http://www.22decembre.eu/gentoo-serveur/)
http://www.22decembre.eu
Back to top
View user's profile Send private message
boozo
Advocate
Advocate


Joined: 01 Jul 2004
Posts: 3193

PostPosted: Wed Dec 22, 2010 1:11 pm    Post subject: Reply with quote

'alute

d'après ton emerge --info il semble que ta variable LINGUAS soit incomplète il manque le "fr_FR" => LINGUAS="fr fr_FR" et relancer un rebuild de kde-l10n

Par ailleurs, tes codepages sont-ils complêts et si oui les noms des fichiers sont-ils correctement orthographiés en console ou juste défaillant sous X ?
_________________
" Un psychotique, c'est quelqu'un qui croit dur comme fer que 2 et 2 font 5, et qui en est pleinement satisfait.
Un névrosé, c'est quelqu'un qui sait pertinemment que 2 et 2 font 4, et ça le rend malade ! "
Back to top
View user's profile Send private message
22decembre
Guru
Guru


Joined: 08 May 2010
Posts: 308
Location: Paris, banlieue sud (Massy et alentours)

PostPosted: Wed Dec 22, 2010 4:06 pm    Post subject: Reply with quote

Je ne sais pas ce qu'est le codepage, même s'il est probable qu'une fois expliqué, je dirais "ah oui !".

Mais en console (Ctl + Alt +F1...), les caractères accentués n’apparaissent pas et sont remplacés par # $ ... Est-ce un problème de clavier sous la console ?
Merci.
_________________
Portable Gentoo installé depuis ~fevrier 2010, kde4 ( doc : http://www.22decembre.eu/gentoo-portable/)
Serveur Maison Gentoo depuis ~avril 2010 (doc : http://www.22decembre.eu/gentoo-serveur/)
http://www.22decembre.eu
Back to top
View user's profile Send private message
boozo
Advocate
Advocate


Joined: 01 Jul 2004
Posts: 3193

PostPosted: Wed Dec 22, 2010 10:40 pm    Post subject: Reply with quote

Quote:
Configuration du noyau.
Lorsque vous configurez votre noyau (branche 2.4 et 2.6), dans le menu File systems -> Native Language Support , pour obtenir les caractères européens dans les partitions windows (FAT32/NTFS) ou certains Cdrom mettez la valeur iso8859-15 dans la rubrique Default NLS Option, puis mettez en modules les choix suivants :
Code:
<M> Codepage 437 (United States, Canada)
<M> Codepage 850 (Europe)
<M> NLS ISO 8859-1 (Latin 1; Western European Languages)
<M> NLS ISO 8859-15 (Latin 9; Western European Languages with Euro)
<M> NLS UTF8

De plus dans DOS/FAT/NT Filesystems vous pouvez définir les le codepage par défaut (850) et le iocharset (iso8859-15)


Donc tu as aussi un pb de charset sous tty. Pour corriger çà c'est dans /etc/conf.d/consolefont normalement avec i.e.
Code:
CONSOLETRANSLATION="8859-15_to_uni"
CONSOLEFONT="lat9w-16"


Est-ce que modifier la valiable du make.conf et recompiler le support fr de kde à changé qqch ?
_________________
" Un psychotique, c'est quelqu'un qui croit dur comme fer que 2 et 2 font 5, et qui en est pleinement satisfait.
Un névrosé, c'est quelqu'un qui sait pertinemment que 2 et 2 font 4, et ça le rend malade ! "
Back to top
View user's profile Send private message
22decembre
Guru
Guru


Joined: 08 May 2010
Posts: 308
Location: Paris, banlieue sud (Massy et alentours)

PostPosted: Fri Dec 24, 2010 10:09 am    Post subject: Reply with quote

Alors, déjà pour l'instant je peux pas emerger, donc kde => out (mes ebuild et distfiles sont sur nfs sur mon serveur home, or je ne suis pas chez moi, mais chez mes parents pour Noël).

Mais en revanche, j'ai bien recompilé le noyau et les modules suivant les indications de boozo et certaines applis dans kde connaissent maintenant les accents et les cédilles dans les noms de fichiers. J'ai aussi les accents dans certains menus et certaines parties de l'aide de kde.

Par contre, c'est pas encore ça en console (dans Konsole et dans un terminal système).
_________________
Portable Gentoo installé depuis ~fevrier 2010, kde4 ( doc : http://www.22decembre.eu/gentoo-portable/)
Serveur Maison Gentoo depuis ~avril 2010 (doc : http://www.22decembre.eu/gentoo-serveur/)
http://www.22decembre.eu
Back to top
View user's profile Send private message
22decembre
Guru
Guru


Joined: 08 May 2010
Posts: 308
Location: Paris, banlieue sud (Massy et alentours)

PostPosted: Mon Dec 27, 2010 5:43 pm    Post subject: Reply with quote

bon, kde accepte toujours pas les "é" !
j'ai mis fr_FR dans Linguas => rien de neuf (au passage, j'ai mis aussi en et dk puisque je vais faire un petit tour chez les Danois bientôt, et que je veux au moins pouvoir afficher correctement les docs et sites web qu'on m'indique - à défaut de les comprendre).
J'ai mis France dans Localisation de KDE.

Résultats : certains trucs de KDE affichent les accents, d'autres, pas ! Et parfois dans la même appli ! Et kmail refuse que j'écrive avec des accents, ce qui est un peu problématique !
_________________
Portable Gentoo installé depuis ~fevrier 2010, kde4 ( doc : http://www.22decembre.eu/gentoo-portable/)
Serveur Maison Gentoo depuis ~avril 2010 (doc : http://www.22decembre.eu/gentoo-serveur/)
http://www.22decembre.eu
Back to top
View user's profile Send private message
22decembre
Guru
Guru


Joined: 08 May 2010
Posts: 308
Location: Paris, banlieue sud (Massy et alentours)

PostPosted: Tue Dec 28, 2010 7:06 pm    Post subject: Reply with quote

J'avance ! Je peux écrire des courriels en français et Dolphin reconnait les caractères accentués partout ! De même de OpenOffice et Konsole.

En fait, j'ai repris toutes les locales qui m’intéressaient depuis /usr/share/i18n/SUPPORTED , hop, copié-collé dans /etc/locale.gen et recompilation de glibc.

Code:
20:06 stephane@luciole ~ $ locale -a
C
POSIX
da_DK
da_DK.iso88591
da_DK.utf8
danish
dansk
en_DK
en_DK.iso88591
en_DK.utf8
en_GB
en_GB.iso88591
en_GB.utf8
en_US
en_US.iso88591
en_US.utf8
fr_FR
fr_FR.iso88591
fr_FR.iso885915@euro
fr_FR.utf8
fr_FR@euro
français
french
20:06 stephane@luciole ~ $ locale
LANG=fr_FR.UTF-8
LC_CTYPE="fr_FR.UTF-8"
LC_NUMERIC="fr_FR.UTF-8"
LC_TIME="fr_FR.UTF-8"
LC_COLLATE=C
LC_MONETARY="fr_FR.UTF-8"
LC_MESSAGES="fr_FR.UTF-8"
LC_PAPER="fr_FR.UTF-8"
LC_NAME="fr_FR.UTF-8"
LC_ADDRESS="fr_FR.UTF-8"
LC_TELEPHONE="fr_FR.UTF-8"
LC_MEASUREMENT="fr_FR.UTF-8"
LC_IDENTIFICATION="fr_FR.UTF-8"
LC_ALL=
20:07 stephane@luciole ~ $


Comme ça, c'est bien propre !

Par contre, j'ai toujours un problème avec ma partition musique, qui est une fat.

Vous allez voir, c'est subtil : quand le fichier est contenu dans un dossier dont le nom ne comporte pas d'accents, amarok y accède ! Que le fichier ait un accent ou pas !
Par contre, quand le dossier a un accent, il est illisible (l'accent n'est pas lisible), et le fichier contenu dans le dossier est inaccessible.

Autrement dit (sans faire de pub) :

/media/musique/Tryo/Mamagubida/Yakamonéyé.mp3 => ok
/media/musique/Tryo/De bouche à oreille/G8.mp3 => niet

Pour moi, c'est parce que Amarok se réfère à une base de données pour les fichiers, donc les noms des fichiers => bof, par contre, l’accès à travers les répertoires => vital !

Et dans le terminal système, par contre, je vois toujours des caractères louches (même problème qu'avec la fat je pense).
_________________
Portable Gentoo installé depuis ~fevrier 2010, kde4 ( doc : http://www.22decembre.eu/gentoo-portable/)
Serveur Maison Gentoo depuis ~avril 2010 (doc : http://www.22decembre.eu/gentoo-serveur/)
http://www.22decembre.eu
Back to top
View user's profile Send private message
xaviermiller
Administrator
Administrator


Joined: 23 Jul 2004
Posts: 8076
Location: ~Brussels - Belgique

PostPosted: Tue Dec 28, 2010 7:43 pm    Post subject: Reply with quote

Fallait pas recompiler glibc pour regénérer les locales ;)
un petit
Code:
locale-gen
suffisait
_________________
Kind regards,
Xavier Miller
Back to top
View user's profile Send private message
22decembre
Guru
Guru


Joined: 08 May 2010
Posts: 308
Location: Paris, banlieue sud (Massy et alentours)

PostPosted: Tue Dec 28, 2010 10:37 pm    Post subject: Reply with quote

bah tant pis ! ça a marché ! le reste...
_________________
Portable Gentoo installé depuis ~fevrier 2010, kde4 ( doc : http://www.22decembre.eu/gentoo-portable/)
Serveur Maison Gentoo depuis ~avril 2010 (doc : http://www.22decembre.eu/gentoo-serveur/)
http://www.22decembre.eu
Back to top
View user's profile Send private message
22decembre
Guru
Guru


Joined: 08 May 2010
Posts: 308
Location: Paris, banlieue sud (Massy et alentours)

PostPosted: Wed Dec 29, 2010 11:50 am    Post subject: Reply with quote

et maintenant, ça y est, j'ai résolu mes problèmes (suffit de monter la fat sans options particulières => on a les accents - surement le noyau correctement compilé grace aux instruction de Boozo - puis on rescan la fat pour réindexer la musique d'amarok)
_________________
Portable Gentoo installé depuis ~fevrier 2010, kde4 ( doc : http://www.22decembre.eu/gentoo-portable/)
Serveur Maison Gentoo depuis ~avril 2010 (doc : http://www.22decembre.eu/gentoo-serveur/)
http://www.22decembre.eu
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index French All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum