Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[Nvidia Xorg] Optimisation Affichage (Résolu)
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index French
View previous topic :: View next topic  
Author Message
jaypeche
Apprentice
Apprentice


Joined: 13 Jun 2007
Posts: 161
Location: France

PostPosted: Mon Dec 06, 2010 11:21 am    Post subject: [Nvidia Xorg] Optimisation Affichage (Résolu) Reply with quote

Hello world,

Bonjour à tous,

Je cherche à optimiser mon xorg.conf car je trouve que Compiz rame pa mal !

Mon PC est un Celeron D @3.2Ghz Em64t en 32 bits avec 1.5 Go RAM et une carte Nvidia 6200 256Mo sur AGP 8x.

Pour avoir déja installer compiz fusion sur ce PC, je trouve que les effets visuels de Compiz sont très lent par rapport à la meme configuration sous Ubuntu par exemple.

Je pense que mon Xorg peut peut-etre être optimisé. (oulala)

Un glxgears --info en plein ecran me renvoie ceçi :

Code:
Running synchronized to the vertical refresh.  The framerate should be
approximately the same as the monitor refresh rate.
GL_RENDERER   = GeForce 6200/AGP/SSE2
GL_VERSION    = 2.1.2 NVIDIA 195.36.31
GL_VENDOR     = NVIDIA Corporation
GL_EXTENSIONS = GL_ARB_color_buffer_float GL_ARB_copy_buffer GL_ARB_depth_clamp GL_ARB_depth_texture GL_ARB_draw_buffers GL_ARB_fragment_program GL_ARB_fragment_program_shadow GL_ARB_fragment_shader GL_ARB_framebuffer_object GL_ARB_half_float_pixel GL_ARB_half_float_vertex GL_ARB_imaging GL_ARB_map_buffer_range GL_ARB_multisample GL_ARB_multitexture GL_ARB_occlusion_query GL_ARB_pixel_buffer_object GL_ARB_point_parameters GL_ARB_point_sprite GL_ARB_provoking_vertex GL_ARB_shader_objects GL_ARB_shading_language_100 GL_ARB_shadow GL_ARB_texture_border_clamp GL_ARB_texture_compression GL_ARB_texture_cube_map GL_ARB_texture_env_add GL_ARB_texture_env_combine GL_ARB_texture_env_crossbar GL_ARB_texture_env_dot3 GL_ARB_texture_float GL_ARB_texture_mirrored_repeat GL_ARB_texture_non_power_of_two GL_ARB_texture_rectangle GL_ARB_transpose_matrix GL_ARB_vertex_array_bgra GL_ARB_vertex_array_object GL_ARB_vertex_buffer_object GL_ARB_vertex_program GL_ARB_vertex_shader GL_ARB_window_pos GL_ATI_draw_buffers GL_ATI_texture_float GL_ATI_texture_mirror_once GL_S3_s3tc GL_EXT_texture_env_add GL_EXT_abgr GL_EXT_bgra GL_EXT_blend_color GL_EXT_blend_equation_separate GL_EXT_blend_func_separate GL_EXT_blend_minmax GL_EXT_blend_subtract GL_EXT_compiled_vertex_array GL_EXT_Cg_shader GL_EXT_depth_bounds_test GL_EXT_direct_state_access GL_EXT_draw_range_elements GL_EXT_fog_coord GL_EXT_framebuffer_blit GL_EXT_framebuffer_multisample GL_EXT_framebuffer_object GL_EXT_gpu_program_parameters GL_EXT_multi_draw_arrays GL_EXT_packed_depth_stencil GL_EXT_packed_pixels GL_EXT_pixel_buffer_object GL_EXT_point_parameters GL_EXT_provoking_vertex GL_EXT_rescale_normal GL_EXT_secondary_color GL_EXT_separate_shader_objects GL_EXT_separate_specular_color GL_EXT_shadow_funcs GL_EXT_stencil_two_side GL_EXT_stencil_wrap GL_EXT_texture3D GL_EXT_texture_compression_s3tc GL_EXT_texture_cube_map GL_EXT_texture_edge_clamp GL_EXT_texture_env_combine GL_EXT_texture_env_dot3 GL_EXT_texture_filter_anisotropic GL_EXT_texture_lod GL_EXT_texture_lod_bias GL_EXT_texture_mirror_clamp GL_EXT_texture_object GL_EXT_texture_sRGB GL_EXT_texture_swizzle GL_EXT_timer_query GL_EXT_vertex_array GL_EXT_vertex_array_bgra GL_IBM_rasterpos_clip GL_IBM_texture_mirrored_repeat GL_KTX_buffer_region GL_NV_blend_square GL_NV_copy_depth_to_color GL_NV_depth_clamp GL_NV_fence GL_NV_float_buffer GL_NV_fog_distance GL_NV_fragment_program GL_NV_fragment_program_option GL_NV_fragment_program2 GL_NV_framebuffer_multisample_coverage GL_NV_half_float GL_NV_light_max_exponent GL_NV_multisample_filter_hint GL_NV_occlusion_query GL_NV_packed_depth_stencil GL_NV_pixel_data_range GL_NV_point_sprite GL_NV_primitive_restart GL_NV_register_combiners GL_NV_register_combiners2 GL_NV_texgen_reflection GL_NV_texture_barrier GL_NV_texture_compression_vtc GL_NV_texture_env_combine4 GL_NV_texture_expand_normal GL_NV_texture_rectangle GL_NV_texture_shader GL_NV_texture_shader2 GL_NV_texture_shader3 GL_NV_vertex_array_range GL_NV_vertex_array_range2 GL_NV_vertex_program GL_NV_vertex_program1_1 GL_NV_vertex_program2 GL_NV_vertex_program2_option GL_NV_vertex_program3 GL_NVX_conditional_render GL_SGIS_generate_mipmap GL_SGIS_texture_lod GL_SGIX_depth_texture GL_SGIX_shadow GL_SUN_slice_accum
342 frames in 5.0 seconds = 68.300 FPS
343 frames in 5.0 seconds = 68.383 FPS
343 frames in 5.0 seconds = 68.548 FPS
341 frames in 5.0 seconds = 68.179 FPS


Quant à mon Xorg.conf :

Code:
Section "ServerLayout"
   Identifier     "X.org Configured"
   Screen      0  "Screen0" 0 0
   InputDevice    "Mouse0" "CorePointer"
   InputDevice    "Keyboard0" "CoreKeyboard"
EndSection

Section "Files"
   ModulePath   "/usr/lib/xorg/modules"
   FontPath     "/usr/share/fonts/misc/"
   FontPath     "/usr/share/fonts/TTF/"
   FontPath     "/usr/share/fonts/OTF"
   FontPath     "/usr/share/fonts/Type1/"
   FontPath     "/usr/share/fonts/100dpi/"
   FontPath     "/usr/share/fonts/75dpi/"
EndSection

Section "Module"
   Load  "record"
   Load  "dri2"
#   Load  "dri"
   Load  "glx"
   Load  "dbe"
   Load  "extmod"
EndSection

Section "InputDevice"
   Identifier  "Keyboard0"
   Driver      "kbd"
EndSection

Section "InputDevice"
   Identifier  "Mouse0"
   Driver      "mouse"
   Option       "Protocol" "auto"
   Option       "Device" "/dev/input/mice"
   Option       "ZAxisMapping" "4 5 6 7"
EndSection

Section "Monitor"
   Identifier   "Monitor0"
   VendorName   "Monitor Vendor"
   ModelName    "Monitor Model"
EndSection

Section "Device"
   Identifier  "Card0"
   Driver      "nvidia"
   VendorName  "nVidia Corporation"
   BoardName   "NV44A [GeForce 6200]"
   BusID       "PCI:1:0:0"
#   Option          "AddARGBGLXVisuals"     "True"
EndSection

Section "Screen"
   Identifier "Screen0"
   Device     "Card0"
   Monitor    "Monitor0"
   SubSection "Display"
      Viewport   0 0
      Depth     1
   EndSubSection
   SubSection "Display"
      Viewport   0 0
      Depth     4
   EndSubSection
   SubSection "Display"
      Viewport   0 0
      Depth     8
   EndSubSection
   SubSection "Display"
      Viewport   0 0
      Depth     15
   EndSubSection
   SubSection "Display"
      Viewport   0 0
      Depth     16
   EndSubSection
   SubSection "Display"
      Viewport   0 0
      Depth     24
   EndSubSection
EndSection


Ma question est donc de savoir si à votre avis ma configuration est bien optimisée ? Merçi pour vos réponses.

Screenshot

Jay
_________________
:-) Gentoo Linux Rullez !


Last edited by jaypeche on Mon Dec 06, 2010 12:18 pm; edited 1 time in total
Back to top
View user's profile Send private message
jaypeche
Apprentice
Apprentice


Joined: 13 Jun 2007
Posts: 161
Location: France

PostPosted: Mon Dec 06, 2010 12:17 pm    Post subject: Reply with quote

Après quelques recherches dans le forum, j'ai finallement trouvé la source de mon problème !

J'utilise compiz-icon pour lancer compiz fusion au démarrage. J'avais coché les options "Loose binding" && "Indirect Rendering".

Loose Binding et Indirect Rendering sont à décocher pour optenir les meilleures performances.

Un petit résolu et on en parle plus :P
_________________
:-) Gentoo Linux Rullez !
Back to top
View user's profile Send private message
El_Goretto
Moderator
Moderator


Joined: 29 May 2004
Posts: 3087
Location: Paris

PostPosted: Mon Dec 06, 2010 12:52 pm    Post subject: Reply with quote

Dans les suggestions, tu pourrais tester le driver "nouveau" pour voir ce qu'il donne chez toi.
_________________
-Gentoo hardened [EoL]: µ-serv Gen8 G1610T, 8Go ECC ; NF9D-2700, 4Go
-FreeBSD 11/Vimage/Jails: DS61, i3 2100T, 16Go ; FreeNAS: µ-serv N40L, 8Go ECC
-Réseau: ERL-3 + ESL-24 + GS108Tv2
-NAS: RN312
Back to top
View user's profile Send private message
jaypeche
Apprentice
Apprentice


Joined: 13 Jun 2007
Posts: 161
Location: France

PostPosted: Mon Dec 06, 2010 1:08 pm    Post subject: Reply with quote

Salut El'goretto,

Je ne pense pas que compiler la version nvidia-drivers 260.19.26 ai pour moi beaucoup d'intérêt car les améliorations sont vraiment moindre du fait que je suis en AGP 8x, pas de HD et tout le toutim.. Je préfère rester avec cette version marquée en stable.

Sinon je profite de l'occasion pour te demander où tu en es avec VDR et XBMC, as tu avancé ?

Si tu as besoin de précisions pas de souçis, perso je rencontre quelques problemes avec vdr en version 1.7.16. Indispensable avec vdr-vnsi pour récuperer le flux dans XBMC.

@+

jay
_________________
:-) Gentoo Linux Rullez !
Back to top
View user's profile Send private message
El_Goretto
Moderator
Moderator


Joined: 29 May 2004
Posts: 3087
Location: Paris

PostPosted: Mon Dec 06, 2010 2:03 pm    Post subject: Reply with quote

"nouveau" est le nom du driver opensource pour cartes nvidia, cf le thread qui lui est consacré ici.
Quand à XBMC, j'ai lâché vdr (1.7.15+streamdev) et la branche pvr2 pour tvheadend et une branche dharma+backports de patchs (+ via PM ou un autre thread si besoin).
_________________
-Gentoo hardened [EoL]: µ-serv Gen8 G1610T, 8Go ECC ; NF9D-2700, 4Go
-FreeBSD 11/Vimage/Jails: DS61, i3 2100T, 16Go ; FreeNAS: µ-serv N40L, 8Go ECC
-Réseau: ERL-3 + ESL-24 + GS108Tv2
-NAS: RN312
Back to top
View user's profile Send private message
Fenril
Apprentice
Apprentice


Joined: 16 May 2009
Posts: 209

PostPosted: Mon Dec 06, 2010 3:20 pm    Post subject: Reply with quote

Hello,

Pour ceux qui malgré tout souhaitent rester avec les drivers proprios, voici mon xorg.conf (section device et screen) que j'utilisais lorsque j'étais encore avec les drivers proprios et qui m'apportait des gains non négligeables en 2D :

Code:
Section "Device"
    Identifier     "nVidia 7600 GT w/ 512 Mo AGP 8x"
    Driver         "nvidia"
    Option         "NoLogo"      "true"
    Option         "Coolbits"      "1"
    Option         "PixmapCacheSize"   "1600000"
    Option         "AllowSHMPixmaps"   "0"
    Option         "BackingStore"   "true"
    Option         "TripleBuffer"       "true"
    Option         "RenderAccel"        "true"
EndSection

Section "Screen"
    Identifier     "Screen 1"
    Device         "nVidia 7600 GT"
    Monitor        "IQT995"
    DefaultDepth   24
    Option         "AddARGBGLXVisuals"  "true"
    SubSection     "Display"
        Viewport    0 0
        Depth       8
        Modes      "1280x1024" "1280x960" "1024x768" "800x600" "640x480"
    EndSubSection
    SubSection     "Display"
        Viewport    0 0
        Depth       16
        Modes      "1280x1024" "1280x960" "1024x768" "800x600" "640x480"
    EndSubSection
    SubSection     "Display"
        Viewport    0 0
        Depth       24
        Modes      "1280x1024" "1280x960" "1024x768" "800x600" "640x480"
    EndSubSection
EndSection


Toutes les infos ont été obtenues là : http://www.nvnews.net/vbulletin/showthread.php?t=118088

J'ai rajouté aussi une commande à lancer au démarrage de l'environnement de bureau :
Code:
nvidia-settings -a InitialPixmapPlacement=2 -a PixmapCacheRoundSizeKB=1024


Enfin, j'ai vu que tu es en AGP, si tu disposes d'un chipset de carte-mère listé ici, il faut utiliser NvAgp qui peut apporter des gains de performances non négligeables ou régler des problèmes (j'avais un problème de flickering sur un de mes pc qui a été réglé en passant à NvAgp).

A+
Back to top
View user's profile Send private message
jaypeche
Apprentice
Apprentice


Joined: 13 Jun 2007
Posts: 161
Location: France

PostPosted: Mon Dec 06, 2010 3:31 pm    Post subject: Reply with quote

@ El'goretto : merçi pour cette news je l'ignorais ...
@ Fenril : Merçi pour ton xorg.conf, il me sera certainement très utile pour optimiser ma machine.

++
jay
_________________
:-) Gentoo Linux Rullez !
Back to top
View user's profile Send private message
Poussin
l33t
l33t


Joined: 08 Jun 2007
Posts: 659
Location: Liège

PostPosted: Mon Dec 06, 2010 9:00 pm    Post subject: Reply with quote

Je suis passé très récemment à nouveau (avec un peu de réticence) et j'ai vraiment été conquis! Rien que compiz tourne vraiment mieux (je trouve), et xrand est quand même plus sympa que nvidia-setting. Le remote desktop fonctionne meme avec compiz activé! Que dire de plus. Plus besoin de xorg.conf 8)

Ensuite, je trouve que tes polices s'affichent très mal! J'ai eu ce souci aussi (resolu en emergeant les polices deja-vu)

Mes 3 kopeks...
Back to top
View user's profile Send private message
guilc
Bodhisattva
Bodhisattva


Joined: 15 Nov 2003
Posts: 3326
Location: Paris - France

PostPosted: Mon Dec 06, 2010 9:31 pm    Post subject: Reply with quote

Pour les polices pourries, essayes d'ajouter ça dans la section de configuration du driver nvidia proprio (option spécifique au driver proprio qui permet de ne pas passer d'option au lancement à X) :
Code:
Option      "DPI"                   "98x98"

_________________
Merci de respecter les règles du forum.

Mon site perso : https://www.xwing.info
Mon PORTDIR_OVERLAY : https://gentoo.xwing.info ou layman -a xwing
Back to top
View user's profile Send private message
Poussin
l33t
l33t


Joined: 08 Jun 2007
Posts: 659
Location: Liège

PostPosted: Mon Dec 06, 2010 10:18 pm    Post subject: Reply with quote

J'avais essayé ça aussi, ça n'avait rien changé (j'avais le problème ma machine "nvidia" comme sur l'intel) Enfin passons ^^
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index French All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum