Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
problems with keyboard layout after updating world
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Other Things Gentoo
View previous topic :: View next topic  
Author Message
rocky323893
n00b
n00b


Joined: 15 Jul 2009
Posts: 7

PostPosted: Sun Sep 26, 2010 5:34 pm    Post subject: problems with keyboard layout after updating world Reply with quote

Hello,

I'm new to Gentoo. I did emerge --update --deep world, and now it seems that my German keyboard layout cannot be load any more.

In my /etc/conf.d/keymaps there is standing:

Code:
KEYMAP=de


but it has no effect. Neither to X nor to the console.

Any idea?
Back to top
View user's profile Send private message
krinn
Watchman
Watchman


Joined: 02 May 2003
Posts: 7447

PostPosted: Sun Sep 26, 2010 7:01 pm    Post subject: Reply with quote

try that
even i think it might work without them, add the ""
Code:
keymap="de"


now /etc/init.d/keymaps restart
and you will see if the keyboard is correctly load & understood
Code:
 * Loading key mappings [fr] ...                                          [ ok ]


Code:
rc-update show | grep keymaps

if you don't get an answer: rc-update add keymaps default

That's the console part


For x, it's a bit different. It highly depend on your xorg version and how you wish it to control your device.
I'll show you the udev less hal with evdev way. You have plenty docs for xorg with hal or old keyboard/mouse combo

in make.conf add/change
USE="udev -hal"
INPUT_DEVICES="evdev"

VIDEO_CARDS="yourvideodriver"
# Because it's the good time to setup that in a proper way too
# as example mine is set as VIDEO_CARDS="vesa nvidia"

then rebuild the server with that
Code:
emerge -uDN1 xorg-server
emerge -1 portage-utils && emerge -1 $(qlist -IC x11-drivers/)


now your xorg is evdev & udev ready.

Code:
mkdir /etc/X11/xorg.conf.d

and put that file in here as 97-evdev.conf, so it's pathname is: /etc/X11/xorg.conf.d/97-evdev.conf

Code:
Section "InputClass"
   Identifier "mouse-all"
        MatchIsPointer "on"
        MatchDevicePath "/dev/input/event*"
        Driver "evdev"
        Option "AutoServerLayout" "on"
EndSection

Section "InputClass"
        Identifier "keyboard-all"
        MatchIsKeyboard "on"
        MatchDevicePath "/dev/input/event*"
        Driver "evdev"
        Option "XkbLayout" "fr"
        Option "XkbRules"  "xorg"
        Option "XkbModel"  "pc105"
        Option "AutoServerLayout" "on"
EndSection


If all is fine, you should have X in the good layout
Back to top
View user's profile Send private message
rocky323893
n00b
n00b


Joined: 15 Jul 2009
Posts: 7

PostPosted: Sun Sep 26, 2010 7:39 pm    Post subject: Reply with quote

keymaps restart does not work:

Code:
* /etc/init.d/keymaps restart
* Caching service depencies...
* Loading key mappings
* /bin/loadkeys not found


What's wrong with it?
Back to top
View user's profile Send private message
krinn
Watchman
Watchman


Joined: 02 May 2003
Posts: 7447

PostPosted: Sun Sep 26, 2010 10:01 pm    Post subject: Reply with quote

Code:
equery b loadkeys
 * Searching for loadkeys ...
sys-apps/kbd-1.15.2-r1 (/usr/bin/loadkeys)


It means someone need to reinstall that package :)
Back to top
View user's profile Send private message
rocky323893
n00b
n00b


Joined: 15 Jul 2009
Posts: 7

PostPosted: Mon Sep 27, 2010 9:44 am    Post subject: Reply with quote

I re-emerged "kbd", but the keymap still can 't be load.
Back to top
View user's profile Send private message
Dr.Willy
Guru
Guru


Joined: 15 Jul 2007
Posts: 520
Location: NRW, Germany

PostPosted: Mon Sep 27, 2010 11:03 am    Post subject: Reply with quote

iirc the libXi update said something about keymaps.
Back to top
View user's profile Send private message
krinn
Watchman
Watchman


Joined: 02 May 2003
Posts: 7447

PostPosted: Mon Sep 27, 2010 11:14 am    Post subject: Reply with quote

rocky323893 wrote:
I re-emerged "kbd", but the keymap still can 't be load.


You think that's an helping comment ?

Are you expecting us to come to your home to look on your screen if the error is still the same or a newer one ?
Back to top
View user's profile Send private message
ade05fr
Apprentice
Apprentice


Joined: 18 Sep 2006
Posts: 281

PostPosted: Sun Oct 10, 2010 5:29 am    Post subject: Reply with quote

hie everyone

did you finally found the solution because since last friday i have the same problem.
The only things that i have emerged were :
- gnome-base/gnome-vfs
- sys-apps/hdparm
- sys-fs/fuse
- sys-fs/lvm2
- sys-fs/mdadm

i still dont understand.

thanks
ade05fr
_________________
[LAPTOP]
DELL Inspiron 5110
i5-2450M CPU @ 2.50GHz
[LINUX-GENTOO]
Gentoo 2018-0
kernel 5.0.6
gnome 3.30
Back to top
View user's profile Send private message
skorefish
Apprentice
Apprentice


Joined: 21 Jun 2015
Posts: 284

PostPosted: Fri Apr 01, 2016 8:49 am    Post subject: Reply with quote

Hi i see this is a rather old thread but maybe this is the solution...

edit /etc/fstab add nofail
eg

Code:

/dev/sda2      /boot   ext4   defaults,noatime,nofail 0 2


i had the same problem with the belgium azerty keyboard be-latin1 after a world update
Maybe fsck can help too

for the filesystem
Code:

init 1
umount /dev/sda4 (root drive)
fsck.ext? /dev/sda4 -pv
init 6



hope this helps :?:
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Other Things Gentoo All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum