Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Openssl in tilt (intero sistema segue a ruota :-() [risolto]
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

Goto page 1, 2  Next  
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian)
View previous topic :: View next topic  
Author Message
allxsan
n00b
n00b


Joined: 11 Aug 2010
Posts: 49

PostPosted: Wed Aug 11, 2010 10:17 pm    Post subject: Openssl in tilt (intero sistema segue a ruota :-() [risolto] Reply with quote

Ciao a tutti :D
Riassumo la situazione per sommi capi.
La mia nuova installazione Gentoo e' recentissima ( fine luglio, dopo aver "tradito" per qualche anno con sistemi piu' pratici e veloci da installare e configurare ) e, al momento, trattasi di installazione "sperimentale" ( per varie ragioni, in primo luogo l'assenza momentanea di una connessione decente, che comunque non si risolvera' fino a dopo natale :( ), in ogni caso funzionava abbastanza bene e stavo cercando solo di risolvere una serie di noiosissimi problemini... quelli che di solito, con diverse distribuzioni, ormai non creano alcun problema:
video Nvidia e ATI, Compiz apparentemente non funzionante a causa di una prima configurazione base "automatica" dopo la compilazione , networking...
Nei giorni scorsi avevo subito compilato e installato Xorg 8.2, i driver Nvidia e ATI non proprietari ( provando anche a mettere e togliere diverse ATi e Nvidia nuove e decisamente meno nuove ).. avevo gia' sperimentato e risolto il problema HAL e EVDEV per Xorg 8.2, l'installazione dei driver non proprietari, alcuni problemi con l'audio non proprio "ortodosso" presente sulle Asrock N68C-S ( anche se uso prevalentemente una Asus P5K-E-AP-WIFI e una Asus M4N78-AM), quindi ero a buon punto e avevo "sciolto i muscoli che, con Gentoo, si erano ormai atrofizzati" a causa del mio abbandono per mancanza di tempo :S

Ieri mi sono dedicato alla soluzione di problemi secondari :
1) sistemato Compiz, che finalmente era perfettamente funzionante e "crashless" :D
2) risolto alcuni problemi di connettivita' wireless
3) compilato e messo a punto il kernel 2.6.35
4) attivato i sensori hardware del kernel 2.6.35 ( prima non andava niente, neppure usando le librerie lm_sensors )
5) compilato Chromium dai sorgenti
6) installati plugins vari ( sia per il web che per i player multimediali)
7) risolto diversi problemi con i font, il sistema era diventato semplicemente inguardabile, non riuscivo piu' ad ottenere un look decente, era tutto "seghettato", puntinato, frastagliato :-D ... ma non ne venivo a capo, tanto che, dopo quasi due ore, avevo quasi deciso di togliere Gentoo e aspettare che la mia connessione tornasse ad essere "umana". Invece ho scoperto che, per ragioni che ancora non ho compreso, se hai Gnome con un look decente e pulito e leggibile con i "corefonts" ( microsoft ? ), appena installi nuovi font, per ragioni ( per il momento ) misteriose, gli ultimi arrivati vanno arbitrariamente a sostituire quelli che c'erano prima.. anche in gnome-panel, nei menu, ovunque. A niente serviva usare temi GTK, usare Emerald o cambiare "aspetto"... per fortuna, togliendo quasi tutti i font installati, il look e' tornato "umano" :)

per ora avrei evitato di rinunciare momentaneamente, per poi rifare tutto da zero dopo dicembre e, intanto, avrei fatto a meno di caratteri che mi sarebbero stati utili per alcuni lavori grafici di secondaria importanza... almeno mentre studiavo il problema.

Arrivare a questo livello di stabilita' e affidabilita' non e' stato facile, un altro problema che mi stava facendo perdere la pazienza era causato da networkmanager e dalla mia connessione provvisoria a mezzo telefono UMTS HSDPA Nokia.. la connessione "moriva" improvvisamente, il bus non funzionava piu' e non c'era piu' verso di riattivarla.
Neppure collegare il telefono su altra porta serviva, oppure riavviare dbus , evdev ( con il relativo rischio di grossi problemi a tutto il sistema ), l'unica era riavviare tutto e poi sperare che la "morte delle porte USB" arrivasse il piu' tardi possibile, nel senso che la cosa si poteva verificare trenta secondi dopo aver effettuato la connessione, come poteva funzionare anche trenta minuti
( ma questo era un problema dovuto alla combinazione del bios della Asus M4N78-AM, e di Gentoo, probabilmente anche perche' il funzionamento "Legacy" delle porte USB non e' interpretato in modo identico a quello di qualsiasi altra scheda madre :S Mai visto prima, se si attiva o si mette su "Auto", il bios visualizza automaticamente e immediatamente un misterioso "HiSpeed" in corrispondenza di "Legacy"...il mistero e' che il resto era comunque impostato su "USB 2.0 HiSpeed" e con Ubuntu, Mandriva, vari LiveCd e Windows 7, le porte non "morivano" )

Questa notte ho lasciato il sistema acceso, ero veramente soddisfatto dei risultati ottenuti.
restava da comprendere la dinamica del problema con i font e risolvere una strana lentezza di avvio di Gnome
Se Gnome, su questa stessa macchina e con generico Ubuntu 10.04 x86, si avvia ipoteticamente in 15 secondi dopo l'inserimento della password. con Gentoo x86 e piu' o meno stesso software e harddisk gemello Seagate SATA da 320Gb, si avvia impiegando almeno un minuto dopo l'inserimento della password. Peccato che, anche in seguito, tutto il resto si apra comunque in modo non proprio immediato, pur essendo stato TUTTO compilato/ricompilato, incluse le ultime GLIBC e GCC come prima cosa e prima di procedere con l'installazione vera e propria, il tutto con ottimizzazioni specifiche ma non estreme per il processore in uso su questa macchina.
Ho lasciato ancora "GDM" in manuale, per completare la messa a punto del software dalla "parte console", evitando la seccatura di un eventuale loop di GDM, schermi neri e blocchi del sistema, causa driver video o altri miei errori/malfunzionamenti, in ogni caso nessun problema e questa mattina Xorg e Gnome stavano funzionando, la connessione era ancora attiva, non era "morta" come al solito, Chromium stava girando tranquillamente... come un paio di javascript e qualche pagina che fa largo uso di java... openoffice Word era aperto.. gli screensaver OpenGL con "autocambiamento" attivo non avevano mandato in crash Compiz. Si, ero proprio contento dei risultati!

Vado con :
"emerge --sync"
trovo "openssl-1.0.0xxx.r1" e un paio di moduli X11 da ricompilare...

ma quando il sistema va a compilare openssl hanno inizio i miei guai
emerge fallisce e dice che:
occorre effettuare un "make depmod" a causa di algoritmi attivati o disattivati sul sistema..
non capisco bene, non ho attivato o disattivato niente di particolare, almeno cosi' mi sembra.
In ogni caso provvede da solo a tentare il make depmod,
Operazione che non riesce.
Effettuo decine di tentativi, cambiando opzioni e USE in make.conf , arrivando anche ad eliminare quasi ogni ottimizzazione, niente da fare, non cambia una virgola!!!
L'ultimo messaggio di errore che mi viene mostrato e' sempre uguale, piu' o meno: "too many files passed to CC1, try CC1 --help"
"CC1 --help" non restituisce niente, in effetti CC1 non mi dice quasi niente e io non sono un programmatore. Diciamo che mi barcameno bene da secoli con make, kernel, ottimizzazioni, ma non scrivo codice... Ero arrabbiato ed ho spento brutalmente, altrimenti avrei segnato il messaggio esatto, prima di montare l'hard disk con un Ubuntu 10,04 sperimentale e ampiamente modificato da me, con software ritenuto altamente instabile, e kernel "development" scaricato questa notte da kernel.org, eppure funziona !
Infine effettuo un "emerge --unmerge openssl" ed e' la fine,
Xorg neppure parte e gli errori sono una persecuzione, ormai appaiono fin dal boot. IO NON VOLEVO ANCORA INSTALLARE SISTEMI DI SUCUREZZA, INOLTRE QUI NON E' LA NASA...alla parte sicurezza, eventualmente, ci penso in un secondo momento. Odio sistemi che ti obblighino ad installare roba CHE NON VUOI "causa dipendenze imprescindibili", Specie in un sistema come Gentoo, che difficilmente un POLLO sprovveduto riuscirebbe ad installare, per cui non mi sarei aspettato "tanta sicurezza" ( non richiesta, indesiderata ),. che mi ha creato problemi fin dal primo momento qualsiasi cosa io abbia cercato di installare, configurare, modificare ! Credo che il sistema "openssl" mi sia stato "iniettato di nascosto" quando ho installato Virtualbox, quindi tre giorni fa.
Comunque, estenuato e stufo e assai demotivato, vado in "/var/....openssl.. ed effettuo a mano il "./config --prefix=/usr", bla bla bla... "make depend" e tutto procede fino in fondo senza errori, con un "make install" Xorg riprende almeno ad avviarsi e funzionare parzialmente, ma niente "gnome-panel". Ora sono davvero stanco e stufo :-D Emerge, ovviamente, non riconosce l'installazione manuale di openssl e qualsiasi operazione io tenti di effettuare si blocca sul tentativo fallimentare di installare openssl., Se qualche anima pia avesse qualche dritta per aiutarmi a rimettere in riga il sistema , ben venga :D :( Dover rinunciare a tutta la fatica fatta e ai risultati ottenuti mi dispiace parecchio, ma senza una mano, ormai, sono troppo concentrato e da troppe ore su questo problema per poter riuscire a trovare una soluzione...mi sa che rinuncio e, in caso, ci riprovo, a gennaio :roll: Grazie e ciao a tutti

:roll: :roll:


Last edited by allxsan on Fri Aug 13, 2010 4:54 am; edited 1 time in total
Back to top
View user's profile Send private message
Onip
Advocate
Advocate


Joined: 02 Sep 2004
Posts: 2912
Location: Parma (Italy)

PostPosted: Thu Aug 12, 2010 7:26 am    Post subject: Reply with quote

allxsan wrote:
Se qualche anima pia avesse qualche dritta per aiutarmi a rimettere in riga il sistema

dovresti postare l'errore preciso, altrimenti è dura tirare ad indovinare.

Come workaround temporaneo potresti usare un BINHOST e installarti una versione di openssl con emerge (da poi ri-emergere immediatamente).
Oppure riemergi la versione vecchia.

Code:
# equery depends dev-libs/openssl
[cut]
app-arch/libarchive-2.7.1-r1 (dev-libs/openssl)
app-emulation/wine-1.3.0 (ssl? dev-libs/openssl)
app-misc/ca-certificates-20090709 (dev-libs/openssl)
dev-games/libggz-0.0.14.1 (!gnutls? dev-libs/openssl)
dev-perl/Crypt-SSLeay-0.57 (>=dev-libs/openssl-0.9.7c)
dev-perl/Net-SSLeay-1.36 (dev-libs/openssl)
dev-python/pyopenssl-0.10-r1 (>=dev-libs/openssl-0.9.6g)
dev-vcs/git-1.7.2-r2 (!blksha1? dev-libs/openssl)
net-misc/openssh-5.3_p1-r1 (>=dev-libs/openssl-0.9.6d)
net-p2p/transmission-2.03 (>=dev-libs/openssl-0.9.4)
x11-base/xorg-server-1.7.7-r1 (dev-libs/openssl)
[cut]

come vedi ci sono una marea di applicazioni che richiedono openssl installato incondizionatamente, più una altra grande quantità che lo installano se la use ssl è attivata. Quindi non è che ti è stato messo nel sistema a caso, semplicemente è necessario e non è una questione di sicurezza "da NASA" o di essere o non essere dei polli.

Sicuramente il tuo problema è stato causato dal fatto che hai rimosso una libreria alla quale molti pacchetti sono linkati, cerca di prestare attenzione prima di rimuovere pacchetti "a caso" perchè hai le balle girate... (io mi documenterei un po' su revdep-rebuild se fossi in te)

Ciao e benvenuto a gentoo

p.s. post con la storia della tua vita e scritti grossi e colorati non fanno una buona impressione (oltre ad essere contrari alle Linee Guida del Forum.
_________________
Linux Registered User n. 373835

Titus Lucretius Carus, De Rerum Natura - Tantum religio potuit suadere malorum
Back to top
View user's profile Send private message
cloc3
Advocate
Advocate


Joined: 13 Jan 2004
Posts: 4669
Location: http://www.gentoo-users.org/user/cloc3/

PostPosted: Thu Aug 12, 2010 10:02 am    Post subject: Reply with quote

Onip wrote:

Sicuramente

beato tu, che vivi di certezze.
con il modo in cui è stato spiegato il fenomeno, ci si può aspettare di tutto. :)

per ricavare utilità dal forum, è importante circoscrivere quanto più possibile i problemi.
dici che è tutta colpa di openssl, ma descrivi sintomi non del tutto attinenti.

tuttavia:
Code:

s939 ~ # eix dev-libs/openssl
[I] dev-libs/openssl
     Available versions: 
   (0)   0.9.8o{tbz2} ~1.0.0a-r1
   (0.9.8)   ~0.9.8o-r1
   {bindist gmp kerberos rfc3779 sse2 test zlib}
     Installed versions:  0.9.8o{tbz2}(13:49:31 04/06/2010)(gmp sse2 zlib -bindist -kerberos -test)
     Homepage:            http://www.openssl.org/

è possibile che tu abbia smascherato una versione di openssl che potrebbe avere generato incongruenze nel sistema.
già che ci sei, ti consiglierei di smascherare anche la versione 2.2_rc67 di portage.
dopodichè, ricompila la versione openssl con questo comando:
emerge -1 =openssl-0.9.8o-r1 =openssl-1.0.0a-r1
e lancia un emerge -av @preserved-rebuild.

dovresti ricevere un lista dei programmi che è necessario reinstallare per riportare il sistema ad uno stato coerente.

scusami se ti sto consigliato un pacchetto hard-masked, ma si tratta di un software in testing da moltissimo tempo, con un insieme di caratteristiche estremamente efficaci. io non vedo l'ora che gli sviluppatori si rendano conto di quanto è buono quello che hanno fatto.
_________________
vu vu vu
gentù
mi piaci tu
Back to top
View user's profile Send private message
allxsan
n00b
n00b


Joined: 11 Aug 2010
Posts: 49

PostPosted: Thu Aug 12, 2010 1:03 pm    Post subject: Reply with quote

Grazie
Con il primo suggerimento, quello relativo ai bin precompilati non sono riuscito a scaricare niente.
Ho provato vari indirizzi, ad alcuni si collega, ma ecco i risultati

emerge --getbinpkg --fetchonly openssl
!!! CANNOT IMPORT HTTP.CLIENT: cannot import name HTTPSConnection
Calculating dependencies... done!
Fetching (1 of 1) dev-libs/openssl-1.0.0a-r1
* openssl-1.0.0a.tar.gz RMD160 SHA1 SHA256 size ;-) ... [ ok ]
* checking ebuild checksums ;-) ... [ ok ]
* checking auxfile checksums ;-) ... [ ok ]
* checking miscfile checksums ;-) ... [ ok ]

( segnalazioni alquanto criptiche, sembrerebbe un laconico avvertimento circa l'impossibilita' a "collegarsi a siti HTTPS perche' non trova le librerie openssl desiderate", ma questo "!!! CANNOT IMPORT HTTP.CLIENT: cannot import name HTTPSConnection" non e' che dica molto !! )
questo e' l'ultimo "mirrorbin" indicato nel mio make.conf, ma il risiultato non cambia usandone altri
" PORTAGE_BINHOST="http://mirrors.haslfree.com/portage-packages/i686-athlon64-desktop/All/"
" PKGDIR="/var/tmp/binpkgs/"
)


la versione openssl che era instalata prima era "openssl-0.9.8o-r1", non ho smascherato io quella piu' recente, che e' apparsa come aggiornamento ieri mattina : "openssl-1.0.0a-r1"

Ho provato con i suggerimenti di cloc3 ( GRAZIE :) e' che il tempo stringe e devo pur lavorare e produrre, non posso stare a leggere documentazione e fare tentativi tutto il giorno )
Il fatto e' che, la versione consigliata di portage non la scarica ( wget si lamenta a causa di openssl ), ora il sistema sembra pretendere openssl-0.9.8o-r1,
ma procediamo con ordine. sono in Gentoo, sono riuscito a far partire una sessione LXDE ( con Gnome niente da fare , senza openssl non funziona in modo utilizzabile )
ho controllato la situazione pacchetti anche con le GUI Porthole e Portato. Ora ( con Portato ) mi appare "dev-libs/openssl-0.9.8o-r1 è bloccato da dev-libs/openssl-0.9.8o-r1". Ora l'intero sistema va a cercare "openssl 0.9.8 ", ecco parte de ltentativo di scaricare il Portage suggerrito ( ma ora non scarica piu' niente da nessuna parte )

>>> Downloading 'http://gentoo.mirrors.pair.com/distfiles/portage-2.2_rc64.tar.bz2'
wget: error while loading shared libraries: libssl.so.0.9.8: cannot open shared object file: No such file or directory
>>> Downloading 'ftp://ftp.ussg.iu.edu/pub/linux/gentoo/distfiles/portage-2.2_rc64.tar.bz2'
wget: error while loading shared libraries: libssl.so.0.9.8: cannot open shared object file: No such file or directory
>>> Downloading 'ftp://ftp.gentoo.mesh-solutions.com/gentoo/distfiles/portage-2.2_rc64.tar.bz2'
wget: error while loading shared libraries: libssl.so.0.9.8: cannot open shared object file: No such file or directory

ho manualmente configurato, compilato e installato senza problemi "openssl-1.0.0a.r1", ora mi piacerebbe sapere in che modo posso "ingannare Portage facendogli capire che openssl e' installato". In ogni caso sto scaricando i sorgenti di "openssl-0.9.8o" da http://www.openssl.org/ , per cui tra poco le librerie 0.9.8 le trova al proprio posto, ovviamente si creera' un caos di openssl
Back to top
View user's profile Send private message
ago
Developer
Developer


Joined: 01 Mar 2008
Posts: 1520
Location: Cosenza, Italy

PostPosted: Thu Aug 12, 2010 1:11 pm    Post subject: Reply with quote

creare un collegamento simbolico?

Hai dato un'occhiata a revdep-rebuild e lafilefixer come diceva onip?
_________________
Contattami se vuoi contribuire in:
-Arch tester
-Chromium tester
-Traduzione doc. it
-Security
Back to top
View user's profile Send private message
allxsan
n00b
n00b


Joined: 11 Aug 2010
Posts: 49

PostPosted: Thu Aug 12, 2010 1:14 pm    Post subject: Reply with quote

niente da fare, ora tento un riavvio e poi mi metto al lavoro :-)
non posso dedicare tutto il mio tempo a cercare di risolvere il pasticcio :(


Since you've disabled or enabled at least one algorithm, you need to do
the following before building:

make depend

Configured for linux-elf.
make -j3 -s -j1 depend
making depend in crypto...
cc1: error: too many filenames given. Type cc1 --help for usage
make[1]: *** [depend] Error 1
make: *** [depend] Error 1
* ERROR: dev-libs/openssl-1.0.0a-r1 failed:
* depend failed
*
* Call stack:
* ebuild.sh, line 54: Called src_compile
* environment, line 2625: Called die
* The specific snippet of code:
* emake -j1 depend || die "depend failed";
*
* If you need support, post the output of 'emerge --info =dev-libs/openssl-1.0.0a-r1',
* the complete build log and the output of 'emerge -pqv =dev-libs/openssl-1.0.0a-r1'.
* The complete build log is located at '/var/tmp/portage/dev-libs/openssl-1.0.0a-r1/temp/build.log'.
* The ebuild environment file is located at '/var/tmp/portage/dev-libs/openssl-1.0.0a-r1/temp/environment'.
* S: '/var/tmp/portage/dev-libs/openssl-1.0.0a-r1/work/openssl-1.0.0a'

Failed to emerge dev-libs/openssl-1.0.0a-r1, Log file:
'/var/tmp/portage/dev-libs/openssl-1.0.0a-r1/temp/build.log'
*** processo completato ***
Back to top
View user's profile Send private message
allxsan
n00b
n00b


Joined: 11 Aug 2010
Posts: 49

PostPosted: Thu Aug 12, 2010 1:34 pm    Post subject: Reply with quote

dopo aver scaricato e compilato anche openssl 0.9.8o direttamente dal sito di origine non cambia niente :(

"revdep-rebuild" vorrebbe scaricare ben 38 files ( prima voleva farlo solo con nove, ora sono 38 a causa di alcune variazioni inutili al mio make.conf )
parte immediatamente con openssl-1.0...", il download e' stato effettuato ieri mattina, quindi se lo ritrova senza scaricare e parte la compilazione.. poi tutto termina come indicato poco piu' sopra

Ho tentato un "globale" : lafilefixer --justfixit /
niente di fatto
Back to top
View user's profile Send private message
ago
Developer
Developer


Joined: 01 Mar 2008
Posts: 1520
Location: Cosenza, Italy

PostPosted: Thu Aug 12, 2010 1:48 pm    Post subject: Reply with quote

cmq ti consiglio di ricompilare gli altri 37 pacchetti che indica revdep

P.S.mi puzza un po il fatto che dici di avere un'installazione recente..non è mai capitato..
_________________
Contattami se vuoi contribuire in:
-Arch tester
-Chromium tester
-Traduzione doc. it
-Security
Back to top
View user's profile Send private message
allxsan
n00b
n00b


Joined: 11 Aug 2010
Posts: 49

PostPosted: Thu Aug 12, 2010 2:37 pm    Post subject: Reply with quote

ago88 wrote:
cmq ti consiglio di ricompilare gli altri 37 pacchetti che indica revdep

P.S.mi puzza un po il fatto che dici di avere un'installazione recente..non è mai capitato..


grazie, l'installazione ha circa dieci giorni

non posso fare nulla perche' il primo file che cerca di ricompilare e' openssl, che pro' ho compilato a mano senza problemi, proprio dalla stessa cartella nella quale emerge si blocca a causa di quanto riportato.. e che non e' del tutto chiaro :(
Volendo potrei riportare tutto allo stadio in cui era l'altro ieri sera, perche' era tutto installato su un piccolo hd ide da 40 gb, il fatto e' che mi interessa capire cosa diavolo sia accaduto e come risolvere seguendo la logica. L'unico "trucco" che mi piacerebbe poter usare sarebbe quello di riuscire ad "ingannare" portage, inserendo openssl-1.0xxxx tra i pacchetti installati ( del resto e' installato ), ma non so come fare ad effettuare questo tentativo
Back to top
View user's profile Send private message
ago
Developer
Developer


Joined: 01 Mar 2008
Posts: 1520
Location: Cosenza, Italy

PostPosted: Thu Aug 12, 2010 3:00 pm    Post subject: Reply with quote

Sicuramente hai creato qualche casino anche con installazioni a mano....cmq se preferisci posso postarti il binpkg di ssl....
_________________
Contattami se vuoi contribuire in:
-Arch tester
-Chromium tester
-Traduzione doc. it
-Security
Back to top
View user's profile Send private message
allxsan
n00b
n00b


Joined: 11 Aug 2010
Posts: 49

PostPosted: Thu Aug 12, 2010 3:42 pm    Post subject: Reply with quote

ago88 wrote:
Sicuramente hai creato qualche casino anche con installazioni a mano....cmq se preferisci posso postarti il binpkg di ssl....


eh, magari, grazie :) non sarebbe male fare una prova finale. Ma ormai ho forti dubbi :(

Ho provato anche a modificare make.conf esclusivamente con gli USE richiesti da openssl ( con gli "exclude" obbligatori ) ma non e' cambiato niente
Back to top
View user's profile Send private message
Onip
Advocate
Advocate


Joined: 02 Sep 2004
Posts: 2912
Location: Parma (Italy)

PostPosted: Thu Aug 12, 2010 3:59 pm    Post subject: Reply with quote

allxsan wrote:
niente da fare, ora tento un riavvio e poi mi metto al lavoro :-)
non posso dedicare tutto il mio tempo a cercare di risolvere il pasticcio :(


Se stai con un sistema totalmente ~ sono cose che possono capitare. (a maggior ragione se è la prima volta che maneggi una gentoo)
Quasi quasi ti conviene re-installare con un sistema stabile e poi smascherare solamente ciò di cui veramente ti serve l'ultima versione. Nota che il concetto di stabile e instabile in gentoo è assolutamente differente da quello di upstream o delle distribuzioni binarie: qui per la libertà data agli utenti e per il grande numero di combinazioni di librerie e use in ogni sistema i pacchetti necessitano di un testing più approfondito. (In genere) i devel sanno quello che fanno quando marcano un pacchetto come utilizzabile tranquillamente oppure no.
_________________
Linux Registered User n. 373835

Titus Lucretius Carus, De Rerum Natura - Tantum religio potuit suadere malorum
Back to top
View user's profile Send private message
cloc3
Advocate
Advocate


Joined: 13 Jan 2004
Posts: 4669
Location: http://www.gentoo-users.org/user/cloc3/

PostPosted: Thu Aug 12, 2010 4:00 pm    Post subject: Reply with quote

allxsan wrote:
Grazie
Con il primo suggerimento, quello relativo ai bin precompilati non sono riuscito a scaricare niente.

in pratica, ti saresti letteralmente tagliato i rifornimenti.
puoi sempre fare i download con il disco di installazione, fuori dal chroot.
in questo caso dovresti fare il fetch con wget, anziché con emerge.

il suggerimento di Onip si può riassumere nel seguente comando:
emerge -aK =openssl-0.9.8o oppure:
emerge -aK =openssl-0.9.8o-r1

può anche essere che tu abbia una versione utile del binario di openssl nel tarball dello stage-3 iniziale.
_________________
vu vu vu
gentù
mi piaci tu
Back to top
View user's profile Send private message
ago
Developer
Developer


Joined: 01 Mar 2008
Posts: 1520
Location: Cosenza, Italy

PostPosted: Thu Aug 12, 2010 4:13 pm    Post subject: Reply with quote

allxsan wrote:
eh, magari, grazie :) non sarebbe male fare una prova finale. Ma ormai ho forti dubbi :(


Magari se mi dici l'architettura e il -march ti do un binario piu adatto ;)
_________________
Contattami se vuoi contribuire in:
-Arch tester
-Chromium tester
-Traduzione doc. it
-Security
Back to top
View user's profile Send private message
allxsan
n00b
n00b


Joined: 11 Aug 2010
Posts: 49

PostPosted: Thu Aug 12, 2010 4:25 pm    Post subject: Reply with quote

Onip wrote:
allxsan wrote:
niente da fare, ora tento un riavvio e poi mi metto al lavoro :-)
non posso dedicare tutto il mio tempo a cercare di risolvere il pasticcio :(


Se stai con un sistema totalmente ~ sono cose che possono capitare. (a maggior ragione se è la prima volta che maneggi una gentoo)
Quasi quasi ti conviene re-installare con un sistema stabile e poi smascherare solamente ciò di cui veramente ti serve l'ultima versione. Nota che il concetto di stabile e instabile in gentoo è assolutamente differente da quello di upstream o delle distribuzioni binarie: qui per la libertà data agli utenti e per il grande numero di combinazioni di librerie e use in ogni sistema i pacchetti necessitano di un testing più approfondito. (In genere) i devel sanno quello che fanno quando marcano un pacchetto come utilizzabile tranquillamente oppure no.



A parte Xorg non ho "unmasked" praticamente niente o quasi niente, per precauzione avevo installato anche un lxde-desktop in caso di problemi e, infatti, oggi e' tutto il giorno che gentoo e' in funzione e collegato via telefono UMTS HSDPA, grazie a LXDE.

Non so, forse stavo dormendo in piedi perche' erano quasi le 4 e non staccavo da diverse ore..per cui, al limite, potrei aver eliminato qualcosa. Ma non ho ricevuto alcuna segnalazione di pericolo, quindi il "guaio" non era prevedibile. Posso tornare in pochi minuti allo stato in cui si trovava due sere fa, come dicevo era installato su un HD da 40 Gb e, visto che iniziava a funzionare a dovere, avevo appena migrato tutto su un SATA da 320 nuovo.
Resta il fatto che mi sarebbe piaciuto poter risolvere il problema, non e' possibile che vada tutto in tilt in modo veramente irrimediabile a causa di una libreria :S
Back to top
View user's profile Send private message
allxsan
n00b
n00b


Joined: 11 Aug 2010
Posts: 49

PostPosted: Thu Aug 12, 2010 4:42 pm    Post subject: Reply with quote

ago88 wrote:
allxsan wrote:
eh, magari, grazie :) non sarebbe male fare una prova finale. Ma ormai ho forti dubbi :(


Magari se mi dici l'architettura e il -march ti do un binario piu adatto ;)


grazie mille ;) :-D
x86 march=j8 ( oppure athlon64, perche' ho visto che j8 viene scelto per sistemi 64bit, ma qui funzionava tutto perfettamente con j8 )


ora mi sorge un dubbio, qualche pacchetto potrebbe aver trascinato con se l'installazione di qualche sistema SSL v2/v3 oppure TLS v1 alternativo ad openssl..non ero piu' molto sveglio e potrei non ricordare bene.. questo spiegherebbe la segnalazione


"Since you've disabled or enabled at least one algorithm, you need to do
the following before building:

make depend"

ho appena trovato l'installazione di "gnutls", non ho idea di come sia "entrata" nel sistema e se possa convivere con openssl.
In ogni caso ho tentato un "unmerge" che non ha risolto il problema
Back to top
View user's profile Send private message
allxsan
n00b
n00b


Joined: 11 Aug 2010
Posts: 49

PostPosted: Thu Aug 12, 2010 4:58 pm    Post subject: Reply with quote

cloc3 wrote:
allxsan wrote:
Grazie
Con il primo suggerimento, quello relativo ai bin precompilati non sono riuscito a scaricare niente.

in pratica, ti saresti letteralmente tagliato i rifornimenti.
puoi sempre fare i download con il disco di installazione, fuori dal chroot.
in questo caso dovresti fare il fetch con wget, anziché con emerge.

il suggerimento di Onip si può riassumere nel seguente comando:
emerge -aK =openssl-0.9.8o oppure:
emerge -aK =openssl-0.9.8o-r1

può anche essere che tu abbia una versione utile del binario di openssl nel tarball dello stage-3 iniziale.


gia', adesso vado controllare subito. Avevo dimenticato di aver lasciato in /mnt i bz2 dello stage3 del 16/06/2010 e di portage del 28/07/2010 ;)
Back to top
View user's profile Send private message
allxsan
n00b
n00b


Joined: 11 Aug 2010
Posts: 49

PostPosted: Thu Aug 12, 2010 5:11 pm    Post subject: Reply with quote

cloc3 wrote:
allxsan wrote:
Grazie
Con il primo suggerimento, quello relativo ai bin precompilati non sono riuscito a scaricare niente.

in pratica, ti saresti letteralmente tagliato i rifornimenti.
puoi sempre fare i download con il disco di installazione, fuori dal chroot.
in questo caso dovresti fare il fetch con wget, anziché con emerge.

il suggerimento di Onip si può riassumere nel seguente comando:
emerge -aK =openssl-0.9.8o oppure:
emerge -aK =openssl-0.9.8o-r1

può anche essere che tu abbia una versione utile del binario di openssl nel tarball dello stage-3 iniziale.



Grande idea, cloc3 :-D

ho estratto, via via che venivano richiesti, tutti i files mancanti dallo stage 3 :D :D
mancavano due libssl e due libcrypto 0.9.8o
Ho appena installato "portage-2.2_rc67" che consigliavi.. ora vedo di rimettere tutto a posto

consigli di fare prima di tutto prima un revdep-rebuild ? :D


----------------------

aggiornamento

per ora niente da fare.. ora inizio a ricordare cosa era successo quando ho trovato openssl-1.0.0xxxx
nel bel mezzo dell'installazione, dopo la compilazione fatta da emerge, mi trovavo davanti ad un "files collision" generale !
Da quel momento in poi non c'e' stato nente da fare.
Ora che ho ripristinato i file della versione opennssl-0.9.8 e riavviato mi sono trovato davanti anche ad una seconda problematica:
a quanto sembra ci sono cose che sono state ricompilate da "emerge --update --deep --newuse world" per openssl-1.0xxx
altre sono state compilate per la versione precedente..infatti al riavvio non tutto e' partito, anzi, quasi niente !!!
Neppure dbus, networkmanager, ntpd...
emerge networkmanager ha sistemato qualcosina e sono nuovamente in linea via lxde.
Ma sono ancora molto lontano dalla soluzione di tutti i problemi :-D


Last edited by allxsan on Thu Aug 12, 2010 7:01 pm; edited 1 time in total
Back to top
View user's profile Send private message
cloc3
Advocate
Advocate


Joined: 13 Jan 2004
Posts: 4669
Location: http://www.gentoo-users.org/user/cloc3/

PostPosted: Thu Aug 12, 2010 6:37 pm    Post subject: Reply with quote

allxsan wrote:


consigli di fare prima di tutto prima un revdep-rebuild ? :D

direi di no. secondo me, revdep-rebuild è meglio lanciarlo dopo emerge @preserved-rebuild.
allxsan wrote:


----------------------

aggiornamento

per ora niente da fare.. ora inizio a ricordare cosa era successo quando ho trovato openssl-1.0.0xxxx
nel bel mezzo dell'installazione, dopo la compilazione fatta da emerge, mi trovavo davanti ad un "files collision" generale !
Da quel momento in poi non c'e' stato nente da fare.

effettivamente le cose che racconti sono strane al punto che una reinstallazione potrebbe risultare l'operazione più economica.
tuttavia, gentoo possiede strumenti di controllo talmente raffinati che val pena, se non altro a scopi istruttivi, provare a tenerla in piedi.

se ti capitano dei "files collision" ingiustificati significa che tu, in precedenza, hai installato manualmente del software senza usare il comando emerge. io ti suggerivo di fare solo il fetch senza emerge. cerca di ricostruire con esattezza questi passaggi, altrimenti non sarà possibile fare pulizia.
abbia fiducia in portage, che è un sistema solidissimo e cerca sempre di individuare, in ogni inceppo che ti capitasse (così catastrofico, tra l'altro), qualche motivo di errore personale.
_________________
vu vu vu
gentù
mi piaci tu
Back to top
View user's profile Send private message
cloc3
Advocate
Advocate


Joined: 13 Jan 2004
Posts: 4669
Location: http://www.gentoo-users.org/user/cloc3/

PostPosted: Thu Aug 12, 2010 6:55 pm    Post subject: Reply with quote

allxsan wrote:
ora il sistema sembra pretendere openssl-0.9.8o-r1

se hai smascherato openssl e se hai dei pacchetti compilati con openssl-0.9.8o, emerge fa bene a comportarsi così.
non è una pretesa, è una protezione.
_________________
vu vu vu
gentù
mi piaci tu
Back to top
View user's profile Send private message
allxsan
n00b
n00b


Joined: 11 Aug 2010
Posts: 49

PostPosted: Thu Aug 12, 2010 7:30 pm    Post subject: Reply with quote

cloc3 wrote:
allxsan wrote:
ora il sistema sembra pretendere openssl-0.9.8o-r1

se hai smascherato openssl e se hai dei pacchetti compilati con openssl-0.9.8o, emerge fa bene a comportarsi così.
non è una pretesa, è una protezione.



Allora:

per far funzionare di nuovo tutto ( spero, quando avra' finito ), ho mascherato sia openssl-1.0.xxxx che 0.9.8o, sperando di far installare la 0.9.8o-r1
non voleva saperne, emerge "diceva che andava in conflitto con se stessa", anche se non risultava installata .. allora ho mascherato tutto tranne la versione piu' vecchia, che e' stata compilata senza nessun problema, ma poi e' stata installata per meta' causa collisione ( possibile che installi alcuni files e poi si interrompa senza rimuovere quel che aveva parzialmente installato ???! )
Rimaschero la versione piu' recente e quella piu' vecchia, con scarse speranze di riuscire, invece la segnlazione di "conflitto con lo stessa versione anche se NON INSTALLATA!!!" :-O e' sparita per ragioni misteriose e ogni cosa va in porto senza piu' mezzo problema. Ho di nuovo "openssl-0.9.8-r1" :-D
Ora lascio mascherata a vita la versione piu' recente, quella che ha fatto partire questo pasticcio :-D

emerge @preserved-rebuild prima non aveva funzionato, errore come se non riconoscesse il comando
Forse si tratta di una novita' presente nel nuovo portage ?
Visto che prima il comando non aveva funzionato mi era sfuggito di mente e volevo andare avanti :-D :-D

quindi ho avviato revdep-rebuild, che ha appena concluso l'elaborarazione di 37 pacchetti ( incrocio le dita :-D )

ho appena provato
emerge @preserved-rebuild

anche se solo dopo revdep-rebuild, in caso avesse effettuato operazioni su pacchetti avrei ripetuto revdep.rebuild

ma questo e' quanto:
emerge: 'preserved-rebuild' is an empty set
emerge: no targets left after set expansion
Back to top
View user's profile Send private message
cloc3
Advocate
Advocate


Joined: 13 Jan 2004
Posts: 4669
Location: http://www.gentoo-users.org/user/cloc3/

PostPosted: Thu Aug 12, 2010 8:14 pm    Post subject: Reply with quote

allxsan wrote:

per far funzionare di nuovo tutto ( spero, quando avra' finito ), ho mascherato sia openssl-1.0.xxxx che 0.9.8o, sperando di far installare la 0.9.8o-r1
non voleva saperne, emerge "diceva che andava in conflitto con se stessa", anche se non risultava installata .. allora ho mascherato tutto tranne la versione piu' vecchia, che e' stata compilata senza nessun problema, ma poi e' stata installata per meta' causa collisione ( possibile che installi alcuni files e poi si interrompa senza rimuovere quel che aveva parzialmente installato ???! )

allora:
Code:

[I] dev-libs/openssl
     Available versions: 
   (0)   0.9.8o{tbz2} ~1.0.0a-r1
   (0.9.8)   ~0.9.8o-r1

le versioni 0.9.8o e 1.0.0a-r1 appartengono alla stessa slot, quindi emerge si rifiuta di installarle entrambe.
invece la 0.9.8o-r1 può essere installata insieme alla 1.0.0a-r1 in caso di necessità.

aggiornando alla 1.*, può accadere che alcuni pacchetti risultino scoperti, come è accaduto a te.
però emerge, se usato correttamente, non si lascia ingannare. al momento di disinstallare la 0.9.8o, toglie tutti i file vecchi tranne la liberia, a protezione del sistema. quando questo accade, emerge @preserved-rebuild segnala i pacchetti scoperti e ne guida la ricompilazione. al termine, la libreria vecchia, ormai inutile, viene rimossa. una successiva chiamata a emerge @preserved-rebuild dovrebbe individuare un empty set.
secondo me, dovrebbe essere questo il momento giusto per controllare il sistema con revdep-rebuild.

forse tu hai cominciato queste operazioni in un momento sbagliato e le cose sono andate diversamente.

per quanto riguarda la collisione, quando viene segnalata, emerge non installa assolutamente nulla.
se tu trovi qualcosa, quel qualcosa era lì in precedenza ed è la causa, non l'effetto, della collisione.

forse è andata così. installando la 1.*, il sistema ha disinstalalto la 0.9.8o, lasciando la libreria di protezione, perché aveva individuato delle dipendenze residue.
a questo punto, installare la 0.9.8o-r1 è risultato impossibile, per collisione.
se tu avessi usato emerge @preserved-rebuild a questo punto, avresti aggiornato il sistema e rimosso la libreria vecchia in un sol colpo.
_________________
vu vu vu
gentù
mi piaci tu
Back to top
View user's profile Send private message
allxsan
n00b
n00b


Joined: 11 Aug 2010
Posts: 49

PostPosted: Thu Aug 12, 2010 8:45 pm    Post subject: Reply with quote

non ho ancora riavviato... :-D speriamo bene

quindi dici che posso riprovare a installare la 1.0.0a-r1 ?
Non era mascherata, infatti e' partito tutto da quel momento in poi.

Per far partire il sistema, che non voleva saperne a causa del fatto che alcune applicazioni, ora, cercavano la 1.0.0a-r1 e altre la 0.9.8o ( quindi, probabilmente, la r1 ) ho creato alcuni simlink tipo "ssl-0.9.8" -> "ssl-1.0.0" e "libcripto-0.8.9" -> "libcrypto-1.0.0"
Non so provare prima e eliminare i simlinks e riavviare, quindi riprovare ad installare la 1.0.0a-r1..

grazie, per la dritta ;)
Avrei potuto recuperare i files scomparsi montando il vecchio HD da 40 Gb, ma avrei dovuto smettere di lavorare al pc, aprire tutto, montare l'HD... era l'ultima spiaggia :D invece ho seguitato a lavorare mentre cercavo info :D


L'installazione iniziale l'ho fatta usando un livecd sabayon CDXCore, che ha funzionato perfettamente allo scopo ed e' molto veloce.
Un primo tentativo, non perfettamente riuscito a causa di mie piccole sviste, lo avevo fatto partendo dal livedvd di gentoo di dicembre, decisamente molto piu' lento.
Consiglierei a chiunque voglia installare gentoo di usare l'ambiente grafico pratico e veloce di Sabayon Corecdx, semplifica e velocizza tutta procedura
Back to top
View user's profile Send private message
cloc3
Advocate
Advocate


Joined: 13 Jan 2004
Posts: 4669
Location: http://www.gentoo-users.org/user/cloc3/

PostPosted: Thu Aug 12, 2010 9:24 pm    Post subject: Reply with quote

allxsan wrote:

Non so provare prima e eliminare i simlinks e riavviare, quindi riprovare ad installare la 1.0.0a-r1..

assolutamente no.

devi eliminare i symlink, ma senza riavviare, prima di avere raggiunto una configurazione autocorente.
e devi smetterla di rendere iniziative senza dichiararle.
non è corretto, e dopo è inutile lamentarsi dei misteriosi ( :roll: ) "files collisions".

aggiungere i symlinks a mano è pericoloso, perchè, appena li togli, potresti ridestabilizzare il sistema.
la cosa giusta è toglierli uno alla volta e reinstallare i pacchetti relativi, fino a quando non sarai certo che tutti i symlinks siano perfettamente sotto controllo. dopdodichè potrai fare tutto quello che vuoi, del tuo sistema.
_________________
vu vu vu
gentù
mi piaci tu
Back to top
View user's profile Send private message
allxsan
n00b
n00b


Joined: 11 Aug 2010
Posts: 49

PostPosted: Thu Aug 12, 2010 9:51 pm    Post subject: Reply with quote

cloc3 wrote:
allxsan wrote:

Non so provare prima e eliminare i simlinks e riavviare, quindi riprovare ad installare la 1.0.0a-r1..

assolutamente no.

devi eliminare i symlink, ma senza riavviare, prima di avere raggiunto una configurazione autocorente.
e devi smetterla di rendere iniziative senza dichiararle.
non è corretto, e dopo è inutile lamentarsi dei misteriosi ( :roll: ) "files collisions".

aggiungere i symlinks a mano è pericoloso, perchè, appena li togli, potresti ridestabilizzare il sistema.
la cosa giusta è toglierli uno alla volta e reinstallare i pacchetti relativi, fino a quando non sarai certo che tutti i symlinks siano perfettamente sotto controllo. dopdodichè potrai fare tutto quello che vuoi, del tuo sistema.


eh no :D
sono stato costretto a crearli perche' altrimenti non avrebbe funzionato niente, a partire dalla connessione.
Dopo essere riuscito a ripristinare openssl 0.9.8o-r1 ho riavviato ma non andava niente, i messaggi di errore durante l'avvio si erano moltiplicati.
Non partivano piu' neppure :
dbus !!!!
networkmanager
ntpd

ho creato i simlinks a avviato tutto manualmente, intanto Gnome seguitava a non funzionare e ho usato ancora LXDE
Ho ricompilato parti di Gnome con emerge ( in primo luogo gnome-panel, che era messo peggio di tutto il resto e neppure partiva )
Questa volta, dopo il riavvio per verificare eventuali messaggi di errore ( anche se irrilevanti li odio, li trovo "antiestetici" :-D ), funzionava tutto perfettamente :-D
Ora ci ci sono ancora i tre simlinks, posso eliminarli e fare un test, per ricrearli impiego cinque secondi. Ma se vedo messaggi di errore, la mente bacata/maniacale, non accettera' mai di usare un trucco pur di avere il sistema funzionante ( mi occupo da una vita di hardware e software, di telecomunicazioni, sono stato sysop Fidonet con tre nodi in nodelist fin da ragazzino dai primi anni 80, ho fatto il "troubleshooter" per IBM per diversi anni presso clienti di una certa portata - comune di milano, universita' cattolica, magneti marelli, banca intesa.. ) un trucco provvisorio per ripristinare momentaneamente il funzionamento di qualsiasi cosa l'ho trovato quasi sempre, ma poi devo risolvere sul serio, altrimenti un tarlo mi dara' il tormento giorno e notte :-S :D

P.S.
hai idea circa l'utilita' di attivare "USE networkmanager" in gnome-applets ? ( "enable net-misc/networkmanager support" )
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian) All times are GMT
Goto page 1, 2  Next
Page 1 of 2

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum