Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
/usr/bin: file not recognized: Is a directory
View unanswered posts
View posts from last 24 hours

Reply to topic    Gentoo Forums Forum Index Installing Gentoo
View previous topic :: View next topic  
Author Message

Joined: 19 Jul 2005
Posts: 356
Location: Wroclaw, Poland

PostPosted: Sat Aug 07, 2010 9:29 am    Post subject: /usr/bin: file not recognized: Is a directory Reply with quote

I get this error when trying to emerge dev-libs/dbus-glib-0.86 as a dependency of xorg-x11.
Build log:
 * CPV:  dev-libs/dbus-glib-0.86
 * REPO: gentoo
 * USE:  amd64 bash-completion elibc_glibc kernel_linux multilib userland_GNU
>>> Unpacking source...
>>> Unpacking dbus-glib-0.86.tar.gz to /var/tmp/portage/dev-libs/dbus-glib-0.86/work
>>> Source unpacked in /var/tmp/portage/dev-libs/dbus-glib-0.86/work
>>> Preparing source in /var/tmp/portage/dev-libs/dbus-glib-0.86/work/dbus-glib-0.86 ...
>>> Source prepared.
>>> Configuring source in /var/tmp/portage/dev-libs/dbus-glib-0.86/work/dbus-glib-0.86 ...
 * Running configure in /var/tmp/portage/dev-libs/dbus-glib-0.86/work/dbus-glib-0.86-build
 * econf: updating dbus-glib-0.86/config.sub with /usr/share/gnuconfig/config.sub
 * econf: updating dbus-glib-0.86/config.guess with /usr/share/gnuconfig/config.guess
/var/tmp/portage/dev-libs/dbus-glib-0.86/work/dbus-glib-0.86/configure --prefix=/usr --build=x86_64-pc-linux-gnu --host=x86_64-pc-linux-gnu --mandir=/usr/share/man --infodir=/usr/share/info --datadir=/usr/share --sysconfdir=/etc --localstatedir=/var/lib --libdir=/usr/lib64 --localstatedir=/var --enable-bash-completion --disable-verbose-mode --disable-asserts --disable-doxygen-docs --disable-gtk-doc
checking build system type... x86_64-pc-linux-gnu
checking host system type... x86_64-pc-linux-gnu
checking target system type... x86_64-pc-linux-gnu
checking for a BSD-compatible install... /usr/bin/install -c
checking whether build environment is sane... yes
checking for a thread-safe mkdir -p... /bin/mkdir -p
checking for gawk... gawk
checking whether make sets $(MAKE)... yes
checking whether to enable maintainer-specific portions of Makefiles... no
checking for x86_64-pc-linux-gnu-gcc... x86_64-pc-linux-gnu-gcc
checking for C compiler default output file name... a.out
checking whether the C compiler works... yes
checking whether we are cross compiling... no
checking for suffix of executables...
checking for suffix of object files... o
checking whether we are using the GNU C compiler... yes
checking whether x86_64-pc-linux-gnu-gcc accepts -g... yes
checking for x86_64-pc-linux-gnu-gcc option to accept ISO C89... none needed
checking for style of include used by make... GNU
checking dependency style of x86_64-pc-linux-gnu-gcc... gcc3
checking for library containing strerror... none required
checking how to run the C preprocessor... x86_64-pc-linux-gnu-gcc -E
checking for grep that handles long lines and -e... /bin/grep
checking for egrep... /bin/grep -E
checking for ANSI C header files... yes
checking whether gcc understands -Wfloat-equal... yes
checking for a sed that does not truncate output... /bin/sed
checking for fgrep... /bin/grep -F
checking for ld used by x86_64-pc-linux-gnu-gcc... /usr/x86_64-pc-linux-gnu/bin/ld
checking if the linker (/usr/x86_64-pc-linux-gnu/bin/ld) is GNU ld... yes
checking for BSD- or MS-compatible name lister (nm)... /usr/bin/nm -B
checking the name lister (/usr/bin/nm -B) interface... BSD nm
checking whether ln -s works... yes
checking the maximum length of command line arguments... 1572864
checking whether the shell understands some XSI constructs... yes
checking whether the shell understands "+="... yes
checking for /usr/x86_64-pc-linux-gnu/bin/ld option to reload object files... -r
checking for x86_64-pc-linux-gnu-objdump... x86_64-pc-linux-gnu-objdump
checking how to recognize dependent libraries... pass_all
checking for x86_64-pc-linux-gnu-ar... x86_64-pc-linux-gnu-ar
checking for x86_64-pc-linux-gnu-strip... x86_64-pc-linux-gnu-strip
checking for x86_64-pc-linux-gnu-ranlib... x86_64-pc-linux-gnu-ranlib
checking command to parse /usr/bin/nm -B output from x86_64-pc-linux-gnu-gcc object... ok
checking for sys/types.h... yes
checking for sys/stat.h... yes
checking for stdlib.h... yes
checking for string.h... yes
checking for memory.h... yes
checking for strings.h... yes
checking for inttypes.h... yes
checking for stdint.h... yes
checking for unistd.h... yes
checking for dlfcn.h... yes
checking for objdir... .libs
checking if x86_64-pc-linux-gnu-gcc supports -fno-rtti -fno-exceptions... no
checking for x86_64-pc-linux-gnu-gcc option to produce PIC... -fPIC -DPIC
checking if x86_64-pc-linux-gnu-gcc PIC flag -fPIC -DPIC works... yes
checking if x86_64-pc-linux-gnu-gcc static flag -static works... yes
checking if x86_64-pc-linux-gnu-gcc supports -c -o file.o... yes
checking if x86_64-pc-linux-gnu-gcc supports -c -o file.o... (cached) yes
checking whether the x86_64-pc-linux-gnu-gcc linker (/usr/x86_64-pc-linux-gnu/bin/ld -m elf_x86_64) supports shared libraries... yes
checking whether -lc should be explicitly linked in... no
checking dynamic linker characteristics... GNU/Linux
checking how to hardcode library paths into programs... immediate
checking whether stripping libraries is possible... yes
checking if libtool supports shared libraries... yes
checking whether to build shared libraries... yes
checking whether to build static libraries... yes
checking for library containing socket... none required
checking whether socklen_t is defined... yes
checking abstract socket namespace... yes
checking locale.h usability... yes
checking locale.h presence... yes
checking for locale.h... yes
checking for LC_MESSAGES... yes
checking libintl.h usability... yes
checking libintl.h presence... yes
checking for libintl.h... yes
checking for ngettext in libc... yes
checking for dgettext in libc... yes
checking for bind_textdomain_codeset... yes
checking for msgfmt... /usr/bin/msgfmt
checking for dcgettext... yes
checking if msgfmt accepts -c... yes
checking for gmsgfmt... /usr/bin/gmsgfmt
checking for xgettext... /usr/bin/xgettext
/var/tmp/portage/dev-libs/dbus-glib-0.86/work/dbus-glib-0.86/configure: line 13694: /var/tmp/portage/dev-libs/dbus-glib-0.86/work/dbus-glib-0.86/po/ No such file or directory
checking for XML_ParserCreate_MM in -lexpat... yes
checking expat.h usability... yes
checking expat.h presence... yes
checking for expat.h... yes
checking for x86_64-pc-linux-gnu-pkg-config... no
checking for pkg-config... /usr/bin/pkg-config
checking pkg-config is at least version 0.9.0... yes
checking for DBUS... yes
checking for DBUS_GLIB... yes
checking for DBUS_GLIB_THREADS... yes
checking whether to build gtk-doc documentation... no
checking for gtkdoc-check... no
checking for doxygen... no
checking whether to build Doxygen documentation... yes
configure: creating ./config.status
config.status: creating Makefile
config.status: creating m4/Makefile
config.status: creating doc/Makefile
config.status: creating doc/reference/Makefile
config.status: creating doc/reference/version.xml
config.status: creating dbus/Makefile
config.status: creating dbus/examples/Makefile
config.status: creating dbus/examples/statemachine/Makefile
config.status: creating test/Makefile
config.status: creating test/core/Makefile
config.status: creating test/interfaces/Makefile
config.status: creating test/data/valid-service-files/debug-glib.service
config.status: creating test/data/valid-service-files/debug-echo.service
config.status: creating test/data/valid-service-files/interfaces-test.service
config.status: creating tools/Makefile
config.status: creating dbus-glib-1.pc
config.status: creating dbus-glib-1-uninstalled.pc
config.status: creating Doxyfile
config.status: creating config.h
config.status: executing depfiles commands
config.status: executing libtool commands
config.status: executing default-1 commands

                    D-BUS GLIB BINDINGS 0.86

   prefix:                   /usr
   exec_prefix:              ${prefix}
        libdir:                   /usr/lib64
        bindir:                   /usr/bin
        sysconfdir:               /etc
        localstatedir:            /var
   datadir:                  /usr/share
   source code location:     /var/tmp/portage/dev-libs/dbus-glib-0.86/work/dbus-glib-0.86
   compiler:        x86_64-pc-linux-gnu-gcc
   cflags:                -O2 -march=native -pipe -g -Wall -Wchar-subscripts -Wmissing-declarations -Wmissing-prototypes -Wnested-externs -Wpointer-arith -Wcast-align -Wfloat-equal -Wsign-compare -fno-strict-aliasing
        Doxygen:                  no

        Maintainer mode:          no
        gcc coverage profiling:   no
        Building unit tests:      no
        Building verbose mode:    no
        Building assertions:      no
        Building checks:          yes
        Building Doxygen docs:    no
        Building Gtk-doc docs:    no
        Bash Completion:          yes
        Gettext libs (empty OK): 
        Using XML parser:         
        'make check' socket dir: 

>>> Source configured.
>>> Compiling source in /var/tmp/portage/dev-libs/dbus-glib-0.86/work/dbus-glib-0.86 ...
 * Running make in /var/tmp/portage/dev-libs/dbus-glib-0.86/work/dbus-glib-0.86-build
make -j2
make  all-recursive
make[1]: Entering directory `/var/tmp/portage/dev-libs/dbus-glib-0.86/work/dbus-glib-0.86-build'
Making all in dbus
make[2]: Entering directory `/var/tmp/portage/dev-libs/dbus-glib-0.86/work/dbus-glib-0.86-build/dbus'
make  all-recursive
make[3]: Entering directory `/var/tmp/portage/dev-libs/dbus-glib-0.86/work/dbus-glib-0.86-build/dbus'
Making all in .
make[4]: Entering directory `/var/tmp/portage/dev-libs/dbus-glib-0.86/work/dbus-glib-0.86-build/dbus'
  CC     dbus-gmain.lo
  CC     dbus-glib.lo
  CC     dbus-gmarshal.lo
  CC     dbus-gobject.lo
  CC     dbus-gproxy.lo
  CC     dbus-gtest.lo
  CC     dbus-gvalue.lo
  CC     dbus-gthread.lo
  CC     dbus-gtype-specialized.lo
  CC     dbus-gutils.lo
  CC     dbus-gsignature.lo
  CC     dbus-gvalue-utils.lo
  CC     dbus-gidl.lo
  CC     dbus-gloader-expat.lo
  CC     dbus-gparser.lo
  CC     dbus-binding-tool-glib.o
  CC     dbus-glib-tool.o
  CC     dbus-bash-completion-helper.o
/usr/bin: file not recognized: Is a directory
collect2: ld returned 1 exit status
make[4]: *** [] Error 1
make[4]: Leaving directory `/var/tmp/portage/dev-libs/dbus-glib-0.86/work/dbus-glib-0.86-build/dbus'
make[3]: *** [all-recursive] Error 1
make[3]: Leaving directory `/var/tmp/portage/dev-libs/dbus-glib-0.86/work/dbus-glib-0.86-build/dbus'
make[2]: *** [all] Error 2
make[2]: Leaving directory `/var/tmp/portage/dev-libs/dbus-glib-0.86/work/dbus-glib-0.86-build/dbus'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/var/tmp/portage/dev-libs/dbus-glib-0.86/work/dbus-glib-0.86-build'
make: *** [all] Error 2
 * ERROR: dev-libs/dbus-glib-0.86 failed:
 *   make failed
 * Call stack:
 *, line  48:  Called src_compile
 *   environment, line 249:  Called die
 * The specific snippet of code:
 *       emake || die "make failed";
 * If you need support, post the output of 'emerge --info =dev-libs/dbus-glib-0.86',
 * the complete build log and the output of 'emerge -pqv =dev-libs/dbus-glib-0.86'.
 * The complete build log is located at '/var/tmp/portage/dev-libs/dbus-glib-0.86/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/dev-libs/dbus-glib-0.86/temp/environment'.
 * S: '/var/tmp/portage/dev-libs/dbus-glib-0.86/work/dbus-glib-0.86'

Did I forget about something when following the handbook?

emerge --info:
Portage 2.2_rc67 (default/linux/amd64/10.0/desktop/kde, gcc-4.4.4, glibc-2.11.2-r0, x86_64)
System uname: Linux-
Timestamp of tree: Sat, 07 Aug 2010 09:05:02 +0000
app-shells/bash:     4.1_p7
dev-lang/python:     2.6.5-r3, 3.1.2-r4
sys-apps/baselayout: 2.0.1
sys-apps/openrc:     0.6.1-r1
sys-apps/sandbox:    2.2
sys-devel/autoconf:  2.65-r1
sys-devel/automake:  1.9.6-r3, 1.10.3, 1.11.1
sys-devel/binutils:  2.20.1-r1
sys-devel/gcc:       4.4.4-r1
sys-devel/gcc-config: 1.4.1
sys-devel/libtool:   2.2.10
virtual/os-headers:  2.6.34
ACCEPT_KEYWORDS="amd64 ~amd64"
CFLAGS="-O2 -march=native -pipe -g"
CONFIG_PROTECT="/etc /usr/share/X11/xkb /usr/share/config"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-O2 -march=native -pipe -g"
FEATURES="assume-digests distlocks fixpackages news parallel-fetch preserve-libs protect-owned sandbox sfperms splitdebug strict unmerge-logs unmerge-orphans userfetch"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
USE="X Xaw3d a52 aac aalib acl acpi alsa amd64 amr amrnb amrwb async audiofile automount bash-completion berkdb bfq bineditor bluetooth branding bzip2 cairo cdaudio cddb cdio cdparanoia cdr cli consolekit cracklib crypt css cups curl cxx dbus devhelp dirac disk-partition divx djvu dri dts dvd dvdr editor emboss emovix enca encode exchange exif faac faad fam fat ffmpeg fftw firefox firefox3 flac fontconfig fortran gd gdbm geoip gif glitz gmedia gphoto2 gpm gtk hal hddtemp htmlhandbook iconv id3 id3tag imagemagick inotify ipod jack jpeg kde kde4 kdehiddenvisibility kipi kpathsea kqemu ladspa lame laptop lcms libcaca libnotify libsamplerate lm_sensors mad mikmod mjpeg mmap mmx mmxext mng modules mp3 mp3tunes mp4 mpeg mplayer mtp mudflap multilib musicbrainz ncurses nls nptl nptlonly nsplugin ntfs ogg openal opencore-amr opencore-amrnb opencore-amrwb opengl openmp pam pango pch pcre pdf perl plasma png policykit ppds pppd python qt-copy qt3 qt3support qt4 rar readline realmedia reflection roe sasl scanner schroedinger sdl secure-delete sensord session sndfile solver soundtouch sourceview spell spl sse sse2 ssl ssse3 startup-notification svg swat symlink sysfs syslog tcpd theora threads tiff truetype unicode upnp usb vamp vcd vorbis webkit wicd wmf wmp wxwidgets wxwindows x264 xcb xcomposite xine xml xorg xscreensaver xulrunner xv xvid xvmc zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="evdev synaptics" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="pl" QEMU_SOFTMMU_TARGETS="x86_64 i386" QEMU_USER_TARGETS="x86_64 i386" RUBY_TARGETS="ruby18" USERLAND="GNU" VIDEO_CARDS="intel" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"

Back to top
View user's profile Send private message

Joined: 21 Jun 2004
Posts: 2150

PostPosted: Sat Aug 07, 2010 1:37 pm    Post subject: Reply with quote

Do you use the sysresc-cd as install medium? If yes, this should help:
Back to top
View user's profile Send private message

Joined: 19 Jul 2005
Posts: 356
Location: Wroclaw, Poland

PostPosted: Sat Aug 07, 2010 1:49 pm    Post subject: Reply with quote

Thanks, I'll try. What is 'path' anyway? It's not the same as 'PATH', right?

EDIT: it worked, thanks ;]

Still, I'd like to know what this variable does. Google isn't much help since it's search is not case-sensitive...
Back to top
View user's profile Send private message

Joined: 21 Jun 2004
Posts: 2150

PostPosted: Sat Aug 07, 2010 3:53 pm    Post subject: Reply with quote

What is 'path' anyway?
Sorry, can't help you with that.

I had a problem which was based on the same bug last year:

The first occurance I could find is stated in this post:

So, over 1 year old and still not fixed, sucks :(

Edit, if you're ok with the solution, please don't forget to add '[solved]' to the title, thanks.
Back to top
View user's profile Send private message

Joined: 11 Aug 2013
Posts: 1
Location: Somwhere out there

PostPosted: Wed Aug 14, 2013 4:52 am    Post subject: still an issue Reply with quote

So, over 1 year old and still not fixed, sucks
4 years later this is still an issue but this post helped by doing
unset path

Thanks , SouthernC
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Installing Gentoo All times are GMT
Page 1 of 1

Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum