Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Problema Xorg e net-nds/openldap-2.4.19-r1
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian)
View previous topic :: View next topic  
Author Message
soeca
n00b
n00b


Joined: 24 Jun 2009
Posts: 57

PostPosted: Fri Jul 30, 2010 1:06 pm    Post subject: Problema Xorg e net-nds/openldap-2.4.19-r1 Reply with quote

Ragazzi ho finito di installare Gentoo e ora vorre mettere un WM come GNOME....volevo però partire da Xorg(anche per vedere se i driver video Intel funzionano correttamente o, come nella prima volta che ho installato gentoo, non funzionano!!) quindi ho scritto
Code:
 emerge xorg-server
ma mi restituisce:
Code:
>>> Emerging (1 of 139) net-nds/openldap-2.4.19-r1
openpty failed: 'out of pty devices'
 * openldap-2.4.19.tgz RMD160 SHA1 SHA256 size ;-) ...                   [ ok ]
 * checking ebuild checksums ;-) ...                                     [ ok ]
 * checking auxfile checksums ;-) ...                                    [ ok ]
 * checking miscfile checksums ;-) ...                                   [ ok ]
 * CPV:  net-nds/openldap-2.4.19-r1
 * REPO: gentoo
 * USE:  berkdb crypt cxx elibc_glibc ipv6 kernel_linux minimal perl ssl tcpd userland_GNU x86
 * ERROR: net-nds/openldap-2.4.19-r1 failed:
 *   To build the ldapc++ library you must emerge openldap with sasl support
 *
 * Call stack:
 *                   ebuild.sh, line  54:  Called pkg_setup
 *   openldap-2.4.19-r1.ebuild, line 206:  Called die
 * The specific snippet of code:
 *         die "To build the ldapc++ library you must emerge openldap with sasl support"
 *
 * If you need support, post the output of 'emerge --info =net-nds/openldap-2.4.19-r1',
 * the complete build log and the output of 'emerge -pqv =net-nds/openldap-2.4.19-r1'.
 * The complete build log is located at '/var/tmp/portage/net-nds/openldap-2.4.19-r1/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/net-nds/openldap-2.4.19-r1/temp/die.env'.
 * S: '/var/tmp/portage/net-nds/openldap-2.4.19-r1/work/openldap-2.4.19'

>>> Failed to emerge net-nds/openldap-2.4.19-r1, Log file:

>>>  '/var/tmp/portage/net-nds/openldap-2.4.19-r1/temp/build.log'

 * Messages for package net-nds/openldap-2.4.19-r1:

 * ERROR: net-nds/openldap-2.4.19-r1 failed:
 *   To build the ldapc++ library you must emerge openldap with sasl support
 *
 * Call stack:
 *                   ebuild.sh, line  54:  Called pkg_setup
 *   openldap-2.4.19-r1.ebuild, line 206:  Called die
 * The specific snippet of code:
 *         die "To build the ldapc++ library you must emerge openldap with sasl support"
 *
 * If you need support, post the output of 'emerge --info =net-nds/openldap-2.4.19-r1',
 * the complete build log and the output of 'emerge -pqv =net-nds/openldap-2.4.19-r1'.
 * The complete build log is located at '/var/tmp/portage/net-nds/openldap-2.4.19-r1/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/net-nds/openldap-2.4.19-r1/temp/die.env'.
 * S: '/var/tmp/portage/net-nds/openldap-2.4.19-r1/work/openldap-2.4.19'
se vado a controllare il file "build.log mi compare:
Code:
 ^[[32;01m*^[[0m CPV:  net-nds/openldap-2.4.19-r1
 ^[[32;01m*^[[0m REPO: gentoo
 ^[[32;01m*^[[0m USE:  berkdb crypt cxx elibc_glibc ipv6 kernel_linux minimal perl ssl tcpd userland_GNU x86
 ^[[31;01m*^[[0m ERROR: net-nds/openldap-2.4.19-r1 failed:
 ^[[31;01m*^[[0m   To build the ldapc++ library you must emerge openldap with sasl support
 ^[[31;01m*^[[0m
 ^[[31;01m*^[[0m Call stack:
 ^[[31;01m*^[[0m                   ebuild.sh, line  54:  Called pkg_setup
 ^[[31;01m*^[[0m   openldap-2.4.19-r1.ebuild, line 206:  Called die
 ^[[31;01m*^[[0m The specific snippet of code:
 ^[[31;01m*^[[0m                die "To build the ldapc++ library you must emerge openldap with sasl support"
 ^[[31;01m*^[[0m
 ^[[31;01m*^[[0m If you need support, post the output of 'emerge --info =net-nds/openldap-2.4.19-r1',
 ^[[31;01m*^[[0m the complete build log and the output of 'emerge -pqv =net-nds/openldap-2.4.19-r1'.
 ^[[31;01m*^[[0m The complete build log is located at '/var/tmp/portage/net-nds/openldap-2.4.19-r1/temp/build.log'.
 ^[[31;01m*^[[0m The ebuild environment file is located at '/var/tmp/portage/net-nds/openldap-2.4.19-r1/temp/die.env'.
 ^[[31;01m*^[[0m S: '/var/tmp/portage/net-nds/openldap-2.4.19-r1/work/openldap-2.4.19'

Non capisco sinceramente cosa vuole sto programma net-nds/openldap-2.4.19-r1 !!!Come mai fallisce subito l'installazione??
Back to top
View user's profile Send private message
cloc3
Advocate
Advocate


Joined: 13 Jan 2004
Posts: 4670
Location: http://www.gentoo-users.org/user/cloc3/

PostPosted: Fri Jul 30, 2010 1:18 pm    Post subject: Reply with quote

prova a chiamare il comando:
USE="-ldap" emerge -pv -uDN xorg-server
e fai sapere se prevede lo stesso la compilazione di openldap.
_________________
vu vu vu
gentù
mi piaci tu
Back to top
View user's profile Send private message
soeca
n00b
n00b


Joined: 24 Jun 2009
Posts: 57

PostPosted: Fri Jul 30, 2010 1:24 pm    Post subject: Reply with quote

questo è l'output:
Code:
(chroot) ubuntu / # USE="-ldap" emerge -pv -uDN xorg-server

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild     U ] sys-libs/glibc-2.11.2 [2.10.1-r1] USE="nls -debug -gd -glibc-omitfp (-hardened) (-multilib) -profile (-selinux) -vanilla" 15,996 kB
[ebuild     U ] dev-libs/expat-2.0.1-r3 [2.0.1-r2] 436 kB
[ebuild   R   ] virtual/libintl-0  ELIBC="(glibc%*) (-uclibc)" 0 kB
[ebuild     U ] sys-devel/gnuconfig-20100122 [20090819] 563 kB
[ebuild   R   ] virtual/libiconv-0  ELIBC="(glibc%*) (-uclibc)" 0 kB
[ebuild     U ] sys-libs/timezone-data-2010j [2009u] USE="nls" 373 kB
[ebuild     U ] sys-devel/autoconf-wrapper-8 [7] 0 kB
[ebuild     U ] dev-libs/libffi-3.0.9 [3.0.8] USE="-debug -static-libs -test" 715 kB
[ebuild     U ] app-shells/bash-4.0_p37 [4.0_p35] USE="net nls -afs -bashlogger -examples -mem-scramble -plugins -vanilla" 6,172 kB
[ebuild     U ] dev-libs/mpfr-2.4.2_p3 [2.4.1_p5] 1,053 kB
[ebuild  N    ] dev-java/java-config-wrapper-0.16  0 kB
[ebuild  N    ] app-arch/unzip-6.0-r1  USE="bzip2 unicode" 0 kB
[ebuild  N    ] virtual/eject-0  0 kB
[ebuild  N    ] sys-apps/usbutils-0.86-r1  USE="zlib -network-cron" 0 kB
[ebuild  N    ] media-libs/tiff-3.9.4  USE="cxx jpeg zlib -jbig -static-libs" 0 kB
[ebuild  N    ] media-libs/lcms-1.19  USE="jpeg python tiff zlib" 0 kB
[ebuild  N    ] x11-base/xorg-drivers-1.7  INPUT_DEVICES="evdev synaptics -acecad -aiptek -fpit -joystick -keyboard -mouse -penmount -tslib -virtualbox -vmmouse -void -wacom" VIDEO_CARDS="intel -apm -ark -ast -chips -cirrus -dummy -epson -fbdev -fglrx -geode -glint -i128 -i740 (-impact) -mach64 -mga -neomagic (-newport) -nouveau -nv -nvidia -r128 -radeon -radeonhd -rendition -s3 -s3virge -savage -siliconmotion -sis -sisusb (-sunbw2) (-suncg14) (-suncg3) (-suncg6) (-sunffb) (-sunleo) (-suntcx) -tdfx -tga -trident -tseng -v4l -vesa -via -virtualbox -vmware (-voodoo) -xgi" 0 kB
[ebuild     U ] sys-devel/autoconf-2.65 [2.63-r1] USE="-emacs" 1,302 kB
[ebuild  N    ] dev-perl/XML-Parser-2.36-r1  0 kB
[ebuild  N    ] dev-lang/nasm-2.08.01  USE="-doc" 0 kB
[ebuild     U ] sys-libs/readline-6.1 [6.0_p4] 2,209 kB
[ebuild  N    ] x11-libs/pixman-0.18.2  USE="(-altivec) -mmx -sse2 -static-libs" 0 kB
[ebuild  N    ] media-libs/audiofile-0.2.7  0 kB
[ebuild  N    ] app-text/sgml-common-0.6.3-r5  0 kB
[ebuild  N    ] dev-libs/libatomic_ops-1.2-r1  0 kB
[ebuild  N    ] media-libs/speex-1.2_rc1  USE="ogg -sse" 0 kB
[ebuild  N    ] media-libs/libvorbis-1.3.1  USE="-static-libs" 0 kB
[ebuild  N    ] media-libs/libmng-1.0.10  USE="lcms" 0 kB
[ebuild  N    ] dev-db/sqlite-3.6.23.1  USE="fts3 readline threadsafe -debug -doc -extensions -icu -secure-delete -soundex -tcl -test" 0 kB
[ebuild  N    ] sys-devel/bc-1.06.95  USE="readline -libedit -static" 284 kB
[ebuild     U ] dev-libs/openssl-0.9.8o [0.9.8l-r2] USE="zlib -bindist -gmp -kerberos -sse2 -test" 3,685 kB
[ebuild  N    ] net-misc/curl-7.20.0-r2  USE="ipv6 ssl -ares -gnutls -idn -kerberos -ldap -libssh2 -nss -test" 0 kB
[ebuild  N    ] gnome-extra/gnome-audio-2.22.2  USE="-debug" 0 kB
[ebuild     U ] app-admin/python-updater-0.8 [0.7-r1] 8 kB
[ebuild  N    ] app-admin/gamin-0.1.10  0 kB
[ebuild  N    ] dev-util/intltool-0.41.1  0 kB
[ebuild  N    ] app-admin/eselect-xvmc-0.1  0 kB
[ebuild  N    ] app-admin/eselect-esd-20060719  0 kB
[ebuild     U ] sys-devel/binutils-2.20.1-r1 [2.18-r3] USE="nls -multislot -multitarget -test -vanilla" 17,106 kB
[ebuild  N    ] x11-proto/recordproto-1.14  0 kB
[ebuild  N    ] dev-libs/libpthread-stubs-0.1  USE="-debug" 0 kB
[ebuild  N    ] x11-proto/xineramaproto-1.2  0 kB
[ebuild  N    ] x11-libs/libpciaccess-0.11.0  USE="zlib -debug -minimal" 0 kB
[ebuild  N    ] x11-proto/resourceproto-1.1.0  0 kB
[ebuild  N    ] x11-proto/trapproto-3.4.3  0 kB
[ebuild  N    ] x11-proto/bigreqsproto-1.1.0  0 kB
[ebuild  N    ] x11-proto/scrnsaverproto-1.2.0  0 kB
[ebuild  N    ] x11-apps/rgb-1.0.3  USE="-debug" 0 kB
[ebuild  N    ] x11-proto/xf86rushproto-1.1.2  0 kB
[ebuild  N    ] x11-proto/xcmiscproto-1.2.0  0 kB
[ebuild  N    ] x11-misc/makedepend-1.0.2  USE="-debug" 0 kB
[ebuild  N    ] x11-proto/fontcacheproto-0.1.3  0 kB
[ebuild  N    ] x11-proto/xf86miscproto-0.9.3  0 kB
[ebuild  N    ] x11-proto/xf86bigfontproto-1.2.0  0 kB
[ebuild  N    ] x11-libs/libdrm-2.4.20-r1  USE="-debug" 0 kB
[ebuild  N    ] dev-libs/glib-2.22.5  USE="fam -debug -doc -hardened (-selinux) -xattr" 0 kB
[ebuild  N    ] app-admin/gam-server-0.1.10  USE="-debug" 0 kB
[ebuild  N    ] dev-libs/liboil-0.3.17  USE="examples -doc -test" 0 kB
[ebuild  N    ] dev-util/desktop-file-utils-0.16  USE="-emacs" 0 kB
[ebuild  N    ] x11-libs/qt-core-4.6.2-r1  USE="exceptions glib iconv qt3support ssl (-aqua) -debug -doc -optimized-qmake -pch" 156,838 kB
[ebuild  N    ] x11-libs/qt-script-4.6.2  USE="exceptions iconv (-aqua) -debug -pch" 0 kB
[ebuild  N    ] x11-libs/qt-sql-4.6.2  USE="exceptions iconv qt3support sqlite (-aqua) -debug -firebird -mysql -odbc -pch -postgres" 0 kB
[ebuild     U ] sys-devel/gettext-0.17-r1 [0.17] USE="acl nls openmp -doc -emacs -nocxx" 11,369 kB
[ebuild     U ] sys-apps/util-linux-2.17.2 [2.16.2] USE="crypt nls perl unicode -loop-aes -old-linux (-selinux) -slang (-uclibc)" 3,727 kB
[ebuild     U ] sys-apps/acl-2.2.49 [2.2.47] USE="nls (-nfs)" 355 kB
[ebuild     U ] sys-apps/findutils-4.4.2 [4.4.0] USE="nls (-selinux) -static" 2,100 kB
[ebuild     U ] sys-devel/bison-2.4.1 [2.3] USE="nls -static" 1,434 kB
[ebuild     U ] dev-libs/popt-1.16 [1.15] USE="nls" 687 kB
[ebuild  N    ] dev-libs/libgpg-error-1.7  USE="nls -common-lisp" 0 kB
[ebuild  N    ] media-libs/flac-1.2.1-r3  USE="cxx ogg -3dnow (-altivec) -debug -doc -sse" 0 kB
[ebuild  N    ] dev-libs/atk-1.28.0  USE="-debug -doc" 0 kB
[ebuild     U ] sys-libs/e2fsprogs-libs-1.41.11 [1.41.9] USE="nls" 479 kB
[ebuild     U ] sys-fs/udev-151-r4 [146-r1] USE="extras* -devfs-compat* -old-hd-rules% (-selinux) -test%" 0 kB
[ebuild     U ] sys-apps/coreutils-8.5 [7.5-r1] USE="acl nls unicode%* -caps -gmp (-selinux) -static -vanilla -xattr" 10,494 kB
[ebuild  NS   ] sys-devel/gcc-4.4.3-r2 [4.3.4] USE="fortran gtk mudflap nls nptl openmp (-altivec) -bootstrap -build -doc (-fixed-point) -gcj -graphite (-hardened) (-libffi) (-multilib) -multislot (-n32) (-n64) -nocxx -objc -objc++ -objc-gc -test -vanilla" 61,486 kB
[ebuild  N    ] dev-libs/libgcrypt-1.4.5  0 kB
[ebuild  N    ] media-libs/libsndfile-1.0.21  USE="alsa -minimal -sqlite" 0 kB
[ebuild  N    ] dev-libs/libtasn1-2.7  USE="-doc" 0 kB
[ebuild  N    ] dev-libs/libIDL-0.8.14  USE="-debug" 418 kB
[ebuild     U ] app-admin/eselect-1.2.10 [1.2.9] USE="bash-completion* -doc" 153 kB
[ebuild  N    ] sys-fs/lvm2-2.02.67-r2  USE="lvm1 readline static -clvm (-cman) (-selinux)" 873 kB
[ebuild  N    ] gnome-base/orbit-2.14.18  USE="-doc" 731 kB
[ebuild     U ] app-admin/eselect-python-20100321 [20091230] 6 kB
[ebuild  N    ] sys-fs/cryptsetup-1.1.2  USE="nls -dynamic (-selinux)" 468 kB
[ebuild  NS   ] dev-lang/python-3.1.2-r3 [2.6.4] USE="gdbm ipv6 ncurses readline ssl threads (wide-unicode) xml -build -doc -examples -sqlite -tk -wininst" 9,558 kB
[ebuild  N    ] dev-java/java-config-2.1.11  0 kB
[ebuild  N    ] dev-python/setuptools-0.6.13  297 kB
[ebuild  N    ] app-text/iso-codes-3.10  0 kB
[ebuild     U ] dev-libs/libxml2-2.7.7 [2.7.3-r2] USE="ipv6 python readline -debug -doc -examples -test" 4,755 kB
[ebuild  N    ] dev-libs/libxslt-1.1.26  USE="crypt python -debug" 0 kB
[ebuild  N    ] media-libs/gstreamer-0.10.29  USE="nls -test" 0 kB
[ebuild  N    ] x11-misc/shared-mime-info-0.71  0 kB
[ebuild  N    ] app-text/docbook-xml-dtd-4.3-r1  0 kB
[ebuild  N    ] dev-libs/xmlrpc-c-1.18.02  USE="cgi curl cxx -abyss -threads -tools" 0 kB
[ebuild  N    ] dev-util/gtk-doc-am-1.13  0 kB
[ebuild  N    ] media-libs/gst-plugins-base-0.10.29  USE="nls -debug" 2,297 kB
[ebuild     U ] dev-lang/python-2.6.5-r2 [2.6.4] USE="berkdb gdbm ipv6 ncurses readline ssl threads (wide-unicode) xml -build -doc -examples -sqlite -tk -wininst" 10,903 kB
[ebuild  N    ] x11-libs/libxcb-1.6  USE="-doc (-selinux) -static-libs" 0 kB
[ebuild     U ] sys-libs/cracklib-2.8.16 [2.8.13-r1] USE="nls python" 604 kB
[ebuild  N    ] x11-libs/libX11-1.3.4  USE="ipv6 xcb -doc -static-libs -test" 0 kB
[ebuild  N    ] x11-libs/xcb-util-0.3.6  USE="-debug -test" 0 kB
[ebuild  N    ] x11-libs/libXext-1.1.2  USE="-static-libs" 0 kB
[ebuild  N    ] media-libs/freetype-2.3.12  USE="X -bindist -debug -doc -fontforge -utils" 0 kB
[ebuild  N    ] x11-libs/libXt-1.0.8  USE="-static-libs" 0 kB
[ebuild  N    ] x11-libs/libXrender-0.9.6  USE="-static-libs" 0 kB
[ebuild  N    ] x11-libs/libXfixes-4.0.5  USE="-static-libs" 0 kB
[ebuild  N    ] x11-libs/libxkbfile-1.0.6  USE="-debug" 0 kB
[ebuild  N    ] x11-apps/iceauth-1.0.3  USE="-debug" 0 kB
[ebuild  N    ] x11-apps/xprop-1.1.0  USE="-debug" 0 kB
[ebuild  N    ] x11-libs/libXi-1.3  USE="-debug" 0 kB
[ebuild  N    ] media-libs/giflib-4.1.6-r1  USE="X -rle" 0 kB
[ebuild  N    ] sys-apps/dbus-1.2.24  USE="X -debug -doc (-selinux) -test" 0 kB
[ebuild  N    ] x11-libs/libXmu-1.0.5  USE="ipv6 -debug" 0 kB
[ebuild  N    ] x11-libs/libXrandr-1.3.0  USE="-debug" 0 kB
[ebuild  N    ] x11-apps/xkbcomp-1.1.1  USE="-debug" 0 kB
[ebuild  N    ] x11-libs/libXfont-1.4.2  USE="ipv6 -static-libs" 0 kB
[ebuild  N    ] x11-libs/libXdamage-1.1.3  USE="-static-libs" 0 kB
[ebuild  N    ] x11-libs/libXcursor-1.1.10  USE="-debug" 0 kB
[ebuild  N    ] x11-libs/libxkbui-1.0.2  USE="-debug" 0 kB
[ebuild  N    ] x11-libs/libXres-1.0.4  USE="-debug" 0 kB
[ebuild  N    ] x11-libs/libXv-1.0.5  USE="-debug" 0 kB
[ebuild  N    ] x11-libs/libXxf86vm-1.1.0  USE="-debug" 0 kB
[ebuild  N    ] x11-libs/libXcomposite-0.4.2  USE="-doc -static-libs" 0 kB
[ebuild  N    ] x11-libs/libXxf86misc-1.0.2  USE="-debug" 0 kB
[ebuild  N    ] x11-libs/libXfontcache-1.0.5  USE="-debug" 0 kB
[ebuild  N    ] x11-libs/libXtst-1.1.0  USE="-debug" 0 kB
[ebuild  N    ] dev-libs/dbus-glib-0.86  USE="bash-completion -debug -doc -test" 0 kB
[ebuild  N    ] media-libs/mesa-7.8.2  USE="nptl xcb -debug (-gallium) -motif -pic (-selinux)" VIDEO_CARDS="intel -mach64 -mga -none -nouveau -r128 -radeon -radeonhd -savage -sis -svga -tdfx -via" 0 kB
[ebuild  N    ] x11-apps/xauth-1.0.4  USE="ipv6 -debug" 0 kB
[ebuild  N    ] x11-misc/xkeyboard-config-1.9  0 kB
[ebuild  N    ] x11-libs/libXvMC-1.0.5  USE="-debug" 0 kB
[ebuild  N    ] x11-apps/xrdb-1.0.6  USE="-debug" 0 kB
[ebuild  N    ] x11-libs/qt-dbus-4.6.2  USE="exceptions (-aqua) -debug -pch" 0 kB
[ebuild  N    ] x11-apps/xset-1.1.0  USE="-debug" 0 kB
[ebuild  N    ] x11-apps/xinit-1.2.0-r3  USE="minimal pam -debug" 0 kB
[ebuild  N    ] dev-libs/eggdbus-0.6  USE="largefile -debug -doc -test" 783 kB
[ebuild  N    ] x11-misc/xdg-utils-1.0.2_p20100618  USE="-doc" 298 kB
[ebuild  N    ] virtual/glu-7.0  0 kB
[ebuild  N    ] virtual/opengl-7.0  0 kB
[ebuild  N    ] media-libs/fontconfig-2.8.0  USE="-doc" 1,513 kB
[ebuild  N    ] app-admin/eselect-fontconfig-1.0  0 kB
[ebuild  N    ] dev-java/icedtea6-bin-1.8.0  USE="X alsa -doc -examples -nsplugin -source" 35,774 kB
[ebuild  N    ] x11-libs/libXft-2.1.14  USE="-debug" 283 kB
[ebuild  N    ] virtual/jdk-1.6.0  0 kB
[ebuild  N    ] x11-libs/cairo-1.8.10  USE="X opengl svg xcb (-aqua) -cleartype -debug -directfb -doc -glitz -lcdfilter" 6,944 kB
[ebuild  N    ] virtual/jre-1.6.0  0 kB
[ebuild  N    ] x11-libs/pango-1.26.2  USE="X -debug -doc -test" 1,501 kB
[ebuild  NS   ] sys-libs/db-4.8.30 [4.7.25_p4] USE="java -doc -examples -nocxx -tcl -test" 22,351 kB
[ebuild   R   ] sys-libs/db-4.7.25_p4  USE="java* -doc -examples% -nocxx -tcl -test" 12,835 kB
[ebuild     U ] sys-libs/pam-1.1.1-r2 [1.1.0] USE="berkdb%* cracklib nls -audit -debug (-selinux) -test -vim-syntax" 1,578 kB
[ebuild  N    ] sys-auth/policykit-0.9-r1  USE="bash-completion pam -doc (-selinux) -zsh-completion" 1,225 kB
[ebuild  N    ] sys-libs/libcap-2.17  USE="pam" 0 kB
[ebuild  N    ] net-print/cups-1.3.11-r2  USE="X acl dbus java jpeg pam perl png ppds python ssl tiff -avahi -gnutls -kerberos -ldap -php -samba -slp -static -xinetd -zeroconf" LINGUAS="-de -en -es -et -fr -he -id -it -ja -pl -sv -zh_TW" 3,711 kB
[ebuild  N    ] x11-libs/gtk+-2.18.9  USE="cups jpeg tiff (-aqua) -debug -doc -jpeg2k -test -vim-syntax -xinerama" 17,769 kB
[ebuild  N    ] app-text/ghostscript-gpl-8.71-r1  USE="X cairo cups gtk -bindist -djvu -jpeg2k" LINGUAS="-ja -ko -zh_CN -zh_TW" 24,660 kB
[ebuild  N    ] x11-libs/qt-gui-4.6.2  USE="accessibility cups dbus exceptions glib gtk mng qt3support tiff (-aqua) -debug -nas -nis -pch -raster -xinerama" 0 kB
[ebuild  N    ] x11-libs/qt-qt3support-4.6.2  USE="accessibility exceptions (-aqua) -debug -kde -pch -phonon" 0 kB
[ebuild  N    ] dev-util/cmake-2.6.4-r3  USE="qt4 -emacs -vim-syntax" 3,209 kB
[ebuild  N    ] app-text/poppler-0.12.4-r3  USE="abiword cairo jpeg lcms png qt4 utils xpdf-headers -cjk -debug -doc -exceptions -jpeg2k" 1,636 kB
[ebuild  N    ] sys-auth/polkit-0.96-r1  USE="nls pam -debug -doc -examples -expat" 1,010 kB
[ebuild  N    ] sys-auth/consolekit-0.4.1  USE="pam policykit -debug -doc" 389 kB
[ebuild  N    ] gnome-base/gconf-2.28.1  USE="policykit -debug -doc -ldap" 1,442 kB
[ebuild  N    ] gnome-base/gnome-keyring-2.28.2  USE="pam -debug -doc -test" 2,939 kB
[ebuild     U ] sys-auth/pambase-20100310 [20090620.1-r1] USE="consolekit* cracklib gnome-keyring* sha512 -debug -mktemp -passwdqc (-selinux) -ssh" 3 kB
[ebuild  N    ] net-wireless/bluez-4.66-r1  USE="alsa consolekit cups gstreamer pcmcia usb -caps -debug -old-daemons -test-programs" 968 kB
[ebuild  N    ] sys-apps/hal-0.5.14-r2  USE="X acpi apm consolekit crypt policykit -debug -dell -disk-partition -doc -laptop (-selinux)" 926 kB
[ebuild  N    ] app-misc/hal-info-20090716  136 kB
[ebuild  N    ] media-sound/pulseaudio-0.9.21.1  USE="X alsa asyncns bluetooth caps dbus glib gnome hal ipv6 tcpd udev -avahi -doc -jack -libsamplerate -lirc (-oss) (-system-wide) -test" 1,886 kB
[ebuild  N    ] media-libs/libsdl-1.2.13-r1  USE="X alsa audio joystick opengl pulseaudio video xv -aalib -custom-cflags -dga -directfb -esd -fbcon -ggi -libcaca -nas -oss -svga -tslib -xinerama" 3,295 kB
[ebuild  N    ] x11-base/xorg-server-1.7.6  USE="hal ipv6 kdrive nptl sdl xorg -debug -dmx -minimal -tslib" 4,813 kB
[ebuild  N    ] x11-drivers/xf86-input-synaptics-1.2.1  USE="hal -debug" 289 kB
[ebuild  N    ] x11-drivers/xf86-video-intel-2.9.1  USE="dri -debug" 771 kB
[ebuild  N    ] x11-drivers/xf86-input-evdev-2.4.0  USE="-debug" 300 kB

Total: 173 packages (29 upgrades, 138 new, 3 in new slots, 3 reinstalls), Size of downloads: 485,138 kB

Forse è meglio che riduco le USE Flags nel make.conf????
Back to top
View user's profile Send private message
cloc3
Advocate
Advocate


Joined: 13 Jan 2004
Posts: 4670
Location: http://www.gentoo-users.org/user/cloc3/

PostPosted: Fri Jul 30, 2010 2:11 pm    Post subject: Reply with quote

soeca wrote:

Forse è meglio che riduco le USE Flags nel make.conf????

già. sembra che aggiungere -ldap in make.conf elimini un problema.
a te openldap non serve. è un servizio di autenticazione di rete.

non ti spventare troppo per la lunghezza dell'output.
è normale che un programma come xorg-server si tiri dietro, all prima compilazione, qualche centinaio di pacchetti.

ma perché, anzichè xorg-server, non provi a compilare direttamente gnome-base/gnome?
così, probabilemente, riusciresti a installare in un solo colpo tutto il tuo sistema minimale.
_________________
vu vu vu
gentù
mi piaci tu
Back to top
View user's profile Send private message
cloc3
Advocate
Advocate


Joined: 13 Jan 2004
Posts: 4670
Location: http://www.gentoo-users.org/user/cloc3/

PostPosted: Fri Jul 30, 2010 2:22 pm    Post subject: Reply with quote

quello che non capisco, invece, è perché emerge abbia tentato di installarti openldap come primo dei 139 pacchetti.
non hai ancora le glibc!

forse hai saltato qualcuno dei passaggi consigliati dal manuale?
se tu dovessi incontrare ancora qualche problema prova a dare un emerge -uDN system .
_________________
vu vu vu
gentù
mi piaci tu
Back to top
View user's profile Send private message
soeca
n00b
n00b


Joined: 24 Jun 2009
Posts: 57

PostPosted: Fri Jul 30, 2010 3:24 pm    Post subject: Reply with quote

Allora prima che rispondessi ho fatto le seguenti cose:
Code:
 nano -w /etc/make.conf
ho eliminato praticamente tutte le USE Flags che avevo messo, ho inserito solamente
Code:
 gnome gtk alsa dvd cd
quindi ho riprovato ad installare xorg-server e ora sta installando tutto...dopodichè sono andato a coricarmi(questo + di un'ora fa)e ora che mi sono svegliato lo trovo bello attivo a compilare il 75esimo pacchetto di Xorg!!!A quanto pare c'era qualcosa che non andava nelle mie variabili USE!! :D dimmi/ditemi tu/voi se ho fatto male ad eliminare tutte le variabili USE e inserire solo quelle elencate perchè,si, è vero che sta funzionando,ma è anche vero che prima xorg-server mi dava 139pacchetti da installare mentre ora me ne da 77!!mmmm....la cosa un pò mi puzza!! 8O
Back to top
View user's profile Send private message
publiosulpicio
Apprentice
Apprentice


Joined: 31 Aug 2008
Posts: 150

PostPosted: Fri Jul 30, 2010 3:41 pm    Post subject: Reply with quote

Se vuoi usare gnome e non hai esigenze particolari usa il profilo gnome. Non mettere nessuna use in make.conf, ma dai
Code:

eselect profile list

guarda che numero ha quello di gnome, da me per esempio è il 3, e dai
Code:

eselect profile set 3

Dopo di che aggiorna tutto con
Code:

emerge -avuDN --with-bdeps y world


Se poi in futuro vorrai funzionalità particolari di alcuni pacchetti usa package.use (ti consiglio di farne una cartella, non un file).
Back to top
View user's profile Send private message
cloc3
Advocate
Advocate


Joined: 13 Jan 2004
Posts: 4670
Location: http://www.gentoo-users.org/user/cloc3/

PostPosted: Fri Jul 30, 2010 4:03 pm    Post subject: Reply with quote

soeca wrote:
prima xorg-server mi dava 139pacchetti da installare mentre ora me ne da 77!!

bè. secondo me il modo migliore di usare gentoo è quello di costruirla per aggiunte successiva.
ma ognuno può farsi le proprie opinioni.

io addirittura, ho sempre lavorato con il profilo desktop semplice, aggiungendo a mano le flag che di volta in volta servivano.
adesso, il mio make.conf è una giungla ingestibile.
ma sono contento di avere aggiunto tutti i pezzi quasi uno ad uno, perché conosco la funzione di molti di essi.

p.s.: sappi che esiste un programma apposito per gestire le useFlag che si chiama euse e che si può installare con il pacchetto app-portage/gentoolkit.
_________________
vu vu vu
gentù
mi piaci tu
Back to top
View user's profile Send private message
soeca
n00b
n00b


Joined: 24 Jun 2009
Posts: 57

PostPosted: Sun Aug 01, 2010 8:56 am    Post subject: Reply with quote

Ragazzi heeelp....ho finito di compilare Xorg da Ubuntu quindi vado a riavviare il PC scrivendo da terminale
Code:

exit
umount /mnt/gentoo/boot
umount /mnt/gentoo/proc
umount /mnt/gentoo/dev
umount /mnt/gentoo
reboot
però quando riavvio in fase di caricamento mi dice:
Code:

Waiting for uevents to be processed ...
udev-work[15842]: error opening ATTR{/sys/class/sound/controlC0/../ueven}for writing: No such file or directory       [ok]

Mounting devpts at /dev/pts ...                                                                                                                               [ok]
Checking root filesystem ...
fsck.ext3:No such file or directory while tryng to open /dev/sda3
/dev/sda3:
The superblock could not be read or does not describe a correct ext2 filesystem. If the device is valid and it really
contains an ext2 filesystem (and not swap or ufs or something else),then the superblock is corrupt, and you might
try running e2fsck with an alternate superblock:
       e2fsck -b 8193 <device>
Filesystem couldn't be fixed :(                                                                                                                                [ !! ]
Give root password for maintenance
(or type Control-D to continue):

Quindi metto la password di root e mi compare
Code:
(none) #

così provo a creare la directory(che sembra non avere +) /mnt/gentoo scrivendo
Code:
 mkdir /mnt/gentoo
mkdir:cannot create directory '/mnt/gentoo': Read-only file system

se invece provo a montare la partizione /dev/sda3 mi dice:
Code:

mount: special device /dev/sda3 does not exist

però sembra che la partizione sia montata infatti se do per esempio
Code:
 nano -w /etc/make.conf
mi apre il file make.conf (senza farmelo modificare) che può essere successo???
Back to top
View user's profile Send private message
xdarma
l33t
l33t


Joined: 08 Dec 2003
Posts: 693
Location: tra veneto e friuli (italy)

PostPosted: Sun Aug 01, 2010 9:16 am    Post subject: Reply with quote

soeca wrote:
Ragazzi heeelp....ho finito di compilare Xorg da Ubuntu quindi vado a riavviare il PC scrivendo da terminale
[...cut...]
però quando riavvio in fase di caricamento mi dice:
Code:

Checking root filesystem ...
fsck.ext3:No such file or directory while tryng to open /dev/sda3
/dev/sda3:
The superblock could not be read or does not describe a correct ext2 filesystem. If the device is valid and it really
contains an ext2 filesystem (and not swap or ufs or something else),then the superblock is corrupt, and you might
try running e2fsck with an alternate superblock:
       e2fsck -b 8193 <device>
Filesystem couldn't be fixed :(                                                                                                                                [ !! ]
Give root password for maintenance
(or type Control-D to continue):


Secondo me non è un problema legato a Xorg.
Secondo me non stai nemmeno seguendo il manuale di installazione.

soeca wrote:

però sembra che la partizione sia montata infatti se do per esempio
Code:
 nano -w /etc/make.conf
mi apre il file make.conf (senza farmelo modificare) che può essere successo???

Non è così che verifichi se un filesystem è montato, prova con:
Code:
df -hTx tmpfs

_________________
proud user of faKeDE-4.7.3
Back to top
View user's profile Send private message
soeca
n00b
n00b


Joined: 24 Jun 2009
Posts: 57

PostPosted: Sun Aug 01, 2010 9:29 am    Post subject: Reply with quote

Scusa in base a cosa affermi che non sto seguendo il manuale di installazione???Non è che mi invento i comandi(ne conosco pochi!!)Proprio nel manuale di installazione è scritto che prima di passare a gnome bisogna aver eseguito tutto quello che si trova scritto nella guida alla configurazione di X!Inoltre lo so che con
Code:
 nano -w /etc/make.conf
non verifico se un filesystem è montato....ho scritto quel comando solamente perchè se l'intera partizione sda3 non fosse montata non mi avrebbe fatto aprire il make.conf perchè non l'avrebbe trovato!!Detto ciò ho scritto il omando che mi hai gentilmente postato e mi compare:
Code:

Filesystem              Type                Size      Used          Avail       Use%      Mounted on
rootfs                     rootfs             145G       3.1G         135G        3%              /   
/dev/sda3               ext3               145G       3.1G         135G        3%              /   

df: '/proc/sys/fs/binfmt_misc': No such file or directory

da questo cosa si deduce????
Back to top
View user's profile Send private message
ago
Developer
Developer


Joined: 01 Mar 2008
Posts: 1521
Location: Milan, Italy

PostPosted: Sun Aug 01, 2010 9:30 am    Post subject: Reply with quote

un errore simile mi è capitato quando avevo un fstab non corretto...fai qualche prova.
Back to top
View user's profile Send private message
cloc3
Advocate
Advocate


Joined: 13 Jan 2004
Posts: 4670
Location: http://www.gentoo-users.org/user/cloc3/

PostPosted: Sun Aug 01, 2010 9:33 am    Post subject: Reply with quote

soeca wrote:

Code:

Waiting for uevents to be processed ...
udev-work[15842]: error opening ATTR{/sys/class/sound/controlC0/../ueven}for writing: No such file or directory       [ok]

Mounting devpts at /dev/pts ...                                                                                                                               [ok]
Checking root filesystem ...
fsck.ext3:No such file or directory while tryng to open /dev/sda3
/dev/sda3:
The superblock could not be read or does not describe a correct ext2 filesystem. If the device is valid and it really
contains an ext2 filesystem (and not swap or ufs or something else),then the superblock is corrupt, and you might
try running e2fsck with an alternate superblock:
       e2fsck -b 8193 <device>
Filesystem couldn't be fixed :(                                                                                                                                [ !! ]
Give root password for maintenance
(or type Control-D to continue):

Quindi metto la password di root e mi compare
Code:
(none) #


strano. al punto in cui si blocca, il kernel dovrebbe avere già caricato il programma di init da qualche parte.
addirittura, sembra addirittura che riesca a leggere la password.
quando sei in linea di comando, puoi cercare le partizioni disponibili con cat /proc/partitions, puoi verificare quali siano già montate dal sistema con cat /proc/mounts, puoi verificare lo stato delle partizioni (non montate) con fsck -n /dev/<partizione> e puoi provare a montarle manualmente con mount. in questo modo, dovresti riuscire a farti una ragione del tuo problema che, con tutta probabilità, risiede nella linea di boot.

ma perché non hai aperto un thread nuovo?
_________________
vu vu vu
gentù
mi piaci tu
Back to top
View user's profile Send private message
soeca
n00b
n00b


Joined: 24 Jun 2009
Posts: 57

PostPosted: Sun Aug 01, 2010 9:49 am    Post subject: Reply with quote

Non l'ho aperto perchè il problema è successo subito dopo aver terminato la compilazione di Xorg-server!Se è un problema lo apro un alto topic!!!comunque con
Code:
 
fsck -n /dev/sda3

fsck from util-linux-ng 2.17.2
e2fsck 1.41.11(14-Mar-2010)
fsck.ext3: No such file or directory while trying to open /dev/sda3

The superblock could not be read or does not describe a correct ext2 filesystem. If the device is valid and it really
contains an ext2 filesystem (and not swap or ufs or something else),then the superblock is corrupt, and you might
try running e2fsck with an alternate superblock:
       e2fsck -b 8193 <device>
che è successo???
Back to top
View user's profile Send private message
xdarma
l33t
l33t


Joined: 08 Dec 2003
Posts: 693
Location: tra veneto e friuli (italy)

PostPosted: Sun Aug 01, 2010 10:03 am    Post subject: Reply with quote

soeca wrote:
Scusa in base a cosa affermi che non sto seguendo il manuale di installazione???

Perché continui a usare una live quando dovresti avere già un sistema funzionante.
Capisco che sia difficile usare links per consultare la guida o stamparsi decine di pagine della documentazione, ma provare a fare il boot del sistema "autonomo" ti evita di dedicare ore di compilazione a qualcosa che è "rotto" a monte. In altre parole devi preoccuparti anzitutto di fare il boot correttamente, poi di Xorg, poi di gnome.

IMO

soeca wrote:

Code:

Filesystem              Type                Size      Used          Avail       Use%      Mounted on
rootfs                     rootfs             145G       3.1G         135G        3%              /   
/dev/sda3               ext3               145G       3.1G         135G        3%              /   

df: '/proc/sys/fs/binfmt_misc': No such file or directory

da questo cosa si deduce????

Che non usi google: binfmt_misc
Il link è di wikipedia ed è il primo della lista.
_________________
proud user of faKeDE-4.7.3
Back to top
View user's profile Send private message
cloc3
Advocate
Advocate


Joined: 13 Jan 2004
Posts: 4670
Location: http://www.gentoo-users.org/user/cloc3/

PostPosted: Sun Aug 01, 2010 10:06 am    Post subject: Reply with quote

soeca wrote:
Non l'ho aperto perchè il problema è successo subito dopo aver terminato la compilazione di Xorg-server!Se è un problema lo apro un alto topic!!!comunque con
Code:
 
fsck -n /dev/sda3

fsck from util-linux-ng 2.17.2
e2fsck 1.41.11(14-Mar-2010)
fsck.ext3: No such file or directory while trying to open /dev/sda3

The superblock could not be read or does not describe a correct ext2 filesystem. If the device is valid and it really
contains an ext2 filesystem (and not swap or ufs or something else),then the superblock is corrupt, and you might
try running e2fsck with an alternate superblock:
       e2fsck -b 8193 <device>
che è successo???

xorg-server non centra nulla.
quella segnalata è una corruzione del file-system.

quello che non posso dire è il motivo:

    a. effettivamente la partizione è compromessa e va riformattata.
    b. per qualche motivo il dispositivo indicato da sda3 non corrisponde all'oggetto fisico che pensi tu.

io sarei per la seconda. infatti,
cosa accade se usi fsck da ubuntu?

ascolta anche ago88.
_________________
vu vu vu
gentù
mi piaci tu
Back to top
View user's profile Send private message
soeca
n00b
n00b


Joined: 24 Jun 2009
Posts: 57

PostPosted: Sun Aug 01, 2010 10:28 am    Post subject: Reply with quote

OFF-Topic per xdarma:Il sistema funzionava...avevo già effettuato il boot e come ho scritto in un altro topic solo la connessione a internet non partiva...per questo mi è stato consigliato di usare Ubuntu per installare il rimanente!!E poi non capisco una cosa:" SEMBRA quasi ti dia fastidio che posto gli errori che mi capitano da come hai risposto fino ad ora........" ma allora perchè postare???è come se dovessi giustificarmi di questi ultimi errori!!Se ti ho già detto che la tua deduzione è errata e ho usato la guida....perchè continuare su questa linea!?!Fino ad ora ho solo ricevuto risposte gentili e cortesi che mi hanno dato davvero un grosso aiuto.....e nessuno li ha mai obbligati a rispondere....quindi visto che puoi scegliere se rispondere o meno, visto che sai cosa dovrai scrivermi una volta premuto il tasto rispondi, visto gli ultimi 2 post davvero SIMPATICI......cortesemente non premere quel tasto un'altra volta!! Fine OT.

@cloc3: Da ubuntu non ho alcun problema a montare partizioni ad usare emerge e a fare tutte le modifiche che voglio....ho controllato il fstab e sembra corretto o meglio non è stato minimamente aterato dall'ultima volta che è partito gentoo!

EDIT: e se ricompilassi il kernel???Potrebbe cambiare qualcosa secondo voi???

EDIT2:questo è il mio fstab:
Code:

# /etc/fstab: static file system information.
#
# noatime turns off atimes for increased performance (atimes normally aren't
# needed; notail increases performance of ReiserFS (at the expense of storage
# efficiency).  It's safe to drop the noatime options if you want and to
# switch between notail / tail freely.
#
# The root filesystem should have a pass number of either 0 or 1.
# All other filesystems should have a pass number of 0 or greater than 1.
#

# See the manpage fstab(5) for more information.
#

# <fs>                  <mountpoint>    <type>          <opts>          <dump/pass>

# NOTE: If your BOOT partition is ReiserFS, add the notail option to opts.
/dev/sda1               /boot           ext2            noauto,noatime  1 2
/dev/sda3               /               ext3            noatime         0 1
/dev/sda2               none            swap            sw              0 0
/dev/cdrom              /mnt/cdrom      auto            noauto,ro       0 0
#/dev/fd0               /mnt/floppy     auto            noauto          0 0

# glibc 2.2 and above expects tmpfs to be mounted at /dev/shm for
# POSIX shared memory (shm_open, shm_unlink).
# (tmpfs is a dynamically expandable/shrinkable ramdisk, and will
#  use almost no memory if not populated with files)
shm                     /dev/shm        tmpfs           nodev,nosuid,noexec    0 0
Back to top
View user's profile Send private message
bandreabis
Advocate
Advocate


Joined: 18 Feb 2005
Posts: 2414
Location: イタリアのロディで

PostPosted: Sun Aug 01, 2010 12:54 pm    Post subject: Reply with quote

sda3 o hda3?
_________________
Il numero di post non fa di me un esperto! Anzi!
Back to top
View user's profile Send private message
soeca
n00b
n00b


Joined: 24 Jun 2009
Posts: 57

PostPosted: Sun Aug 01, 2010 1:28 pm    Post subject: Reply with quote

sda3!!!!
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum