Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[ Solved ]segfault in
View unanswered posts
View posts from last 24 hours

Reply to topic    Gentoo Forums Forum Index Gentoo on AMD64
View previous topic :: View next topic  
Author Message

Joined: 20 Jul 2010
Posts: 35

PostPosted: Wed Jul 21, 2010 6:25 am    Post subject: [ Solved ]segfault in Reply with quote

I am getting random segfault with libpyhton, application will crash and the kernel log will show something like this :

Jul 21 14:08:12 [kernel] deluged[13067]: segfault at 10f370f8 ip 00007f1b7ca14f28 sp 00007f1b73c8fa20 error 4 in[7f1b7c98a000+157000]

this problem affect emerge and portage especially e.g.

Jul 21 10:17:31 [kernel] portageq[5562]: segfault at 7fffbb82b178 ip 00007fd89de69f74 sp 00007fffbb82b178 error 4 in[7fd89ddef000+157000]
Jul 21 10:54:31 [kernel] portageq[2215]: segfault at 10839c90 ip 00007f627a16a711 sp 00007fff57139b40 error 4 in[7f627a06a000+157000]
Jul 21 13:29:16 [kernel] portageq[17620]: segfault at 7fffb1787b58 ip 00007f5fbbadaf74 sp 00007fffb1787b58 error 4 in[7f5fbba60000+157000]

This don't look like hardware error as the CPU, motherboard and RAM were changed to try to fix this problem.

emerge --info output is :
Portage (default/linux/amd64/10.0/desktop, gcc-4.4.3, glibc-2.11.2-r0, 2.6.33-gentoo-r2 x86_64)
System uname: Linux-2.6.33-gentoo-r2-x86_64-AMD_Athlon-tm-_II_X4_635_Processor-with-gentoo-1.12.13
Timestamp of tree: Wed, 21 Jul 2010 01:00:01 +0000
app-shells/bash: 4.0_p37
dev-java/java-config: 2.1.11
dev-lang/python: 2.6.5-r2, 3.1.2-r3
dev-util/cmake: 2.8.1-r2
sys-apps/baselayout: 1.12.13
sys-apps/sandbox: 1.6-r2
sys-devel/autoconf: 2.13, 2.65
sys-devel/automake: 1.7.9-r2, 1.8.5-r4, 1.9.6-r3, 1.10.3, 1.11.1
sys-devel/binutils: 2.20.1-r1
sys-devel/gcc: 4.4.3-r2
sys-devel/gcc-config: 1.4.1
sys-devel/libtool: 2.2.6b
virtual/os-headers: 2.6.30-r1
ACCEPT_LICENSE="* -@EULA AdobeFlash-10.1"
CFLAGS="-march=native -O2 -pipe"
CONFIG_PROTECT="/etc /usr/share/X11/xkb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-march=native -O2 -pipe"
FEATURES="assume-digests buildpkg distlocks fixpackages news parallel-fetch protect-owned sandbox sfperms strict unmerge-logs unmerge-orphans userfetch"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
USE="3Dnow 3Dnowext X a52 aac acl acpi alsa amd64 berkdb bluetooth branding bzip2 cairo cdparanoia cdr cjk cli consolekit cracklib crypt cups cxx dbus dri dts dvd dvdr dvdread emboss encode exif fam ffmpeg firefox flac fortran gdbm gif gpm gtk gtk2 hal iconv immqt-bc ipv6 jpeg lcms ldap libnotify mad mikmod mmx mng modules mp3 mp4 mpeg mudflap multilib ncurses nls nptl nptlonly nsplugin ogg opengl openmp pam pango pcre pdf perl png ppds pppd python qt3support readline reflection sdl session spell spl sse sse2 ssl startup-notification svg sysfs tcpd tiff truetype truetype-fonts type1-fonts unicode usb vcd vorbis x264 xcb xml xorg xscreensaver xulrunner xv xvid xvmc zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" RUBY_TARGETS="ruby18" USERLAND="GNU" VIDEO_CARDS="radeon vesa fbdev" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"

Last edited by whywhy on Wed Aug 11, 2010 1:23 am; edited 1 time in total
Back to top
View user's profile Send private message

Joined: 20 Jul 2010
Posts: 35

PostPosted: Fri Jul 30, 2010 12:08 am    Post subject: Reply with quote

I finally track down the problem, it is a hardware issue.

The 3rd core on my brand new AMD x4 635 is faulty, it fails under high load. With the way that process are schedule in linux/unix, this mean jobs will seg fault randomly with no apparent reason like how hot the CPU is running. As long as the job is not running on the faulty core, it will run fine.

I found the problem using the package "cpuburn", more details about cpuburn are here :

I am now running with maxcpus=2 until I can get the rma done.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo on AMD64 All times are GMT
Page 1 of 1

Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum