Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Gnome won't start after upgrading to 2.28 [SOLVED]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
selig
Guru
Guru


Joined: 31 Jul 2005
Posts: 425
Location: Prague, Czech Republic

PostPosted: Wed Jun 16, 2010 11:07 am    Post subject: Gnome won't start after upgrading to 2.28 [SOLVED] Reply with quote

Hello,
I have upgraded Gnome to 2.28 on my desktop and now it won't start. It loads up the background but after that nothing happens. Logging in from another system I can see that there is some problem with dbus:

Code:

top - 13:01:16 up 2 min,  2 users,  load average: 2.42, 0.88, 0.31
Tasks: 109 total,   5 running, 104 sleeping,   0 stopped,   0 zombie
Cpu(s): 84.8%us, 14.9%sy,  0.3%ni,  0.0%id,  0.0%wa,  0.0%hi,  0.0%si,  0.0%st
Mem:   3092028k total,   369376k used,  2722652k free,    27084k buffers
Swap:   497972k total,        0k used,   497972k free,   130944k cached

  PID USER      PR  NI  VIRT  RES  SHR S %CPU %MEM    TIME+  COMMAND
 4163 messageb  20   0 19508 1344  800 R 23.2  0.0   0:20.33 /usr/bin/dbus-daemon --system
 6053 root      20   0 39072 3480 2660 S 17.2  0.1   0:15.92 /usr/libexec/devkit-disks-daemon
 6010 sharn-lu  20   0 25008 6316  668 S  5.6  0.2   0:05.01 /usr/bin/dbus-daemon --fork --print-pid 6 --print-address 9 --session
 5989 sharn-lu  20   0  162m 8424 6736 S  1.3  0.3   0:01.68 gnome-session
 6032 sharn-lu  20   0 38964 3608 2040 S  1.3  0.1   0:00.67 /usr/libexec/gvfsd
 6040 sharn-lu  20   0  362m  26m  15m S  0.7  0.9   0:01.12 nautilus
 6077 root      20   0 54096 3944 3216 S  0.7  0.1   0:00.67 /usr/libexec/polkit-1/polkitd
 8746 sharn-lu  20   0 57392 3244 2656 R  0.7  0.1   0:00.02 /usr/libexec/gvfs-gdu-volume-monitor
    1 root      20   0  3876  668  572 S  0.3  0.0   0:00.20 init [3]
 4226 root      20   0 49076 3384 2428 S  0.3  0.1   0:00.39 /usr/sbin/console-kit-daemon
 5346 root      20   0  706m  43m 6740 S  0.3  1.5   0:02.38 /usr/bin/X :0 -audit 0 -auth /var/gdm/:0.Xauth vt7
 6018 root      20   0 43460 3040 2448 S  0.3  0.1   0:00.28 /usr/libexec/devkit-power-daemon
 8712 root      39  19  9288 1356  868 S  0.3  0.0   0:00.01 /bin/awk ???    function readline() {?              if (use_zcat || use_bzcat || use_lzcat) {???
    2 root      20   0     0    0    0 S  0.0  0.0   0:00.00 [kthreadd]
    3 root      20   0     0    0    0 S  0.0  0.0   0:00.01 [ksoftirqd/0]
    4 root      20   0     0    0    0 S  0.0  0.0   0:00.00 [events/0]
    5 root      20   0     0    0    0 S  0.0  0.0   0:00.00 [khelper]
   10 root      20   0     0    0    0 S  0.0  0.0   0:00.00 [async/mgr]
   74 root      20   0     0    0    0 S  0.0  0.0   0:00.00 [sync_supers]
   76 root      20   0     0    0    0 S  0.0  0.0   0:00.00 [bdi-default]
   78 root      20   0     0    0    0 S  0.0  0.0   0:00.00 [kblockd/0]
   80 root      20   0     0    0    0 S  0.0  0.0   0:00.00 [kacpid]
   81 root      20   0     0    0    0 S  0.0  0.0   0:00.00 [kacpi_notify]
   82 root      20   0     0    0    0 S  0.0  0.0   0:00.00 [kacpi_hotplug]
  186 root      20   0     0    0    0 S  0.0  0.0   0:00.02 [ata/0]
  187 root      20   0     0    0    0 S  0.0  0.0   0:00.00 [ata_aux]
  189 root      20   0     0    0    0 S  0.0  0.0   0:00.00 [kseriod]
  238 root      20   0     0    0    0 S  0.0  0.0   0:00.00 [kswapd0]
  239 root      20   0     0    0    0 S  0.0  0.0   0:00.00 [aio/0]
  321 root      20   0     0    0    0 S  0.0  0.0   0:00.00 [scsi_eh_0]
  324 root      20   0     0    0    0 S  0.0  0.0   0:00.00 [scsi_eh_1]
  363 root      20   0     0    0    0 S  0.0  0.0   0:00.00 [reiserfs/0]


I also tried running revdep-rebuild but it did not help.

In ~/.xsession-errors I get lots and lots of these:

Code:

(nautilus:6040): GVFS-RemoteVolumeMonitor-WARNING **: invoking List() failed for type GProxyVolumeMonitorGdu: org.freedesktop.DBus.Error.NoReply: Message did not receive a reply (timeout by message bus)

(gnome-panel:6039): GVFS-RemoteVolumeMonitor-WARNING **: New owner :1.26 for volume monitor org.gtk.Private.GduVolumeMonitor connected to the bus; seeding drives/volumes/mounts

(gnome-panel:6039): GVFS-RemoteVolumeMonitor-WARNING **: invoking List() failed for type GProxyVolumeMonitorGdu: org.freedesktop.DBus.Error.NoReply: Message did not receive a reply (timeout by message bus)

(gnome-panel:6039): GVFS-RemoteVolumeMonitor-WARNING **: New owner :1.28 for volume monitor org.gtk.Private.GduVolumeMonitor connected to the bus; seeding drives/volumes/mounts

(gnome-panel:6039): GVFS-RemoteVolumeMonitor-WARNING **: invoking List() failed for type GProxyVolumeMonitorGdu: org.freedesktop.DBus.Error.NoReply: Message did not receive a reply (timeout by message bus)

(gnome-panel:6039): GVFS-RemoteVolumeMonitor-WARNING **: New owner :1.30 for volume monitor org.gtk.Private.GduVolumeMonitor connected to the bus; seeding drives/volumes/mounts


Does anyone know what the problem could be? Thank you!


Last edited by selig on Sat Oct 02, 2010 4:39 pm; edited 1 time in total
Back to top
View user's profile Send private message
d2_racing
Bodhisattva
Bodhisattva


Joined: 25 Apr 2005
Posts: 13047
Location: Ste-Foy,Canada

PostPosted: Wed Jun 16, 2010 11:18 am    Post subject: Reply with quote

Hi, did you run this :
Code:

# emerge -av lafilefixer
# emerge -auDNv world
# revdep-rebuild -i
# dispatch-conf
# lafilefixer --justfixit
Back to top
View user's profile Send private message
bornfreethinker
n00b
n00b


Joined: 17 Dec 2007
Posts: 26

PostPosted: Sat Jun 19, 2010 8:15 am    Post subject: Re: Gnome won't start after upgrading to 2.28 Reply with quote

selig wrote:


Does anyone know what the problem could be? Thank you!


i have the same problem. Swich to console e wrote:
Code:
# locale-gen
Back to top
View user's profile Send private message
selig
Guru
Guru


Joined: 31 Jul 2005
Posts: 425
Location: Prague, Czech Republic

PostPosted: Sat Jun 19, 2010 4:25 pm    Post subject: Reply with quote

locale-gen did not help, the only thing I have not tried yet is updating everything with emerge -uDN world... that will take some time to complete but that is probably my only option now so I am going to try it.
Back to top
View user's profile Send private message
selig
Guru
Guru


Joined: 31 Jul 2005
Posts: 425
Location: Prague, Czech Republic

PostPosted: Mon Jul 12, 2010 5:56 am    Post subject: Reply with quote

I have rebuild everything and still no success. :( It must be some configuration glitch, maybe some old config file lying somewhere around the system? Unfortunately logs do not tell me where the problem is.
Back to top
View user's profile Send private message
floc_12
Apprentice
Apprentice


Joined: 28 Jun 2006
Posts: 191

PostPosted: Thu Jul 15, 2010 11:11 am    Post subject: Reply with quote

Hello,

I have the same problem (https://forums.gentoo.org/viewtopic-t-836017.html?sid=b68d5f090c2057081eb09126af714672).

Have you found a solution ?

Thanks
Back to top
View user's profile Send private message
krinn
Watchman
Watchman


Joined: 02 May 2003
Posts: 7071

PostPosted: Thu Jul 15, 2010 2:17 pm    Post subject: Reply with quote

downgrade to dbus 1.2.24 if you are using the 1.3.0
Back to top
View user's profile Send private message
floc_12
Apprentice
Apprentice


Joined: 28 Jun 2006
Posts: 191

PostPosted: Thu Jul 15, 2010 4:37 pm    Post subject: Reply with quote

Thanks Krinn,

my version dbus is already the 1.2.24:

emerge -pv dbus

Quote:
These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild R ] sys-apps/dbus-1.2.24 USE="X -debug -doc (-selinux) -test" 0 kB

Total: 1 package (1 reinstall), Size of downloads: 0 kB


another idea?
Back to top
View user's profile Send private message
krinn
Watchman
Watchman


Joined: 02 May 2003
Posts: 7071

PostPosted: Sat Jul 17, 2010 10:08 am    Post subject: Reply with quote

One of my computer have the same problem as you.

And here's my personal computer that don't have the problem where i plugin an usb key in it
Code:
top
 PID USER      PR  NI  VIRT  RES  SHR S %CPU %MEM    TIME+  COMMAND           
 2562 messageb  20   0  3012 1600  932 S   31  0.1   2:52.36 dbus-daemon       
 3583 root      20   0  5264 2844 2344 S   23  0.1   0:27.04 udisks-daemon     


With it, gnome is taken to its knees (31+23=54% of 8 cores, lol) and is really really slow to respond (unusable), as soon as the usb key is remove, all came back to normal.

And on my other computer (the one that saw same symptoms as you), a webcam and ipod are plugin.

Now considering you also show devkit-disks-daemon+dbus(from user messageb"us") with a kicking 23.2+17.2% cpu usage, i feel that the gnome desktop isn't frozen, but just slow to death.

try USE="-gdu" emerge gvfs -1
you will loose device automounter, but should solve your problem (until a better solve is found -> dbus/udisks bug?)
Back to top
View user's profile Send private message
selig
Guru
Guru


Joined: 31 Jul 2005
Posts: 425
Location: Prague, Czech Republic

PostPosted: Sat Oct 02, 2010 4:39 pm    Post subject: Reply with quote

Re-emerging gvfs with the USE flag gdu disabled solved my issue... and even automounting is still working so I do not know what that feature is good for. :)
Back to top
View user's profile Send private message
wangfei584521
n00b
n00b


Joined: 20 Apr 2010
Posts: 1

PostPosted: Wed Oct 20, 2010 4:13 pm    Post subject: I also come across this problem Reply with quote

This problem confuses me for 5 days,even I am intend to switch OS to Debian.
_________________
I am a linuxer in Wuhan of China,.
Back to top
View user's profile Send private message
jrepetto
n00b
n00b


Joined: 26 Mar 2003
Posts: 40

PostPosted: Tue Oct 26, 2010 8:09 am    Post subject: Reply with quote

Same problem here. As soon as I install a version of gvfs newer than 1.2.3, gnome does not display icons and menus.
Back to top
View user's profile Send private message
ippo
n00b
n00b


Joined: 09 May 2010
Posts: 35
Location: PL

PostPosted: Mon Nov 01, 2010 8:08 am    Post subject: Reply with quote

Hello,
I`ve this problem on my x86 (laptop) too - if I merge gvfs +gdu my gnome won`t start, it start with -gdu, but automount cd-rom and pendrive doesn`t work. Furthermore, i can`t do emerge -avuDN world without -gdu:
Code:

# emerge -avuDN world

These are the packages that would be merged, in order:

Calculating dependencies... done!

emerge: there are no ebuilds built with USE flags to satisfy ">=gnome-base/gvfs-1.6.2[gdu]".
!!! One of the following packages is required to complete your request:
- gnome-base/gvfs-1.6.3 (Change USE: +gdu)
(dependency required by "gnome-base/gnome-2.30.2" [installed])
(dependency required by "world" [argument])


My emerge --info:
Code:

emerge --info
Portage 2.1.8.3 (default/linux/x86/10.0/desktop/gnome, gcc-4.4.4, glibc-2.11.2-r2, 2.6.34-gentoo-r12 i686)
=================================================================
System uname: Linux-2.6.34-gentoo-r12-i686-Intel-R-_Pentium-R-_M_processor_1.70GHz-with-gentoo-1.12.13
Timestamp of tree: Sun, 31 Oct 2010 20:00:01 +0000
distcc 3.1 i686-pc-linux-gnu [disabled]
ccache version 2.4 [disabled]
app-shells/bash:     4.1_p7
dev-java/java-config: 2.1.11
dev-lang/python:     2.6.5-r3, 3.1.2-r4
dev-util/ccache:     2.4-r7
dev-util/cmake:      2.8.1-r2
sys-apps/baselayout: 1.12.13
sys-apps/sandbox:    2.3-r1
sys-devel/autoconf:  2.13, 2.65-r1
sys-devel/automake:  1.9.6-r3, 1.10.3, 1.11.1
sys-devel/binutils:  2.20.1-r1
sys-devel/gcc:       4.4.4-r2
sys-devel/gcc-config: 1.4.1
sys-devel/libtool:   2.2.10
sys-devel/make:      3.81-r2
virtual/os-headers:  2.6.30-r1
ACCEPT_KEYWORDS="x86"
ACCEPT_LICENSE="*"
ACCEPT_PROPERTIES="*"
ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1 emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci"
ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol"
APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias"
ARCH="x86"
AUTOCLEAN="yes"
CBUILD="i686-pc-linux-gnu"
CCACHE_SIZE="2G"
CFLAGS="-O2 -march=pentium-m -pipe -fomit-frame-pointer"
CHOST="i686-pc-linux-gnu"
CLEAN_DELAY="5"
COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog"
COLLISION_IGNORE="/lib/modules"
CONFIG_PROTECT="/etc /usr/share/X11/xkb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CVS_RSH="ssh"
CXXFLAGS="-O2 -march=pentium-m -pipe -fomit-frame-pointer"
DCCC_PATH="/usr/lib/distcc/bin"
DISTCC_LOG=""
DISTCC_VERBOSE=""
DISTDIR="/usr/portage/distfiles"
ELIBC="glibc"
EMERGE_DEFAULT_OPTS="--ask --verbose --keep-going"
EMERGE_WARNING_DELAY="10"
EPREFIX=""
EROOT="/"
FEATURES="assume-digests distlocks fixpackages news parallel-fetch protect-owned sandbox sfperms strict unmerge-logs unmerge-orphans userfetch"
FETCHCOMMAND="/usr/bin/wget -t 5 -T 60 --passive-ftp -O "${DISTDIR}/${FILE}" "${URI}""
GDK_USE_XFT="1"
GENTOO_MIRRORS="http://ftp.vectranet.pl/gentoo/ http://gentoo.mirror.pw.edu.pl/ http://gentoo.prz.rzeszow.pl http://gentoo.po.opole.pl ftp://ftp.vectranet.pl/gentoo/ ftp://gentoo.po.opole.pl http://gentoo.mirror.dkm.cz/pub/gentoo/ http://ftp.fi.muni.cz/pub/linux/gentoo/ http://gentoo.supp.name/ http://gentoo.mirror.web4u.cz/ ftp://gentoo.mirror.web4u.cz/ ftp://ftp.fi.muni.cz/pub/linux/gentoo/ ftp://gentoo.mirror.dkm.cz/pub/gentoo/ ftp://ftp.wh2.tu-dresden.de/pub/mirrors/gentoo"
GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx"
HOME="/root"
INFOPATH="/usr/share/info:/usr/share/binutils-data/i686-pc-linux-gnu/2.20.1/info:/usr/share/gcc-data/i686-pc-linux-gnu/4.4.4/info"
INPUT_DEVICES="evdev keyboard mouse"
KERNEL="linux"
LANG="pl_PL.UTF-8"
LANGUAGE="48"
LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text"
LC_ALL="pl_PL"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
LESS="-R -M --shift 5"
LESSOPEN="|lesspipe.sh %s"
LINGUAS="pl"
LOGNAME="root"
LS_COLORS="rs=0:di=01;34:ln=01;36:mh=00:pi=40;33:so=01;35:do=01;35:bd=40;33;01:cd=40;33;01:or=01;05;37;41:mi=01;05;37;41:su=37;41:sg=30;43:ca=30;41:tw=30;42:ow=34;42:st=37;44:ex=01;32:*.tar=01;31:*.tgz=01;31:*.arj=01;31:*.taz=01;31:*.lzh=01;31:*.lzma=01;31:*.tlz=01;31:*.txz=01;31:*.zip=01;31:*.z=01;31:*.Z=01;31:*.dz=01;31:*.gz=01;31:*.lz=01;31:*.xz=01;31:*.bz2=01;31:*.bz=01;31:*.tbz=01;31:*.tbz2=01;31:*.tz=01;31:*.deb=01;31:*.rpm=01;31:*.jar=01;31:*.rar=01;31:*.ace=01;31:*.zoo=01;31:*.cpio=01;31:*.7z=01;31:*.rz=01;31:*.jpg=01;35:*.jpeg=01;35:*.gif=01;35:*.bmp=01;35:*.pbm=01;35:*.pgm=01;35:*.ppm=01;35:*.tga=01;35:*.xbm=01;35:*.xpm=01;35:*.tif=01;35:*.tiff=01;35:*.png=01;35:*.svg=01;35:*.svgz=01;35:*.mng=01;35:*.pcx=01;35:*.mov=01;35:*.mpg=01;35:*.mpeg=01;35:*.m2v=01;35:*.mkv=01;35:*.ogm=01;35:*.mp4=01;35:*.m4v=01;35:*.mp4v=01;35:*.vob=01;35:*.qt=01;35:*.nuv=01;35:*.wmv=01;35:*.asf=01;35:*.rm=01;35:*.rmvb=01;35:*.flc=01;35:*.avi=01;35:*.fli=01;35:*.flv=01;35:*.gl=01;35:*.dl=01;35:*.xcf=01;35:*.xwd=01;35:*.yuv=01;35:*.cgm=01;35:*.emf=01;35:*.axv=01;35:*.anx=01;35:*.ogv=01;35:*.ogx=01;35:*.pdf=00;32:*.ps=00;32:*.txt=00;32:*.patch=00;32:*.diff=00;32:*.log=00;32:*.tex=00;32:*.doc=00;32:*.aac=00;36:*.au=00;36:*.flac=00;36:*.mid=00;36:*.midi=00;36:*.mka=00;36:*.mp3=00;36:*.mpc=00;36:*.ogg=00;36:*.ra=00;36:*.wav=00;36:*.axa=00;36:*.oga=00;36:*.spx=00;36:*.xspf=00;36:"
MAIL="/var/mail/root"
MAKEOPTS="-j2"
MANPATH="/usr/local/share/man:/usr/share/man:/usr/share/binutils-data/i686-pc-linux-gnu/2.20.1/man:/usr/share/gcc-data/i686-pc-linux-gnu/4.4.4/man:/etc/java-config/system-vm/man/"
NETBEANS="apisupport cnd groovy gsf harness ide identity j2ee java mobility nb php profiler soa visualweb webcommon websvccommon xml"
OPENGL_PROFILE="xorg-x11"
PAGER="/usr/bin/less"
PATH="/bin:/sbin:/usr/bin:/usr/sbin:/usr/local/bin:/usr/local/sbin:/opt/bin"
PHP_TARGETS="php5-2"
PKGDIR="/usr/portage/packages"
PORTAGE_ARCHLIST="ppc x86-openbsd ppc-openbsd ppc64 x86-winnt x86-fbsd ppc-aix alpha arm x86-freebsd s390 amd64 arm-linux x86-macos x64-openbsd ia64-hpux hppa x86-netbsd x86-cygwin amd64-linux ia64-linux x86 sparc-solaris x64-freebsd sparc64-solaris x86-linux x64-macos sparc m68k-mint ia64 mips ppc-macos x86-interix hppa-hpux amd64-fbsd x64-solaris mips-irix m68k sh x86-solaris sparc-fbsd"
PORTAGE_BINHOST_CHUNKSIZE="3000"
PORTAGE_BIN_PATH="/usr/lib/portage/bin"
PORTAGE_COMPRESS_EXCLUDE_SUFFIXES="css gif htm[l]? jp[e]?g js pdf png"
PORTAGE_CONFIGROOT="/"
PORTAGE_DEBUG="0"
PORTAGE_DEPCACHEDIR="/var/cache/edb/dep"
PORTAGE_ELOG_CLASSES="warn error log"
PORTAGE_ELOG_MAILFROM="portage@localhost"
PORTAGE_ELOG_MAILSUBJECT="[portage] ebuild log for ${PACKAGE} on ${HOST}"
PORTAGE_ELOG_MAILURI="root"
PORTAGE_ELOG_SYSTEM="echo save"
PORTAGE_FETCH_CHECKSUM_TRY_MIRRORS="5"
PORTAGE_FETCH_RESUME_MIN_SIZE="350K"
PORTAGE_GID="250"
PORTAGE_INST_GID="0"
PORTAGE_INST_UID="0"
PORTAGE_NICENESS="5"
PORTAGE_PYM_PATH="/usr/lib/portage/pym"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_RSYNC_RETRIES="3"
PORTAGE_SYNC_STALE="30"
PORTAGE_TMPDIR="/var/tmp"
PORTAGE_VERBOSE="1"
PORTAGE_WORKDIR_MODE="0700"
PORTDIR="/usr/portage"
PRELINK_PATH_MASK="/usr/lib/libfreebl3.so:/usr/lib/libnssdbm3.so:/usr/lib/libsoftokn3.so"
PROFILE_ONLY_VARIABLES="ARCH ELIBC KERNEL USERLAND"
PYTHONDONTWRITEBYTECODE="1"
RESUMECOMMAND="/usr/bin/wget -c -t 5 -T 60 --passive-ftp -O "${DISTDIR}/${FILE}" "${URI}""
ROOT="/"
ROOTPATH="/opt/bin:/usr/i686-pc-linux-gnu/gcc-bin/4.4.4"
RPMDIR="/usr/portage/rpm"
RUBY_TARGETS="ruby18"
SHELL="/bin/bash"
SUDO_COMMAND="/usr/bin/emerge --info"
SUDO_GID="1008"
SUDO_UID="1000"
SUDO_USER="filip"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
TERM="xterm"
USE="X a52 aac acl acpi alsa berkdb bluetooth branding bzip2 cairo cdr cli consolekit cracklib crypt cxx dbus dri dts dvd dvdr eds emboss encode evo exif fam firefox flac fortran gdbm gdu gif gnome gnome-keyring gpm gstreamer gtk iconv irda jpeg lcms ldap libnotify mad mikmod mng modules mp3 mp4 mpeg mudflap nautilus ncurses networkmanager nls nptl nptlonly obex ogg opengl openmp pam pango pcre pdf perl png policykit ppds pppd python qt3support readline samba saveconfig sdl session spell ssl startup-notification svg sysfs tcpd tiff truetype unicode usb userlocales vorbis x264 x86 xcb xml xorg xulrunner xv xvid zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1 emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="evdev keyboard mouse" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="pl" PHP_TARGETS="php5-2" RUBY_TARGETS="ruby18" USERLAND="GNU" VIDEO_CARDS="intel vesa" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
USER="root"
USERLAND="GNU"
USERNAME="root"
USE_EXPAND="ALSA_CARDS ALSA_PCM_PLUGINS APACHE2_MODULES APACHE2_MPMS CAMERAS COLLECTD_PLUGINS CROSSCOMPILE_OPTS DVB_CARDS ELIBC FCDSL_CARDS FOO2ZJS_DEVICES FRITZCAPI_CARDS GPSD_PROTOCOLS INPUT_DEVICES KERNEL LCD_DEVICES LINGUAS LIRC_DEVICES MISDN_CARDS NETBEANS_MODULES NGINX_MODULES_HTTP NGINX_MODULES_MAIL PHP_TARGETS QEMU_SOFTMMU_TARGETS QEMU_USER_TARGETS RUBY_TARGETS SANE_BACKENDS USERLAND VIDEO_CARDS XFCE_PLUGINS XTABLES_ADDONS"
USE_EXPAND_HIDDEN="CROSSCOMPILE_OPTS ELIBC KERNEL USERLAND"
USE_ORDER="env:pkg:conf:defaults:pkginternal:env.d"
VIDEO_CARDS="intel vesa"
XDG_CONFIG_DIRS="/etc/xdg"
XDG_DATA_DIRS="/usr/local/share:/usr/share:/usr/share/gdm"
XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
XZ_OPT="--memory=max"



It strange, but in my main frame amd64 gnome works perfectly with +gdu

Somebody help me, please :)

Edit:

Ok, i missed it:
Quote:

try USE="-gdu" emerge gvfs -1


...but automount still doesn`t work; it seems be a bug... Each emerge -avuDN world want merge gvfs with +gdu....

Edit 2:
I could log as another user and as a root 1 shot; the second and next times i can only see wallpaper - there aren`t any menus or icons.

Edit 3:
There aren`t buttons [suspend] & [hibernate] in gdm (suspend & hibernate work in console); when i`ve logged first time as root there buttons existed and worked (automounting not). I guess that it may be dbus problem...
Back to top
View user's profile Send private message
ippo
n00b
n00b


Joined: 09 May 2010
Posts: 35
Location: PL

PostPosted: Wed Nov 03, 2010 5:06 am    Post subject: Reply with quote

Hm, nobody knows?

Is it normal - half working gnome in gentoo stable? ;)

PS. My gnome version is 2.30.2
_________________
Gentoo - compile your own bug!
Back to top
View user's profile Send private message
selig
Guru
Guru


Joined: 31 Jul 2005
Posts: 425
Location: Prague, Czech Republic

PostPosted: Thu Nov 04, 2010 3:12 pm    Post subject: Reply with quote

It is probably normal :( I upgraded two x86 systems recently from an older version of Gnome and one works with +gdu while I had to use the work-around for the other one (-gdu) and it is just half-working, like my own system.
Back to top
View user's profile Send private message
ippo
n00b
n00b


Joined: 09 May 2010
Posts: 35
Location: PL

PostPosted: Fri Nov 05, 2010 9:28 am    Post subject: Reply with quote

selig wrote:
It is probably normal :( I upgraded two x86 systems recently from an older version of Gnome and one works with +gdu while I had to use the work-around for the other one (-gdu) and it is just half-working, like my own system.


Hm, i think that gentoo stable doesn`t exist :(

It is strange, coz on amd64 gnome work perfectly (it may be another USE flags - mainframe hasn`t bluetooth, irda, wifi).


I installed new gentoo (x86) on another partition; Today i haven`t polish locale (perhaps i skiped somthings during installation) but gnome starts with +gdu, automount works and i have buttons for suspend and hibernation (but pm-utils doesn`t work yet).
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum