Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
divx subtitles in top of movie always
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Multimedia
View previous topic :: View next topic  
Author Message
azambuja
Apprentice
Apprentice


Joined: 12 Jul 2002
Posts: 257
Location: Porto Alegre, RS, Brazil

PostPosted: Sat Jul 27, 2002 2:04 am    Post subject: divx subtitles in top of movie always Reply with quote

hello!

im trying to put subtitles in the bottom of the screen (black part of widescreen movies) with mplayer and xine.
Both of them always put the subs on top of the movie...
is there a way i can put the subs in the bottom?

thanx,
cheers
Back to top
View user's profile Send private message
b-llwyd
Guru
Guru


Joined: 24 Jul 2002
Posts: 302
Location: Uppsala, Sweden

PostPosted: Fri Aug 02, 2002 10:08 am    Post subject: subs with mplayer Reply with quote

tip for using subs with mplayer:

First, find out what resolution your movie is played in, then add this to your mplayer command line:

Code:
mplayer [...] -vop expand=720:484:0:0


in this case, the movie I was playing had a resolution of 720x384, but as you notice, I used the numbers 720 and -484- above...that tells mplayer to expand the movie area to a height of 484 instead of 384, which gives us another 100 pixls. the two zero's at the end tells where in this field mplayer should put the original movie - in my case, i put it in the upper left corner (0,0), and thus I will have the extra 100 pxls below the movie. This is where the subtitles should be displayed now. Try it.
Back to top
View user's profile Send private message
zen_guerrilla
Guru
Guru


Joined: 18 Apr 2002
Posts: 343
Location: Greece

PostPosted: Tue Aug 06, 2002 12:55 pm    Post subject: Reply with quote

Also another tip for subtitles with MPlayer, for mplayer's docs :

-subpos <0 - 100>: Specify the position of subtitles.
Back to top
View user's profile Send private message
Mandr4ke
Apprentice
Apprentice


Joined: 25 Jul 2002
Posts: 214
Location: Chicago, IL

PostPosted: Wed Aug 07, 2002 6:30 pm    Post subject: Reply with quote

Hmm MPlayer has that Time Display in the movie window also,, when i try to uncheck it in the options panel.. it's not accessable.. anyway to turn that off so i can enjoy the movie without a counter.. hehe
Back to top
View user's profile Send private message
b-llwyd
Guru
Guru


Joined: 24 Jul 2002
Posts: 302
Location: Uppsala, Sweden

PostPosted: Wed Aug 07, 2002 7:41 pm    Post subject: Reply with quote

Try hitting the 'o' on your keyboard (o as in 'oh'). It will cycle between the three states of On screen display.
Back to top
View user's profile Send private message
azambuja
Apprentice
Apprentice


Joined: 12 Jul 2002
Posts: 257
Location: Porto Alegre, RS, Brazil

PostPosted: Wed Aug 07, 2002 10:50 pm    Post subject: yep, works Reply with quote

hello,
the command line that tells mplayer to put the movie a hundred pixels up works perfectly with me...
thanx for the help,
now i can enjoy all my divx movies without having to boot windows...
sorry for the late response, i was in some "kinda" vacation off the computer :)

cheers
Back to top
View user's profile Send private message
zen_guerrilla
Guru
Guru


Joined: 18 Apr 2002
Posts: 343
Location: Greece

PostPosted: Thu Aug 08, 2002 12:24 pm    Post subject: Reply with quote

Mandr4ke wrote:
Hmm MPlayer has that Time Display in the movie window also,, when i try to uncheck it in the options panel.. it's not accessable.. anyway to turn that off so i can enjoy the movie without a counter.. hehe


Consider putting the following line :
Code:

osdlevel=1   

on your /etc/mplayer.conf
Back to top
View user's profile Send private message
azambuja
Apprentice
Apprentice


Joined: 12 Jul 2002
Posts: 257
Location: Porto Alegre, RS, Brazil

PostPosted: Tue Aug 13, 2002 10:10 pm    Post subject: Reply with quote

hello,

after "playing" with all available movie players around, ive found that:
- the best movie player to watch widescreen divx movies is MPLAYER. And to put the subtitles down a bit (the dark part of the screen) you must run it with the following (for a 720x272 format movie):
mplayer filename.avi -vop expand=720:302:0:0
To check the movie size, run mplayer movie.avi in a terminal window and check the output...
----> always increase the height in 50, to get the proper output, or try other values if you find them better
oh, xine is a good player also, but i didnt find out how to move the subs position...
cheers
Back to top
View user's profile Send private message
Zu`
l33t
l33t


Joined: 26 May 2002
Posts: 716
Location: BE

PostPosted: Tue Aug 13, 2002 10:27 pm    Post subject: Reply with quote

Mandr4ke wrote:
Hmm MPlayer has that Time Display in the movie window also,, when i try to uncheck it in the options panel.. it's not accessable.. anyway to turn that off so i can enjoy the movie without a counter.. hehe


Press 'o'
Back to top
View user's profile Send private message
Zu`
l33t
l33t


Joined: 26 May 2002
Posts: 716
Location: BE

PostPosted: Tue Aug 13, 2002 10:29 pm    Post subject: Reply with quote

When I try to load subtitles with mplayer in X I always get an error that it couldn't load the subtitles. (It are mostly *.sub files)

However when I try loading the movie with subs in console with fbdev it usually just loads fine.

Any ideas on how to fix this?
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Multimedia All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum