Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
(SOLVED) Can't boot any iso's on Ultra 5.
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Gentoo on Sparc
View previous topic :: View next topic  
Author Message
chris_andrew
Apprentice
Apprentice


Joined: 19 Sep 2004
Posts: 271
Location: Wiltshire, England

PostPosted: Sat Apr 10, 2010 6:20 am    Post subject: (SOLVED) Can't boot any iso's on Ultra 5. Reply with quote

Hi, guys!

I've just taken delivery of a 'new' Ultra 5. It's a while since I've had a Sparc and I'm struggling to boot any iso's. I think this is due to the media I'm using. Can't anyone remind me wht CDs these machines accept. I know they don't do CDRW, but need to know which they will accept, before buying some more.

Can anyone help?

Cheers,

Chris.
_________________
http://www.whylinuxisbetter.net/


Last edited by chris_andrew on Sat Sep 18, 2010 9:21 pm; edited 1 time in total
Back to top
View user's profile Send private message
loxins
n00b
n00b


Joined: 16 Aug 2005
Posts: 19
Location: Iceland

PostPosted: Thu Apr 15, 2010 6:34 am    Post subject: Reply with quote

i did not know you needed special cd media for the ultra5. I've had a few ultra5 and ultra10 some years ago and never had any problems with any cds for booting.
on the other hand, yearlier this year i did have problems booting a cdrom on a sunblade100, i ended up netbooting the machine, by then i had burned at least 10cds of different types and iso-files and no-go.

the sparc netboot guide still works pretty good :)
_________________
skammastu thin svo
Back to top
View user's profile Send private message
chris_andrew
Apprentice
Apprentice


Joined: 19 Sep 2004
Posts: 271
Location: Wiltshire, England

PostPosted: Thu Apr 15, 2010 5:56 pm    Post subject: Reply with quote

loxins,

Thanks for your reply. I'm not familiar with netbooting. Does it involve RARP? One possibility is that when I type

Code:
boot cdrom


that the OBP isn't pointing to my cdrom.

I'll have to Google around to see how I'd check that.

Cheers,

Chris.
_________________
http://www.whylinuxisbetter.net/
Back to top
View user's profile Send private message
loxins
n00b
n00b


Joined: 16 Aug 2005
Posts: 19
Location: Iceland

PostPosted: Thu Apr 15, 2010 9:00 pm    Post subject: Reply with quote

yes it involved the RARP.
here is the netboot guide.
http://www.gentoo.org/doc/en/gentoo-sparc-netboot-howto.xml

and if you have problems with the OPB then this is absolute gold. check your environment varibles and aliases.
http://www.gentoo.org/doc/en/gentoo-sparc-obpreference.xml

I hope you get it up and running, these machines are truly great.
_________________
skammastu thin svo
Back to top
View user's profile Send private message
chris_andrew
Apprentice
Apprentice


Joined: 19 Sep 2004
Posts: 271
Location: Wiltshire, England

PostPosted: Sat Apr 17, 2010 7:58 pm    Post subject: Reply with quote

Thanks, loxins.

I'm still struggling to work out whether my CDROM device is set correctly. I'm struggling a bit with devalias, though. I Googled my CDROM device and it should support the CD's I have, so I think the problem is OBP, not the CD's. I looked at the Gentoo guide and am still stuck, so I'll look at the other links at the end of the Gentoo document.

Fingers crossed.

Chris.
_________________
http://www.whylinuxisbetter.net/
Back to top
View user's profile Send private message
chris_andrew
Apprentice
Apprentice


Joined: 19 Sep 2004
Posts: 271
Location: Wiltshire, England

PostPosted: Sat Apr 17, 2010 8:20 pm    Post subject: Reply with quote

Hmmm, still no luck!

When I do devalias, I notice that I have two entries for cdrom! Is it possible to delete one, as I only have one cdrom device?

Last time I needed to change the cdrom devalias (a couple of years ago), I used a command that allowed me to yank (copy) a device path straight into something like devalias. This meant I didn't miss any characters out. Can anyone remind me what that command me have been?

Cheers,

Chris.
_________________
http://www.whylinuxisbetter.net/
Back to top
View user's profile Send private message
chris_andrew
Apprentice
Apprentice


Joined: 19 Sep 2004
Posts: 271
Location: Wiltshire, England

PostPosted: Fri Apr 23, 2010 7:54 am    Post subject: Reply with quote

Well I now have one devalias for cdrom, so that's better. Unfortunately I am still no further forward than this. Can anyone give me a step-by-step guide to seeing how my cdrom is identified (or where) and then help me to associate that location with the cdrom alias. I've done and un-done this so many times, that I have got myself confused, now. Failing this, I may need to do the RARP thing which looks intimidating.

Cheers,

Chris.
_________________
http://www.whylinuxisbetter.net/
Back to top
View user's profile Send private message
loxins
n00b
n00b


Joined: 16 Aug 2005
Posts: 19
Location: Iceland

PostPosted: Fri Apr 23, 2010 10:02 pm    Post subject: Reply with quote

dear chris,

you have my sympathy.

i know this can be a pain.

is your cdrom connected as master or slave settings ? default settings are that it is as master on the secondary controller, if i remember correctly. maybe your settings are not so default anymore :) it would be great if it would solve your problem to change the cable order in your box.

shame i dont have my ultra10 no more. and i cannot access the opb on my sunblade to check the device parameters because its always on :D

how does your devalias look like ?

you shouldn't be intimidated by rarp. in my opinion it a lot easier work then the opm. probably the easiest way for you is to boot the tftpimage via windows.
_________________
skammastu thin svo
Back to top
View user's profile Send private message
chris_andrew
Apprentice
Apprentice


Joined: 19 Sep 2004
Posts: 271
Location: Wiltshire, England

PostPosted: Sat Apr 24, 2010 7:16 am    Post subject: Reply with quote

Really sorry, guys. I just burned another cd-r and it booted first time. Rather than suspecting the good old Ultra was at fault, I forgot that the problem could be between the keyboard and seat (me). Thanks for all the replies.

Cheers,

Chris.
_________________
http://www.whylinuxisbetter.net/
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo on Sparc All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum