Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
radeon hd 5770
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
legit
Apprentice
Apprentice


Joined: 04 Jan 2006
Posts: 216
Location: Denver, CO

PostPosted: Tue Mar 23, 2010 11:57 pm    Post subject: radeon hd 5770 Reply with quote

Hey all,

I am installing gentoo and was wondering if someone could help me in knowing what kernel options I need to support my radeon hd 5770?

Also, can i install the standard xorg server from portage or will I need a custom version one. looking at the ati driver it looks like only xorg 6.7-7.4.

Any other tips you have for this card would be greatly appreciated.
Back to top
View user's profile Send private message
disi
Veteran
Veteran


Joined: 28 Nov 2003
Posts: 1354
Location: Out There ...

PostPosted: Wed Mar 24, 2010 11:59 am    Post subject: Reply with quote

you have to know which driver you want to use, before you install the xorg-server

radeon = open source, fast desktop, kms, no 3D acceleration yet, no crossfire yet, works with >=xorg-server-1.7
fglrx = binary, slaggy desktop for me, no kms, 3D acceleration, crossfire, works with <=xorg-server-1.6.5

For your kernel that means:
in device drivers -> graphics support
radeon = use the drm, kms default, install and use the AMD firmware (radeon-ucode)
fglrx = don't use drm or something, you can use uvesafb or something for console resolution, backgrounds etc.

Those are my personal experiences, if someone knows better, go ahead :)

//edit: if you use the x11 overlay and the prerelease of radeon 6.13, it can change every day. With kernel 2.6.34 we would get dri2 as far as I read...
_________________
Gentoo on Uptime Project - Larry is a cow
Back to top
View user's profile Send private message
hedmo
l33t
l33t


Joined: 29 Aug 2009
Posts: 943
Location: halmstad

PostPosted: Wed Mar 24, 2010 3:29 pm    Post subject: Reply with quote

If you use fglrx you can put away all in your kernel
but you cant use xorg 1.7.5 and need à mask filé to emerge xorg
Back to top
View user's profile Send private message
chithanh
Developer
Developer


Joined: 05 Aug 2006
Posts: 2152
Location: Berlin, Germany

PostPosted: Wed Mar 24, 2010 5:14 pm    Post subject: Reply with quote

ati-drivers-10.2 will work with the current stable xorg-server-1.6.5 but not with 1.7
ati-drivers-8.721 is a beta release which will also work with 1.7

The open source radeon driver supports your card since kernel 2.6.33 and xf86-video-ati-6.12.192, however only modesetting and no 2D/3D acceleration yet.
Back to top
View user's profile Send private message
hedmo
l33t
l33t


Joined: 29 Aug 2009
Posts: 943
Location: halmstad

PostPosted: Wed Mar 24, 2010 7:55 pm    Post subject: Reply with quote

is there some thing extra to do with beta driver
with the ati-drivers-10.2 i had to make à /portage/package.mask
long as the bible.does the 2.6.33 and beta work with 2900xt to?
advice to you Legit "and guys corect me if i am wrong" only ati-drivers
have à grafik program when you use an enviroment that configure xorg.conf
for you.
Back to top
View user's profile Send private message
legit
Apprentice
Apprentice


Joined: 04 Jan 2006
Posts: 216
Location: Denver, CO

PostPosted: Wed Mar 24, 2010 9:34 pm    Post subject: Reply with quote

ok, im getting confused.

fglrx IS the official ati radeon (non-open source) driver correct?
Back to top
View user's profile Send private message
disi
Veteran
Veteran


Joined: 28 Nov 2003
Posts: 1354
Location: Out There ...

PostPosted: Wed Mar 24, 2010 11:33 pm    Post subject: Reply with quote

Both drivers are official ati drivers and both developed by AMD (unlike nvidia-drivers and nouveau)
fglrx is the binary one and non open source.

Just to confuse you a little more, there is another binary driver from ATI for workstations called firesomething and Novell developed on their own a driver called radeonhd. On the other hand might/will everything go into Gallium3D at some stage and we don't need an extra driver anymore :)
_________________
Gentoo on Uptime Project - Larry is a cow
Back to top
View user's profile Send private message
dE_logics
Advocate
Advocate


Joined: 02 Jan 2009
Posts: 2253
Location: $TERM

PostPosted: Thu Mar 25, 2010 5:06 am    Post subject: Reply with quote

I would recommend you to try x11-drivers/ati-drivers.

Most probably they will work well.
_________________
My blog
Back to top
View user's profile Send private message
hedmo
l33t
l33t


Joined: 29 Aug 2009
Posts: 943
Location: halmstad

PostPosted: Thu Mar 25, 2010 6:13 pm    Post subject: Reply with quote

Chithanh

The ati-drivers-8.721 have been masked

legit

I recomend fglrx to (have not got VIDEO_CARDS=ati radeon radeonhd
smouth with out timekilling)

at this typeing moment i reinstall gentoo and going
to use fglrx again.if you decide to use fglrx.
Just scream and i post the mask i am useing
Back to top
View user's profile Send private message
dE_logics
Advocate
Advocate


Joined: 02 Jan 2009
Posts: 2253
Location: $TERM

PostPosted: Fri Mar 26, 2010 6:48 am    Post subject: Reply with quote

I always though ati-drivers are the fglrx ones...and I really think they are. Unmask and give it a shot.
_________________
My blog
Back to top
View user's profile Send private message
hedmo
l33t
l33t


Joined: 29 Aug 2009
Posts: 943
Location: halmstad

PostPosted: Fri Mar 26, 2010 8:58 am    Post subject: Reply with quote

dE_logics

Give oss some info about unmask (allways move forwards)
i got comp errors when i try to rm my masks (libxinerama)
Back to top
View user's profile Send private message
legit
Apprentice
Apprentice


Joined: 04 Jan 2006
Posts: 216
Location: Denver, CO

PostPosted: Fri Mar 26, 2010 8:25 pm    Post subject: Reply with quote

I'm going to give fglrx a try this weekend and we'll see what happens... I'll report back if anything bad happens, smoke, explosions, smells of burnt silicon.. that kind of thing.
Back to top
View user's profile Send private message
hedmo
l33t
l33t


Joined: 29 Aug 2009
Posts: 943
Location: halmstad

PostPosted: Fri Mar 26, 2010 9:30 pm    Post subject: Reply with quote

Ok that is nice beware if want to use ati....... -10.2.
and have some things in make.conf like X and more
and dont or did not set the masks in portage.mask when
emerge --newuse --update --deep --ask world you could
have got some new xorg stuff allready and have to --unmerge
manually but it was nothing when i made it yesterday
Back to top
View user's profile Send private message
Deathwing00
Bodhisattva
Bodhisattva


Joined: 13 Jun 2003
Posts: 4087
Location: Dresden, Germany

PostPosted: Fri Apr 02, 2010 11:52 am    Post subject: Reply with quote

Moved from Installing Gentoo to Desktop Environments.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum