Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[Risolto] Xorg non parte
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian)
View previous topic :: View next topic  
Author Message
davedeth
Tux's lil' helper
Tux's lil' helper


Joined: 10 Mar 2010
Posts: 81
Location: Cesena

PostPosted: Fri Mar 12, 2010 7:50 pm    Post subject: [Risolto] Xorg non parte Reply with quote

Sera gente! Ho un problemino con xorg: non mi si avvia 8O L'output dell'errore mi restituisce questa frase:
Fatal server error:
no screens found.
Le ho provate tutte! Qualcuno sa come togliermi di impaccio?


Last edited by davedeth on Sun Mar 14, 2010 11:43 am; edited 1 time in total
Back to top
View user's profile Send private message
k01
Arch/Herd Tester
Arch/Herd Tester


Joined: 13 Feb 2008
Posts: 617
Location: Milano

PostPosted: Fri Mar 12, 2010 8:26 pm    Post subject: Reply with quote

qualche informazione in più non sarebbe male, puoi redirigere l'output in un file con

startx 2> logfile

oppure trovi il file di log completo in /var/log/Xorg.0.log

hald e dbus sono avviati correttamente?
Back to top
View user's profile Send private message
davedeth
Tux's lil' helper
Tux's lil' helper


Joined: 10 Mar 2010
Posts: 81
Location: Cesena

PostPosted: Sat Mar 13, 2010 9:05 am    Post subject: Reply with quote

Cercando a destra e a manca e rileggendo più volte il log di xorg ho scoperto che nel mio kernel (di cui ero fiducioso visto che compilato con genkernel) mancava il supporto ad agp. Percui ho ricompilato il kernel aggiungendo tali moduli e il risultato è stato che xorg adesso funziona ma non mi riconosce mouse e tastiera quindi non posso loggare :D Hald e dbus vengono caricati correttamente... almeno così sembra.
Come faccio?
Back to top
View user's profile Send private message
ago
Developer
Developer


Joined: 01 Mar 2008
Posts: 1520
Location: Cosenza, Italy

PostPosted: Sat Mar 13, 2010 9:35 am    Post subject: Reply with quote

hai inserito in make.conf qualcosa tipo:
Code:
INPUT_DEVICES="mouse keyboard evdev"
?
_________________
Contattami se vuoi contribuire in:
-Arch tester
-Chromium tester
-Traduzione doc. it
-Security
Back to top
View user's profile Send private message
davedeth
Tux's lil' helper
Tux's lil' helper


Joined: 10 Mar 2010
Posts: 81
Location: Cesena

PostPosted: Sat Mar 13, 2010 10:01 am    Post subject: Reply with quote

Mi manca evdev perchè sulla guida non c'era scritto :x Adesso come faccio ad impedire a gdm di avviarsi per emergere evdev?
Back to top
View user's profile Send private message
darkmanPPT
Veteran
Veteran


Joined: 13 Apr 2006
Posts: 1069
Location: vi/bo

PostPosted: Sat Mar 13, 2010 11:13 am    Post subject: Reply with quote

io per questi casi, facevo così.

1) prendi il livecd di gentoo (o un qualsiasi livecd)
2) inserisci e caricalo
3) apri una shell e montati su /mnt/gentoo la partizione corretta dove sta la tua "/"
4) chroot /mnt/gentoo /bin/bash
5) env-update
6) rc-update del xdm default
7) control+d (in modo da uscire dal chroot)
8) umount /mnt/gentoo
9) riavvia il pc e carica il tuo linux (senza usare livecd)

oppure, se per caso hai un demone ssh attivo sulla tua macchina gentoo, ti colleghi in remoto ed esegui l'rc-update come scritto sopra

mi pare che, in teoria, si possa anche passare qualche parametro al kernel in modo chenon carichi X, ma non ricordo bene

--------------------------------------------------------
sulla configurazione del mio grub (io uso grub 2) nella riga riguardante il "recovery mode", il boot loader carica questo:
Code:
        linux   /boot/vmlinuz-2.6.32-zen46 root=/dev/sda1 ro single                             


forse se provi a passare
Code:
ro single   
come parametro al tuo kernel, può darsi che parta in recovery mode (e quindi caricando solo una shell e basta)

se ti chedi come fare a passare il parametro, questo è presto detto:
1) riavvia il pc
2) alla schermata di grub (se usi grub ok, altrimenti non so come si faccia con lilo o qualcos'altro) premi "e" (edit) sopra il kernel che vuoi caricare
3) alla schermata successiva, posizionati sopra la riga dove v'è scritto quale kernel caricare e premi "e"
4) inserisci in fondo alla riga i due parametri e premi invio
5) premi "b" per fare il boot
_________________
Darkman
Back to top
View user's profile Send private message
ago
Developer
Developer


Joined: 01 Mar 2008
Posts: 1520
Location: Cosenza, Italy

PostPosted: Sat Mar 13, 2010 11:34 am    Post subject: Reply with quote

si ma dato che inserisce il livecd e fa il chroot sulla partizione, se lo emerge direttamente da li il driver input :wink:
_________________
Contattami se vuoi contribuire in:
-Arch tester
-Chromium tester
-Traduzione doc. it
-Security
Back to top
View user's profile Send private message
davedeth
Tux's lil' helper
Tux's lil' helper


Joined: 10 Mar 2010
Posts: 81
Location: Cesena

PostPosted: Sat Mar 13, 2010 12:30 pm    Post subject: Reply with quote

Sono riuscito ad inserire nel make.conf evdev e ho ricompilato xorg (emerge xorg-server) ma ancora il mouse e la tastiera non ne vogliono sapere.
Back to top
View user's profile Send private message
spillo
Tux's lil' helper
Tux's lil' helper


Joined: 29 Feb 2008
Posts: 125
Location: S.Angelo Lodigiano

PostPosted: Sat Mar 13, 2010 12:54 pm    Post subject: Reply with quote

davedeth wrote:
Sono riuscito ad inserire nel make.conf evdev e ho ricompilato xorg (emerge xorg-server) ma ancora il mouse e la tastiera non ne vogliono sapere.
hal è avviato correttamente?
Code:
/etc/init.d/hald start
rc-update add hald default

_________________
spillo

GnuLinuxExperience

Il mio blog! :)
Back to top
View user's profile Send private message
ago
Developer
Developer


Joined: 01 Mar 2008
Posts: 1520
Location: Cosenza, Italy

PostPosted: Sat Mar 13, 2010 1:17 pm    Post subject: Reply with quote

spillo wrote:
davedeth wrote:
Sono riuscito ad inserire nel make.conf evdev e ho ricompilato xorg (emerge xorg-server) ma ancora il mouse e la tastiera non ne vogliono sapere.
hal è avviato correttamente?
Code:
/etc/init.d/hald start
rc-update add hald default


più che altro direi:

emerge -DNav xorg-server
_________________
Contattami se vuoi contribuire in:
-Arch tester
-Chromium tester
-Traduzione doc. it
-Security
Back to top
View user's profile Send private message
darkmanPPT
Veteran
Veteran


Joined: 13 Apr 2006
Posts: 1069
Location: vi/bo

PostPosted: Sat Mar 13, 2010 1:31 pm    Post subject: Reply with quote

ago88 wrote:
spillo wrote:
davedeth wrote:
Sono riuscito ad inserire nel make.conf evdev e ho ricompilato xorg (emerge xorg-server) ma ancora il mouse e la tastiera non ne vogliono sapere.
hal è avviato correttamente?
Code:
/etc/init.d/hald start
rc-update add hald default


più che altro direi:

emerge -DNav xorg-server


nel momento in cui fai l'emerge di xorg-server, le dipendenze vengono automaticamente soddisfatte. mettere "-DN" non vedo come ti potrebbe aiutare.

semmai (riferito a davedeth), potresti postare le flag attivate per il pacchetto xorg-server e per il pacchetto xorg-drivers?

:wink:
_________________
Darkman
Back to top
View user's profile Send private message
ago
Developer
Developer


Joined: 01 Mar 2008
Posts: 1520
Location: Cosenza, Italy

PostPosted: Sat Mar 13, 2010 1:34 pm    Post subject: Reply with quote

darkmanPPT wrote:
nel momento in cui fai l'emerge di xorg-server, le dipendenze vengono automaticamente soddisfatte. mettere "-DN" non vedo come ti potrebbe aiutare


Prova a modificare il tuo INPUT_DEVICES in make.conf, lancia emerge xorg-server e vedi se vengono applicati cambiamenti -.-'
_________________
Contattami se vuoi contribuire in:
-Arch tester
-Chromium tester
-Traduzione doc. it
-Security
Back to top
View user's profile Send private message
davedeth
Tux's lil' helper
Tux's lil' helper


Joined: 10 Mar 2010
Posts: 81
Location: Cesena

PostPosted: Sat Mar 13, 2010 1:37 pm    Post subject: Reply with quote

Le use del mio make.conf sono: "-qt3 -qt4 -arts -kde X dbus gtk gnome hal alsa"
Back to top
View user's profile Send private message
ago
Developer
Developer


Joined: 01 Mar 2008
Posts: 1520
Location: Cosenza, Italy

PostPosted: Sat Mar 13, 2010 1:41 pm    Post subject: Reply with quote

davedeth wrote:
Le use del mio make.conf sono: "-qt3 -qt4 -arts -kde X dbus gtk gnome hal alsa"


eix -I xorg
_________________
Contattami se vuoi contribuire in:
-Arch tester
-Chromium tester
-Traduzione doc. it
-Security
Back to top
View user's profile Send private message
davedeth
Tux's lil' helper
Tux's lil' helper


Joined: 10 Mar 2010
Posts: 81
Location: Cesena

PostPosted: Sat Mar 13, 2010 1:53 pm    Post subject: Reply with quote

Qualcuno mi spiega come montarmi su /mnt/gentoo la partizione corretta dove sta la mia "/"?
Scusate se lo chiedo ma il metodo che ho usato prima non funziona più e neanche quello di aggiungere ro single alla linea del kernel funziona.
Back to top
View user's profile Send private message
ago
Developer
Developer


Joined: 01 Mar 2008
Posts: 1520
Location: Cosenza, Italy

PostPosted: Sat Mar 13, 2010 2:18 pm    Post subject: Reply with quote

per montare e chrootare da livecd basta:
Code:
mount /dev/$nomedeltuodevice /mnt; chroot /mnt

fai tutte le modifiche che vuoi ed esci dal chroot con
Code:
exit

e successivamente smonti la partizione con
Code:
umount

_________________
Contattami se vuoi contribuire in:
-Arch tester
-Chromium tester
-Traduzione doc. it
-Security
Back to top
View user's profile Send private message
davedeth
Tux's lil' helper
Tux's lil' helper


Joined: 10 Mar 2010
Posts: 81
Location: Cesena

PostPosted: Sun Mar 14, 2010 9:03 am    Post subject: Reply with quote

Grazie infinite per tutti i consigli che mi avete date... adesso il sistema funziona benissimo! Siete i migliori!
Davvero grazie mille! Per caso sapete come avere gnome 2.28 visto che mi ha installato gnome 2.26?
Back to top
View user's profile Send private message
ago
Developer
Developer


Joined: 01 Mar 2008
Posts: 1520
Location: Cosenza, Italy

PostPosted: Sun Mar 14, 2010 9:12 am    Post subject: Reply with quote

un thread un problema...
Code:
echo "gnome-base/gnome" >> /etc/portage/package.keywords

oppure gnome-light se hai installato quello
_________________
Contattami se vuoi contribuire in:
-Arch tester
-Chromium tester
-Traduzione doc. it
-Security
Back to top
View user's profile Send private message
lavish
Bodhisattva
Bodhisattva


Joined: 13 Sep 2004
Posts: 4296

PostPosted: Sun Mar 14, 2010 10:09 am    Post subject: Reply with quote

davedeth wrote:
[...] ... adesso il sistema funziona benissimo! [...]

Oltre a quanto detto da ago non dimenticare di aggiungere al titolo del thread il tag [RISOLTO], grazie ;)
_________________
minimalblue.com | secgroup.github.io/
Back to top
View user's profile Send private message
davedeth
Tux's lil' helper
Tux's lil' helper


Joined: 10 Mar 2010
Posts: 81
Location: Cesena

PostPosted: Sun Mar 14, 2010 11:49 am    Post subject: Reply with quote

ago88 wrote:
un thread un problema...


Hai ragione... scusate non lo farò più... è che mi sembrava poco furbo aprire un thread per una cosa da poco come quella di gnome... chiedo perdono ancora.
Grazie infinite per tutto l'aiuto che mi avete dato! Gentoo è LA distro (per quanto mi riguarda)!
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum