Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
stranezza su aggiornamenti
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian)
View previous topic :: View next topic  
Author Message
uoslagelo
Tux's lil' helper
Tux's lil' helper


Joined: 24 Jul 2009
Posts: 81

PostPosted: Mon Feb 15, 2010 6:49 pm    Post subject: stranezza su aggiornamenti Reply with quote

anche voi usate emerge -avuDNq world per aggiornare? Ultimamente sto notanto che non installa tutti gli aggiornamenti. Sembra che se ne "dimentichi" qualcuno. Ho pensato che ci fossero delle dipendenze che richiedessero delle precise versioni, ma con un equery d <pacchetto> ho subito scartato questa ipotesi. Allora ho provato ad aggiornare manualmente il pacchetto. Compila tranquillamente. Allora ho pensato: se do un emerge -avuDNq world dovrebbe riportare il pacchetto appena installato alla versione precedentemente installata. Ed invece non è così. Sembra che qualche pacchetto passi inosservato. Ho provato anche con un emerge -avuDNq system, ma non cambia nulla.

I pacchetti "sfuggiti" li ho trovati con un eix -u
Back to top
View user's profile Send private message
ago
Developer
Developer


Joined: 01 Mar 2008
Posts: 1520
Location: Cosenza, Italy

PostPosted: Mon Feb 15, 2010 7:35 pm    Post subject: Reply with quote

lancia
Code:
eix-sync; emerge -DuN world
deve aggiornare per forza tutti gli elementi contenuti nel file world
_________________
Contattami se vuoi contribuire in:
-Arch tester
-Chromium tester
-Traduzione doc. it
-Security
Back to top
View user's profile Send private message
publiosulpicio
Apprentice
Apprentice


Joined: 31 Aug 2008
Posts: 150

PostPosted: Mon Feb 15, 2010 7:38 pm    Post subject: Reply with quote

Prova
Code:

emerge -uDN --with-bdeps y world
Back to top
View user's profile Send private message
riverdragon
Veteran
Veteran


Joined: 14 Sep 2006
Posts: 1269
Location: Verona

PostPosted: Mon Feb 15, 2010 11:09 pm    Post subject: Reply with quote

eix -u mostra tutti i pacchetti teoricamente aggiornabili. Ci sono però programmi che hanno dipendenze strette su una specifica versione di un pacchetto; fino a che l'ebuild per il primo programma non modificherà la richiesta della dipendenza tutte le versioni successive del pacchetto verranno ignorate.

Mi viene in mente eclipse-sdk, che richiede dev-java/lucene-1.9 nonostante l'ultima versione stabile in portage sia la 2.4.1

Per scoprire se il tuo caso è come questo (molto probabile) lancia equery d <nomepacchetto> e guarda che ti dice.
Back to top
View user's profile Send private message
Onip
Advocate
Advocate


Joined: 02 Sep 2004
Posts: 2912
Location: Parma (Italy)

PostPosted: Mon Feb 15, 2010 11:21 pm    Post subject: Reply with quote

emerge considera come "da aggiornare" i pacchetti installati in world e le loro dipendenze a runtime, quelle, per intenderci, che servono alla esecuzione del programma e che negli ebuild sono specificate nella variabile RDEPEND.

I pacchetti tralasciati sono delle build-dependencies, cioè servono solamente per la compilazione dei sorgenti del pacchetto X e poi non vengono più utilizzati. per dire ad emerge di considerare anche questo insieme di pacchetti devi specificare, come già detto da ago88 l'opzione --with-bdeps=y.

Oppure a volte un pacchetto dipendenza è "aggiornabile", ma gli utilizzatori ne richiedono una specifica versione (es. <dev-cpp/foobar-1.23), di conseguenza aggiornare la dipendenza sarebbe errato e questa viene, giustamente, lasciata stare anche con le bdeps abilitate.
_________________
Linux Registered User n. 373835

Titus Lucretius Carus, De Rerum Natura - Tantum religio potuit suadere malorum
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum