Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
cannot compile xorg-server-1.7.1
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
spankmeister7
Tux's lil' helper
Tux's lil' helper


Joined: 10 Apr 2005
Posts: 76

PostPosted: Tue Nov 17, 2009 6:28 am    Post subject: cannot compile xorg-server-1.7.1 Reply with quote

Hi.

I'm in the process of a routine update and I have difficulty emerging xorg-server-1.7.1.

The tail end of the error is:

rensize.c: In function '__glXImageSize':
rensize.c:222: error: 'GL_DEPTH_STENCIL_MESA' undeclared (first use in this function)
rensize.c:222: error: (Each undeclared identifier is reported only once
rensize.c:222: error: for each function it appears in.)
rensize.c:261: error: 'GL_UNSIGNED_SHORT_15_1_MESA' undeclared (first use in this function)
rensize.c:262: error: 'GL_UNSIGNED_SHORT_1_15_REV_MESA' undeclared (first use in this function)
rensize.c:276: error: 'GL_UNSIGNED_INT_24_8_MESA' undeclared (first use in this function)
rensize.c:277: error: 'GL_UNSIGNED_INT_8_24_REV_MESA' undeclared (first use in this function)
CC singlepix.o
make[1]: *** [rensize.lo] Error 1
make[1]: *** Waiting for unfinished jobs....
make: *** [all-recursive] Error 1
* ERROR: x11-base/xorg-server-1.7.1 failed:
* emake failed
*
* Call stack:
* ebuild.sh, line 55: Called src_compile
* environment, line 3683: Called x-modular_src_compile
* environment, line 4607: Called x-modular_src_make
* environment, line 4646: Called die
* The specific snippet of code:
* emake || die "emake failed"
*
* If you need support, post the output of 'emerge --info =x11-base/xorg-server-1.7.1',
* the complete build log and the output of 'emerge -pqv =x11-base/xorg-server-1.7.1'.
* The complete build log is located at '/var/tmp/portage/x11-base/xorg-server-1.7.1/temp/build.log'.
* The ebuild environment file is located at '/var/tmp/portage/x11-base/xorg-server-1.7.1/temp/environment'.
* S: '/var/tmp/portage/x11-base/xorg-server-1.7.1/work/xorg-server-1.7.1'


Xorg info shows:

Portage 2.1.7.5 (default/linux/x86/10.0/desktop, gcc-4.4.2, glibc-2.11-r0, 2.6.31-gentoo i686)
=================================================================
System Settings
=================================================================
System uname: Linux-2.6.31-gentoo-i686-Intel-R-_Pentium-R-_D_CPU_3.46GHz-with-gentoo-2.0.1
Timestamp of tree: Mon, 16 Nov 2009 04:15:01 +0000
app-shells/bash: 4.0_p35
dev-java/java-config: 2.1.9-r1
dev-lang/python: 2.6.4, 3.1.1-r1
dev-util/cmake: 2.6.4-r3
sys-apps/baselayout: 2.0.1
sys-apps/openrc: 0.5.2-r2
sys-apps/sandbox: 2.2
sys-devel/autoconf: 2.13, 2.63-r1
sys-devel/automake: 1.9.6-r2, 1.10.2, 1.11
sys-devel/binutils: 2.20
sys-devel/gcc-config: 1.4.1
sys-devel/libtool: 2.2.6a
virtual/os-headers: 2.6.30-r1
ACCEPT_KEYWORDS="x86 ~x86"
ACCEPT_LICENSE="* -@EULA"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-O3 -march=prescott -pipe -fomit-frame-pointer"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/X11/xkb /usr/share/config"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5/ext-active/ /etc/php/cgi-php5/ext-active/ /etc/php/cli-php5/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/udev/rules.d"
CXXFLAGS="-O3 -march=prescott -pipe -fomit-frame-pointer"
DISTDIR="/usr/portage/distfiles"
FEATURES="assume-digests distlocks fixpackages news parallel-fetch protect-owned sandbox sfperms strict unmerge-logs unmerge-orphans userfetch"
GENTOO_MIRRORS="http://gentoo.osuosl.org/ "
LDFLAGS="-Wl,-O1"
MAKEOPTS="-j4"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
SYNC="rsync://rsync.namerica.gentoo.org/gentoo-portage"
USE="X a52 aac aalib acl acpi alsa berkdb bluetooth branding bzip2 cairo cdb cddb cdparanoia cdr cli consolekit cracklib crypt cups curl dbus dga directfb dri dts dvd dvdr dvdread eds embedded emboss encode evdev evo exif fam fbcon ffmpeg fftw firefox flac fontconfig foomaticdb fortran ftp gd gdbm gif gimp glitz glut gmp gnome gnutls gphoto2 gpm gstreamer gtk gtkhtml hal iconv ieee1394 imagemagick imlib java javascript jpeg jpeg2k kde lame latex ldap libcaca libgda libnotify libwww lmsensors lzo mad mikmod mime mmap mmx mng modplay modules mozilla mp3 mp4 mpeg mpi mplayer mudflap mysql mysqli ncurses nls nptl nptlonly nsplugin ogg openal opengl openmp oss pam pcre pdf perl php plasma png posix ppds pppd python qt3 qt3support qt4 quicktime raw readline reflection samba sasl scanner sdl session smp sndfile sockets spell spl sql sse ssl startup-notification subversion svg svga sysfs tcpd threads thunar tiff tk truetype unicode univode usb v4l v4l2 vnc vorbis wavpack webkit win32codecs x264 x86 xcb xcomposite xine xinerama xinetd xml xmlrpc xorg xosl xpm xscreensaver xulrunner xv xvid xvmc zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1 emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="keyboard mouse" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" SANE_BACKENDS="epson" USERLAND="GNU" VIDEO_CARDS="nvidia"
Unset: CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, LANG, LC_ALL, LINGUAS, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, PORTDIR_OVERLAY

errata:
[ebuild U ] x11-base/xorg-server-1.7.1 [1.6.5] USE="hal nptl sdl xorg -debug -dmx -ipv6 -kdrive -minimal -tslib"



I'll be the first to admit that I don't know how any of this works.

Thanks.
Back to top
View user's profile Send private message
theotherjoe
Guru
Guru


Joined: 22 Nov 2003
Posts: 368

PostPosted: Tue Nov 17, 2009 8:05 am    Post subject: Reply with quote

since the error message is refering to
mesa symbols, maybe mesa version not up to date
or missing?
had a look at the ebuild, looks like >=mesa-7.4 is
needed?
Back to top
View user's profile Send private message
Yttrium
n00b
n00b


Joined: 22 Oct 2009
Posts: 29
Location: Germany

PostPosted: Tue Nov 17, 2009 9:28 am    Post subject: Reply with quote

Perhaps it doesn't like O3?
Try changing it to O2 or try FEATURES=""
_________________
LILA - Live Iptables Log Analyzer
Back to top
View user's profile Send private message
Mike Hunt
Watchman
Watchman


Joined: 19 Jul 2009
Posts: 5287

PostPosted: Tue Nov 17, 2009 2:00 pm    Post subject: Reply with quote

try with
Code:
CFLAGS="-march=native -O2 -pipe"


... but leave FEATURES alone please. :)
Back to top
View user's profile Send private message
Halcy0n
Developer
Developer


Joined: 17 Sep 2003
Posts: 1682
Location: Freehold, NJ

PostPosted: Tue Nov 17, 2009 4:40 pm    Post subject: Reply with quote

What x11 drivers are you using? Nvidia? What version?
_________________
Mark Loeser
http://www.halcy0n.com
Back to top
View user's profile Send private message
spankmeister7
Tux's lil' helper
Tux's lil' helper


Joined: 10 Apr 2005
Posts: 76

PostPosted: Tue Nov 17, 2009 5:58 pm    Post subject: more info Reply with quote

Thanks for the responses, everyone.

Mesa compiled cleanly without complaint, and is currently at version 7.5.2.
I'm using an nvidia video card, and the driver version is nvidia-drivers-185.18.36-r1.


Changing the O3 to O2 flag in the make.conf file made no difference.
Back to top
View user's profile Send private message
Halcy0n
Developer
Developer


Joined: 17 Sep 2003
Posts: 1682
Location: Freehold, NJ

PostPosted: Tue Nov 17, 2009 6:20 pm    Post subject: Re: more info Reply with quote

spankmeister7 wrote:
I'm using an nvidia video card, and the driver version is nvidia-drivers-185.18.36-r1.


Upgrade the driver to the latest unstable. Then compiling xorg-server should work.
_________________
Mark Loeser
http://www.halcy0n.com
Back to top
View user's profile Send private message
spankmeister7
Tux's lil' helper
Tux's lil' helper


Joined: 10 Apr 2005
Posts: 76

PostPosted: Tue Nov 17, 2009 6:34 pm    Post subject: ** Reply with quote

.. and so it does.


Thank you, everyone.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum