Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Fehlende ICONS: GDK-PIXBUFF Fehler! [solved]
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German)
View previous topic :: View next topic  
Author Message
root_tux_linux
l33t
l33t


Joined: 21 Dec 2003
Posts: 966

PostPosted: Wed Oct 07, 2009 10:57 pm    Post subject: Fehlende ICONS: GDK-PIXBUFF Fehler! [solved] Reply with quote

Hi

Ich hab endlich mal wieder mein Gentoo geupdatet und seitdem funktioniert qtcurve und gtk-engines-qt nicht mehr richtig.

Und zwar fehlen Icons!


Code:
angelus@gentoo ~ $ firefox                                                                                                                                               

(firefox:9080): Gtk-WARNING **: Fehler beim Laden des Symbols: Das Format der Bilddatei »/usr/share/icons//oxygen/16x16/actions/list-add.png« konnte nicht erkannt werden

(firefox:9080): Gtk-WARNING **: Fehler beim Laden des Symbols: Das Format der Bilddatei »/usr/share/icons//oxygen/16x16/actions/list-add.png« konnte nicht erkannt werden

(firefox:9080): Gtk-WARNING **: Fehler beim Laden des Symbols: Das Format der Bilddatei »/usr/share/icons//oxygen/16x16/actions/window-close.png« konnte nicht erkannt werden

(firefox:9080): Gtk-WARNING **: Fehler beim Laden des Symbols: Das Format der Bilddatei »/usr/share/icons//oxygen/16x16/actions/window-close.png« konnte nicht erkannt werden

(firefox:9080): Gtk-WARNING **: Fehler beim Laden des Symbols: Das Format der Bilddatei »/usr/share/icons//oxygen/22x22/actions/go-previous.png« konnte nicht erkannt werden

(firefox:9080): Gtk-WARNING **: Fehler beim Laden des Symbols: Das Format der Bilddatei »/usr/share/icons//oxygen/16x16/actions/go-previous.png« konnte nicht erkannt werden

(firefox:9080): Gtk-WARNING **: Fehler beim Laden des Symbols: Das Format der Bilddatei »/usr/share/icons//oxygen/22x22/actions/go-next.png« konnte nicht erkannt werden

(firefox:9080): Gtk-WARNING **: Fehler beim Laden des Symbols: Das Format der Bilddatei »/usr/share/icons//oxygen/16x16/actions/go-next.png« konnte nicht erkannt werden

(firefox:9080): Gtk-WARNING **: Fehler beim Laden des Symbols: Das Format der Bilddatei »/usr/share/icons//oxygen/22x22/actions/view-refresh.png« konnte nicht erkannt werden

(firefox:9080): Gtk-WARNING **: Fehler beim Laden des Symbols: Das Format der Bilddatei »/usr/share/icons//oxygen/16x16/actions/view-refresh.png« konnte nicht erkannt werden

(firefox:9080): Gtk-WARNING **: Fehler beim Laden des Symbols: Das Format der Bilddatei »/usr/share/icons//oxygen/22x22/actions/process-stop.png« konnte nicht erkannt werden

(firefox:9080): Gtk-WARNING **: Fehler beim Laden des Symbols: Das Format der Bilddatei »/usr/share/icons//oxygen/16x16/actions/process-stop.png« konnte nicht erkannt werden

(firefox:9080): Gtk-WARNING **: Fehler beim Laden des Symbols: Das Format der Bilddatei »/usr/share/icons//oxygen/22x22/actions/go-home.png« konnte nicht erkannt werden

(firefox:9080): Gtk-WARNING **: Fehler beim Laden des Symbols: Das Format der Bilddatei »/usr/share/icons//oxygen/16x16/actions/go-home.png« konnte nicht erkannt werden



Weiss jemand wie man das ganze fixt?

kde-qxygen, qtcurve und gtk-engines-qt hab ich schon mehrfach recompiliert ohne erfolg.
_________________
Intel Core i7 6700K@4.6GHz, Gigabyte GTX 980 Ti G1, Gigabyte Gaming 7, Hyper X Fury 32GB, 2 TB Samsung EVO 840 Basic
ASUS ROG Swift PG348Q Display
ASUS ROG ASUS G771JW Notebook


Last edited by root_tux_linux on Thu Oct 08, 2009 9:11 am; edited 2 times in total
Back to top
View user's profile Send private message
ChrisJumper
Advocate
Advocate


Joined: 12 Mar 2005
Posts: 2227
Location: Germany

PostPosted: Thu Oct 08, 2009 2:45 am    Post subject: Reply with quote

Servus root_tux_linux!

Ich habe grade folgendes probiert...

Code:
 $ equery b  /usr/share/icons//oxygen/22x22/actions/go-home.png
[ Searching for file(s) /usr/share/icons/oxygen/22x22/actions/go-home.png in *... ]
kde-base/oxygen-icons-4.3.1 (/usr/share/icons/oxygen/22x22/actions/go-home.png)


...und würde versuchen kde-base/oxygen-icons zu emergen.

Viel Erfolg
Back to top
View user's profile Send private message
root_tux_linux
l33t
l33t


Joined: 21 Dec 2003
Posts: 966

PostPosted: Thu Oct 08, 2009 6:37 am    Post subject: Reply with quote

ChrisJumper wrote:
Servus root_tux_linux!

Ich habe grade folgendes probiert...

Code:
 $ equery b  /usr/share/icons//oxygen/22x22/actions/go-home.png
[ Searching for file(s) /usr/share/icons/oxygen/22x22/actions/go-home.png in *... ]
kde-base/oxygen-icons-4.3.1 (/usr/share/icons/oxygen/22x22/actions/go-home.png)


...und würde versuchen kde-base/oxygen-icons zu emergen.

Viel Erfolg


Danke für die rasche Antwort aber leider klappt es nicht...

Ich hatte oxygen-icons schon installiert und eben nach deinem Posting 2x remerged leider ohne Erfolg.
Die Icons fehlen noch und die Fehlermeldung kommt noch immer.


Code:
gentoo ~ # equery l oxygen-icons
 * Searching for oxygen-icons ...
[IP-] [ ~] kde-base/oxygen-icons-4.3.1 (4.3)
gentoo ~ #


Code:
angelus@gentoo ~ $ firefox

(firefox:7097): Gtk-WARNING **: Fehler beim Laden des Symbols: Das Format der Bilddatei »/usr/share/icons//oxygen/16x16/actions/list-add.png« konnte nicht erkannt werden

(firefox:7097): Gtk-WARNING **: Fehler beim Laden des Symbols: Das Format der Bilddatei »/usr/share/icons//oxygen/16x16/actions/list-add.png« konnte nicht erkannt werden

(firefox:7097): Gtk-WARNING **: Fehler beim Laden des Symbols: Das Format der Bilddatei »/usr/share/icons//oxygen/16x16/actions/window-close.png« konnte nicht erkannt werden


Kann der Fehler irgendwie mit gtk bzw gdk-pix-buf zusammenhängen?


EDIT

Anscheinend hängt es tatsächlich mit gtk+ bzw gdk-pixbuf zusammen!
Wenn ich GIMP kompiliere bekomm ich auch eine Fehlermeldung bei PNG Dateien!

Code:
/usr/bin/gdk-pixbuf-csource --raw --build-list `cat tool-cursors.list` > gimp-tool-cursors.h                                                                                                                                                 
failed to load "./cursor-bad.png": Couldn't recognize the image file format for file './cursor-bad.png'   



Weiss jemand wie man gdk-pixbuf fixt? :(

* Searching for gtk+ ...
[IP-] [ ] x11-libs/gtk+-2.16.6 (2)
_________________
Intel Core i7 6700K@4.6GHz, Gigabyte GTX 980 Ti G1, Gigabyte Gaming 7, Hyper X Fury 32GB, 2 TB Samsung EVO 840 Basic
ASUS ROG Swift PG348Q Display
ASUS ROG ASUS G771JW Notebook
Back to top
View user's profile Send private message
Josef.95
Advocate
Advocate


Joined: 03 Sep 2007
Posts: 3649
Location: Germany

PostPosted: Thu Oct 08, 2009 8:23 am    Post subject: Reply with quote

Hi
es gab die letzten Tage ja doch zwei tiefgreifende Updates die damit zusammenhängen könnten..

1. Das Update auf "x11-libs/libxcb-1.4.1"
Quote:
# eselect news read new
2009-10-02-xorg-server-1-6-libxcb-1.4
Title Migration to X.org Server 1.6 and libxcb 1.4
Author Remi Cardona <remi@gentoo.org>
Posted 2009-10-02
Revision 1

We're pleased to announce the stabilization of xorg-server-1.6. Users
are strongly encouraged to read the following two guides before
upgrading:

http://www.gentoo.org/proj/en/desktop/x/x11/xorg-server-1.6-upgrade-guide.xml
http://www.gentoo.org/proj/en/desktop/x/x11/libxcb-1.4-upgrade-guide.xml


2. Und das Update auf "media-libs/jpeg-7"
Code:
WARN: postinst
Old versions of installed libraries were detected on your system.
In order to avoid breaking packages that depend on these old libs,
the libraries are not being removed.  You need to run revdep-rebuild
in order to remove these old dependencies.  If you do not have this
helper program, simply emerge the 'gentoolkit' package.

  # revdep-rebuild --library libjpeg.so.62

Once you've finished running revdep-rebuild, it should be safe to
delete the old libraries.  Here is a copy & paste for the lazy:
  # rm '/usr/lib64/libjpeg.so.62'

Falls schon installiert, hast du dies beides sauber durch? (ist recht umfangreich)
ansonsten kommt es bei zahlreichen Paketen zu Problemen...
Back to top
View user's profile Send private message
root_tux_linux
l33t
l33t


Joined: 21 Dec 2003
Posts: 966

PostPosted: Thu Oct 08, 2009 9:11 am    Post subject: Reply with quote

Josef.95 wrote:
Hi
es gab die letzten Tage ja doch zwei tiefgreifende Updates die damit zusammenhängen könnten..

1. Das Update auf "x11-libs/libxcb-1.4.1"
Quote:
# eselect news read new
2009-10-02-xorg-server-1-6-libxcb-1.4
Title Migration to X.org Server 1.6 and libxcb 1.4
Author Remi Cardona <remi@gentoo.org>
Posted 2009-10-02
Revision 1

We're pleased to announce the stabilization of xorg-server-1.6. Users
are strongly encouraged to read the following two guides before
upgrading:

http://www.gentoo.org/proj/en/desktop/x/x11/xorg-server-1.6-upgrade-guide.xml
http://www.gentoo.org/proj/en/desktop/x/x11/libxcb-1.4-upgrade-guide.xml


2. Und das Update auf "media-libs/jpeg-7"
Code:
WARN: postinst
Old versions of installed libraries were detected on your system.
In order to avoid breaking packages that depend on these old libs,
the libraries are not being removed.  You need to run revdep-rebuild
in order to remove these old dependencies.  If you do not have this
helper program, simply emerge the 'gentoolkit' package.

  # revdep-rebuild --library libjpeg.so.62

Once you've finished running revdep-rebuild, it should be safe to
delete the old libraries.  Here is a copy & paste for the lazy:
  # rm '/usr/lib64/libjpeg.so.62'

Falls schon installiert, hast du dies beides sauber durch? (ist recht umfangreich)
ansonsten kommt es bei zahlreichen Paketen zu Problemen...


Thx hab den Fehler gelöst ^^

libxcb-xlib hat nen Fehler bei gtk+ bzw gdk-pixbuff ausgelöst dieser Fehler wiederum verhinderte das gtk+ bzw gdk-pixbuff *.png Files lesen/erkennen konnte und das wiederum lies die Icons verschwinden. ^^

Anscheinend hatte ich den upgrade Leitfaden nicht korrekt gemacht. :)

Jetzt funzt es auf jedenfall...

Danke für die Hilfe :)
_________________
Intel Core i7 6700K@4.6GHz, Gigabyte GTX 980 Ti G1, Gigabyte Gaming 7, Hyper X Fury 32GB, 2 TB Samsung EVO 840 Basic
ASUS ROG Swift PG348Q Display
ASUS ROG ASUS G771JW Notebook
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum