Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
problème clavier qwerty - azerty
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index French
View previous topic :: View next topic  
Author Message
limax1er
n00b
n00b


Joined: 29 Nov 2006
Posts: 5

PostPosted: Sun Dec 10, 2006 7:35 am    Post subject: problème clavier qwerty - azerty Reply with quote

bonjour

suite à un changement de noyau je me retrouve pour me logger avec un
clavier qwerty.
J'ai réglé dans un premier temps le problème avec une connection
automatique mais si j'ai un problème de x ca ne sera pas idéal, surtout avec vim.

Je retrouve bien un clavier azerty après m'être logger. Je n'ai aucun
(xgk)dm et je boot avec grub.

merci de m'aider.
Back to top
View user's profile Send private message
gbetous
l33t
l33t


Joined: 15 Jan 2004
Posts: 679
Location: Toulouse

PostPosted: Sun Dec 10, 2006 8:19 am    Post subject: Reply with quote

c'est pas la faute du noyau, il y est pour rien lui ! :D

dans ton /etc/conf.d/keymaps as-tu mis 'fr' ?

tu peux aussi verifier que le /etc/init.d/keymaps est bien exécuté au niveau boot...
Back to top
View user's profile Send private message
gbetous
l33t
l33t


Joined: 15 Jan 2004
Posts: 679
Location: Toulouse

PostPosted: Sun Dec 10, 2006 8:22 am    Post subject: Reply with quote

j'ai lu un peu trop vite... t'es en qwerty en console ou sous X ?

si c'est sous X, alors regarde ton /etc/X11/xorg.conf, et vérifie que dans la section de ton clavier tu as bien :

Code:
Option      "XkbModel" "pc105"
Option      "XkbLayout" "fr"
Back to top
View user's profile Send private message
limax1er
n00b
n00b


Joined: 29 Nov 2006
Posts: 5

PostPosted: Sun Dec 10, 2006 10:29 am    Post subject: Reply with quote

gbetous wrote:
dans ton /etc/conf.d/keymaps as-tu mis 'fr'
C'était ca merci.

Je ne m'en sert pas souvent car j'ai mis une connection automatique mais utiliser vim avec un clavier qwerty est un calvaire.

merci encore
Back to top
View user's profile Send private message
boozo
Advocate
Advocate


Joined: 01 Jul 2004
Posts: 3193

PostPosted: Sun Dec 10, 2006 12:00 pm    Post subject: Reply with quote

'alute et bienvenu sur le forum :)

Je joue un peu les rabat-joie mais bien que ton problème soit résolu, pourrais-tu lire ce post en sticky sur la page d'accueil du forum (et plus particulièrement celui-ci - section 3/3) et faire le nécessaire pour le respect de nos convention. Par avance merci :wink:

PS: et... si tu pouvais faire de même pour ton autre thread... ^^
_________________
" Un psychotique, c'est quelqu'un qui croit dur comme fer que 2 et 2 font 5, et qui en est pleinement satisfait.
Un névrosé, c'est quelqu'un qui sait pertinemment que 2 et 2 font 4, et ça le rend malade ! "
Back to top
View user's profile Send private message
_KdZ
n00b
n00b


Joined: 13 Jan 2009
Posts: 33

PostPosted: Wed Sep 09, 2009 11:08 pm    Post subject: Reply with quote

Bonsoir,

je remonte ce petit topic car j'ai le même problème à savoir que gdm et xfce sont en qwerty alors qu'en shell de base sans xfce je suis bien en azerty.

Mon xorg.conf est bien configuré avec "fr" ainsi que le /etc/conf.d/keymaps.

Code:
Section "InputDevice"
        Identifier      "Keyboard0"
        Driver  "kbd"
        Option  "CoreKeyboard"
        Option  "XkbRules" "xorg"
        Option  "XkbModel" "pc105"
        Option  "XkbOptions" "grp:toggle,grp_led:scroll"
        Option  "XkbVariant" ",winkeys"
        Option  "XkbLayout" "fr"
EndSection


Je me demande si Keyboard0 est réellement Keyboard0 ? lspci ne me retourne pas mon clavier.
Back to top
View user's profile Send private message
ghoti
Advocate
Advocate


Joined: 30 Dec 2002
Posts: 3581
Location: Belgium

PostPosted: Wed Sep 09, 2009 11:32 pm    Post subject: Reply with quote

Woua le déterrage, l'autre ! 8O

Bon depuis 2006, les choses ont pas mal évolué niveau xorg : si tu l'as compilé avec le flag hal, alors xorg.conf n'est plus pris en compte.
Il y a eu plusieurs posts à ce sujet ces derniers mois ... ;)
Back to top
View user's profile Send private message
_KdZ
n00b
n00b


Joined: 13 Jan 2009
Posts: 33

PostPosted: Thu Sep 10, 2009 1:08 am    Post subject: Reply with quote

Effectivement je pense que c'est la cas ( USE="hal ?) :

Code:
 sudo emerge -pv xorg-server

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild   R   ] x11-base/xorg-server-1.5.3-r6  USE="hal ipv6 nptl sdl xorg -3dfx -debug -dmx -kdrive -minimal -tslib" INPUT_DEVICES="evdev keyboard mouse -acecad -aiptek -citron -elographics -fpit -hyperpen -joystick -mutouch -penmount -synaptics -tslib -virtualbox -vmmouse -void -wacom" VIDEO_CARDS="-apm -ark -ast -chips -cirrus -dummy -epson -fbdev -geode -glint -i128 -i740 (-impact) -imstt -intel -mach64 -mga -neomagic (-newport) -nv -nvidia -r128 -radeon -radeonhd -rendition -s3 -s3virge -savage -siliconmotion -sis -sisusb (-sunbw2) (-suncg14) (-suncg3) (-suncg6) (-sunffb) (-sunleo) (-suntcx) -tdfx -tga -trident -tseng -v4l -vermilion -vesa -via -virtualbox -vmware -voodoo -xgi" 0 kB



Par contre quand tu dis que le xorg.conf n'est plus pris en compte c'est que pour les claviers ? Parceque ma résolution est configurée dedans comme tout le reste d'ailleurs et je peux te confirmer qu'il est bien utilisé pour la conf.

Qu'en penses-tu ?
Back to top
View user's profile Send private message
ghoti
Advocate
Advocate


Joined: 30 Dec 2002
Posts: 3581
Location: Belgium

PostPosted: Thu Sep 10, 2009 8:21 am    Post subject: Reply with quote

_KdZ wrote:
Par contre quand tu dis que le xorg.conf n'est plus pris en compte c'est que pour les claviers ?

Pour tous les "InputDevices" ;)

Néanmoins, >=xorg-1.6 est capable de détecter et configurer le matériel en interrogeant hal de sorte que xorg.conf n'est en principe plus nécessaire sauf cas particuliers (par exemple : si tu utilises des pilotes propriétaires ou si tu veux des options qui sortent de l'ordinaire ...)
Back to top
View user's profile Send private message
mr-ti
Tux's lil' helper
Tux's lil' helper


Joined: 09 Jul 2006
Posts: 96
Location: Tours

PostPosted: Thu Sep 10, 2009 8:32 am    Post subject: Reply with quote

et si tu emploie evdev (module de xorg) il faut éditer le fichier /etc/hal/fdi/policy/keymap.fdi et mettre fr à la place de en dans la ligne suivante :
<merge key="input.xkb.layout" type="string">en</merge>

si le fichier /etc/hal/fdi/policy/keymap.fdi n'existe pas il fait le copier à partir de /usr/share/hal/fdi/policy/10osvendor/10-keymap.fdi
_________________
Core i5 750 / 16Go DDR3 > DD 2To / OVH / Gentoo LINUX x86_64
Phenon II 940 / 8Go DDR2 / 2DD 500GB / GF 250GTX / Gentoo LINUX x86_64
Core i7 740 / 6Go DDR3 / DD 340GB / GF GT 425M / Gentoo LINUX x86_64
Back to top
View user's profile Send private message
_KdZ
n00b
n00b


Joined: 13 Jan 2009
Posts: 33

PostPosted: Thu Sep 10, 2009 12:50 pm    Post subject: Reply with quote

Super !

ça fonctionne, et effectivement le fichier n'existait pas je l'ai donc copier.

Doublement résolu ce topic !

Merci ;)
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index French All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum