Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
(emerge) mise a jours. ati-drivers bloque ma geForce.
View unanswered posts
View posts from last 24 hours

 
This topic is locked: you cannot edit posts or make replies.    Gentoo Forums Forum Index French
View previous topic :: View next topic  
Author Message
pasmoi
n00b
n00b


Joined: 22 Aug 2007
Posts: 59

PostPosted: Mon Jul 06, 2009 12:30 pm    Post subject: (emerge) mise a jours. ati-drivers bloque ma geForce. Reply with quote

Bonjour,
bon, ma touche crochet ne fonctionne plus sur ma vielle gentoo de secours, mais on s'en fout ... juste pour le titre ...

Je viens d'essayer de mettre ma gentoo @ jours.
Mais en plein millieu de la mise a jours, lors de la compilation du drivers ATI fglrx, la compile plante (j'avais deja des problemes lorsque j'avais une carte ati avec le drivers proprietaire ed merde d'ati, mais pas a ce point la), et du coup, ma mise a jours est bloquee.

Le probleme, c'est que j'ai un systeme a moitie mis a jours, et donc qui ne marche plus: xorg plante tout mon ordi au lancement desormais.
En plus, je n'ai pas une carte ATI, mais une GeForce de chez nvidia, donc ce driver de merde qui me fait chiez, je voudrais juste le virer, mais les dependances du serveur graphique me le remettent.


Donc voila, comment je fait pour avoir de nouveau une gentoo qui marche?

Et au passage: pourquoi une fois sur 2, la mise a jours de la gentoo casses-t-elle tout????? meme le systeme pouris de ms a pas des mises a jours qui beugent a ce point!
Back to top
View user's profile Send private message
kernelsensei
Bodhisattva
Bodhisattva


Joined: 22 Feb 2004
Posts: 5619
Location: Woustviller/Moselle/FRANCE (49.07°N;7.02°E)

PostPosted: Mon Jul 06, 2009 1:42 pm    Post subject: Reply with quote

Salut,

si portage veut installer les drivers ATI il y a sûrement une raison. Peux-tu nous donner ton emerge --info ?

Sinon pour poursuivre après un plantage de compil tu peux simplement faire emerge --resume --skipfirst ou alors commencer la mise a jour avec l'option --keep-going
_________________
$ ruby -e'puts " .:@BFegiklnorst".unpack("x4ax7aaX6ax5aX15ax4aax6aaX7ax2aX5aX8 \
axaX3ax8aX4ax6aX3aX6ax3ax3aX9ax4ax2aX9axaX6ax3aX2ax4ax3aX4aXaX12ax10aaX7a").join'
Back to top
View user's profile Send private message
CryoGen
Veteran
Veteran


Joined: 11 Feb 2004
Posts: 1426
Location: Bamako - Mali - Afrique

PostPosted: Mon Jul 06, 2009 7:59 pm    Post subject: Re: (emerge) mise a jours. ati-drivers bloque ma geForce. Reply with quote

pasmoi wrote:
Et au passage: pourquoi une fois sur 2, la mise a jours de la gentoo casses-t-elle tout????? meme le systeme pouris de ms a pas des mises a jours qui beugent a ce point!


... j'en ai vu de beau des trolls mais là :roll:
_________________
- CryoGen` on #gentoofr@irc.freenode.net
- ~amd64 / KDE4
- I'm the bone of my sword...
Back to top
View user's profile Send private message
ppg
Apprentice
Apprentice


Joined: 05 Oct 2008
Posts: 178
Location: Toulouse

PostPosted: Mon Jul 06, 2009 9:30 pm    Post subject: Reply with quote

Euh si tu veux recevoir un peu d'aide il faudrait être plus précis parce que là c'est vague ; les logs avec les erreurs seraient un bon début.
Back to top
View user's profile Send private message
ghoti
Advocate
Advocate


Joined: 30 Dec 2002
Posts: 3581
Location: Belgium

PostPosted: Tue Jul 07, 2009 12:05 am    Post subject: Re: (emerge) mise a jours. ati-drivers bloque ma geForce. Reply with quote

CryoGen wrote:
pasmoi wrote:
Et au passage: pourquoi une fois sur 2, la mise a jours de la gentoo casses-t-elle tout????? meme le systeme pouris de ms a pas des mises a jours qui beugent a ce point!


... j'en ai vu de beau des trolls mais là :roll:

Bah, le personnage est assez coutumier du genre :roll:
Vu sa piètre opinion concernant Gentoo, on se demande pourquoi il vient encore traîner ici :twisted:

/me retourne à sa sieste ...
Back to top
View user's profile Send private message
pasmoi
n00b
n00b


Joined: 22 Aug 2007
Posts: 59

PostPosted: Wed Jul 08, 2009 6:05 am    Post subject: Reply with quote

ben je peut pas être précis.

sauf si vous me dites comment copier les 3 écran en mode console que me sort emerge,
puis rédémmarrer sur un système qui marche
et enfin faire le "coller".

Je ne vais pas recopier les 3 écrans à la main sur une feuille de papier, puis venier les retaper ici.

Tout ce que je dit, c'est que c'est pas normal que le drivers proprio de merde d'ati viennne me flinguer mon système alors que j'ai une carte graphique NVidia!

sinon, c'est pas un troll: la gentoo m'a fait perdre des heures de travail, même les reformatages mensuels de windobe98 n'en avaient pas fait autant. Je réparre mon système, je récupère mes bookmarks, sessions, configs ... et je passe à slackware! Gentoo, ça à l'air bien pour faire mumuse comme lfs, mais ça ne permet pas de travailler de manière fiable!

la je vais essayer le --skip-first ...
j'avais essayé de masquer ces drivers, mais le serveur x reffusait de s'installer ...

_______
pasmoi
A la recherche d'une distrib qui marche!


------------------------
Edit avec lynk ... je ne voi rien, j'esp}re que /a s'{crit correctement.
bon, voila avec --skipfirst, /a ne met qu'un seul {cran d'erreur:

Code:

localhost ~ # emerge --skipfirst

 * IMPORTANT: 2 news items need reading for repository 'gentoo'.
 * Use eselect news to read news items.

Calculating dependencies \
 * One or more packages are either masked or have missing dependencies:
 *
 *   >=x11-drivers/ati-drivers-8.552-r2 pulled in by:
 *     ('installed', '/', 'x11-base/xorg-server-1.5.3-r6', 'nomerge')
 *
 * The resume list contains packages that are either masked or have
 * unsatisfied dependencies. Please restart/continue the operation
 * manually, or use --skipfirst to skip the first package in the list and
 * any other packages that may be masked or have missing dependencies.

 * IMPORTANT: 2 news items need reading for repository 'gentoo'.
 * Use eselect news to read news items.



Last edited by pasmoi on Wed Jul 08, 2009 6:19 am; edited 1 time in total
Back to top
View user's profile Send private message
kwenspc
Advocate
Advocate


Joined: 21 Sep 2003
Posts: 4954

PostPosted: Wed Jul 08, 2009 6:19 am    Post subject: Reply with quote

Qu'est ce qu'il faut pas lire comme niaiseries :roll:

Si ati est en dépendance c'est uniquement la faute du truc qu'il y a entre la chaise et le clavier. Vas voir à VIDEO_CARDS dans ton make.conf...

S'énerver quand on comprend rien, je conçois. Porter des jugements hâtifs et stériles basés sur l'ignorance, ça me sidère.
Back to top
View user's profile Send private message
kernelsensei
Bodhisattva
Bodhisattva


Joined: 22 Feb 2004
Posts: 5619
Location: Woustviller/Moselle/FRANCE (49.07°N;7.02°E)

PostPosted: Wed Jul 08, 2009 7:57 am    Post subject: Reply with quote

moi je pense effectivement aux video_cards. un emerge --info nous en dira plus.

Tu peux très bien rediriger les sorties d'une commande vers un fichier texte et le copier / uploader à partir d'un système qui fonctionne :
Code:
emerge --info > emerge_info

_________________
$ ruby -e'puts " .:@BFegiklnorst".unpack("x4ax7aaX6ax5aX15ax4aax6aaX7ax2aX5aX8 \
axaX3ax8aX4ax6aX3aX6ax3ax3aX9ax4ax2aX9axaX6ax3aX2ax4ax3aX4aXaX12ax10aaX7a").join'
Back to top
View user's profile Send private message
pasmoi
n00b
n00b


Joined: 22 Aug 2007
Posts: 59

PostPosted: Wed Jul 08, 2009 10:04 am    Post subject: Reply with quote

kwenspc wrote:
Qu'est ce qu'il faut pas lire comme niaiseries :roll:

Si ati est en dépendance c'est uniquement la faute du truc qu'il y a entre la chaise et le clavier. Vas voir à VIDEO_CARDS dans ton make.conf...

S'énerver quand on comprend rien, je conçois. Porter des jugements hâtifs et stériles basés sur l'ignorance, ça me sidère.


en effet: tu devrais éviter de te ridiculiser avec tes jugements hâtifs: vérifier qu'il n'y avait plus d' "ati" dans mon make.conf, c'est le premier truc que j'ai fait quand j'ai vu ce problème (sachant qu'avant, j'avais une carte ati).

Bon, heureusement que je sait programmer: j'ai regardé la compilation, et apparament, il ne trouve pas la lib GL, et c'est ce qui fait tout foirer.
(le -lGL qui resort en erreur au niveau du ld)

j'ai essayé plein de truc, mais la j'ai plus le temps, je fout ma gentoo a la poubelle, et je vais essayer une autre distrib, pour continuer à travailler!
Back to top
View user's profile Send private message
xaviermiller
Administrator
Administrator


Joined: 23 Jul 2004
Posts: 7972
Location: ~Brussels - Belgique

PostPosted: Wed Jul 08, 2009 10:07 am    Post subject: Reply with quote

Avant de prendre des conclusions trop rapides, pourrais-tu nous donner le résultat de "emerge --info" ?
_________________
Kind regards,
Xavier Miller
Back to top
View user's profile Send private message
kernelsensei
Bodhisattva
Bodhisattva


Joined: 22 Feb 2004
Posts: 5619
Location: Woustviller/Moselle/FRANCE (49.07°N;7.02°E)

PostPosted: Wed Jul 08, 2009 10:29 am    Post subject: Reply with quote

Dans la cas où tu as viré le flag ati, je suppose que tu as pensé à faire un emerge --depclean ou alors virer les drivers ATI à la main emerge -aC ati-drivers

Peux-tu aussi nous donner le résultat de eselect opengl list ?

Et oui, 3e demande pour emerge --info
_________________
$ ruby -e'puts " .:@BFegiklnorst".unpack("x4ax7aaX6ax5aX15ax4aax6aaX7ax2aX5aX8 \
axaX3ax8aX4ax6aX3aX6ax3ax3aX9ax4ax2aX9axaX6ax3aX2ax4ax3aX4aXaX12ax10aaX7a").join'
Back to top
View user's profile Send private message
kwenspc
Advocate
Advocate


Joined: 21 Sep 2003
Posts: 4954

PostPosted: Wed Jul 08, 2009 11:00 am    Post subject: Reply with quote

pasmoi wrote:

en effet: tu devrais éviter de te ridiculiser avec tes jugements hâtifs: vérifier qu'il n'y avait plus d' "ati" dans mon make.conf, c'est le premier truc que j'ai fait quand j'ai vu ce problème (sachant qu'avant, j'avais une carte ati).

C'est fglrx qu'il faut regarder, pas ati... [edit]quand je dis que tu piges que dalle à ce que tu fais.[/edit]
Back to top
View user's profile Send private message
kernelsensei
Bodhisattva
Bodhisattva


Joined: 22 Feb 2004
Posts: 5619
Location: Woustviller/Moselle/FRANCE (49.07°N;7.02°E)

PostPosted: Wed Jul 08, 2009 11:05 am    Post subject: Reply with quote

@kwenspc: bien vu ;)

EDIT : Pas contre c'est pas la peine de jetter de l'huile sur le feu...
_________________
$ ruby -e'puts " .:@BFegiklnorst".unpack("x4ax7aaX6ax5aX15ax4aax6aaX7ax2aX5aX8 \
axaX3ax8aX4ax6aX3aX6ax3ax3aX9ax4ax2aX9axaX6ax3aX2ax4ax3aX4aXaX12ax10aaX7a").join'
Back to top
View user's profile Send private message
mrpouet
Retired Dev
Retired Dev


Joined: 29 Jul 2008
Posts: 87
Location: Bordeaux, France

PostPosted: Wed Jul 08, 2009 11:30 am    Post subject: Reply with quote

pasmoi wrote:

Gentoo, ça à l'air bien pour faire mumuse comme lfs, mais ça ne permet pas de travailler de manière fiable!


Ben c'est à dire que sans aucun argument technique formulé avec, c'est trés subjectif comme raisonnement tout de même.
Gentoo s'adresse en génèral à un public avertis, QUI SAIT LIRE , QUI SAIT CHERCHER, et QUI SAIT FORMULER UNE REQUETE,
sans porter de jugements qui n'ont pas lieux d'être (ya même des débutants qui sont sous gentoo, qui sont trés agréable, qui savent chercher et poser les question correctement)

pasmoi wrote:

en effet: tu devrais éviter de te ridiculiser avec tes jugements hâtifs


sauf mon respect, c'est pas kwenspc qui se ridiculise là ^^.

Surtout que bon porter un jugement sur une distribution pour UN problême euh... excuses moi c'est pas valable.

EDIT: quand je lis des choses comme çà désolé mais çà me dépasse ^^
Back to top
View user's profile Send private message
kernelsensei
Bodhisattva
Bodhisattva


Joined: 22 Feb 2004
Posts: 5619
Location: Woustviller/Moselle/FRANCE (49.07°N;7.02°E)

PostPosted: Wed Jul 08, 2009 1:27 pm    Post subject: Reply with quote

Bon vu que pasmoi a sûrement balancé sa gentoo à la poubelle, ce thread n'apportera plus rien. Lock
_________________
$ ruby -e'puts " .:@BFegiklnorst".unpack("x4ax7aaX6ax5aX15ax4aax6aaX7ax2aX5aX8 \
axaX3ax8aX4ax6aX3aX6ax3ax3aX9ax4ax2aX9axaX6ax3aX2ax4ax3aX4aXaX12ax10aaX7a").join'
Back to top
View user's profile Send private message
Display posts from previous:   
This topic is locked: you cannot edit posts or make replies.    Gentoo Forums Forum Index French All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum