Joined: 12 May 2004
|Posted: Mon Jun 29, 2009 11:26 pm Post subject: [ GLSA 200906-03 ] phpMyAdmin: Multiple vulnerabilities
|Gentoo Linux Security Advisory
Title: phpMyAdmin: Multiple vulnerabilities (GLSA 200906-03)
Date: June 29, 2009
Multiple errors in phpMyAdmin might allow the remote execution of arbitrary code or a Cross-Site Scripting attack.
phpMyAdmin is a web-based management tool for MySQL databases.
Vulnerable: < 184.108.40.206
Unaffected: >= 220.127.116.11
Architectures: All supported architectures
Multiple vulnerabilities have been reported in phpMyAdmin:
- Greg Ose discovered that the setup script does not sanitize input properly, leading to the injection of arbitrary PHP code into the configuration file (CVE-2009-1151).
- Manuel Lopez Gallego and Santiago Rodriguez Collazo reported that data from cookies used in the "Export" page is not properly sanitized (CVE-2009-1150).
A remote unauthorized attacker could exploit the first vulnerability to execute arbitrary code with the privileges of the user running phpMyAdmin and conduct Cross-Site Scripting attacks using the second vulnerability.
Removing the "scripts/setup.php" file protects you from CVE-2009-1151.
All phpMyAdmin users should upgrade to the latest version:
|# emerge --sync
# emerge --ask --oneshot --verbose ">=dev-db/phpmyadmin-18.104.22.168"