Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
DSM_G600, chroot gentoo stage 2006, maj portage impossible
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2  
Reply to topic    Gentoo Forums Forum Index French
View previous topic :: View next topic  
Author Message
kwenspc
Advocate
Advocate


Joined: 21 Sep 2003
Posts: 4954

PostPosted: Wed Jun 24, 2009 1:36 pm    Post subject: Reply with quote

Yamashita Ren wrote:

Là je comprends pas tout ...
Il sort d'où ce portage-2.1.5 ?

Hum, ne fais pas un update de portage en spécifiant toi même la version. Ensuite tu risques d'avoir des soucis de paquets bloquants de ce genre et une floppée dû au fait que l'arbre portage actuel est très loin de 2006. Sinon oui c'est bizarre ce truc. Peux tu faire un emerge -pv sys-apps/portage app-shells/bash sys-apps/util-linux
Back to top
View user's profile Send private message
xaviermiller
Administrator
Administrator


Joined: 23 Jul 2004
Posts: 7972
Location: ~Brussels - Belgique

PostPosted: Wed Jun 24, 2009 1:39 pm    Post subject: Reply with quote

Salut,

Essaie d'installer d'abord un autre firmware supportant Linux 2.6, en cherchant un peu, je suis tombé sur ceci : http://www.nslu2-linux.org/wiki/DSMG600/InstallingSlugOS
_________________
Kind regards,
Xavier Miller
Back to top
View user's profile Send private message
Yamashita Ren
n00b
n00b


Joined: 23 Jun 2009
Posts: 17

PostPosted: Wed Jun 24, 2009 4:16 pm    Post subject: Reply with quote

XavierMiller wrote:
Salut,

Essaie d'installer d'abord un autre firmware supportant Linux 2.6, en cherchant un peu, je suis tombé sur ceci : http://www.nslu2-linux.org/wiki/DSMG600/InstallingSlugOS


Quote:
DSM-G600 Rev A Hardware only


J'ai la rev B ...

Mais je vais quand même chercher dans ce créneau là.

kwenspc wrote:

Hum, ne fais pas un update de portage en spécifiant toi même la version. Ensuite tu risques d'avoir des soucis de paquets bloquants de ce genre et une floppée dû au fait que l'arbre portage actuel est très loin de 2006. Sinon oui c'est bizarre ce truc. Peux tu faire un emerge -pv sys-apps/portage app-shells/bash sys-apps/util-linux

Le problème c'est que si je fais une update de la dernière version de portage, il me dit qu'il a besoin de python(qui nécessite une version récente de portage pour être installé).
Je vais tester la commande que tu m'as donné.

edit : le problème est toujours le même
Code:
root@DSM-G600 esearch # emerge -pv sys-apps/portage app-shells/bash sys-apps/util-linux

These are the packages that would be merged, in order:

Calculating dependencies -
!!! All ebuilds that could satisfy ">=dev-lang/python-2.5" have been masked.
!!! One of the following masked packages is required to complete your request:
- dev-lang/python-2.6.2-r1 (masked by: required EAPI -2, supported EAPI 0)
- dev-lang/python-2.5.4-r2 (masked by: required EAPI -1, supported EAPI 0)
- dev-lang/python-2.5.4-r3 (masked by: required EAPI -1, supported EAPI 0)

For more information, see MASKED PACKAGES section in the emerge man page or
refer to the Gentoo Handbook.
(dependency required by "sys-apps/portage-2.1.6.13" [ebuild])


Pour updater portage, il me faut python et pour avoir python il faut updater portage vers une version intermédiaire ...
Back to top
View user's profile Send private message
xaviermiller
Administrator
Administrator


Joined: 23 Jul 2004
Posts: 7972
Location: ~Brussels - Belgique

PostPosted: Wed Jun 24, 2009 4:59 pm    Post subject: Reply with quote

Oui, ça va être galère.

Etape 1 : cherche un firmware avec noyau linux 2.6.*
Etape 2: prends un stage récent (2009) pour ARM.

Et tout ira plus facilement.
_________________
Kind regards,
Xavier Miller
Back to top
View user's profile Send private message
Yamashita Ren
n00b
n00b


Joined: 23 Jun 2009
Posts: 17

PostPosted: Wed Jun 24, 2009 6:08 pm    Post subject: Reply with quote

Malheureusement je crois qu'il n'y en a pas comme semble l'indiquer ce post : http://forum.dsmg600.info/viewtopic.php?id=477&p=2
Back to top
View user's profile Send private message
truc
Advocate
Advocate


Joined: 25 Jul 2005
Posts: 3199

PostPosted: Wed Jun 24, 2009 6:26 pm    Post subject: Reply with quote

XavierMiller wrote:
N'as-tu pas trouvé un stage plus récent ? (sur http://www.funtoo.org entre autres)


Mais y'a des stages 'gentoo' à jour également sur les mirroirs dans las section release/arch/autobuild par exemple.
_________________
The End of the Internet!
Back to top
View user's profile Send private message
xaviermiller
Administrator
Administrator


Joined: 23 Jul 2004
Posts: 7972
Location: ~Brussels - Belgique

PostPosted: Wed Jun 24, 2009 9:18 pm    Post subject: Reply with quote

Oui, c'est récent, Funtoo a permis que Gentoo le fasse ;)
(et pour info Funtoo ne construit des stages que pour les architectures PC/x86(_64). Pas les ARM.
_________________
Kind regards,
Xavier Miller
Back to top
View user's profile Send private message
xaviermiller
Administrator
Administrator


Joined: 23 Jul 2004
Posts: 7972
Location: ~Brussels - Belgique

PostPosted: Wed Jun 24, 2009 9:23 pm    Post subject: Reply with quote

Sinon, il reste une solution : tout compiler à la main : binutils , glibc, gcc, et toutes les dépendances de ton serveur torrent. Tout cela "nativement", c'est-à-dire dans le shell même de ton NAS.

Dans ce cas, tu devras zyeuter un projet genre "Linux From Scratch", du moins la partie "compile toolchain".
_________________
Kind regards,
Xavier Miller
Back to top
View user's profile Send private message
Yamashita Ren
n00b
n00b


Joined: 23 Jun 2009
Posts: 17

PostPosted: Wed Jun 24, 2009 10:16 pm    Post subject: Reply with quote

Oulah, là ça devient trop bourrin pour moi.
désolé ^^
Mais ça m'étonne qu'il n'y ait aucun moyen de maj portage ...
Par exemple dans une distrib binaire tu sort les paquets qui vont bien et tu maj tout (sauf dans mon cas si le paquet dépend d'un kernel récent).
Ces EAPI, y'a aucun moyen de les contourner ?
Back to top
View user's profile Send private message
kwenspc
Advocate
Advocate


Joined: 21 Sep 2003
Posts: 4954

PostPosted: Thu Jun 25, 2009 5:17 am    Post subject: Reply with quote

Yamashita Ren wrote:

Ces EAPI, y'a aucun moyen de les contourner ?

Pas vraiment vu que ça concerne les api utilisé dans les ebuilds.

Par contre doit bien y avoir un moyen de mettre à jour portage, faut qu'on trouve comment.
Back to top
View user's profile Send private message
xaviermiller
Administrator
Administrator


Joined: 23 Jul 2004
Posts: 7972
Location: ~Brussels - Belgique

PostPosted: Thu Jun 25, 2009 7:19 am    Post subject: Reply with quote

Oh, j'y pense !

Le "profile" est-il bon (eselect profile list) ?

Il y a, si je me souviens bien, un profile "linux 2.4"

A vérifier...
_________________
Kind regards,
Xavier Miller
Back to top
View user's profile Send private message
Yamashita Ren
n00b
n00b


Joined: 23 Jun 2009
Posts: 17

PostPosted: Thu Jun 25, 2009 12:01 pm    Post subject: Reply with quote

Code:
root@DSM-G600 / # eselect profile list
Available profile symlink targets:
  [1]   default/linux/powerpc/ppc32/2008.0
  [2]   default/linux/powerpc/ppc32/2008.0/desktop
  [3]   default/linux/powerpc/ppc32/2008.0/developer
  [4]   default/linux/powerpc/ppc32/2008.0/server
  [5]   default/linux/powerpc/ppc64/2008.0/32bit-userland
  [6]   default/linux/powerpc/ppc64/2008.0/32bit-userland/desktop
  [7]   default/linux/powerpc/ppc64/2008.0/32bit-userland/developer
  [8]   default/linux/powerpc/ppc64/2008.0/32bit-userland/server
  [9]   hardened/ppc
  [10]  hardened/linux/powerpc/ppc32


Pas de trace de linux 2.4 ...

@kwenspc
Oui mettre à jour portage, si seulement c'était si facile ...
Et compiler portage à la main, ça pourrait pas passer ?
Back to top
View user's profile Send private message
boozo
Advocate
Advocate


Joined: 01 Jul 2004
Posts: 3193

PostPosted: Thu Jun 25, 2009 12:17 pm    Post subject: Reply with quote

'alute

pour un profiles 2.4 faut passer par uclibc non ? ( genre /usr/portage/profiles/uclibc/arm/2.4 )

Sinon j'avais toujours en réserve cet how-to pour NSLU2 dans mes bookmarks ('atin elle ne maigrira jamais cette todo list :roll: )
Jette un oeil si jamais qu'il se puisse facilement décliner à ta bestiole (enfin, à vérifier auprès de plus compétent)
_________________
" Un psychotique, c'est quelqu'un qui croit dur comme fer que 2 et 2 font 5, et qui en est pleinement satisfait.
Un névrosé, c'est quelqu'un qui sait pertinemment que 2 et 2 font 4, et ça le rend malade ! "
Back to top
View user's profile Send private message
El_Goretto
Moderator
Moderator


Joined: 29 May 2004
Posts: 3090
Location: Paris

PostPosted: Thu Jun 25, 2009 12:17 pm    Post subject: Reply with quote

Code:
$ find /usr/portage/profiles/ -name "*2.4"
/usr/portage/profiles/uclibc/ppc/2.4
/usr/portage/profiles/uclibc/ppc/hardened/2.4

Aucune idée de ce que c'est, uclibc...

--
edit:
damned, gilled pour un poil de rien :)
et du coup maintenant je sais...

_________________
-Gentoo hardened [EoL]: µ-serv Gen8 G1610T, 8Go ECC ; NF9D-2700, 4Go
-FreeBSD 11/Vimage/Jails: DS61, i3 2100T, 16Go ; FreeNAS: µ-serv N40L, 8Go ECC
-Réseau: ERL-3 + ESL-24 + GS108Tv2
-NAS: RN312


Last edited by El_Goretto on Thu Jun 25, 2009 12:19 pm; edited 1 time in total
Back to top
View user's profile Send private message
boozo
Advocate
Advocate


Joined: 01 Jul 2004
Posts: 3193

PostPosted: Thu Jun 25, 2009 12:19 pm    Post subject: Reply with quote

@ El_Goretto : c'est une libc compacte très utilisé pour l'embarqué :wink:

Edit:
@ OP : au fait, faudrait sans doute modifier le titre du topic parce que là c'est pas vraiment explicite :)
_________________
" Un psychotique, c'est quelqu'un qui croit dur comme fer que 2 et 2 font 5, et qui en est pleinement satisfait.
Un névrosé, c'est quelqu'un qui sait pertinemment que 2 et 2 font 4, et ça le rend malade ! "
Back to top
View user's profile Send private message
Yamashita Ren
n00b
n00b


Joined: 23 Jun 2009
Posts: 17

PostPosted: Thu Jun 25, 2009 2:10 pm    Post subject: Reply with quote

Je vais voir ton tuto pour le nslu2 mais ça m'étonnerait que ça passe.
Suffit que l'architecture soit différente ...

Sinon je viens de changer le titre du topic.
Back to top
View user's profile Send private message
brubru
Tux's lil' helper
Tux's lil' helper


Joined: 14 May 2008
Posts: 109
Location: France

PostPosted: Thu Jun 25, 2009 3:55 pm    Post subject: Reply with quote

Et du côté de Gentoo/Alt aka Gentoo Prefix ? le but du projet est de pouvoir compiler (avec portage) et faire tourner des applications « préfixées » dans /home/user/gentoo par exemple, sur un système différent: Debian, MacOSX, Solaris, Windows.
L'overlay indique la présence de rtorrent : http://overlays.gentoo.org/proj/alt/browser/trunk/prefix-overlay/net-p2p/rtorrent
Mais niveau architecture, il y a seulement amd64-linux x86-linux ppc-macos x86-macos, il faudrait ppc-linux et encore on a pas l'assurance que Gentoo Prefix fonctionne avec un noyau 2.4.
Quelqu'un a plus d'infos sur Prefix ?

Sinon, en regardant les dépendances de rtorrent j'ai quelquechose comme :
Code:
            >=net-libs/libtorrent-0.12.4
            >=dev-libs/libsigc++-2.2.2
            >=net-misc/curl-7.19.1
            sys-libs/ncurses
            xmlrpc? (
                dev-libs/xmlrpc-c
            )
            daemon? (
                app-misc/screen
            )
            dev-util/pkgconfig


Donc une compilation à la mano reste du possible, mais bon tu perds les avantages de gentoo : avoir un système linux pour tout bidouiller, là tu n'aurais qu'un exécutable :D
Il te faut aussi une toolchain pour compiler, le stage3 de 2006 doit faire l'affaire je pense, mais l'idéal serait un sdk pour la machine (et pouvoir faire du cross-compile).
Back to top
View user's profile Send private message
yoyo
Bodhisattva
Bodhisattva


Joined: 04 Mar 2003
Posts: 4273
Location: Lyon - France

PostPosted: Thu Jun 25, 2009 4:24 pm    Post subject: Reply with quote

Yamashita Ren wrote:
J'avais un laptop presque perso (Intel core duo, 1 GB de ram).
Mais le laptop professionel de mon père à eu un problème (du jour au lendemain il a déconné; depuis impossible de réinstaller un SE dessus, même en changeant le disque dur; d'ailleurs si vous avez une piste pour le diagnostic je suis plus que preneur).
Donc maintenant il me pique mon laptop (qui était lui aussi + ou - familial).
Bon je dévie un peu le sujet mais personne n'a semblé prêter attention à ce post : tu as testé la mémoire vive ? Avec Memtest86+ ou via un LiveCD type SystemRescueCd.
C'est assez courant comme "panne" et le changement de mémoire vive souvent assez simple (sûrement plus que la manip' que tu veux faire :roll: ).

Enjoy !
_________________
La connaissance s'accroît quand on la partage.
JCB
Back to top
View user's profile Send private message
Yamashita Ren
n00b
n00b


Joined: 23 Jun 2009
Posts: 17

PostPosted: Thu Jun 25, 2009 5:53 pm    Post subject: Reply with quote

J'ai lancé le memtest plusieurs fois et à chaque fois mon père me disait qu'il ne détectait aucun problème (j'ai jamais pu voir les résultats personnellement).
Sinon j'ai l'impression que ça déconne plutôt au niveau du bios (je sais reconnaitre le moment ou c'est le bootloader qui prends la main).
Il me semble que le bios peut agir de lui même sans ram (ais-je tort ?)
Or là il déconne complètement en nous sortant une histoire de DDR nécessitant un password.
Si on y va au forcing en appuyant 20 fois sur "entrée", je crois qu'on a le choix du support de boot.
Dans ce cas je peux lancer un live cd (élimination de l'hypothèse RAM défectueuse non ?) sans encombres (il me rabâche juste une erreur I/O je crois).
Je peux même installer l'OS sur certains secteurs du disque.
Mais si j'utilise tout le disque, le disque commence à déconner (peu importe le disque d'ailleurs).

Enfin c'est vraiment bizar.

Exemple : j'installe Windows sur les 20 premiers GO aucun problème, puis j'installe Ubuntu sur les GO restant ça déconne.
Si j'installe Ubuntu puis Windows le constat est le même.
Comme je le disais précédemment, jai l'impression qu'après une certain tranche de secteurs, ça déconne.
Et pourtant changer le DDR, n'a rien arrangé !
Idem si j'installe un seul os sur tout le disque, ça bug.

Bref un jour ou j'en aurais le courage je tenterais un flash bios, mais je n'y crois guère ...

J'espère que vous comprenez au moins quel est le problème (à défaut d'avoir une solution et je ne vous en veux guère ^^)



Sinon pour la compil rtorrent, je vais y penser.
A la base, soyons honnêtes, je suis allé sur gentoo à défaut de pouvoir utiliser debian.
J'aimerais utiliser portage mais si je peux compiler rtorrent ça serait déjà bien.
Enfin le problème de cette méthode, c'est qu'elle n'est pas très pérenne car un jour je vais être obligé de faire une grosse MAJ pour compiler la version supérieure et là ça sera pire ...
Par contre une compilation de portage, vous pensez que ça pourrait passer ?
Back to top
View user's profile Send private message
Yamashita Ren
n00b
n00b


Joined: 23 Jun 2009
Posts: 17

PostPosted: Sat Jun 27, 2009 6:52 pm    Post subject: Reply with quote

Bon oublions l'histoire du laptop défectueux.
Ce n'est pas le problème et à chaque fois que j'en parle ça fait le même effet qu'un trou noir.

brubru wrote:


Sinon, en regardant les dépendances de rtorrent j'ai quelquechose comme :
Code:
            >=net-libs/libtorrent-0.12.4
            >=dev-libs/libsigc++-2.2.2
            >=net-misc/curl-7.19.1
            sys-libs/ncurses
            xmlrpc? (
                dev-libs/xmlrpc-c
            )
            daemon? (
                app-misc/screen
            )
            dev-util/pkgconfig


Donc une compilation à la mano reste du possible, mais bon tu perds les avantages de gentoo : avoir un système linux pour tout bidouiller, là tu n'aurais qu'un exécutable :D
Il te faut aussi une toolchain pour compiler, le stage3 de 2006 doit faire l'affaire je pense, mais l'idéal serait un sdk pour la machine (et pouvoir faire du cross-compile).


En fait quand je compile rtorrent avec emerge, il me dit qu'il manque openssl.
Je vais plutôt essayer de chercher le problème de ce coté là.

edit : en fait j'en reviens toujours au même problème, portage.
Il suffirait que je le mette à jour vers une version supportant l'EAPI 1 pour que mes problèmes se résolvent d'eux même ...
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index French All times are GMT
Goto page Previous  1, 2
Page 2 of 2

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum