Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[RISOLTO] Notebook lento graficamente
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian)
View previous topic :: View next topic  
Author Message
lsegalla
l33t
l33t


Joined: 27 Jun 2007
Posts: 796

PostPosted: Mon Apr 27, 2009 7:22 am    Post subject: [RISOLTO] Notebook lento graficamente Reply with quote

Salve, ho un notebook e ho finito di installarci gentoo da una settimana. In linea di massima ho fatto un po' tutto quel che mi serviva pero' mi sembra che sia un pochettino lento almeno graficamente. Poi ho partizionato e dall'altra parte ho installato sabayon. Quest'ultimo non lo uso ma ero curioso di provarlo, anche perchè l'ho forzatamente buttato su a un mio collega e ogni tanto ha qualche problema quindi mi capita pero' raramente di metterci le mani sopra per capire alcune cose.

Detto questo noto comunque che su sabayon il sistema è piu' rapido nonostante le mille cose che ci sono installate (detto questo non c'entra niente magari), fatto sta che vorrei migliorare il mio gentoo che come da titolo lo trovo un pelino lento graficamente (un sintomo è che se apro graficamente KONSOLE e dopo un comando scorro con un PAGE UP e PAGE DOWN il refresh ad esempio è scattoso). Suppongo un qualcosa di compilato non bene dal punto di vista grafico, ma sono qui per migliorare ovviamente...
Nelle finestre con grafica invece (ad esempio nella navigazione web o scorrendo questo commento nel form o anche in un file word) ho gli stessi sintomi anche scorrendo con la rotella del mouse... noto una certa pesantezza... appena scorro la rotellina ci mette un bel po' a scorrere il testo...

La mia macchina è un notebook SONY VAIO VGN-NR10E on installato un kde 3.5.9 al quale accedo da modalità testo (cioè accendo il pc e non faccio partire kdm: digito le credenziali, faccio startx e vado... perchè non sempre mi interessa avviare il tutto graficamente)

Questa è la mia macchina:
Code:

user8-gentoo luca # lspci
00:00.0 Host bridge: Intel Corporation Mobile PM965/GM965/GL960 Memory Controller Hub (rev 0c)
00:02.0 VGA compatible controller: Intel Corporation Mobile GM965/GL960 Integrated Graphics Controller (rev 0c)
00:02.1 Display controller: Intel Corporation Mobile GM965/GL960 Integrated Graphics Controller (rev 0c)
00:1a.0 USB Controller: Intel Corporation 82801H (ICH8 Family) USB UHCI Controller #4 (rev 03)
00:1a.1 USB Controller: Intel Corporation 82801H (ICH8 Family) USB UHCI Controller #5 (rev 03)
00:1a.7 USB Controller: Intel Corporation 82801H (ICH8 Family) USB2 EHCI Controller #2 (rev 03)
00:1b.0 Audio device: Intel Corporation 82801H (ICH8 Family) HD Audio Controller (rev 03)
00:1c.0 PCI bridge: Intel Corporation 82801H (ICH8 Family) PCI Express Port 1 (rev 03)
00:1c.1 PCI bridge: Intel Corporation 82801H (ICH8 Family) PCI Express Port 2 (rev 03)
00:1c.2 PCI bridge: Intel Corporation 82801H (ICH8 Family) PCI Express Port 3 (rev 03)
00:1d.0 USB Controller: Intel Corporation 82801H (ICH8 Family) USB UHCI Controller #1 (rev 03)
00:1d.1 USB Controller: Intel Corporation 82801H (ICH8 Family) USB UHCI Controller #2 (rev 03)
00:1d.2 USB Controller: Intel Corporation 82801H (ICH8 Family) USB UHCI Controller #3 (rev 03)
00:1d.7 USB Controller: Intel Corporation 82801H (ICH8 Family) USB2 EHCI Controller #1 (rev 03)
00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev f3)
00:1f.0 ISA bridge: Intel Corporation 82801HEM (ICH8M) LPC Interface Controller (rev 03)
00:1f.1 IDE interface: Intel Corporation 82801HBM/HEM (ICH8M/ICH8M-E) IDE Controller (rev 03)
00:1f.2 SATA controller: Intel Corporation 82801HBM/HEM (ICH8M/ICH8M-E) SATA AHCI Controller (rev 03)
00:1f.3 SMBus: Intel Corporation 82801H (ICH8 Family) SMBus Controller (rev 03)
02:00.0 Ethernet controller: Marvell Technology Group Ltd. 88E8039 PCI-E Fast Ethernet Controller (rev 14)
06:00.0 Ethernet controller: Atheros Communications Inc. AR242x 802.11abg Wireless PCI Express Adapter (rev 01)
08:03.0 CardBus bridge: Texas Instruments PCIxx12 Cardbus Controller
08:03.1 FireWire (IEEE 1394): Texas Instruments PCIxx12 OHCI Compliant IEEE 1394 Host Controller
08:03.2 Mass storage controller: Texas Instruments 5-in-1 Multimedia Card Reader (SD/MMC/MS/MS PRO/xD)


-- EDIT --
Anche se faccio un emerge da KONSOLE sotto KDE vedo il refresh scattoso


Last edited by lsegalla on Wed May 20, 2009 2:17 pm; edited 1 time in total
Back to top
View user's profile Send private message
djinnZ
Advocate
Advocate


Joined: 02 Nov 2006
Posts: 4831
Location: somewhere in L.O.S.

PostPosted: Mon Apr 27, 2009 11:54 am    Post subject: Re: Notebook lento graficamente Reply with quote

lsegalla wrote:
kde 3.5.9 al quale accedo da modalità testo (cioè accendo il pc e non faccio partire kdm: digito le credenziali, faccio startx e vado... perchè non sempre mi interessa avviare il tutto graficamente)
mai sentito parlare di qingy? Login in modalità testo o grafica a scelta, autolock sui terminali e salvaschermo, provalo ne vale la pena. :wink:

Non hai qualche indizio, messaggi di errore in dmesg per esempio...

Su ati ho notato che il mio portatile tende a rallentare se usa il driver agp sbagliato (il mio ha il problema che risponde sia all'irongate che al''amd64 gart per dirne una), altre opzioni potrebbero essere firmware edid o tile biting od i9l supporto pe la console rotation od il supporto vga (che sulle matrox ho completamente disabilitato).

Se non è tutto builtin (cosa che preferisco, altrimenti che cavolo compilo a fare il kernel) darei anche uno sguardo ad una eventuale sovrapposizione dei driver intel.

Visto che sabayon è abbastanza vicina a gentoo perchè non ti copi la conf del kernel da li e provi a partire da quella?
_________________
scita et risus abundant in ore stultorum sed etiam semper severi insani sunt:wink:
mala tempora currunt...mater stultorum semper pregna est :evil:
Murpy'sLaw:If anything can go wrong, it will - O'Toole's Corollary:Murphy was an optimist :wink:
Back to top
View user's profile Send private message
cloc3
Advocate
Advocate


Joined: 13 Jan 2004
Posts: 4665
Location: http://www.gentoo-users.org/user/cloc3/

PostPosted: Mon Apr 27, 2009 12:15 pm    Post subject: Reply with quote

siccome mi pare che tu non li dica esplicitamente, credi di utilizzzare i driver specifici per la tua scheda grafica o un driver generico?
controlla la configurazione di Xorg.conf della sabayon e fai il confronto.
_________________
vu vu vu
gentù
mi piaci tu
Back to top
View user's profile Send private message
lsegalla
l33t
l33t


Joined: 27 Jun 2007
Posts: 796

PostPosted: Mon Apr 27, 2009 12:17 pm    Post subject: Reply with quote

Ti ringrazio, qingy lo sto tirando su, poi lo provo (basta fare emerge qingy o serve qualche altro pacchetto per farlo lavorare?)
Detto cio' riporto il link del mio dmesg completo se per caso vuoi darci un occhio: http://rafb.net/p/oDNhF283.html

Nel frattempo io non sapendo cosa e come greppare via quanto non serve me lo scorro e riporto a manina alcune cose che trovo magari che possono c'entrare:
Code:

vesafb: framebuffer at 0xd0000000, mapped to 0xf8d00000, using 6144k, total 7616k
vesafb: mode is 1024x768x32, linelength=4096, pages=1
vesafb: scrolling: redraw
vesafb: Truecolor: size=8:8:8:8, shift=24:16:8:0
Console: switching to colour frame buffer device 128x48
fb0: VESA VGA frame buffer device


e poi anche
Code:

Linux agpgart interface v0.103
i801_smbus 0000:00:1f.3: PCI INT C -> GSI 19 (level, low) -> IRQ 19
agpgart-intel 0000:00:00.0: Intel 965GM Chipset
agpgart-intel 0000:00:00.0: detected 7676K stolen memory
agpgart-intel 0000:00:00.0: AGP aperture is 256M @ 0xd0000000
sony-laptop: Sony Notebook Control Driver v0.6.
input: Sony Vaio Keys as /class/input/input9
input: Sony Vaio Jogdial as /class/input/input10
sony-laptop: detected Sony Vaio N Series
intelfb: Framebuffer driver for Intel(R) 830M/845G/852GM/855GM/865G/915G/915GM/945G/945GM/965G/965GM chipsets
intelfb: Version 0.9.5
intelfb 0000:00:02.0: PCI INT A -> GSI 16 (level, low) -> IRQ 16
intelfb: Cannot reserve FB region.


Per il resto io all'epoca ho fatto tutto con genkernel quindi sicuramente tutto perfetto non è, magari provo a compilare il tutto come builtin e vediamo come va, poi pero' immagino non ci sia bisogno di riemergere il mondo no?
Back to top
View user's profile Send private message
lsegalla
l33t
l33t


Joined: 27 Jun 2007
Posts: 796

PostPosted: Mon Apr 27, 2009 12:18 pm    Post subject: Reply with quote

cloc3 wrote:
siccome mi pare che tu non li dica esplicitamente, credi di utilizzzare i driver specifici per la tua scheda grafica o un driver generico?
controlla la configurazione di Xorg.conf della sabayon e fai il confronto.

Non c'era un comandino fra l'altro per fare le differenze fra files?
In teoria almeno... senno' comunque mi guardo il tutto a manina... :-)
Back to top
View user's profile Send private message
djinnZ
Advocate
Advocate


Joined: 02 Nov 2006
Posts: 4831
Location: somewhere in L.O.S.

PostPosted: Mon Apr 27, 2009 12:26 pm    Post subject: Reply with quote

lsegalla wrote:
basta fare emerge qingy o serve qualche altro pacchetto per farlo lavorare?
lo devi solo configurare ed attivare il mouse per directfb.
lsegalla wrote:
intelfb: Cannot reserve FB region.
mi sa che sei alle prese con i soliti problemi dei sony e stai usando il driver vga o peggio quello intel ma senza accesso alla memoria, nota che molti produttori del piffero hanno reso necessario abilitare una shadow ram per la scheda grafica di pari dimensioni a quella della memoria video perché questa sia riconosciuta; mi pare c'entrasse qualcosa per la sospensione ma non so dirti.
lsegalla wrote:
Non c'era un comandino fra l'altro per fare le differenze fra files?
8O :?: :!: :evil: :x :P
_________________
scita et risus abundant in ore stultorum sed etiam semper severi insani sunt:wink:
mala tempora currunt...mater stultorum semper pregna est :evil:
Murpy'sLaw:If anything can go wrong, it will - O'Toole's Corollary:Murphy was an optimist :wink:
Back to top
View user's profile Send private message
lsegalla
l33t
l33t


Joined: 27 Jun 2007
Posts: 796

PostPosted: Mon Apr 27, 2009 12:47 pm    Post subject: Reply with quote

Quote:
mi sa che sei alle prese con i soliti problemi dei sony e stai usando il driver vga o peggio quello intel ma senza accesso alla memoria, nota che molti produttori del piffero hanno reso necessario abilitare una shadow ram per la scheda grafica di pari dimensioni a quella della memoria video perché questa sia riconosciuta; mi pare c'entrasse qualcosa per la sospensione ma non so dirti.

Potrei guardare sempre sul sabayon, sai dirmi dove ?
Back to top
View user's profile Send private message
lsegalla
l33t
l33t


Joined: 27 Jun 2007
Posts: 796

PostPosted: Mon Apr 27, 2009 1:07 pm    Post subject: Reply with quote

Sulla partizione sabayon il nopaste non funziona e non mi soffermo quindi sull'intero dmesg pero' scorrendolo noto quanto segue:

Code:

[    1.077697] Linux agpgart interface v0.103
[    1.077878] uvesafb: failed to execute /sbin/v86d
[    1.077884] uvesafb: make sure that the v86d helper is installed and executable
[    1.077890] uvesafb: Getting VBE info block failed (eax=0x4f00, err=-2)
[    1.077895] uvesafb: vbe_init() failed with -22
[    1.077901] uvesafb: probe of uvesafb.0 failed with error -22
[    1.078051] vesafb: framebuffer at 0xd0000000, mapped to 0xf8d00000, using 3072k, total 7616k
[    1.078055] vesafb: mode is 1024x768x16, linelength=2048, pages=3
[    1.078057] vesafb: scrolling: redraw
[    1.078060] vesafb: Truecolor: size=0:5:6:5, shift=0:11:5:0
[    1.096288] Console: switching to colour frame buffer device 128x48
[    1.297735] fbcondecor: console 0 using theme 'sabayon'
[    1.452164] fbcondecor: switched decor state to 'on' on console 0
[    1.453390] fb0: VESA VGA frame buffer device
[    1.453501] vga16fb: initializing
[    1.453504] vga16fb: mapped to 0xc00a0000
[    1.453594] fb1: VGA16 VGA frame buffer device


Code:

[   19.531823] agpgart-intel 0000:00:00.0: Intel 965GM Chipset
[   19.532208] agpgart-intel 0000:00:00.0: detected 7676K stolen memory
[   19.547380] agpgart-intel 0000:00:00.0: AGP aperture is 256M @ 0xd0000000


-- EDIT --
Aggiungo:
Code:
luca@user8-gentoo / $ diff config-sabayon.txt config-gentoo.txt |grep AGP
< CONFIG_AGP=y
> CONFIG_AGP=m


Code:
luca@user8-gentoo / $ diff config-sabayon.txt config-gentoo.txt |grep INTEL
< CONFIG_X86_INTEL_USERCOPY=y
< CONFIG_MTD_CFI_INTELEXT=m
< CONFIG_MTD_INTEL_VR_NOR=m
< CONFIG_INTEL_MENLOW=m
> # CONFIG_INTEL_MENLOW is not set
< CONFIG_MOXA_INTELLIO=m
< # CONFIG_FB_INTEL is not set
> CONFIG_FB_INTEL=m
> # CONFIG_FB_INTEL_DEBUG is not set
> CONFIG_FB_INTEL_I2C=y
< CONFIG_INTEL_IOATDMA=m
> CONFIG_INTEL_IOATDMA=y
< CONFIG_KVM_INTEL=m
Back to top
View user's profile Send private message
lsegalla
l33t
l33t


Joined: 27 Jun 2007
Posts: 796

PostPosted: Mon Apr 27, 2009 3:06 pm    Post subject: Re: Notebook lento graficamente Reply with quote

[quote="djinnZ"]
lsegalla wrote:
Visto che sabayon è abbastanza vicina a gentoo perchè non ti copi la conf del kernel da li e provi a partire da quella?

Sto provando così: da sabayon sotto a /usr/src/linux mi son preso il .config e l'ho copiato nella partizione di gentoo nello stesso percorso
Poi ho dato un make oldconfig, e quindi genkernel --menuconfig all e ho come l'impressione che non sia servito a niente quel che ho fatto giusto?

Ora rileggendo la guida di genkernel http://www.gentoo.org/doc/it/genkernel.xml realizzo che forse dovevo dare un
Code:

genkernel --oldconfig all


Am i right ? :(
Back to top
View user's profile Send private message
Scen
Retired Dev
Retired Dev


Joined: 29 Jul 2003
Posts: 2470
Location: Padova, Italy

PostPosted: Mon Apr 27, 2009 4:30 pm    Post subject: Reply with quote

Intanto bisognerebbe individuare la causa dei rallentamenti: hai provato ad avviare Gentoo disabilitando temporaneamente il framebuffer?

Se provi e vedi che i rallentamenti spariscono, allora o lasci perdere questa caratteristica, oppure prova ad utilizzare il driver uvesafb, in quanto tu mi pare stia utilizzando il driver "vesafb" vecchio:
Code:

vesafb: framebuffer at 0xd0000000, mapped to 0xf8d00000, using 6144k, total 7616k
vesafb: mode is 1024x768x32, linelength=4096, pages=1
vesafb: scrolling: redraw
vesafb: Truecolor: size=8:8:8:8, shift=24:16:8:0
Console: switching to colour frame buffer device 128x48

Inoltre, come notato da djinnZ, vedo sta roba strana:
Code:

intelfb: Framebuffer driver for Intel(R) 830M/845G/852GM/855GM/865G/915G/915GM/945G/945GM/965G/965GM chipsets
intelfb: Version 0.9.5
intelfb 0000:00:02.0: PCI INT A -> GSI 16 (level, low) -> IRQ 16
intelfb: Cannot reserve FB region.


E sempre riguardo alla grafica, noto un problema sul DRM:
Code:

[drm] Initialized i915 1.6.0 20060119 on minor 0
[drm:i915_getparam] *ERROR* Unknown parameter 5
[drm:i915_getparam] *ERROR* Unknown parameter 5
[stesso errore che si ripete più volte]


Io configuro e compilo il kernel manualmente, per cui non so darti supporto su Genkernel (ti consiglio caldamente di imparare a farlo anche tu, anche solo per cultura personale, almeno in caso di necessità avrai meno problemi a spippolare sul kernel), però tieni presente che
Guida a Genkernel in Gentoo Linux wrote:

Disclaimer : Questo documento non è più valido e non è più mantenuto.

PEr sicurezza è meglio se fai (anche) riferimento alla documentazione interna del pacchetto :?
_________________
I was born in a deep forest/I wish I could live here all my life/I am made from stones and roots/My home, these woods and roads
All my life I loved this sound/Of the woods all around/Eagles flies where the winds blows free
Journey is my destiny
Back to top
View user's profile Send private message
djinnZ
Advocate
Advocate


Joined: 02 Nov 2006
Posts: 4831
Location: somewhere in L.O.S.

PostPosted: Mon Apr 27, 2009 7:16 pm    Post subject: Reply with quote

per genkernel basta copiare il .config in /etc/kernels/kernel-config-versione (per esempio il mio corrente è kernel-config-x86-2.6.28-hardened-r7) oppure lanciarlo con --noclean --nomrproper (io ho preferito configurarlo al contrario quindi devo aggiungere il --clean --mrproper , basta leggere in genkernel.conf, è commentato) ed ovviamente il magico --menuconfig/--xconfig per poterlo modificare.
Con un banale
Code:
genkernel --clean --mrproper --menuconfig all ; module-rebuild -X rebuild ; lilo
mi levo il pensiero di ricompilare tutto senza sbattimenti, quando devo. Questa è la reale utilità di genkernel.
La configurazione del kernel la devi affrontare lo stesso, sei in gentoo.

Su sabayon vedi anche quali moduli vengono caricati e se ci sono opzioni particolari
_________________
scita et risus abundant in ore stultorum sed etiam semper severi insani sunt:wink:
mala tempora currunt...mater stultorum semper pregna est :evil:
Murpy'sLaw:If anything can go wrong, it will - O'Toole's Corollary:Murphy was an optimist :wink:
Back to top
View user's profile Send private message
lsegalla
l33t
l33t


Joined: 27 Jun 2007
Posts: 796

PostPosted: Thu Apr 30, 2009 11:29 am    Post subject: Reply with quote

Vediamo se riesco a fare un po' di ordine. :D
Innanzitutto sono partito a ricompilare il kernel come mi era stato detto usando il .config di sabayon e qualcosa di diverso l'ho notato, e il sistema non va male come prima, pero' non è nemmeno veloce come sotto sabayon per dirla tutta. Detto questo:

Relativamente al problema del vesafb
Vedo che col nuovo .config tutto effettivamente era già stato ricompilato con uvesa, pero' sono perplesso perchè non mi par che sia tutto a posto guardando dmesg, infatti vedo quanto segue:
Code:

user8-gentoo luca # dmesg|grep vesa
[    0.453445] uvesafb: failed to execute /sbin/v86d
[    0.453450] uvesafb: make sure that the v86d helper is installed and executable
[    0.453457] uvesafb: Getting VBE info block failed (eax=0x4f00, err=-2)
[    0.453462] uvesafb: vbe_init() failed with -22
[    0.453469] uvesafb: probe of uvesafb.0 failed with error -22
[    0.453684] vesafb: framebuffer at 0xd0000000, mapped to 0xf8d00000, using 6144k, total 7616k
[    0.453693] vesafb: mode is 1024x768x32, linelength=4096, pages=1
[    0.453697] vesafb: scrolling: redraw
[    0.453702] vesafb: Truecolor: size=8:8:8:8, shift=24:16:8:0


la cosa strana di intelfb è scomparsa, bene
Code:

user8-gentoo luca # dmesg|grep intel
[   18.215574] agpgart-intel 0000:00:00.0: Intel 965GM Chipset
[   18.215947] agpgart-intel 0000:00:00.0: detected 7676K stolen memory
[   18.235283] agpgart-intel 0000:00:00.0: AGP aperture is 256M @ 0xd0000000

user8-gentoo luca # dmesg|grep intelfb
user8-gentoo luca #


il problema sul drm persiste, ma non so neanche cosa sia, faro' una ricerca o mi spulcero' qualche link chiarificatore
user8-gentoo luca # dmesg|grep drm
Code:
[  319.039285] [drm] Initialized drm 1.1.0 20060810
[  319.044431] [drm] Initialized i915 1.6.0 20060119 on minor 0
[  319.045889] [drm:i915_getparam] *ERROR* Unknown parameter 5
[  320.215704] [drm:i915_getparam] *ERROR* Unknown parameter 5


Per Djinnz
Mi sto leggendo il significato delle opzioni mrproper e clean di genkernel pero' mi mancano i seguenti concetti: "i file oggetto e le dipendenze dall'albero dei sorgenti del kernel", da quel che vedo mrproper rimuove anche i vecchi .config cosa che io eviterei. Alla fine allora non capisco bene l'utilità del tutto. Mmmah... continuo a leggere le guide che trovo in giro...
Ma alla fine per ora ho configurato anche io nel genkernel.conf mrproper=no e clean=no, mi par che per me sia quella la cosa migliore...

-- EDIT --

Installando qingy ottengo un errore
Code:
 * Messages for package sys-apps/qingy-0.9.7:

 * qingy expects DirectFB to provide certain capabilities.
 * It depends on the theme you use, but at least the following USE flags
 * should be enabled in DirectFB: fbcon jpeg png truetype.
 * You must rebuild DirectFB those USE flags enabled!
 *
 * ERROR: sys-apps/qingy-0.9.7 failed.
 * Call stack:
 *               ebuild.sh, line   49:  Called src_unpack
 *             environment, line 2502:  Called die
 * The specific snippet of code:
 *               die "USE flags check failed";
 *  The die message:
 *   USE flags check failed
 *
 * If you need support, post the topmost build error, and the call stack if relevant.
 * A complete build log is located at '/var/tmp/portage/sys-apps/qingy-0.9.7/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/sys-apps/qingy-0.9.7/temp/environment'.

Ho provato ad abilitare leuse flags in questione infatti:
Code:
USE="X directfb fbcon kde qt3 rdesktop encode bluetooth usb xulrunner gtk symlink -gnome mp3 bzip2 hal mmx sse mtrr acl cups kerberos -ldap -ldapsam pam -swat winbind samba jpeg png tiff gif accessibility dbus qt-static -esd cdda glitz svg aiglx qt3support ssl zlib cdio utempter gcj sqlite dvd dvdr ffmpeg flac sndfile laptop mjpeg mpeg acpi foomaticdb ppds java eapi-2 xine png truetype"


Ma siccome le USE erano già abilitate non mi aggiornava directdb se facevo
Code:
emerge -uDNp directfb


Forse devo ricompilare directfb in qualche altra maniera?

-- RE EDIT --
Vedo che ho compilato sia il vesafb che uvesafb, ora sto ricompilando solo con uvesafb
Back to top
View user's profile Send private message
lsegalla
l33t
l33t


Joined: 27 Jun 2007
Posts: 796

PostPosted: Thu Apr 30, 2009 2:02 pm    Post subject: Reply with quote

Affrontando i problemi uno alla volta, ho provato a disabilitare vesafb sul kernel e lasciare solo uvesafb ma non va niente
La devo riattivare e quindi resto fermo qui:
Code:
luca@user8-gentoo ~ $ dmesg|grep vesa
[    0.443385] uvesafb: failed to execute /sbin/v86d
[    0.443390] uvesafb: make sure that the v86d helper is installed and executable
[    0.443397] uvesafb: Getting VBE info block failed (eax=0x4f00, err=-2)
[    0.443402] uvesafb: vbe_init() failed with -22
[    0.443409] uvesafb: probe of uvesafb.0 failed with error -22
[    0.443646] vesafb: framebuffer at 0xd0000000, mapped to 0xf8d00000, using 6144k, total 7616k
[    0.443655] vesafb: mode is 1024x768x32, linelength=4096, pages=1
[    0.443660] vesafb: scrolling: redraw
[    0.443665] vesafb: Truecolor: size=8:8:8:8, shift=24:16:8:0


-- EDIT --
In realtà anche nella macchina SABAYON io ho:
Code:

user8-sabayon luca # dmesg|grep vesa
[    1.077162] uvesafb: failed to execute /sbin/v86d
[    1.077169] uvesafb: make sure that the v86d helper is installed and executable
[    1.077175] uvesafb: Getting VBE info block failed (eax=0x4f00, err=-2)
[    1.077180] uvesafb: vbe_init() failed with -22
[    1.077186] uvesafb: probe of uvesafb.0 failed with error -22
[    1.077338] vesafb: framebuffer at 0xd0000000, mapped to 0xf8d00000, using 3072k, total 7616k
[    1.077342] vesafb: mode is 1024x768x16, linelength=2048, pages=3
[    1.077344] vesafb: scrolling: redraw
[    1.077347] vesafb: Truecolor: size=0:5:6:5, shift=0:11:5:0


Mentre per quanto riguarda il drm sempre in sabayon
Code:

user8-sabayon luca # dmesg|grep drm
[   33.326989] [drm] Initialized drm 1.1.0 20060810
[   33.392076] [drm] Initialized i915 1.6.0 20060119 on minor 0
[   33.393023] [drm:i915_getparam] *ERROR* Unknown parameter 5


Quindi di fatto mi sa che non sono queste due a rallentare il tutto... o no ?
Back to top
View user's profile Send private message
table
Apprentice
Apprentice


Joined: 17 Feb 2007
Posts: 279
Location: Gazzaniga (BG) Italy

PostPosted: Sat May 02, 2009 4:07 pm    Post subject: Reply with quote

Anch'io ho problemi molto simili con i driver intel
Code:
dmesg | grep intel
[    0.835614] agpgart-intel 0000:00:00.0: Intel 965GM Chipset
[    0.836072] agpgart-intel 0000:00:00.0: detected 7676K stolen memory
[    0.839357] agpgart-intel 0000:00:00.0: AGP aperture is 256M @ 0xd0000000
[    0.916311] intelfb: intelfb_init
[    0.916314] intelfb: Framebuffer driver for Intel(R) 830M/845G/852GM/855GM/865G/915G/915GM/945G/945GM/945GME/965G/965GM chipsets
[    0.920564] intelfb: Version 0.9.6
[    0.922703] intelfb: intelfb_setup
[    0.922704] intelfb: no options
[    0.922715] intelfb: intelfb_pci_register
[    0.922752] intelfb 0000:00:02.0: PCI INT A -> GSI 16 (level, low) -> IRQ 16
[    0.924990] intelfb: fb aperture: 0xd0000000/0x10000000, MMIO region: 0xfc000000/0x100000
[    0.924995] intelfb: Cannot reserve FB region.
[    0.927225] intelfb: cleanup



Code:
stealth ~ # dmesg | grep vesa
[    0.000000] Kernel command line: root=/dev/sda6 video=vesafb:mtrr:3,ywrap vga=0x318
[    0.839771] uvesafb: failed to execute /sbin/v86d
[    0.839776] uvesafb: make sure that the v86d helper is installed and executable
[    0.839782] uvesafb: Getting VBE info block failed (eax=0x4f00, err=-2)
[    0.839787] uvesafb: vbe_init() failed with -22
[    0.839793] uvesafb: probe of uvesafb.0 failed with error -22
[    0.840182] vesafb: framebuffer at 0xd0000000, mapped to 0xf8280000, using 6144k, total 7616k
[    0.840189] vesafb: mode is 1024x768x32, linelength=4096, pages=1
[    0.840194] vesafb: scrolling: redraw
[    0.840198] vesafb: Truecolor: size=8:8:8:8, shift=24:16:8:0


le prestazioni della scheda video su ubuntu sono nettamente superiori...
_________________
Pulisci l'html con:
Code:
sed 's/<[Bb][Rr][ \t]*\/*>/\n/g;s/<\/*[^>]\+\/*>//g'

skype: matteopinguino
Back to top
View user's profile Send private message
lsegalla
l33t
l33t


Joined: 27 Jun 2007
Posts: 796

PostPosted: Mon May 04, 2009 8:56 am    Post subject: Reply with quote

Per qingy ho fatto così invece:
Code:

echo "dev-libs/DirectFB fbcon -X" >> /etc/portage/package.use
emerge DirectFB
revdep-rebuild
emerge qingy


Adesso mi manca la configurazione, mo' me la vedo...
Back to top
View user's profile Send private message
lsegalla
l33t
l33t


Joined: 27 Jun 2007
Posts: 796

PostPosted: Thu May 07, 2009 5:18 pm    Post subject: Reply with quote

Qingy l'ho messo su, funziona e non ho particolari problemi.
Invece tutto cio' che riguarda la scheda video persiste; la sensazione è che qualcosa sia migliorato dopo che ho usato il .config di sabayon e ricompilato il kernel.
Tutt'ora vedo che sabayon sembra migliore, mah...

disabilitare vesafb nel kernel non ci son riuscito... e comunque anche sabayon ha le stesse cose compilate quindi non mi do' una spiegazione
lo stesso xorg è praticamente uguale

(sob)
Back to top
View user's profile Send private message
lsegalla
l33t
l33t


Joined: 27 Jun 2007
Posts: 796

PostPosted: Wed May 20, 2009 2:15 pm    Post subject: Reply with quote

Sembra che io sia riuscito a risolvere la cosa, e si trattava del drm.
Ho colto l'occasione dell'ultimo kernel da compilare per scendere nel dettaglio di alcune cose (anzi voglio configurare a puntino anche altre cose).

Sostanzialmente nel log di xorg in /var/log/ trovavo un errore del drm
Code:

luca@user8-gentoo ~ $ less /var/log/Xorg.1.log.old |grep drm
drmOpenDevice: node name is /dev/dri/card0
drmOpenDevice: open result is -1, (No such device)
drmOpenDevice: open result is -1, (No such device)
drmOpenDevice: Open failed
drmOpenDevice: node name is /dev/dri/card0
drmOpenDevice: open result is -1, (No such device)
drmOpenDevice: open result is -1, (No such device)
drmOpenDevice: Open failed
[drm] failed to load kernel module "i915"
(EE) [drm] drmOpen failed.


Quindi ricompilando il kernel ho abilitato anchei moduli del caso (e se ben ricordo infatti nella guida di installazione di gentoo c'era anche citato che "nel dubbio è meglio abilitarli tutti come moduli", almeno mi sembra). Fatto questo e riavviato ho fatto un bellissimo
Code:

ls -R /

e vedo che va come una scheggia, non riesco manco a leggere quel che passa mentre prima il tutto era scattoso in maniera impressionante

Ora nel log vedo:
Code:

luca@user8-gentoo ~ $ less /var/log/Xorg.1.log |grep drm
drmOpenDevice: node name is /dev/dri/card0
drmOpenDevice: open result is -1, (No such device)
drmOpenDevice: open result is -1, (No such device)
drmOpenDevice: Open failed
drmOpenDevice: node name is /dev/dri/card0
drmOpenDevice: open result is -1, (No such device)
drmOpenDevice: open result is -1, (No such device)
drmOpenDevice: Open failed
drmOpenByBusid: Searching for BusID pci:0000:00:02.0
drmOpenDevice: node name is /dev/dri/card0
drmOpenDevice: open result is 11, (OK)
drmOpenByBusid: drmOpenMinor returns 11
drmOpenByBusid: drmGetBusid reports pci:0000:00:02.0
(II) [drm] loaded kernel module for "i915" driver.
(II) [drm] DRM interface version 1.3
(II) [drm] DRM open master succeeded.
(II) intel(0): [drm] Using the DRM lock SAREA also for drawables.
(II) intel(0): [drm] framebuffer mapped by ddx driver
(II) intel(0): [drm] added 1 reserved context for kernel
(II) intel(0): [drm] installed DRM signal handler
(II) intel(0): [drm] Registers = 0xfc000000
(II) intel(0): [drm] Initialized kernel agp heap manager, 33554432
(II) intel(0): [drm] mapped front buffer at 0xd179f000, handle = 0xd179f000
(II) intel(0): [drm] mapped back buffer at 0xd0f9f000, handle = 0xd0f9f000
(II) intel(0): [drm] mapped depth buffer at 0xd079f000, handle = 0xd079f000
(II) intel(0): [drm] mapped classic textures at 0xde000000, handle = 0xde000000
drmOpenDevice: node name is /dev/dri/card0
drmOpenDevice: open result is 12, (OK)
drmOpenByBusid: Searching for BusID pci:0000:00:02.0
drmOpenDevice: node name is /dev/dri/card0
drmOpenDevice: open result is 12, (OK)
drmOpenByBusid: drmOpenMinor returns 12
drmOpenByBusid: drmGetBusid reports pci:0000:00:02.0


Ora per me si tratta di configurare bene xorg, perchè vedo altri errorini che non so come risolvere, ma apriro' un thread a parte per quelli...

Grazie a tutti
Back to top
View user's profile Send private message
table
Apprentice
Apprentice


Joined: 17 Feb 2007
Posts: 279
Location: Gazzaniga (BG) Italy

PostPosted: Wed May 20, 2009 2:25 pm    Post subject: Reply with quote

lsegalla wrote:
....


che kernel stai usando?
che impostazioni hai usato per il drm? puoi postarle per favore?
_________________
Pulisci l'html con:
Code:
sed 's/<[Bb][Rr][ \t]*\/*>/\n/g;s/<\/*[^>]\+\/*>//g'

skype: matteopinguino
Back to top
View user's profile Send private message
lsegalla
l33t
l33t


Joined: 27 Jun 2007
Posts: 796

PostPosted: Wed May 20, 2009 2:38 pm    Post subject: Reply with quote

Varie
Code:

user8-gentoo log # uname -a
Linux user8-gentoo 2.6.28-gentoo-r5 #5 SMP Wed May 20 15:50:57 CEST 2009 i686 Intel(R) Pentium(R) Dual CPU T2310 @ 1.46GHz GenuineIntel GNU/Linux


La mia macchina (Sony Vaio VGN-NR10E)
Code:
user8-gentoo log # lspci
00:00.0 Host bridge: Intel Corporation Mobile PM965/GM965/GL960 Memory Controller Hub (rev 0c)
00:02.0 VGA compatible controller: Intel Corporation Mobile GM965/GL960 Integrated Graphics Controller (rev 0c)
00:02.1 Display controller: Intel Corporation Mobile GM965/GL960 Integrated Graphics Controller (rev 0c)
00:1a.0 USB Controller: Intel Corporation 82801H (ICH8 Family) USB UHCI Controller #4 (rev 03)
00:1a.1 USB Controller: Intel Corporation 82801H (ICH8 Family) USB UHCI Controller #5 (rev 03)
00:1a.7 USB Controller: Intel Corporation 82801H (ICH8 Family) USB2 EHCI Controller #2 (rev 03)
00:1b.0 Audio device: Intel Corporation 82801H (ICH8 Family) HD Audio Controller (rev 03)
00:1c.0 PCI bridge: Intel Corporation 82801H (ICH8 Family) PCI Express Port 1 (rev 03)
00:1c.1 PCI bridge: Intel Corporation 82801H (ICH8 Family) PCI Express Port 2 (rev 03)
00:1c.2 PCI bridge: Intel Corporation 82801H (ICH8 Family) PCI Express Port 3 (rev 03)
00:1d.0 USB Controller: Intel Corporation 82801H (ICH8 Family) USB UHCI Controller #1 (rev 03)
00:1d.1 USB Controller: Intel Corporation 82801H (ICH8 Family) USB UHCI Controller #2 (rev 03)
00:1d.2 USB Controller: Intel Corporation 82801H (ICH8 Family) USB UHCI Controller #3 (rev 03)
00:1d.7 USB Controller: Intel Corporation 82801H (ICH8 Family) USB2 EHCI Controller #1 (rev 03)
00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev f3)
00:1f.0 ISA bridge: Intel Corporation 82801HEM (ICH8M) LPC Interface Controller (rev 03)
00:1f.1 IDE interface: Intel Corporation 82801HBM/HEM (ICH8M/ICH8M-E) IDE Controller (rev 03)
00:1f.2 SATA controller: Intel Corporation 82801HBM/HEM (ICH8M/ICH8M-E) SATA AHCI Controller (rev 03)
00:1f.3 SMBus: Intel Corporation 82801H (ICH8 Family) SMBus Controller (rev 03)
02:00.0 Ethernet controller: Marvell Technology Group Ltd. 88E8039 PCI-E Fast Ethernet Controller (rev 14)
06:00.0 Ethernet controller: Atheros Communications Inc. Device ff1b (rev 01)
08:03.0 CardBus bridge: Texas Instruments PCIxx12 Cardbus Controller
08:03.1 FireWire (IEEE 1394): Texas Instruments PCIxx12 OHCI Compliant IEEE 1394 Host Controller
08:03.2 Mass storage controller: Texas Instruments 5-in-1 Multimedia Card Reader (SD/MMC/MS/MS PRO/xD)


sezione del .config
Code:

CONFIG_AGP=y
# CONFIG_AGP_ALI is not set
# CONFIG_AGP_ATI is not set
# CONFIG_AGP_AMD is not set
# CONFIG_AGP_AMD64 is not set
CONFIG_AGP_INTEL=y
# CONFIG_AGP_NVIDIA is not set
# CONFIG_AGP_SIS is not set
# CONFIG_AGP_SWORKS is not set
# CONFIG_AGP_VIA is not set
# CONFIG_AGP_EFFICEON is not set
CONFIG_DRM=y
# CONFIG_DRM_TDFX is not set
# CONFIG_DRM_R128 is not set
# CONFIG_DRM_RADEON is not set
CONFIG_DRM_I810=m
CONFIG_DRM_I830=m
CONFIG_DRM_I915=m
# CONFIG_DRM_MGA is not set
# CONFIG_DRM_SIS is not set
# CONFIG_DRM_VIA is not set
# CONFIG_DRM_SAVAGE is not set
CONFIG_VGASTATE=y
CONFIG_VIDEO_OUTPUT_CONTROL=m
CONFIG_FB=y
CONFIG_FIRMWARE_EDID=y
CONFIG_FB_DDC=y
CONFIG_FB_BOOT_VESA_SUPPORT=y
CONFIG_FB_CFB_FILLRECT=y
CONFIG_FB_CFB_COPYAREA=y
CONFIG_FB_CFB_IMAGEBLIT=y
# CONFIG_FB_CFB_REV_PIXELS_IN_BYTE is not set
CONFIG_FB_SYS_FILLRECT=m
CONFIG_FB_SYS_COPYAREA=m
CONFIG_FB_SYS_IMAGEBLIT=m
# CONFIG_FB_CFB_REV_PIXELS_IN_BYTE is not set
CONFIG_FB_SYS_FILLRECT=m
CONFIG_FB_SYS_COPYAREA=m
CONFIG_FB_SYS_IMAGEBLIT=m
# CONFIG_FB_FOREIGN_ENDIAN is not set
CONFIG_FB_SYS_FOPS=m
# CONFIG_FB_SVGALIB is not set
# CONFIG_FB_MACMODES is not set
# CONFIG_FB_BACKLIGHT is not set
CONFIG_FB_MODE_HELPERS=y
# CONFIG_FB_TILEBLITTING is not set


Per quanto riguarda il framebuffer
Code:

# Frame buffer hardware drivers
#
# CONFIG_FB_CIRRUS is not set
# CONFIG_FB_PM2 is not set
# CONFIG_FB_CYBER2000 is not set
# CONFIG_FB_ARC is not set
# CONFIG_FB_ASILIANT is not set
# CONFIG_FB_IMSTT is not set
CONFIG_FB_VGA16=y
CONFIG_FB_UVESA=y
CONFIG_FB_VESA=y
CONFIG_FB_EFI=y
# CONFIG_FB_N411 is not set
# CONFIG_FB_HGA is not set
# CONFIG_FB_S1D13XXX is not set
# CONFIG_FB_NVIDIA is not set
# CONFIG_FB_RIVA is not set
# CONFIG_FB_I810 is not set
# CONFIG_FB_LE80578 is not set
CONFIG_FB_INTEL=y
# CONFIG_FB_INTEL_DEBUG is not set
CONFIG_FB_INTEL_I2C=y
# CONFIG_FB_MATROX is not set
# CONFIG_FB_RADEON is not set
# CONFIG_FB_ATY128 is not set
# CONFIG_FB_ATY is not set
# CONFIG_FB_S3 is not set
# CONFIG_FB_SAVAGE is not set
# CONFIG_FB_SIS is not set
# CONFIG_FB_VIA is not set
# CONFIG_FB_NEOMAGIC is not set
# CONFIG_FB_KYRO is not set
# CONFIG_FB_3DFX is not set
# CONFIG_FB_VOODOO1 is not set
# CONFIG_FB_VT8623 is not set
# CONFIG_FB_CYBLA is not set
# CONFIG_FB_TRIDENT is not set
# CONFIG_FB_ARK is not set
# CONFIG_FB_PM3 is not set
# CONFIG_FB_CARMINE is not set
# CONFIG_FB_GEODE is not set
# CONFIG_FB_SM501 is not set
# CONFIG_FB_VIRTUAL is not set
# CONFIG_FB_METRONOME is not set
# CONFIG_FB_MB862XX is not set
CONFIG_BACKLIGHT_LCD_SUPPORT=y
CONFIG_LCD_CLASS_DEVICE=m
CONFIG_LCD_LTV350QV=m
CONFIG_LCD_ILI9320=m
# CONFIG_LCD_TDO24M is not set
CONFIG_LCD_VGG2432A4=m
CONFIG_LCD_PLATFORM=m
CONFIG_BACKLIGHT_CLASS_DEVICE=y
CONFIG_BACKLIGHT_CORGI=m
CONFIG_BACKLIGHT_PROGEAR=m
CONFIG_BACKLIGHT_MBP_NVIDIA=m
# CONFIG_BACKLIGHT_SAHARA is not set


C'è tutto? Spero di sì perchè son sempre un po' tardivo :P
Back to top
View user's profile Send private message
table
Apprentice
Apprentice


Joined: 17 Feb 2007
Posts: 279
Location: Gazzaniga (BG) Italy

PostPosted: Wed May 20, 2009 2:39 pm    Post subject: Reply with quote

lsegalla wrote:
....



Grazie,
tra oggi e domani provo a fare così ;)
_________________
Pulisci l'html con:
Code:
sed 's/<[Bb][Rr][ \t]*\/*>/\n/g;s/<\/*[^>]\+\/*>//g'

skype: matteopinguino
Back to top
View user's profile Send private message
lsegalla
l33t
l33t


Joined: 27 Jun 2007
Posts: 796

PostPosted: Wed May 20, 2009 2:41 pm    Post subject: Reply with quote

Dimenticavo xorg
Code:

Section "Module"
    SubSection  "extmod"
      Option    "omit xfree86-dga"
    EndSubSection
    Load   "i2c"
    Load   "ddc"
    Load   "vbe"
    Load        "dri"
    Load  "synaptics"
EndSection
 
Section "ServerFlags"
     Option    "AllowMouseOpenFail" "true"
EndSection
 
 
 
Section "InputDevice"
   Identifier  "Touchpad"
   Driver      "synaptics"
   Option      "SendCoreEvents"
   Option      "Protocol" "auto-dev"
   Option      "SHMConfig" "on"
EndSection
 
 
 
Section "InputDevice"
    Identifier   "Keyboard1"
    Driver   "kbd"
    Option "AutoRepeat" "500 30"
    Option "XkbRules"    "xorg"
    Option "XkbModel"    "pc105"
    Option "XkbLayout"   "it"
    Option "XkbVariant"  "intl,nodeadkeys,"
    Option "XkbOptions"  "grp:alt_shift_toggle"
EndSection
 
 
 
 
Section "Monitor"
    Identifier   "Generic Monitor"
    VertRefresh 43 - 60
    HorizSync   28 - 80
EndSection
 
 
 
 
 
Section "Device"
    Identifier   "VESA"
    Driver       "intel"
    Option       "UseEvents" "True"
EndSection
 
 
 
 
Section "Screen"
 
    Identifier   "Screen 1"
    Device   "VESA"
    Monitor   "Generic Monitor"
 
    DefaultDepth 24
 
    SubSection "Display"
        Depth      8
        ViewPort   0 0
    EndSubsection
 
    SubSection "Display"
        Depth           16
        ViewPort        0 0
    EndSubsection
 
    SubSection "Display"
        Depth           24
        ViewPort        0 0
    EndSubsection
 
EndSection
 
 
Section "ServerLayout"
    Identifier   "Main Layout"
    Screen 0    "Screen 1"
    InputDevice "Touchpad" "CorePointer"
EndSection
 
Section "DRI"
    Mode 0666
EndSection
 
Section "Extensions"
EndSection
 
Section "ServerFlags"
   Option "AutoAddDevices" "False"
EndSection


Nella ricompila del kernel ho anche ridotto una opzione (MAX CPU o qualcosa del genere che non ricordo da 256 a 2)
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum