Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Can't view japanese text
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Other Languages
View previous topic :: View next topic  
Author Message
revil
n00b
n00b


Joined: 06 Oct 2002
Posts: 68
Location: Japan

PostPosted: Sat Aug 02, 2003 11:29 pm    Post subject: Can't view japanese text Reply with quote

I have a problem viewing japanese text. Any program or webpage that uses it comes up with these weird funky boxes.

here is an example of what I mean: http://eecs.oregonstate.edu/~hendripa/google.ja.jpg

I tried installing the programs that allow you to type japanese (canna, kinput2, etc) and that allows me to write japanese and I can see that just fine.

any ideas on what may be happening?

edit: tried an emerge -u --deep and now everything works. whatever. :|
Back to top
View user's profile Send private message
asbesto
Tux's lil' helper
Tux's lil' helper


Joined: 18 Sep 2003
Posts: 78
Location: Palazzolo Acreide, ITALY

PostPosted: Thu Sep 18, 2003 9:47 pm    Post subject: japanese fonts like box with numbers inside !!!!! Reply with quote

i have the same problem

netscape/mozilla/firebird can't display japanese, chinese, korean, cyrillic fonts. instead
i obtain strange boxes with numbers inside

this is very annoying

can someone help me ?

tnx
asbesto
_________________
AMEN
Back to top
View user's profile Send private message
jarealist
Apprentice
Apprentice


Joined: 07 Oct 2002
Posts: 227

PostPosted: Thu Sep 18, 2003 10:05 pm    Post subject: Reply with quote

I had the same problem displaying japaness fonts with mozilla. Emerging: media-fonts/kochi-substitute/kochi-substitute-20030809 solved it for me.
Back to top
View user's profile Send private message
yamakawa
Guru
Guru


Joined: 28 Jul 2003
Posts: 340

PostPosted: Thu Sep 18, 2003 10:24 pm    Post subject: Reply with quote

They DO. just emerge with USE="cjk" option and emerge some font packages.
Back to top
View user's profile Send private message
asbesto
Tux's lil' helper
Tux's lil' helper


Joined: 18 Sep 2003
Posts: 78
Location: Palazzolo Acreide, ITALY

PostPosted: Fri Sep 19, 2003 2:30 pm    Post subject: no way, i continue seeing that F&#^%@# boxes :( Reply with quote

nothing to do

emerging that font solved nothing for me

i continue seeing that weird boxes :((((
_________________
AMEN
Back to top
View user's profile Send private message
tomapd
n00b
n00b


Joined: 26 Aug 2003
Posts: 22
Location: Sendai

PostPosted: Fri Sep 19, 2003 5:16 pm    Post subject: Reply with quote

First of all, you must check your "cjk" and "nls" USE flags and re-compile packeges. "cjk" flag enables 2-byte characters (Chinese, Japanese, Korean) for some programs and it is not "ON" by default.

You also have to install japanese fonts.
    media-fonts/kochi-substitute
    media-fonts/shinome

then add font paths to XF86Config file.

Finally, choose appropriate fonts in the options dialog of mozilla if wrong fonts are selected.
Back to top
View user's profile Send private message
asbesto
Tux's lil' helper
Tux's lil' helper


Joined: 18 Sep 2003
Posts: 78
Location: Palazzolo Acreide, ITALY

PostPosted: Fri Sep 19, 2003 10:41 pm    Post subject: NO WAY - i recompiled all day long - NO WAY ! :( Reply with quote

[quote="tomapd"]First of all, you must check your "cjk" and "nls" USE flags and re-compile packeges.
You also have to install japanese fonts.
[list]media-fonts/kochi-substitute
media-fonts/shinome[/list]
then add font paths to XF86Config file.
Finally, choose appropriate fonts in the options dialog of mozilla if wrong fonts are selected.[/quote]

NO WAY !

i spent all day in recompiling, and i still obtain those F@#^$%^ BOXES

i can't manage that - my nervous system is collapsing (as you can see in the foto :)))

i don't know

HINT

when i first installed GENTOO, all was working correctly !!! a day later, after i emerged
some packages, well, i obtained those boxes. Maybe there's something in the system
that can interfere with netscape/mozilla/firebird ???

p.s OPERA BROWSER IS OK


8O 8O
_________________
AMEN
Back to top
View user's profile Send private message
miknight
n00b
n00b


Joined: 03 Jul 2003
Posts: 74
Location: Sydney, Australia

PostPosted: Sat Sep 20, 2003 6:29 am    Post subject: Reply with quote

You have failed to configure Mozilla properly.

Go into Edit->Preferences->Appearance->Fonts.

Now up the top there is a drop down box. Select fonts for "Japanese" (or whichever type you're after). Then you can, for example, set your Proportional font to "Sans Serif", but you must then set your Sans Serif font to a font that has the Japanese characters in it (as explained in previous helpful posts).

You'd find you get better help if you're more polite in your posts to those who are just trying to help you.

EDIT: Spelling.
Back to top
View user's profile Send private message
asbesto
Tux's lil' helper
Tux's lil' helper


Joined: 18 Sep 2003
Posts: 78
Location: Palazzolo Acreide, ITALY

PostPosted: Sat Sep 20, 2003 12:12 pm    Post subject: More on this "font" problem Reply with quote

well,

the news today is that opera also have this "box" problem

:(

i think this is not a problem of mozilla font. this because when i first made the
gentoo installation here, from a plain stage 3 system, i emerged netscape, and it
was working perfectly. also for mozilla and firebird.

and i was able to see japanese text WITHOUT selecting any "japanese" font
or whatever in edit---preferences---font.

after an "emerge system" or an "emerge world", i don't remember now, i obtained this
"font" problem, on mozilla, netscape, firebird, and now on OPERA 7.11

so, why now i have to do that setting ? it seem evident that the problem here is
not netscape, or mozilla, or opera, but something in the system that changed some
fonts....

hmmmm ... maybe PANGO ????? i will work on this.

any idea ?
_________________
AMEN
Back to top
View user's profile Send private message
tomapd
n00b
n00b


Joined: 26 Aug 2003
Posts: 22
Location: Sendai

PostPosted: Sat Sep 20, 2003 6:49 pm    Post subject: Reply with quote

well, i think it is due to the lack of truetype japanese fonts on your system.
i don't know about OPERA but, mozilla 1.4 or mozilla-firebird 0.6.1 renders fonts with XFT by default. and i think XFT can not render bitmap fonts correctly.
in order to disable XFT rendering, there are two ways. First way is to disable XFT font rendering in compile configuration. you can do it with "moznoxft" USE flag.

second way is to disable the xft font rendering in mozilla's configuration files. Once you start up mozilla, you will find a config file in your home directory.
Code:
~/.phoenix/default/zdv18tqo.slt/prefs.js

this is my mozilla-firebird's config file location. ".phoenix" may be different name if you use mozilla and "zdv18tqo.slt" is a random name so you should use your own name instead.

in this config file, you can disable XFT rendering with this option.
Code:
user_pref("fonts.xft.enabled", false);

Don't edit this file while you are using mozilla because it overwrites the file when quitting.

after disabling XFT rendering, you can choose bitmap japanese fonts (Shinonome?) in options dialog and mozilla will no longer render boxes.

i am a Japanese linux user but i'm not using shinonome or kochi fonts now and i heard that kochi font is not published now because of some licence problems(?) (i don't know for detail) though it is the only easy-to-get free truetype font on linux. this is now a very big problem for japanese linux users and some people are making kochi-alternative fonts but it is not finished yet.

so if you cannot install some commercial(?) truetype fonts to your linux box, it is difficult time to use japanese fonts with XFT until kochi-alternative fonts are released.

well, this is a tip not for mozilla but for other gtkr+-2.x programs. you can diable XFT rendering by setting environemt variable
Code:
export GDK_USE_XFT=0

if you want to use bitmap fonts.
Back to top
View user's profile Send private message
tomapd
n00b
n00b


Joined: 26 Aug 2003
Posts: 22
Location: Sendai

PostPosted: Sat Sep 20, 2003 7:18 pm    Post subject: Reply with quote

sorry i was misunderstanding about kochi fonts.
kochi-substitute is what i said kochi-alternative fonts so japanese truetype fonts are already available.

but after emerging "kochi-substitute" fonts, i cannot select kochi fonts too.
Code:
xlsfonts | grep kochi

shows nothing for me so X-Window seems to be not recognizing them (of course i surely added font paths to XF86Config file).

if you are in the same trouble, fixing this will make your mozilla work well. i'm going to work on this.

anyway, my last post about XFT will also work.
XFT and fonts related problems are really confusing and annoying.
Back to top
View user's profile Send private message
asbesto
Tux's lil' helper
Tux's lil' helper


Joined: 18 Sep 2003
Posts: 78
Location: Palazzolo Acreide, ITALY

PostPosted: Sat Sep 20, 2003 7:26 pm    Post subject: problem partially solved Reply with quote

well,

i think i solved part of the problem in this brutal way :

1) i emerged ANY japanese font i've found with emerge -s font :)

2) i brutally UNMERGED PANGO :)

and now i can see kanji in netscape, opera and firebird :)

i haven't tried mozilla now, it make a lot recompiling :)))
_________________
AMEN
Back to top
View user's profile Send private message
erwan
Apprentice
Apprentice


Joined: 01 Jun 2003
Posts: 150
Location: Tokyo

PostPosted: Sun Sep 21, 2003 3:21 am    Post subject: Reply with quote

Try to unmerge then merge again fontconfig.

You should really stick with gtk+2 application because of im-ja, is much more confortable to input Japanese than in other applications.

https://forums.gentoo.org/viewtopic.php?t=58142&highlight=japanese
_________________
See me on Jabber: erwan@im.loisant.org
Back to top
View user's profile Send private message
tomapd
n00b
n00b


Joined: 26 Aug 2003
Posts: 22
Location: Sendai

PostPosted: Sun Sep 21, 2003 6:12 am    Post subject: Reply with quote

thank you!
erwan wrote:
Try to unmerge then merge again fontconfig

this solved the problem. but i cannot understand why this works well. because when i check USE flags of fontconfig by
Code:
etcat -u fontconfig

it showed no flags. so if this program really depends on "cjk" or "nls" flags, ebuild file should contain these flags...?
Back to top
View user's profile Send private message
pubecon
Guru
Guru


Joined: 03 Mar 2003
Posts: 342
Location: Glasgow, Scotland

PostPosted: Sun Sep 28, 2003 9:46 pm    Post subject: Reply with quote

tomapd wrote:
...[llist]...media-fonts/shinome...[/list]
...
shinonome
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Other Languages All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum