Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[risolto]direct rendering YES, ma mplayer -vo gl lentissimo
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian)
View previous topic :: View next topic  
Author Message
darkmanPPT
Veteran
Veteran


Joined: 13 Apr 2006
Posts: 1069
Location: vi/bo

PostPosted: Mon Feb 16, 2009 9:11 am    Post subject: [risolto]direct rendering YES, ma mplayer -vo gl lentissimo Reply with quote

Il problema è molto semplice.
possiedo un ati mobility radeon x300 su un notebook. l'altro giorno sono passato a xorg-server-1.5.3-r1 e, già che c'ero, ho provato i nuovi driver ati open source x11-drivers/xf86-video-ati versione 6.10.0. utilizzo le mesa 7.3 il pacchetto x11-base/x11-drm 20080710

Scopro, con mia somma gioia, che effettivamente essi supportano il direct rendering 3d sulla mia scheda!

Il problema è questo: glxinfo mi dice direct rendering yes. difatti, se provo ad aprire un qualsiasi gioco 3d o blender o chissà che altro che richiede l'accelerazione grafica non sento alcun rallentamento.

(premetto che con i driver ati closed non avevo questi problemi)
glxgears mi fa sui 120 frame per secondo (un po' pochetti, eh?). vabbè.. ho sempre letto in giro che glxgears non è molto attendibile.

dopodichè provo ad aprire un filmato con mplayer. Casualmente provo a vedere un filmato con l'opzione -vo gl. in poche parole dovrebbe utilizzare opengl per il rendering. giusto?
il filmato che vedo è così scattoso che bene o male farà 1 o 2 (posso azzardare anche 3fps, ma non di più) frame al secondo.

lo stesso filmato visualizzato con il driver xv (opzione -vo xv) o con x11 (opzione -vo x11) si vede molto fluido.

ho fatto la prova anche con altri filmati e il risultato è sempre lo stesso. A dirla tutta ho visto che anche i filmati di youtube visti in modalità fullscreen mi vanno molto molto lenti.

Qualcuno saprebbe darmi qualche indicazione?

ps: so di essere un po' fuori topic con la seguente :roll: : nel caso, non rispondetemi (vedasi il discorso un problema un thread). nemmeno l'estensione AIGLX mi va (ho guardato i log di xorg). difatti non riesco ad attivare gli effetti di kde.
_________________
Darkman


Last edited by darkmanPPT on Wed Feb 18, 2009 10:16 pm; edited 1 time in total
Back to top
View user's profile Send private message
darkmanPPT
Veteran
Veteran


Joined: 13 Apr 2006
Posts: 1069
Location: vi/bo

PostPosted: Wed Feb 18, 2009 7:28 pm    Post subject: Reply with quote

sigh, speravo che qualcuno avesse idea.
vi posto alcuni pezzi del log di xorg, magari potrà essere utile...

Code:
(II) LoadModule: "glx"                                                 

(II) Loading /usr/lib/xorg/modules/extensions//libglx.so
(II) Module glx: vendor="X.Org Foundation"             
        compiled for 1.5.3, module version = 1.0.0     
        ABI class: X.Org Server Extension, version 1.1 
(**) AIGLX enabled                                     
(**) Exporting typical set of GLX visuals               
(II) Loading extension GLX   
...
(**) RADEON(0): Using EXA acceleration architecture
(EE) RADEON(0): [dri] RADEONDRIGetVersion failed because of a version mismatch.
[dri] radeon.o kernel module version is 8.57.2 but version 1.17.0 or newer is needed.
[dri] Disabling DRI.
....
(II) EXA(0): Driver registered support for the following operations:
(II)         Solid
(II)         Copy
(II)         Composite (RENDER acceleration)
(II)         UploadToScreen
(II)         DownloadFromScreen
(II) RADEON(0): Acceleration enabled
...
(WW) RADEON(0): Direct rendering disabled
...
(WW) RADEON(0): Option "XAANoOffscreenPixmaps" is not used
(WW) RADEON(0): Option "MonitorLayout" is not used
(WW) RADEON(0): Option "TexturedVideo" is not used
(WW) RADEON(0): Option "OverlayOnCRTC2" is not used
(WW) RADEON(0): Option "OpenGLOverlay" is not used
(WW) RADEON(0): Option "EnableMonitor" is not used
(WW) RADEON(0): Option "ReducedBlanking" is not used
...
(WW) RADEON(0): Unknown vendor-specific block 0
(II) RADEON(0): No DPMS capabilities specified
...
(II) RADEON(0): RandR 1.2 enabled, ignore the following RandR disabled message.
(II) AIGLX: Loaded and initialized /usr/lib/dri/swrast_dri.so
(II) AIGLX: Screen 0 is not DRI capable

ma non ci sono un po' di controsensi? prima dice che AIGLX è enabled e poi no, mi dice che non ha il direct rendering ma in realtà ce l'ho...
_________________
Darkman
Back to top
View user's profile Send private message
riverdragon
Veteran
Veteran


Joined: 14 Sep 2006
Posts: 1269
Location: Verona

PostPosted: Wed Feb 18, 2009 9:09 pm    Post subject: Reply with quote

Mi è venuto lo scupolo di controllare, e ho trovato questo. Probabilmente il problema è in mplayer e non nei driver.

Code:
[dri] radeon.o kernel module version is 8.57.2 but version 1.17.0 or newer is needed.
[dri] Disabling DRI.
Non è che hai lasciato in giro i driver vecchi? Prova a compilare un kernel nuovo così che /lib/modules/2.6.XX sia pulita, e riprova.
Back to top
View user's profile Send private message
darkmanPPT
Veteran
Veteran


Joined: 13 Apr 2006
Posts: 1069
Location: vi/bo

PostPosted: Wed Feb 18, 2009 9:46 pm    Post subject: Reply with quote

uhm...
bella là! non ci avevo fatto caso che la prima indicava la versione di quelli closed!

mo' ne faccio uno nuovo :wink:


---------------------
RISOLTO!! e che cavolo... era proprio quello il problema!
duclis in fundo: funziona anche AIGLX!

toh!
grazie grazie grazie grazie! :wink:
ti offro un caffè alle macchinette la prox volta che ci vediamo all'univ :D
_________________
Darkman
Back to top
View user's profile Send private message
bandreabis
Advocate
Advocate


Joined: 18 Feb 2005
Posts: 2413
Location: イタリアのロディで

PostPosted: Thu Feb 19, 2009 11:45 am    Post subject: Re: [risolto]direct rendering YES, ma mplayer -vo gl lentiss Reply with quote

darkmanPPT wrote:
Il problema è molto semplice.
possiedo un ati mobility radeon x300 su un notebook. l'altro giorno sono passato a xorg-server-1.5.3-r1 e, già che c'ero, ho provato i nuovi driver ati open source x11-drivers/xf86-video-ati versione 6.10.0. utilizzo le mesa 7.3 il pacchetto x11-base/x11-drm 20080710

Scopro, con mia somma gioia, che effettivamente essi supportano il direct rendering 3d sulla mia scheda!


Ciao.
Io ho una x200 e uso per ora i driver closed.
Mi spiegheresti come fare ad installare i drivers open che hai usato tu? Hai una guida dettagliata passo passo?
_________________
Il numero di post non fa di me un esperto! Anzi!
Back to top
View user's profile Send private message
darkmanPPT
Veteran
Veteran


Joined: 13 Apr 2006
Posts: 1069
Location: vi/bo

PostPosted: Thu Feb 19, 2009 12:06 pm    Post subject: Reply with quote

passo passo?
beh.. ti posso dire "il casino" che ho fatto :D sul mio pc.

1) ho aggiornato xorg-server al 1.5.3-r1 (togliendo la flag fglrx e disinstallando il driver)
2) aggiornato le mesa alle 7.2
3) aggiornato x11-drm al 20080710
4) aggiornato il driver xf86-video-ati alla versione 6.10.0
5) sistemato adeguatamente lo xorg.conf (probabilmente alcune voci sono inutili)
Code:

Section "Module"
        Load  "bitmap"
        Load  "glx"
        Load  "GLcore"
        Load  "dbe"
        Load  "ddc"
        Load  "dri"
        Load  "drm"
        Load  "extmod"
        Load  "freetype"
        Load  "record"
        Load  "xtrap"
        Load  "vbe"
        Load  "i2c"
EndSection
......
Section "Device"
Identifier     "ATI Graphics Adapter 0"
               Driver         "radeon"
               Option     "AGPMode" "4"
               Option     "AGPFastWrite" "True"
                Option     "EnablePageFlip" "True"
               Option         "AccelMethod" "EXA"
               Option         "XAANoOffscreenPixmaps" "true"
               Option         "BusType" "PCIE"
               Option         "MonitorLayout" "LVDS, TMDS"
               Option         "TexturedVideo" "On"
               Option         "DRI"     "true"
               Option         "ColorTiling"   "on"
               Option         "OverlayOnCRTC2"        "on"
               Option         "OpenGLOverlay"   "On"
               Option         "EnableMonitor"   "auto"
               Option         "TVDACLoadDetect" "on"
               Option         "TVStandard"              "pal"
               BusID          "PCI:1:0:0"
EndSection

6) come suggeritomi sopra ho creato un nuovo kernel (senza installarci i driver closed e ricompilando i pacchetti che mi inserivano il modulo nel kernel).
7) eselect opengl set xorg-x11
8) riavviato il pc, et voilà.

Ti cito dal log di xorg, ecco le schede supportate dal driver.
Code:

RADEON: Driver for ATI Radeon chipsets:       
        ATI Radeon Mobility X600 (M24) 3150 (PCIE), ATI FireMV 2400 (PCI),
        ATI Radeon Mobility X300 (M24) 3152 (PCIE),                       
        ATI FireGL M24 GL 3154 (PCIE), ATI Radeon X600 (RV380) 3E50 (PCIE),
        ATI FireGL V3200 (RV380) 3E54 (PCIE), ATI Radeon IGP320 (A3) 4136,
        ATI Radeon IGP330/340/350 (A4) 4137, ATI Radeon 9500 AD (AGP),     
        ATI Radeon 9500 AE (AGP), ATI Radeon 9600TX AF (AGP),             
        ATI FireGL Z1 AG (AGP), ATI Radeon 9800SE AH (AGP),               
        ATI Radeon 9800 AI (AGP), ATI Radeon 9800 AJ (AGP),               
        ATI FireGL X2 AK (AGP), ATI Radeon 9600 AP (AGP),                 
        ATI Radeon 9600SE AQ (AGP), ATI Radeon 9600XT AR (AGP),           
        ATI Radeon 9600 AS (AGP), ATI FireGL T2 AT (AGP), ATI Radeon 9650,
        ATI FireGL RV360 AV (AGP), ATI Radeon 7000 IGP (A4+) 4237,         
        ATI Radeon 8500 AIW BB (AGP), ATI Radeon 8500 AIW BC (AGP),       
        ATI Radeon IGP320M (U1) 4336, ATI Radeon IGP330M/340M/350M (U2) 4337,
        ATI Radeon Mobility 7000 IGP 4437, ATI Radeon 9000/PRO If (AGP/PCI),
        ATI Radeon 9000 Ig (AGP/PCI), ATI Radeon X800 (R420) JH (AGP),       
        ATI Radeon X800PRO (R420) JI (AGP),                                 
        ATI Radeon X800SE (R420) JJ (AGP), ATI Radeon X800 (R420) JK (AGP), 
        ATI Radeon X800 (R420) JL (AGP), ATI FireGL X3 (R420) JM (AGP),     
        ATI Radeon Mobility 9800 (M18) JN (AGP),                             
        ATI Radeon X800 SE (R420) (AGP), ATI Radeon X800XT (R420) JP (AGP), 
        ATI Radeon X850 XT (R480) (AGP), ATI Radeon X850 SE (R480) (AGP),   
        ATI Radeon X850 PRO (R480) (AGP), ATI Radeon X850 XT PE (R480) (AGP),
        ATI Radeon Mobility M7 LW (AGP),                                     
        ATI Mobility FireGL 7800 M7 LX (AGP),                               
        ATI Radeon Mobility M6 LY (AGP), ATI Radeon Mobility M6 LZ (AGP),   
        ATI FireGL Mobility 9000 (M9) Ld (AGP),                             
        ATI Radeon Mobility 9000 (M9) Lf (AGP),                             
        ATI Radeon Mobility 9000 (M9) Lg (AGP), ATI Radeon 9700 Pro ND (AGP),
        ATI Radeon 9700/9500Pro NE (AGP), ATI Radeon 9600TX NF (AGP),       
        ATI FireGL X1 NG (AGP), ATI Radeon 9800PRO NH (AGP),                 
        ATI Radeon 9800 NI (AGP), ATI FireGL X2 NK (AGP),                   
        ATI Radeon 9800XT NJ (AGP),                                         
        ATI Radeon Mobility 9600/9700 (M10/M11) NP (AGP),                   
        ATI Radeon Mobility 9600 (M10) NQ (AGP),                             
        ATI Radeon Mobility 9600 (M11) NR (AGP),                             
        ATI Radeon Mobility 9600 (M10) NS (AGP),                             
        ATI FireGL Mobility T2 (M10) NT (AGP),                               
        ATI FireGL Mobility T2e (M11) NV (AGP), ATI Radeon QD (AGP),         
        ATI Radeon QE (AGP), ATI Radeon QF (AGP), ATI Radeon QG (AGP),       
        ATI FireGL 8700/8800 QH (AGP), ATI Radeon 8500 QL (AGP),             
        ATI Radeon 9100 QM (AGP), ATI Radeon 7500 QW (AGP/PCI),             
        ATI Radeon 7500 QX (AGP/PCI), ATI Radeon VE/7000 QY (AGP/PCI),       
        ATI Radeon VE/7000 QZ (AGP/PCI), ATI ES1000 515E (PCI),             
        ATI Radeon Mobility X300 (M22) 5460 (PCIE),                         
        ATI Radeon Mobility X600 SE (M24C) 5462 (PCIE),                     
        ATI FireGL M22 GL 5464 (PCIE), ATI Radeon X800 (R423) UH (PCIE),     
        ATI Radeon X800PRO (R423) UI (PCIE),                                 
        ATI Radeon X800LE (R423) UJ (PCIE),                                 
        ATI Radeon X800SE (R423) UK (PCIE),                                 
        ATI Radeon X800 XTP (R430) (PCIE), ATI Radeon X800 XL (R430) (PCIE),
        ATI Radeon X800 SE (R430) (PCIE), ATI Radeon X800 (R430) (PCIE),     
        ATI FireGL V7100 (R423) (PCIE), ATI FireGL V5100 (R423) UQ (PCIE),   
        ATI FireGL unknown (R423) UR (PCIE),                                 
        ATI FireGL unknown (R423) UT (PCIE),                                 
        ATI Mobility FireGL V5000 (M26) (PCIE),                             
        ATI Mobility FireGL V5000 (M26) (PCIE),                             
        ATI Mobility Radeon X700 XL (M26) (PCIE),                           
        ATI Mobility Radeon X700 (M26) (PCIE),                               
        ATI Mobility Radeon X700 (M26) (PCIE),                               
        ATI Radeon X550XTX 5657 (PCIE), ATI Radeon 9100 IGP (A5) 5834,       
        ATI Radeon Mobility 9100 IGP (U3) 5835,                             
        ATI Radeon XPRESS 200 5954 (PCIE),                                   
        ATI Radeon XPRESS 200M 5955 (PCIE), ATI Radeon 9250 5960 (AGP),     
        ATI Radeon 9200 5961 (AGP), ATI Radeon 9200 5962 (AGP),             
        ATI Radeon 9200SE 5964 (AGP), ATI FireMV 2200 (PCI),                 
        ATI ES1000 5969 (PCI), ATI Radeon XPRESS 200 5974 (PCIE),           
        ATI Radeon XPRESS 200M 5975 (PCIE),                                 
        ATI Radeon XPRESS 200 5A41 (PCIE),                                   
        ATI Radeon XPRESS 200M 5A42 (PCIE),                                 
        ATI Radeon XPRESS 200 5A61 (PCIE),                                   
        ATI Radeon XPRESS 200M 5A62 (PCIE),                                 
        ATI Radeon X300 (RV370) 5B60 (PCIE),                                 
        ATI Radeon X600 (RV370) 5B62 (PCIE),                                 
        ATI Radeon X550 (RV370) 5B63 (PCIE),                                 
        ATI FireGL V3100 (RV370) 5B64 (PCIE),                               
        ATI FireMV 2200 PCIE (RV370) 5B65 (PCIE),                           
        ATI Radeon Mobility 9200 (M9+) 5C61 (AGP),                           
        ATI Radeon Mobility 9200 (M9+) 5C63 (AGP),                           
        ATI Mobility Radeon X800 XT (M28) (PCIE),                           
        ATI Mobility FireGL V5100 (M28) (PCIE),                             
        ATI Mobility Radeon X800 (M28) (PCIE), ATI Radeon X850 5D4C (PCIE), 
        ATI Radeon X850 XT PE (R480) (PCIE),                                 
        ATI Radeon X850 SE (R480) (PCIE), ATI Radeon X850 PRO (R480) (PCIE),
        ATI unknown Radeon / FireGL (R480) 5D50 (PCIE),                     
        ATI Radeon X850 XT (R480) (PCIE),                                   
        ATI Radeon X800XT (R423) 5D57 (PCIE),                               
        ATI FireGL V5000 (RV410) (PCIE), ATI Radeon X700 XT (RV410) (PCIE), 
        ATI Radeon X700 PRO (RV410) (PCIE),                                 
        ATI Radeon X700 SE (RV410) (PCIE), ATI Radeon X700 (RV410) (PCIE),   
        ATI Radeon X700 SE (RV410) (PCIE), ATI Radeon X1800,                 
        ATI Mobility Radeon X1800 XT, ATI Mobility Radeon X1800,             
        ATI Mobility FireGL V7200, ATI FireGL V7200, ATI FireGL V5300,       
        ATI Mobility FireGL V7100, ATI Radeon X1800, ATI Radeon X1800,       
        ATI Radeon X1800, ATI Radeon X1800, ATI Radeon X1800,               
        ATI FireGL V7300, ATI FireGL V7350, ATI Radeon X1600, ATI RV505,     
        ATI Radeon X1300/X1550, ATI Radeon X1550, ATI M54-GL,               
        ATI Mobility Radeon X1400, ATI Radeon X1300/X1550,                   
        ATI Radeon X1550 64-bit, ATI Mobility Radeon X1300,                 
        ATI Mobility Radeon X1300, ATI Mobility Radeon X1300,               
        ATI Mobility Radeon X1300, ATI Radeon X1300, ATI Radeon X1300,       
        ATI RV505, ATI RV505, ATI FireGL V3300, ATI FireGL V3350,           
        ATI Radeon X1300, ATI Radeon X1550 64-bit, ATI Radeon X1300/X1550,   
        ATI Radeon X1600, ATI Radeon X1300/X1550, ATI Mobility Radeon X1450,
        ATI Radeon X1300/X1550, ATI Mobility Radeon X2300,                   
        ATI Mobility Radeon X2300, ATI Mobility Radeon X1350,               
        ATI Mobility Radeon X1350, ATI Mobility Radeon X1450,               
        ATI Radeon X1300, ATI Radeon X1550, ATI Mobility Radeon X1350,       
        ATI FireMV 2250, ATI Radeon X1550 64-bit, ATI Radeon X1600,         
        ATI Radeon X1650, ATI Radeon X1600, ATI Radeon X1600,               
        ATI Mobility FireGL V5200, ATI Mobility Radeon X1600,               
        ATI Radeon X1650, ATI Radeon X1650, ATI Radeon X1600,               
        ATI Radeon X1300 XT/X1600 Pro, ATI FireGL V3400,                     
        ATI Mobility FireGL V5250, ATI Mobility Radeon X1700,               
        ATI Mobility Radeon X1700 XT, ATI FireGL V5200,                     
        ATI Mobility Radeon X1700, ATI Radeon X2300HD,                       
        ATI Mobility Radeon HD 2300, ATI Mobility Radeon HD 2300,           
        ATI Radeon X1950, ATI Radeon X1900, ATI Radeon X1950,               
        ATI Radeon X1900, ATI Radeon X1900, ATI Radeon X1900,               
        ATI Radeon X1900, ATI Radeon X1900, ATI Radeon X1900,               
        ATI Radeon X1900, ATI Radeon X1900, ATI Radeon X1900,               
        ATI AMD Stream Processor, ATI Radeon X1900, ATI Radeon X1950,       
        ATI RV560, ATI RV560, ATI Mobility Radeon X1900, ATI RV560,         
        ATI Radeon X1950 GT, ATI RV570, ATI RV570, ATI FireGL V7400,         
        ATI RV560, ATI Radeon X1650, ATI Radeon X1650, ATI RV560,           
        ATI Radeon 9100 PRO IGP 7834, ATI Radeon Mobility 9200 IGP 7835,     
        ATI Radeon X1200, ATI Radeon X1200, ATI Radeon X1200,               
        ATI Radeon X1200, ATI Radeon X1200, ATI RS740, ATI RS740M, ATI RS740,
        ATI RS740M, ATI Radeon HD 2900 XT, ATI Radeon HD 2900 XT,           
        ATI Radeon HD 2900 XT, ATI Radeon HD 2900 Pro, ATI Radeon HD 2900 GT,
        ATI FireGL V8650, ATI FireGL V8600, ATI FireGL V7600,               
        ATI Radeon 4800 Series, ATI Radeon HD 4870 x2,                       
        ATI Radeon 4800 Series, ATI FirePro V8750 (FireGL),                 
        ATI FirePro V7760 (FireGL), ATI Mobility RADEON HD 4850,             
        ATI Mobility RADEON HD 4850 X2, ATI Radeon 4800 Series,             
        ATI FirePro RV770, AMD FireStream 9270, AMD FireStream 9250,         
        ATI FirePro V8700 (FireGL), ATI Mobility RADEON HD 4870,             
        ATI Mobility RADEON M98, ATI Radeon RV730 (AGP),                     
        ATI Radeon RV730 (AGP), ATI RV730XT [Radeon HD 4670],               
        ATI RV730 PRO [Radeon HD 4650], ATI FirePro V7750 (FireGL),         
        ATI FirePro V5700 (FireGL), ATI FirePro V3750 (FireGL), ATI RV610,   
        ATI Radeon HD 2400 XT, ATI Radeon HD 2400 Pro,                       
        ATI Radeon HD 2400 PRO AGP, ATI FireGL V4000, ATI RV610,             
        ATI Radeon HD 2350, ATI Mobility Radeon HD 2400 XT,                 
        ATI Mobility Radeon HD 2400, ATI RADEON E2400, ATI RV610, ATI RV670,
        ATI Radeon HD3870, ATI Radeon HD3850, ATI RV670,                     
        ATI Radeon HD3870 X2, ATI FireGL V7700, ATI Radeon HD3850,           
        ATI Radeon HD 4550, ATI Radeon RV710, ATI Radeon RV710,             
        ATI Radeon HD 4350, ATI Mobility Radeon 4300 Series,                 
        ATI Mobility Radeon 4500 Series, ATI RV630,                         
        ATI Mobility Radeon HD 2600, ATI Mobility Radeon HD 2600 XT,         
        ATI Radeon HD 2600 XT AGP, ATI Radeon HD 2600 Pro AGP,               
        ATI Radeon HD 2600 XT, ATI Radeon HD 2600 Pro, ATI Gemini RV630,     
        ATI Gemini Mobility Radeon HD 2600 XT, ATI FireGL V5600,             
        ATI FireGL V3600, ATI Radeon HD 2600 LE, ATI Radeon RV710,           
        ATI Radeon HD 3470, ATI Mobility Radeon HD 3430,                     
        ATI Mobility Radeon HD 3400 Series, ATI Radeon HD 3450,             
        ATI Radeon HD 3430, ATI FireMV 2450, ATI FireMV 2260,               
        ATI FireMV 2260, ATI Radeon HD 3600 Series, ATI Radeon HD 3650 AGP, 
        ATI Radeon HD 3600 PRO, ATI Radeon HD 3600 XT,                       
        ATI Radeon HD 3600 PRO, ATI Mobility Radeon HD 3650,                 
        ATI Mobility Radeon HD 3670, ATI Radeon HD 3200 Graphics,           
        ATI Radeon 3100 Graphics, ATI Radeon HD 3200 Graphics,               
        ATI Radeon 3100 Graphics, ATI Radeon HD 3300 Graphics     


boh, poi prova a chiedermi qualcosa di specifico e cercherò di darti una mano (nei limiti del possibile e delle mie conoscenze). :wink:
_________________
Darkman
Back to top
View user's profile Send private message
bandreabis
Advocate
Advocate


Joined: 18 Feb 2005
Posts: 2413
Location: イタリアのロディで

PostPosted: Thu Feb 19, 2009 12:41 pm    Post subject: Reply with quote

Stasera provo.
Grazie 1000.

Andrea
_________________
Il numero di post non fa di me un esperto! Anzi!
Back to top
View user's profile Send private message
bandreabis
Advocate
Advocate


Joined: 18 Feb 2005
Posts: 2413
Location: イタリアのロディで

PostPosted: Mon Feb 23, 2009 8:29 pm    Post subject: Reply with quote

E' normale che non abbia il comando glxinfo?
Per ora pare andare, xorg parte, mouse si muove e la tastiera scrive.
_________________
Il numero di post non fa di me un esperto! Anzi!
Back to top
View user's profile Send private message
riverdragon
Veteran
Veteran


Joined: 14 Sep 2006
Posts: 1269
Location: Verona

PostPosted: Mon Feb 23, 2009 9:19 pm    Post subject: Reply with quote

glxinfo fa parte di mesa-progs.
Back to top
View user's profile Send private message
bandreabis
Advocate
Advocate


Joined: 18 Feb 2005
Posts: 2413
Location: イタリアのロディで

PostPosted: Tue Feb 24, 2009 6:55 am    Post subject: Reply with quote

OK, stasera lo installo, grazie.
In ogni caso anche la risoluzione è quella corretta 1440x900 e tutto in automatico.
Devo ricredermi su xorg con hal!
Stanotte ho "emerged" kdebase, così poi vedo.
Devo testare se synaptics funziona, se la tastiera posso impostarla con layout it, se davvero funzionano già i tasti multimediali (anche se dubito).

Devo dire che sono contento di come sta procedendo la mia Gentoo parallela. :P
_________________
Il numero di post non fa di me un esperto! Anzi!
Back to top
View user's profile Send private message
riverdragon
Veteran
Veteran


Joined: 14 Sep 2006
Posts: 1269
Location: Verona

PostPosted: Tue Feb 24, 2009 8:20 am    Post subject: Reply with quote

Occhio al touchpad, qui ci è voluto un po' per farlo funzionare decentemente, e comunque non è ancora ai livelli a cui ero abituato usando xorg-1.3 (per dire, il tocco con due dita separate mi faceva da clic centrale, qui funziona una volta su dieci - no good).
Back to top
View user's profile Send private message
bandreabis
Advocate
Advocate


Joined: 18 Feb 2005
Posts: 2413
Location: イタリアのロディで

PostPosted: Tue Feb 24, 2009 1:06 pm    Post subject: Reply with quote

riverdragon wrote:
Occhio al touchpad, qui ci è voluto un po' per farlo funzionare decentemente, e comunque non è ancora ai livelli a cui ero abituato usando xorg-1.3 (per dire, il tocco con due dita separate mi faceva da clic centrale, qui funziona una volta su dieci - no good).


Non è sufficiente copiare la relativa configurazione da un altro xorg?
Io uso il mouse e raramente il touchpad, stasera vedo, nella gentoo stabile funziona la "rotellina", il tasto destro e il tasto centrale.

Magari poi ti chiedo un consulto.

Grazie.
_________________
Il numero di post non fa di me un esperto! Anzi!
Back to top
View user's profile Send private message
riverdragon
Veteran
Veteran


Joined: 14 Sep 2006
Posts: 1269
Location: Verona

PostPosted: Tue Feb 24, 2009 3:06 pm    Post subject: Reply with quote

Se imposti hal tra le USE devi convertire la configurazione del touchpad in un file .fdi da mettere in /etc/hal/fdi/policy, e pur copiando pari pari non tutto funzionava (per esempio non funzionava il clic singolo, ho dovuto aggiungere una riga esplicitamente).
Back to top
View user's profile Send private message
bandreabis
Advocate
Advocate


Joined: 18 Feb 2005
Posts: 2413
Location: イタリアのロディで

PostPosted: Tue Feb 24, 2009 7:19 pm    Post subject: Reply with quote

In effetti il clic funziona quando vuole lui. Come si fa a configurarlo come si deve?
Il tuo fdi com è?
Ho trovato questo:
Code:
emerge -pv ksynaptics

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild  N    ] x11-drivers/synaptics-0.14.6  124 kB
[ebuild  N    ] x11-libs/libsynaptics-0.14.6c-r1  217 kB
[ebuild  N    ] kde-misc/ksynaptics-0.3.3  USE="-arts -debug -xinerama" 815 kB
[blocks B     ] x11-drivers/xf86-input-synaptics ("x11-drivers/xf86-input-synaptics" is blocking x11-drivers/synaptics-0.14.6)
[blocks B     ] x11-drivers/synaptics ("x11-drivers/synaptics" is blocking x11-drivers/xf86-input-synaptics-0.15.2-r2)

ma come si vede vuole eliminare f86-input-synaptics.
_________________
Il numero di post non fa di me un esperto! Anzi!
Back to top
View user's profile Send private message
riverdragon
Veteran
Veteran


Joined: 14 Sep 2006
Posts: 1269
Location: Verona

PostPosted: Wed Feb 25, 2009 10:30 am    Post subject: Reply with quote

Ti rispondo quando sono davanti al mio pc.
Riguardo all'eliminazione di xf86-input-synaptics, prova a guardare le dipendenze di ksynaptics, potrebbe essere il colpevole.
Back to top
View user's profile Send private message
bandreabis
Advocate
Advocate


Joined: 18 Feb 2005
Posts: 2413
Location: イタリアのロディで

PostPosted: Wed Feb 25, 2009 11:35 am    Post subject: Reply with quote

riverdragon wrote:
Ti rispondo quando sono davanti al mio pc.
Riguardo all'eliminazione di xf86-input-synaptics, prova a guardare le dipendenze di ksynaptics, potrebbe essere il colpevole.

Attendo la tua configurazione .fdi di synaptics.
ksynaptics solo se non metto a posto con hald.
_________________
Il numero di post non fa di me un esperto! Anzi!
Back to top
View user's profile Send private message
riverdragon
Veteran
Veteran


Joined: 14 Sep 2006
Posts: 1269
Location: Verona

PostPosted: Thu Feb 26, 2009 9:18 am    Post subject: Reply with quote

Code:
<?xml version="1.0" encoding="ISO-8859-1"?>
<deviceinfo version="0.2">
  <device>
    <match key="info.capabilities" contains="input.touchpad">
        <merge key="input.x11_driver" type="string">synaptics</merge>
        <!-- Arbitrary options can be passed to the driver using
             the input.x11_options property since xorg-server-1.5. -->
        <merge key="input.x11_options.SHMConfig" type="string">true</merge>
        <merge key="input.x11_options.TapButton1" type="string">1</merge>
        <merge key="input.x11_options.TapButton2" type="string">2</merge>
        <merge key="input.x11_options.TapButton3" type="string">3</merge>
        <merge key="input.x11_options.Emulate3Buttons" type="string">yes</merge>
        <merge key="input.x11_options.LockedDrags" type="string">0</merge>
        <merge key="input.x11_options.PalmDetect" type="string">yes</merge>
        <merge key="input.x11_options.CoastingSpeed" type="string">20</merge>
        <merge key="input.x11_options.MaxTapMove" type="string">220</merge>
        <merge key="input.x11_options.MaxTapTime" type="string">180</merge>
        <merge key="input.x11_options.LeftEdge" type="string">1900</merge>
        <merge key="input.x11_options.RightEdge" type="string">5000</merge>
        <merge key="input.x11_options.TopEdge" type="string">1700</merge>
        <merge key="input.x11_options.BottomEdge" type="string">4200</merge>
        <merge key="input.x11_options.FingerLow" type="string">25</merge>
        <merge key="input.x11_options.FingerHigh" type="string">30</merge>
        <merge key="input.x11_options.VertScrollDelta" type="string">100</merge>
        <merge key="input.x11_options.MinSpeed" type="string">0.09</merge>
        <merge key="input.x11_options.MaxSpeed" type="string">0.18</merge>
        <merge key="input.x11_options.AccelFactor" type="string">0.0015</merge>
        <!--<merge key="input.x11_options.TwoFingerButton1" type="string">2</merge>
        <merge key="input.x11_options.TwoFingerButton2" type="string">3</merge>
        <merge key="input.x11_options.TwoFingerButton3" type="string">0</merge>-->
        <merge key="input.x11_options.MaxTapTime" type="string">180</merge>
        <merge key="input.x11_options.MaxTapTime" type="string">180</merge>


        <merge key="input.x11_options.VertEdgeScroll" type="string">true</merge>

        <merge key="input.x11_options.VertTwoFingerScroll" type="string">true</merge>

        <merge key="input.x11_options.HorizTwoFingerScroll" type="string">true</merge>

        <merge key="input.x11_options.CircularScrolling" type="string">true</merge>

        <!-- For other possible options, check CONFIGURATION DETAILS in synaptics man page
        -->
    </match>
  </device>
</deviceinfo>
Credo che ci sia troppa roba; mi piacerebbe pulirlo un po' ma sembra che per vedere gli effetti delle modifiche si debba riavviare hal... non è granché efficiente.
Se passa di qua un moderatore valuti se dividere la seconda parte del thread dalla prima :wink:
Back to top
View user's profile Send private message
bandreabis
Advocate
Advocate


Joined: 18 Feb 2005
Posts: 2413
Location: イタリアのロディで

PostPosted: Thu Feb 26, 2009 9:09 pm    Post subject: Reply with quote

OHHH!
Ora il tapping funziona perfettamente.... solo che (scusa se sono una piattola) non funziona più il tasto destro ed il tasto centrale.
_________________
Il numero di post non fa di me un esperto! Anzi!
Back to top
View user's profile Send private message
riverdragon
Veteran
Veteran


Joined: 14 Sep 2006
Posts: 1269
Location: Verona

PostPosted: Thu Feb 26, 2009 10:36 pm    Post subject: Reply with quote

bandreabis wrote:
non funziona più il tasto destro ed il tasto centrale.
Ecco, se riesci a capire dov'è il problema fammi un fischio, fa comodo anche a me saperlo! :lol:
Back to top
View user's profile Send private message
bandreabis
Advocate
Advocate


Joined: 18 Feb 2005
Posts: 2413
Location: イタリアのロディで

PostPosted: Thu Feb 26, 2009 11:05 pm    Post subject: Reply with quote

riverdragon wrote:
bandreabis wrote:
non funziona più il tasto destro ed il tasto centrale.
Ecco, se riesci a capire dov'è il problema fammi un fischio, fa comodo anche a me saperlo! :lol:


:lol:
_________________
Il numero di post non fa di me un esperto! Anzi!
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum